胡伊萱视频:腾龙分时-(分时走势通道 源码)

来源:百度文库 编辑:宝宝故事网 时间:2020/06/02 09:28:35
腾龙分时,分时走势通道指标,分时线性特征有柱状提示。源码如下:

A1:=(EMA(C,5)+EMA(C,15))/2;
B1:=(EMA(C,30)+EMA(C,60))/2;
C1:=SUM(C*V,(BARSSINCE(V>0)+1))/SUM(V,(BARSSINCE(V>0)+1))+((BARSSINCE(V>0)+1)*0);
D1:=(C1+DYNAINFO(5))/2;
E1:=(C1+DYNAINFO(6))/2;
振幅:=DYNAINFO(13)*100;
线幅1:=ABS((D1-B1)/B1)*100;
上涨幅:=ABS((D1-REF(D1,1))/REF(D1,1))*100;
线幅2:=ABS((C1-B1)/B1)*100;
均涨幅:=ABS((C1-REF(C1,1))/REF(C1,1))*100;
线幅3:=ABS((E1-B1)/B1)*100;
下涨幅:=ABS((E1-REF(E1,1))/REF(E1,1))*100;
慢线幅:=ABS((B1-REF(B1,1))/REF(B1,1))*100;
上差:=ABS(C1-D1);
下差:=ABS(C1-E1);
偏下:=COUNT(下差*3<上差,15)=15;
偏上:=COUNT(上差*3<下差,15)=15;
下横:=(COUNT(线幅2<0.15,10)=10 AND COUNT(均涨幅<0.01,10)=10 AND COUNT(慢线幅<0.01,5)=5) OR (COUNT(线幅3<0.15,10)=10 AND COUNT(下涨幅<0.01,10)=10 AND COUNT(慢线幅<0.01,5)=5);
上横:=(COUNT(线幅1<0.15,10)=10 AND COUNT(上涨幅<0.01,10)=10 AND COUNT(慢线幅<0.01,5)=5) OR (COUNT(线幅2<0.15,10)=10 AND COUNT(均涨幅<0.01,10)=10 AND COUNT(慢线幅<0.01,5)=5);
上突:=偏下 AND 下横;
下破:=偏上 AND 上横;
标准1:=COUNT(B1标准2:=COUNT(B1标准3:=COUNT(B1低位:=IF(振幅>=5,标准3,IF(振幅<5 AND 振幅>=3,标准2,标准1));
DRAWBAND(D1,RGB(75,0,0),C1,0);
DRAWBAND(C1,RGB(0,75,0),E1,0);
STICKLINE(低位,E1,D1,0,0),COLORYELLOW;
STICKLINE(上突,E1,C1,0,0),COLORRED;
STICKLINE(下破,D1,C1,0,0),COLORGREEN;
均价:C1,COLOR860086;
上轨:D1,COLOR000086;
下轨:E1,COLOR008600;
走势:A1,COLORWHITE;
生命:B1,COLORYELLOW;