花样男神新老大:通达信主副图指标----------股票实战技术指标公式研究本博500人腾讯群81329...

来源:百度文库 编辑:宝宝故事网 时间:2019/10/19 18:05:06
东方财富网首页|博客首页登录|开通博客股票实战技术指标公式研究本博500人腾讯群81329885网址:http://blog.eastmoney.com/linfuneng
  • ')" href="javascript:;" href_cetemp="javascript:;">收藏本页 | 复制链接与MSN、QQ上的朋友分享
  • 自创盘前选股同步发财的:
  • 博客首页
  • 博文
  • 相册
  • 发表博文
  • 管理评论
首页 | 博文博主自创盘前选股同步发财博客级别
45积分:4775分
访问:512143次排名:1120名最新博文
  • 家长如何纠正孩子粗心的问题
  • 怎样拥有一颗健康的心脏
  • 根治所有胃病
  • 哪些蔬果可能农药多
  • 补肾偏方
  • 孩子优秀,父母成就
  • 治疗癌症偏方
  • 人见人爱的家庭补血方
  • 教你养心秘诀
  • 震惊:生活中最脏的日常用品
  通达信主副图指标集锦一起贡献给大家(2010-11-02 23:23:31)分类:指标公式源码

 

{千载难逢选股}

VAR22:=REF(CLOSE,1);
VAR23:=SMA(MAX(CLOSE-VAR22,0),7,1)/SMA(ABS(CLOSE-VAR22),7,1)*100;
VAR24:=SMA(MAX(CLOSE-VAR22,0),13,1)/SMA(ABS(CLOSE-VAR22),13,1)*100;
VAR25:=BARSLAST(VAR24<23)<=3 AND CROSS(VAR23,VAR24);
VAR26:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5;
VAR27:=LLV(LOW,5);
VAR28:=HHV(HIGH,10);
VAR29:=EMA((CLOSE-VAR27)/(VAR28-VAR27)*100,4);
VAR2A:=EMA(0.667*REF(VAR29,1)+0.333*VAR29,2);
千载难逢: 0-(-1)*VAR25 AND VAR26 AND CROSS(VAR29,VAR2A) AND VAR29<=25;


{千载难逢低吸}

VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR3:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),20,1)*100;
VAR4:=BARSLAST(VAR3<48)<=3 AND CROSS(VAR2,VAR3);
VAR5:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<-12.5;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,10);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4);
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
VARB:=VAR5;
低吸: 0-(-1)*VAR4 AND VAR5 AND CROSS(VAR8,VAR9) AND VAR8<=25;


{千载难逢枯木逢春选股}

VARC:=REF(CLOSE,1);
VARD:=SMA(MAX(CLOSE-VARC,0),7,1)/SMA(ABS(CLOSE-VARC),7,1)*100;
VARE:=SMA(MAX(CLOSE-VARC,0),13,1)/SMA(ABS(CLOSE-VARC),13,1)*100;
VARF:=BARSLAST(VARE<43)<=3 AND CROSS(VARD,VARE);
VAR10:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR11:=LLV(LOW,5);
VAR12:=HHV(HIGH,10);
VAR13:=EMA((CLOSE-VAR11)/(VAR12-VAR11)*100,4);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2);
枯木逢春:=0-(-1)*VARF AND VAR10 AND CROSS(VAR13,VAR14) AND VAR13<=25;
枯木逢春选股:枯木逢春>0;


{难得一遇选股}

VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100;
VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100;
VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR1C:=LLV(LOW,5);
VAR1D:=HHV(HIGH,10);
VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4);
VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2);
难得一遇: 0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25;

{对比量比  DBLB}

{N  2,100,11; M  2,100,6}

GG:=VOL/SUM(REF(VOL,1),N);
ZS:=INDEXV/SUM(REF(INDEXV,1),N);
DBLB:GG/ZS;
MADBLB:MA(DBLB,M);


长短趋势 主图
Var3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),18)/4;
Var4:=IF(DATE<1091231,IF(Var3>23.16,Var3,0),0);
Var5:=Var3<10;
Var6:=Var3<2;
Var7:=Var5 OR Var6;
长期趋势: ZIG(3,19), , COLORBLUE;
短期趋势: ZIG(3,6.5), , COLORYELLOW;
年线: EMA(CLOSE,250), , COLOR0099FF;
三年线: EMA(CLOSE,725), , COLORWHITE;
九日: EMA(CLOSE,9), , COLOR009090;
十三日: EMA(CLOSE,13), , COLORB0FFFF;
七十二日: EMA(CLOSE,72), , COLORRED;
IF(CROSS(ZIG(3,13),REF(ZIG(3,13),1)),长期趋势+1,长期趋势-1), COLORRED;

{个股大盘(120)}
{N 1,500,120}
个股趋势:MA(C,1)/MA(REF(C,18),18)*100,COLOR0000FF,LINETHICK4;
个股风险:MA(FORCAST(个股趋势,20),N),CROSSDOT,COLORFF00FF,LINETHICK2;
大盘趋势:EMA(INDEXC,1)/MA(REF(INDEXC,18),18)*100,COLORFF9900,LINETHICK2;
大盘风险:MA(FORCAST(大盘趋势,20),N),CIRCLEDOT,COLORCYAN,LINETHICK2;
DRAWICON(CROSS(个股趋势,个股风险),个股风险-0.1,13);
DRAWICON(CROSS(个股趋势,大盘风险),个股风险-0.25,9);
DRAWICON(CROSS(大盘风险,个股风险),大盘风险-0.4,6);
PM:=个股趋势,COLOR0000FF,LINETHICK2;
K1:=BACKSET(个股趋势IF(K1,个股趋势,DRAWNULL), COLOR00CC33,LINETHICK4;
K2:=BACKSET(个股风险IF(K2,个股风险,DRAWNULL),CROSSDOT,COLORFF9900,LINETHICK2;
K3:=BACKSET(大盘风险IF(K3,大盘风险,DRAWNULL),CIRCLEDOT,COLOR0066FF,LINETHICK2;
K4:=BACKSET(大盘趋势IF(K4,大盘趋势,DRAWNULL),COLOR00FFFF,LINETHICK2;
DRAWTEXT(大盘趋势=0,80,'大底将现'),COLORFFFFCC;


{上证指数K线副图指标}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
上证:"999999$C",COLORWHITE,NODRAW;
_±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
五:MA("999999$C",5),COLORWHITE;
十:MA("999999$C",10),COLORYELLOW;
二十:MA("999999$C",20),COLORMAGENTA;
六十:MA("999999$C",60),COLORGREEN;


{大盘指数K线副图指标}
DRAWKLINE(INDEXH,INDEXO,INDEXL,INDEXC);
大盘:INDEXC,COLORWHITE,NODRAW;
±:INDEXC-REF(INDEXC,1),COLORLIGRAY,NODRAW;
沪深:"000300$CLOSE",NODRAW;
_±:"000300$CLOSE"-REF("000300$CLOSE",1),COLORLIGRAY,NODRAW;
五:MA(INDEXC,5),COLORWHITE;
十:MA(INDEXC,10),COLORYELLOW;
三十:MA(INDEXC,30),COLORMAGENTA;
六十:MA(INDEXC,60);

懒汉操盘

A1:=Ma(C,5);
A2:=MA(C,10); {可以自设均线,牛市21日线,熊市10日线}
A3:=(A1+A2)/2;
IF (A1>A2,A1,A3),COLORRED,LINETHICK2;
IF (A1>A2,A2,A3),COLORRED,LINETHICK2;
IF (A1<=A2,A1,A3),COLOR00FF00,LINETHICK2;
IF (A1<=A2,A2,A3),COLOR00FF00,LINETHICK2;
A3,COLORWHITE,LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
DRAWICON(CROSS(84,RSI) ,H*1.03,5);
DRAWICON(CROSS(RSI,11) ,L*0.99,4);
VAR27:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-VAR27,0),5.5,1)/SMA(ABS(CLOSE-VAR27),6,1)*100;
DRAWICON(IF(CROSS(76,VAR28),1,0),H*1.03,5);
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0
AND EMA(CLOSE,12)/LOW>1.15,5),
LOW,''),LINETHICK7 , COLORFF00FF;
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARF,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(AA>SS),H*1.02,''),LINETHICK7,COLORGREEN;
VAR1:=ZIG(3,10)REF(ZIG(3,10),2); {含未来函数ZIG}
VAR2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)STICKLINE(VAR1,C,O,8,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR1,C,O,3,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR1,H,L,1,0),COLORYELLOW,LINETHICK2;
STICKLINE(VAR2,C,O,8,0),COLORFF00FF,LINETHICK2;
STICKLINE(VAR2,C,O,3,0),COLORFF00FF,LINETHICK2;
STICKLINE(VAR2,H,L,1,0),COLORFF00FF,LINETHICK2;

这个公式可用于主图也可用于副图.


超人黄金
小鼹鼠
VAR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),10,1);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SMA(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),10,1);
VAR5:=SMA(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),10,1);
消息1:VAR4/VAR1*3;
消息2:VAR5/VAR1*3;
买入:IF(消息1>消息2,1,0) COLORSTICK;
卖出:IF(消息2>消息1,-1,0) COLORSTICK;
{新版股海神偷 副图}

AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
风险:80,COLORFF00FF;
狼狗:87.5,COLOR00FF00;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股海神偷:DD,COLOR0000FF,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
目标出现:IF(CROSS(股海,90) AND (股海神偷<40),70,0),COLORFFFF00;
跟踪:10,COLOR0000FF;
神偷出现:IF((COUNT((股海神偷>REF(股海神偷,1)),1)=1) AND (REF(股海神偷,1)

{股海神偷}
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5) ;
股经:J,COLORLIMAGENTA,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
跟踪:10,COLOR0000FF,LINETHICK1;
神偷出现:IF((COUNT((DD>REF(DD,1)),1)=1) AND (REF(DD,1)DRAWICON(CROSS(10,股经),5,1);
V1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
V2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
V3:=SMA(V2,2,1);
顶:100+(-ABS(V1)),COLORGRAY;
底:ABS(V1),COLORGRAY;

VR1:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VR2:=SMA(VR1,3,1);
VR3:=SMA(VR2,3,1);
VR4:=SMA(VR3,3,1);
VR5:=CROSS(VR3,VR4) AND VR3<20;
VR8:=CROSS(VR2,VR3) AND VR3>80 AND VR3>VR4;
VR9:=CROSS(VR4,VR3) AND VR3>80;
DRAWTEXT(FILTER(VR5,10)=1,21,'底'),COLORRED;
STICKLINE(FILTER(VR5,10)=1,0,20,2,0),COLORRED;
STICKLINE(FILTER(VR9,5)=1,80,100,2,0),COLORGREEN;
DRAWTEXT(FILTER(VR9,5)=1,79,'顶'),COLORGREEN;
STICKLINE(VR8,85,100,2,0),COLOR0099FF;

真实量比
VAR0:=100*(CLOSE-MA(AMOUNT/(100*VOL),5))/MA(AMOUNT/(100*VOL),5);
VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=((VAR1-EMA(VAR1,21))/STD(VAR1,21)*100+200)/4;
VAR3:=(EMA(VAR2,5)-25)*1.56;
VAR4:=EMA(EMA(VAR3,2)*1.22,2);
VAR5:=3*EMA(VAR3,2)*1.22-2*VAR4;
VAR6:=EMA((VAR1-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,13);
VAR7:=EMA(0.667*REF(VAR6,1)+0.333*VAR6,2);
VAR8:=EMA(VAR1,13)-EMA(VAR1,21);
VAR9:=2*(VAR8-EMA(VAR6,2))*3.8;
VAR10:=VAR9>REF(VAR9,1) AND VAR6 < 63 AND VAR7 < 63 AND EMA(VAR3,2)*1.22 < 63 AND VAR4 < 63 AND VAR5 < 63 AND CROSS(VAR5,EMA(VAR3,2)*1.22) AND FINANCE(33)> 0.01 AND FINANCE(34)> 1 AND REF(CLOSE,23)/CLOSE> 1.2 AND REF(CLOSE,10)/CLOSE < 1.5 ;
VAR11:=MIN(REF(CLOSE,2)*0.865,REF(CLOSE,13)*0.772);
VAR12:=IF((CLOSE-VAR11)/CLOSE < 4/100 AND SUM(100*VOL/CAPITAL,5)/5 < 1.8 AND WINNER(CLOSE)*100 < 0.1,1,0);
VAR13:=CLOSE < (MA(CLOSE,80)-MA(CLOSE,10)/3) AND VOL/240 > MA(VOL,5)/240 AND CLOSE > REF(CLOSE,1)*1.08 AND CLOSE < MA(CLOSE,13)*1.3;
VAR14:=VAR0<-10 AND CLOSE < 10 AND CLOSE/REF(CLOSE,1) > 0.935;
VAR15:=MA(CLOSE,3)-CLOSE-WINNER(OPEN)+(COST(55)-COST(45))/(COST(97)-COST(3))+(WINNER(C)-REF(WINNER(C),4))*0.05/MA(V/CAPITAL,5);
STICKLINE(VAR15>=0,0,VAR15,6,0),COLOR6600CC;
STICKLINE(VAR15<=0,0,VAR15,6,0),COLOR00FF99;
STICKLINE(VAR15<=0,0,VAR15*0.4,6,0),COLORCC0033;
STICKLINE(VAR15>=0,0,VAR15*0.4,6,0),COLORCC0033;
STICKLINE(VAR12 > 0 OR VAR10 > 0 OR VAR13 > 0 OR VAR14 > 0,0,0.6,6,0),LINETHICK4,STICK,COLOR0000FF;

这个横盘三十分我没有用过,不过在一分钟K线图下使用有买入提示。。

{回调整理}
{振幅 1,8,3; 量比 1,5,1; N 5,300,26; M 1,240,30; P 1,240,10}
H1:=CLOSE > MA(CLOSE,5);
H2:=MA(CLOSE,10) > MA(CLOSE,5);
H3:=MA(CLOSE,10) > MA(CLOSE,30);
H4:=MA(CLOSE,30) > REF(MA(CLOSE,30),1);
H5:=MA(CLOSE,10) > REF(MA(CLOSE,10),1);
HP3R:=(HHV(HIGH,3)-LLV(LOW,3))/LLV(LOW,3) < 振幅/100;
HP4R:=(HHV(HIGH,4)-LLV(LOW,4))/LLV(LOW,4) < 振幅/100;
HP5R:=(HHV(HIGH,5)-LLV(LOW,5))/LLV(LOW,5) < 振幅/100;
HP6R:=(HHV(HIGH,6)-LLV(LOW,6))/LLV(LOW,6) < 振幅/100;
HP7R:=(HHV(HIGH,7)-LLV(LOW,7))/LLV(LOW,7) < 振幅/100;
HP8R:=(HHV(HIGH,8)-LLV(LOW,8))/LLV(LOW,8) < 振幅/100;
HP9R:=(HHV(HIGH,9)-LLV(LOW,9))/LLV(LOW,9) < 振幅/100;
HP10R:=(HHV(HIGH,10)-LLV(LOW,10))/LLV(LOW,10) < 振幅/100;
HP11R:=(HHV(HIGH,11)-LLV(LOW,11))/LLV(LOW,11) < 振幅/100;
HP12R:=(HHV(HIGH,12)-LLV(LOW,12))/LLV(LOW,12) < 振幅/100;
HP312:=HP3R OR HP4R OR HP5R OR HP6R OR HP7R OR HP8R OR HP9R OR HP10R OR HP11R OR HP12R;
V3R:=LLV(VOL,3) / HHV(VOL,20) < 量比/10;
V4R:=LLV(VOL,4) / HHV(VOL,20) < 量比/10;
V5R:=LLV(VOL,5) / HHV(VOL,20) < 量比/10;
V35R:=V3R OR V4R OR V5R;
回调: H1 AND H2 AND H3 AND H4 AND H5 AND HP312 AND V35R;

{短暂整理}
{AA1:="EXPLORER.W回档";
A1:=REF(AA1,1)=1;
A2:=(C-REF(C,1))/REF(C,1)<0.03 AND (H-L)/REF(C,1)<0.06;
T1:=A1 AND A2;
T2:=REF(T1,1)=1 AND (C-REF(C,1))/REF(C,1)<0.03 AND (H-L)/REF(C,1)<0.06 ;
T3:=SLOPE(MA(C,5),2)*100>3;
短暂整理: (T1 OR T2) AND T3 AND C>MA(C,13);}

{天量,N,26,5,300}
AJ1:=MA(C,250)<=REF(MA(C,250),1);
AJ2:=CMA(C,250)*0.90;
AJ3:=MA(C,5)REF(MA(C,5),1);
A4:=CAPITAL/V/100>0.03;
XX:= (HIGH+LOW+CLOSE)/3;
A5:=SUM(MAX(0,HIGH-REF(XX,1)),N)/SUM(MAX(0,REF(XX,1)-L),N)*100>175;
TJ1:=AJ1 AND AJ2 AND AJ3 AND A4 AND A5;
B1:=V>MA(V,5)*3.33 AND V>REF(V,1)*2.5;
B2:=V>MA(V,5)*2.5 AND MA(V,5)>MA(V,10) AND MA(V,10)>MA(V,30);
TJ2:=B1 OR B2 OR V>REF(MA(V,3),1)*4 OR 100*V/CAPITAL>10;
TJ3:=TJ2 AND MA(C,5)>REF(MA(C,5),1) AND 100*V/CAPITAL>1;
天量:TJ1 OR TJ3;

{横盘30分,M,30,1,240;P,10,1,240}{这个公式分析周期是1分钟}
QA:="QQ引用.YYO#DAY";
QW:="QQ引用.YYH#DAY";
A1:=(HHV(H,M)-LLV(L,M))/MA(C,M)

A2:=BARSSINCE(C);
A3:=(HHV(H,A2)-LLV(L,A2))/QA<0.04;
AA4:=IF(A2>M AND A2>3,M,A2);
AA5:=1.5*ABS((HHV(INDEXH,AA4)-LLV(INDEXL,AA4))/QA)>ABS((HHV(H,AA4)-LLV(L,AA4))/QA);
A6:=COUNT(V>1,AA4)>AA4/5;
AA7:=(QA-LLV(L,A4))/QA<(QA-LLV(INDEXL,A4))/QA;

A8:=V>REF(HHV(V,A2),1) AND C>REF(QW,1);
AA1:=REF(A1,1) AND A3 AND AA5 AND A6;
AA:= AA1;
BB1:=COUNT(V>1,AA4)<3;
BB2:=(HHV(H,A2)-LLV(L,A2))/QA<0.002;
BB:=BB1 AND BB2;
强于大盘:=C/REF(C,1)>INDEXC/REF(INDEXC,1);
横盘30分:强于大盘 AND (AA OR BB) AND DYNAINFO(7)>=DYNAINFO(11);
扫黑马
VOL/240>REF(VOL,N)*1.2/240*1.5 AND CLOSE>LOW*1.06 AND CLOSE>REF(MA(CLOSE,3),1) AND
MA(CLOSE,3)>REF(MA(CLOSE,3),1) AND DYNAINFO(17)>=1.3;   n:1.1000.30  x:0.100.8
{夜雨VOL 副图 含WINNER函数}

VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
获利盘: WINNER(CLOSE)*100;
VAR33:=SMA(VAR22,3,1);
VAR44:=SMA(VAR33,9,1);
VAR55:=3*VAR33-2*VAR44;
VAR66:=VOL;
量比: VOL/MA(VOL,5);
涨跌: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
换手: VOL/CAPITAL*100;
VAR77:=SUM(换手,30);
VAR88:=LLV(INDEXL,5);
VAR99:=HHV(INDEXH,5);
VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);
VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);
VARCC:=MA(VARBB,30);
VARDD:=EMA(获利盘,4);
本盘亿股: CAPITAL/1000000,;
V5: MA(VOL,5)*2;
VARE:=MA(V5,3);
V34: MA(VOL,34)*2;
VARF:=(涨跌>VARDD AND 角度<-30 AND 涨跌>3);
CROSS(VARBB,VARCC) AND VARCC<29;
CROSS(VARCC,VARBB) AND VARCC>58;
STICKLINE(VOL AND VAR33>VAR44,0,VOL,3,1),COLORRED;
STICKLINE(VOL AND VAR33<=VAR44,0,VOL,3,1),COLORCYAN;
DRAWTEXT(CROSS(VARBB,VARCC) AND 角度<-18 AND VARCC<29,VOL*1.2,'买 '),COLORYELLOW;
W:DRAWTEXT(CROSS(VARCC,VARBB) AND VARCC>58,VOL*1.2,'卖'),COLORWHITE;
DRAWTEXT(CROSS(VARE,V5) AND 角度>22,V5,'<----');

VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,16)/SUM(VAR5,16);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,16);
VAR9:=EMA(VAR8,8);
VARA:=EMA(VAR8,45);
MO:=(VAR8-VARA);
ML:=(VAR9-VARA);
VAR1A:=EMA(CLOSE,32);
VAR2A:=MA(OPEN,32);
趋势:=(VAR1A-VAR2A);
STICKLINE(MO>ML AND 趋势<0 AND MO>REF(MO,3) AND 趋势>REF(趋势,3),VOL,0,3,0) COLORYELLOW;
{鬼双林 副图}

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),8,0),COLORRED;
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),8,0),COLORGREEN;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORRED;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORBLUE;

{布林线}
BOLL : MA(CLOSE,26),POINTDOT,COLORWHITE,LINETHICK2;
上: BOLL +2*STD(CLOSE,26),POINTDOT,COLORRED,LINETHICK2;
下: BOLL -2*STD(CLOSE,26),POINTDOT,COLORGREEN,LINETHICK2;

{多空布林线}
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORYELLOW;
空:BBI-3*STD(BBI,10),COLORWHITE;
A:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-3*A0,4,0),COLORWHITE;
DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-2.5*A0,'时间窗'),COLORWHITE;

{寻庄出击 副图}

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3;
段: VAR4;
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR5,10)=1,40,'逢低吸纳'),COLORYELLOW;
STICKLINE(FILTER(VAR5,10)=1,0,30,10,0),COLORRED;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR9,5)=1,80,100,10,0),COLORGREEN;
DRAWTEXT(FILTER(VAR9,5)=1,70,'减仓'),COLOR00FF00;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8,85,100,10,0),COLOR0099FF;
{100,COLORBBBBBB,LINETHICK3; }
0,,LINETHICK3;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
风险:80,COLORFF00FF;
小心:87.5,COLOR00FF00;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:DD,COLOR0000FF,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
目标出现B:IF(CROSS(股海,90) AND (股神<40),70,0),COLORFFFF00;
DRAWTEXT(CROSS(股海,90) AND (股神<40),75,'目标B出现'),COLORFFFF00;
跟踪:10,COLOR0000FF;
目标出现A:IF((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)DRAWTEXT((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)

{♀妹妹追哥哥 N1:1 100 5; M1:1 100 5}
A:=(C-MA(C,10))/MA(C,10)*(-1);
B:=(C-MA(C,30))/MA(C,30)*(-1);
操作线:MA(A-B,3),COLORFFCC66,LINETHICK2;
操作线8:MA(操作线,8),COLOR00FF00,LINETHICK2;
短均线差:=A-B,;
DRAWICON(CROSS(操作线,操作线8),操作线,1);
A1:=(C-MA(C,N1))/MA(C,N1)*(-1);
B1:=(C-MA(C,M1))/MA(C,M1)*(-1);
长均线差:=A1-B1,;
负差:=A-B,COLORF0F000,LINETHICK2;
STICKLINE(A-B>0,A-B,0,0.8,0),COLORRED;
STICKLINE(A-B<0,A-B,0,0.8,0),COLORGREEN;
AA:IF(操作线>0,A-B,0),COLORRED{,LINETHICK2};
BB:IF(A-B<0,A-B,0),COLORGREEN{,LINETHICK2};

{股神  副图}

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3;
段: VAR4;
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR5,10)=1,40,'抄底'),COLORRED;
STICKLINE(FILTER(VAR5,10)=1,0,30,10,0),COLORRED;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR9,5)=1,80,100,10,0),COLORGREEN;
DRAWTEXT(FILTER(VAR9,5)=1,70,'逃顶'),COLORGREEN;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8,85,100,10,0),COLOR0099FF;
100,COLORBBBBBB,LINETHICK3;
0,COLORGRAY,LINETHICK3;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
风险:80,COLORFF00FF;
小心:87.5,COLOR00FF00;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:DD,COLOR0000FF,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
买入时机B:IF(CROSS(股海,90) AND (股神<40),70,0),COLORFFFF00;
跟踪:10,COLOR0000FF;
卖出机会A:IF((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)

{股经X线6线  主图}

X1:EMA(C,7),COLOR0088FF;
X2:EMA(C,21),COLOR44BBFF;
X3:EMA(X2,21),COLOR0088FF;
X4:EMA(X3,27),COLOR009900;
X5:EMA(X2,100),COLORFFAA00;
X6:EMA(X5,100),COLOR009900;

{◎短线战神◎}

{N.1.100.19;其中19可在1---100之内调整}

指标:0,COLORRED;
TYP := (HIGH + LOW + CLOSE)/3;
战神CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),LINETHICK2;
STICKLINE(战神CCI<-200,战神CCI,战神CCI-150,10,150),COLORGREEN;
战神出世:IF(战神CCI<-200,180,0),STICK,LINETHICK2;
战神出世2:IF(战神CCI<-200,-198,0),STICK,LINETHICK2;
DRAWICON(战神出世,180,4);
DRAWTEXT(战神出世2,-200,'战神一出,短线可进'),,,COLORYELLOW;

{春暖花开 副图}

VAR1:=(CLOSE-OPEN)/OPEN*100;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),3,1)/SMA(ABS(CLOSE-VAR2),3,1)*100;
VAR4:=COUNT(VAR3<13,18)>=1;
VAR6:=O=L AND H=C;VAR7:=V < MA(V,3) AND V < REF(V,1);
P1:=(C/REF(C,1)-1);
P2:=SUM(P1,3)*SUM(P1,5)*SUM(P1,5)*SUM(P1,8)*SUM(P1,10)*SUM(P1,13)*SUM(P1,18);
P3:=3*P2;
P4:=SUM(P2,18)+0.00005;
A:=C>REF(C,1);
B:=(C-REF(C,1))/L*100;
LC := REF(CLOSE,1);
RSI:= SMA(MAX(C-LC,0),5,1)/SMA(ABS(CLOSE-LC),3,1)*100;
A4 := COUNT(RSI<13,21)>=1;
春:VAR6 AND VAR7 AND COUNT(VAR6 AND VAR3,13)=3,COLOR00FF00 ;
暖:VAR1>4.88 AND VAR4 AND CROSS(P3,P4),COLORF00FF0;
花:A4 AND B>7  AND REF(L,1);

{新庄杀手 副图 含WINNER函数}
{    最小  最大  缺省
M1   3     10    5
M2   5     20    10
M3   10    40    20 }
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
看(我)实力:=(100-VARA),COLOR0099FF,LINETHICK2;
散户: MA(WINNER(CLOSE*0.95)*100,3),COLORYELLOW, ;
新庄: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0)),COLORGREEN , ;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
小心断裂:(IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50),COLORCC9900 ,LINETHICK2 ,CROSSDOT;
STICKLINE(VARD,VAR4,散户,5,0),, ;
STICKLINE(1,散户,0,1,0),COLORYELLOW , ;
STICKLINE(1,新庄,100,1,0),COLORGREEN, ;
STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,60,'有钱不赚是傻蛋!'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,70,'赚钱我走啦!'), , ;
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
波段王: SMA(VAR28,3,1),COLORFF00FF,LINETHICK2;
波段鬼: SMA(波段王,3,1),COLORYELLOW,LINETHICK2;
地狱:IF(CROSS(波段王,波段鬼) AND 波段王<40,35,0),COLOR0066FF ,LINETHICK2 ;
天堂:IF(CROSS(波段鬼,波段王) AND 波段鬼>75,70,100),COLORGREEN ,LINETHICK2 ;
DRAWTEXT(CROSS(波段王,波段鬼) AND 波段王<40,25,'逢低吸呐 !'),COLORWHITE , ;
DRAWTEXT(CROSS(波段鬼,波段王) AND 波段鬼>75,85,'逢高减磅!'),COLORFFFF00 , ;

{散户线}
{M 3,100,60; N  3,100,30}
散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M));
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
主力线:EMA(J,6),COLORYELLOW;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
吸筹:STICKLINE(VAR9>-120,0,VAR9,2,5),COLORMAGENTA;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK2;
AA6:=SMA(AA3,21,8);
买观注: STICKLINE(走势-AA6<-65,0,7,15,1);
DRAWICON(FILTER(J>REF(J,1)AND 走势>=REF(走势,1)AND 走势<25 ,5),走势,4);
卖观注: STICKLINE(走势-AA6>85,98,90,15,1),COLORFFFF00;
DRAWICON(FILTER(J85 ,5),J,5);

阻力位
强阻力:(HIGH+LOW+OPEN+2*CLOSE)/5+H-L,STICK;
阻力位:(HIGH+LOW+OPEN+2*CLOSE)/5*2-L,STICK;
平衡点:(HIGH+LOW+OPEN+2*CLOSE)/5,STICK;
支撑位:(HIGH+LOW+OPEN+2*CLOSE)/5*2-H,STICK;
强支撑:(HIGH+LOW+OPEN+2*CLOSE)/5-H+L,STICK;
{分时公式 主图}

A1:(EMA(C,3)+EMA(C,9)+EMA(C,27))/3,COLORFFAA99;
A2:(EMA(C,6)+EMA(C,18)+EMA(C,54))/3,COLORFFAA55;
A3:(EMA(C,9)+EMA(C,27)+EMA(C,81))/3,COLORFFAA00;
A4:(EMA(C,12)+EMA(C,36)+EMA(C,108))/3,COLORFFBB00;
A5:(EMA(C,15)+EMA(C,45)+EMA(C,135))/3,COLORFFBB55;
A6:(EMA(C,18)+EMA(C,54)+EMA(C,162))/3,COLORFFBB99;
A7:(EMA(C,21)+EMA(C,63)+EMA(C,189))/3,COLORFFCC00;
A8:(EMA(C,24)+EMA(C,72)+EMA(C,216))/3,COLORFFCC55;
A9:(EMA(C,27)+EMA(C,81)+EMA(C,243))/3,COLORFFCC99;
A10:(EMA(C,30)+EMA(C,90)+EMA(C,270))/3,COLORFFDD00;
A11:(EMA(C,33)+EMA(C,99)+EMA(C,297))/3,COLORFFDD55;
A12:(EMA(C,36)+EMA(C,108)+EMA(C,316))/3,COLORFFDD99;
A13:(EMA(C,39)+EMA(C,117)+EMA(C,351))/3,COLORFFEE00;
A14:(EMA(C,42)+EMA(C,126)+EMA(C,378))/3,COLORFFEE55;
A15:(EMA(C,45)+EMA(C,135)+EMA(C,405))/3,COLORFFEE99;
A16:(EMA(C,48)+EMA(C,144)+EMA(C,432))/3,COLORFFFF00,LINETHICK2;
{A17:(EMA(C,51)+EMA(C,153)+EMA(C,459))/3,COLORCYAN,LINETHICK2;};

{捕捉分时起涨点 副图}
{N 1 , 20, 13; M , 20,13; P , 30, 25}

A:=3*SMA((CLOSE-LLV(LOW,P))/(HHV(HIGH,P)-LLV(LOW,P))*100,M,1)-2*SMA(SMA((CLOSE-LLV(LOW,P))/(HHV(HIGH,P)-LLV(LOW,P))*100,M,1),3,1); 
B:=N;  
信号:IF(CROSS(A,B),1,0);

{绝岭霹雳 主图}

操作线:EMA(C,7),COLORRED;
A:=(REF(操作线,1));
STICKLINE((操作线>A),A,操作线,6,0),COLOR0000FF;
STICKLINE((操作线<=A),A,操作线,6,0),COLOR00FF00;
VARA:=IF((CLOSE>150),91.3,0.91299998);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
绝岭霹雳:BBI+2*STD(BBI,10),COLORYELLOW,LINETHICK5;
A1:=MA(C,2);
A3:=(A1+绝岭霹雳)/2;
A3,COLORWHITE,LINETHICK2;
VARC:=EMA(HIGH,21)/HIGH*CLOSE;
警戒:EMA(VARC,21)*1.18,COLORFF9900,LINETHICK2;
H20:HHV(H,20),COLORWHITE,LINETHICK2;
Y:=CYC(1);
U1:=CYC(5);
主力:CYC(8),COLORFF00FF,LINETHICK3;
U3:=CYC(13);
XX1:=U1>主力 AND 主力>U3;
C5:=IF(XX1>0,LLV(U1, 5),HHV(主力,5));
C8:=IF(XX1>0,LLV(主力, 8),HHV(主力,5));
C13:=IF(XX1>0,LLV(U3, 13),HHV(主力,5));
散户:LLV(主力, 8),COLORGRAY,LINETHICK3;
雷达:DYNAINFO(7),COLORBLUE;
{DRAWTEXT(散户=REF(散户,1),散户,' ┬ '),COLORYELLOW;
DRAWTEXT(REF(散户,1)DRAWLINE(散户R1:=C;
R2:=LLV(LOW,45);
R3:=HHV(HIGH,45);
Y1:=C;
Y2:=LLV(LOW,144);
Y3:=HHV(HIGH,144);
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
RSVR:=((R1-R2)/(R3-R2))*100;
KR:=SMA(RSVR,3,1);
DR:=SMA(KR,3,1);
RSVY:=((Y1-Y2)/(Y3-Y2))*100;
KY:=SMA(RSVY,3,1);
DY:=SMA(KY,3,1);
X1:=CYC(8);
X2:=CYC(13);
X3:=CYC(21);
XX:=C>X2 AND C>X2;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
DIFF:= EMA(CLOSE,8) - EMA(CLOSE,21);
DEA:= EMA(DIFF,8);
MACD:= 2*(DIFF-DEA);
J13:=CYC(8)-CYC(21);
K13:=SMA(J13,3,1);
D13:=SMA(K13,3,1);
MACD13:=4*(K13-D13);
JS:= MACD>0 AND K>D AND RSI1>50  AND DR<60 AND DY<60 AND XX>0 AND MACD13>0 AND MACD13>REF(MACD13,1);
XG:= JS>0 AND CROSS(K,D) AND CROSS(MACD,0)AND MA(V,5)>MA(V,40);
短:=D;
短1:=REF(D,1);
中:=DR;
中1:=REF(DR,1);
长:=DY;
长1:=REF(DY,1);
AAA:=CROSS(D,REF(D,2))AND 短1<50 AND DR>REF(DR,1)AND DY>REF(DY,1) AND D<30 AND DR<20 AND DY <20 ;
黄:=IF(AAA>0,50,0);
白:=IF(XG>0,30,0);
IF (A1>绝岭霹雳,A1,A3),COLORBLUE,LINETHICK2;
{IF (A1>绝岭霹雳,绝岭霹雳,A3),COLORBLUE,LINETHICK2;}
IF (A1<=绝岭霹雳,A1,A3),COLOR00FF00,LINETHICK2;
{IF (A1<=绝岭霹雳,绝岭霹雳,A3),COLOR00FF00,LINETHICK2;}
DRAWTEXT(黄>0 ,LOW*0.999,'O'),COLORYELLOW;
DRAWTEXT(白>0 ,LOW*0.999,'O'),COLORWHITE;


筹码雷达
PJJ:=MA(CLOSE,5);
PJC:=MA(MA(CLOSE,20),5);
KL:=((PJJ-REF(PJJ,1))/REF(PJJ,1))*1000;
KU:=((PJC-REF(PJC,1))/REF(PJC,1))*1000;
KM:=KL-KU;
KK:=IF(KLKL1:=KL+50;
KK1:=KK+50;
集散上轨:=IF(MAX(KL1,KK1)>100,100,MAX(KL1,KK1));
集散下轨:=IF(MIN(KL1,KK1)<0,0,MIN(KL1,KK1));
短线活筹百分比:=(集散上轨+集散下轨)/2;
短线筹码集散:(集散上轨-集散下轨)*2.5,STICK;
短线筹码进出:=短线活筹百分比-50;
强弱系数:短线筹码进出*2.5;
PT:IF(REF(集散下轨,1)<17 AND C=LLV(C,7),50,0),COLORRED,LINETHICK2;
控盘成本
MA(CLOSE,2), , COLORWHITE;
MA(CLOSE,4), , COLORYELLOW;
生命: MA(CLOSE,15), , COLORRED;
顶: COST(95), , COLORMAGENTA;
拉升: COST(75), , COLORMAGENTA;
控盘成本: COST(30), , COLORCYAN;
主力成本: COST(4), , COLORGREEN;
底: COST(0.05), , COLORWHITE;
VAR2:=WINNER(CLOSE);
VAR3:=DMA(VAR2,VOL/CAPITAL);
VAR4:=DMA(VOL,VOL/CAPITAL)/CAPITAL;
VAR5:=VAR2/VAR4;
VAR6:=VAR3/VAR4;
STICKLINE(VAR5>VAR6 AND 100*WINNER(CLOSE)>50,CLOSE,OPEN,8,1), , COLORWHITE;
VAR7:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR7>50 AND COST(85)< CLOSE,CLOSE,OPEN,8,1), ,  COLORCYAN;
STICKLINE(VAR7>50 AND COST(85)< CLOSE,CLOSE,OPEN,2.5,0), , COLORMAGENTA;
控盘度
VAR3:=(CLOSE+HIGH+LOW)/3;
VAR4:=EMA(EMA(EMA(VAR3,1),13),21);
控盘度:(VAR4-REF(VAR4,1))/REF(VAR4,1)*100,,COLORSTICK,LINETHICK7;DRAWTEXT(CROSS(控盘度,0),0.2,'我是股医生')COLORRED;
这是第二天的股价预测,据此在盘中可掌握股价变动情况作出买卖决断。

{股价预测 }
OO:=REF(OPEN,1);
HH:=REF(HIGH,1);
CC:=REF(CLOSE,1);
LL:=REF(LOW,1);
JC:=HH-LL;
CDP:=(HH+LL+CC*2)/4;
强阻力价:CDP+JC;
阻力价:2*CDP-LL;
支撑价:2*CDP-HH;
强支撑价:CDP-JC;

此公式可把它拷贝到任何一个主图公式中作参考。

如果收盘后要对明天的股价作一个预示,可更改如下:

{股价预示 }
OO:=OPEN;
HH:=HIGH;
CC:=CLOSE;
LL:=LOW;
JC:=HH-LL;
CDP:=(HH+LL+CC*2)/4;
明日强阻力价:CDP+JC;
明日阻力价:2*CDP-LL;
明日支撑价:2*CDP-HH;
明日强支撑价:CDP-JC;

加入盘中虚拟
动态市盈:C/FINANCE(33),COLOR16CDEC,LINETHICK0 ;
量能饱和:(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100,NODRAW;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MA5:MA(VOLUME,M1),COLORWHITE ;
MA10:MA(VOLUME,M2),COLORYELLOW ;
MA20:MA(VOLUME,M3),COLOR00FF00;
AHC2:=(HIGH - LOW);
AHC3:=ABS((OPEN - CLOSE));
AHC4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
AHC5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
AHC6:=((AHC3 / AHC2) * VOL);
AHC7:=((AHC4 / AHC2) * VOL);
AHC8:=((AHC5 / AHC2) * VOL);
AHC9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
AHCA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
AHCB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
AHCC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
相对地量:STICKLINE(((AHC9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,5,0),,COLOR00FFFF;
地量:DRAWTEXT(((AHC9 > 2) AND (VOL < (MA(VOL,5) / 2))),VOL,'地量'),COLOR00FFFF;
放量:STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0),,COLORFFFFFF;
高出:DRAWTEXT(((((((((AHC7 > AHC6) AND (AHCA > 2)) AND (AHC7 > AHC8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (AHC7 >= MA(VOL,5))),VOL,'高出'),COLOR00FF00;
低进:DRAWTEXT(((((((AHC8 > AHC6) AND (AHC8 > AHC7)) AND (AHCA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (AHC8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'低进'),COLORFF00FF;
强势参与:DRAWTEXT((((((AHC6 > (MA(VOL,5) * 2)) AND (AHC6 >= AHC7)) AND (AHC6 >= AHC8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND AHCB)),VOL,'参与'),,COLOR00FF00;
空头释放:DRAWTEXT(((((((AHC6 >= AHC7) AND (AHC6 >= AHC8)) AND (CLOSE < OPEN)) AND ((AHC6 / VOL) > 0.7)) AND AHCC) AND (AHC6 > MA(VOL,5))),(AHC6 * 1),'空头释放'),,COLOR00FF00;

{昊晨绝品  (副)}
{此公式尚未完成,仅供参考。风险自负。}
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
VC1:=AMOUNT/VOL;
VD1:=LVE1:=(C-REF(C,1))/REF(C,1)*100>1.2;
VF1:=LVG1:=VOLVH1:=VD1 AND VE1 AND VF1 AND VG1,LINETHICK0;
V10:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
V11:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
V12:=V10REF(VOL,1) AND CLOSE>REF(CLOSE,1);
V13:=(C-REF(C,1))/REF(C,1)*100<1.02;
V14:=H>MA(C,5)*1.12;
AA:= V13 AND V14;
大盘资金进场: IF(VB>=0,VB,0),COLORYELLOW;
VAH:=CROSS(MA(C,5),MA(C,20)) AND  CROSS(MA(C,5),MA(C,30)) AND CROSS(MA(C,5),MA(C,60));
VBI:=MA(C,60)>MA(C,10) AND CROSS(MA(C,10),MA(C,30)) AND MA(C,30)>MA(C,20) AND ABS(MA(C,60)-MA(C,20))/MA(C,20)<0.05;
VCG:=MA(C,30)>MA(C,5) AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,10), COLORYELLOW;
VDK:=ABS((MA(C,5)-MA(C,10))+(MA(C,10)-MA(C,20))+(MA(C,20)-MA(C,30)))<0.02 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
VEL:=MA(C,20)>MA(C,5) AND CROSS(MA(C,5),MA(C,10)) AND MA(C,10)>MA(C,60) AND ABS(MA(C,20)-MA(C,60))/MA(C,60)<0.05;
VFM:=VAH OR VBI OR VCG OR VDK OR VEL ;
资金异动:=VFM AND FILTER( VFM,8),LINETHICK0;
V15:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
V16:=V15>9 AND FILTER(V15< REF(V15,1),5),COLOR8CFF00;
V17:=V15>20 AND FILTER(V15< REF(V15,1),5),COLOR00FF00;
V18:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,COLORFF937F;
V19:=REF(CLOSE,1);
V20:=((SMA(MAX((CLOSE - V19),0),3,1) / SMA(ABS((CLOSE - V19)),3,1)) * 100);
V21:=REF(CLOSE,2);
AT2:=SMA(MAX(CLOSE-V21,0),7,1)/SMA(ABS(CLOSE-V21),7,1)*100, , COLORGREEN;
超卖1:=IF(AT2<12,30,0);
V22:=REF(CLOSE,1);
V23:=SMA(MAX(CLOSE-V22,0),7,1)/SMA(ABS(CLOSE-V22),7,1)*100;
超卖2:=IF(V23<12,30,0);
抄底资金进入:=超卖1 AND 超卖2;
主力撤: IF(V4<=0,V4,0),COLORCYAN;
主力进: IF(V4>=0,V4,0),COLORRED,LINETHICK2;
抄底资金: STICKLINE(抄底资金进入,0,-5,2,0),COLORRED;
DRAWTEXT(V12 AND COUNT(V12,30)=1,15,'有大资金进 关注!'),LINETHICK1,COLORFF00FF;
DRAWTEXT(V16,L*2.00,'短顶'),COLOR00FF00;
DRAWTEXT(V17,L*3.50,'大顶'),COLOR00FF00;
DRAWTEXT(资金异动,L*0.99,'资金异动'),COLORYELLOW;
DRAWTEXT(VH1,L*0.99,'小资金流入'),COLOR00FF00;
DRAWTEXT(V18,H*3.05,'牛股'),COLOR00FFFF;
DRAWTEXT(CROSS(85,V20),(HIGH * 1.02),'回调!'),COLORFFFFFF;
DRAWTEXT(AA,H*1.05,'小资金撤离'),COLOR00FFFF;
DRAWTEXT(抄底资金进入,-8,'抄底资金进入'),COLORRED;

红买黄卖
{N  1  100  15     P   0  20  2 }

MID :  MA(CLOSE,N);
UPPER: MID + P*STD(CLOSE,N);
LOWER: MID - P*STD(CLOSE,N);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
{STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),6,1),COLORMAGENTA;}
DRAWICON(VAR19,L*0.98,1);
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
{STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),6,1),COLORYELLOW;}
DRAWICON(VAR1A,H*1.02,2);

绝地反击

Var2:=llv(low,3)<=llv(low,60);
Var3:=  c>o and (c/o>1.03 or c>1.03*ref(C,1));
绝地反击:if(Var2 and Var3,5,0),colorred,linethick2;
—————————————————————————————————————————————
本公式看似简单,但却是按于理义教授的上涨定式编写的.如图所示,它能较为准确地指出波段的买点.

使用本公式的玄机是:

1.和"波段高手",布林线,或薛斯通道等指标一起使用,它能给这些通道指标标明准确的买点.

2.如果将公式稍加改变,使其参数可调,则可大大提高其成功率.如:

Var2:=llv(low,3)<=llv(low,N);
Var3:=  c>o and (c/o>M or c>=M*ref(C,1));
绝地反击:if(Var2 and Var3,5,0),colorred,linethick2;

N可选60,90,120,直至240;
M可选1.03,1.05,1.08,直至涨停.
但是,出现的信号量会因此而降低.如果一年只做两三波行情,参数可设成:N,120   M,1.08.
喜欢做波段的,参数可设成:N,60    M,1.03
好指标送大家
买入:CLOSE/COST(45)>0.89,STICK,LINETHICK2,COLORRED;
{进场加仓洗盘 副图含WINNER}
AA:=WINNER(CLOSE+CLOSE*15/100)*100;
BB:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=AA-BB;
DD:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
EE:=CC<3 AND DD<0.5 AND OPEN!=LOW;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGHA3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR EE,10,0);
进场:STICKLINE(A11,0,5,5,0),COLORFF7700;
加仓:STICKLINE(A12,0,15,5,0),COLORFF00FF;
{STICKLINE(A11,0,5,5,0),COLORFF7700;
STICKLINE(A11,0,5,4.5,0),COLORFF8800;
STICKLINE(A11,0,5,4,0),COLORFF9900;}
STICKLINE(A11,0,5,3.5,0),COLORFFAA00;
STICKLINE(A11,0,5,3,0),COLORFFBB00;
{STICKLINE(A11,0,5,2.5,0),COLORFFCC00;}
STICKLINE(A11,0,5,2,0),COLORFFDD00;
STICKLINE(A11,0,5,1,0),COLORFFEE00;
{STICKLINE(A12,0,15,4.5,0),COLOR102099;
STICKLINE(A12,0,15,4,0),COLOR1020AA;}
STICKLINE(A12,0,15,3.5,0),COLOR1020BB;
STICKLINE(A12,0,15,3,0),COLOR1020CC;
{STICKLINE(A12,0,15,2.5,0),COLOR1020DD;}
STICKLINE(A12,0,15,2,0),COLOR1020EE;
STICKLINE(A12,0,15,1,0),COLOR1020FF;
买盘:=EMA(IF(CLOSE>OPEN,VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*(HIGH-LOW),IF(CLOSE卖盘:=EMA(IF(CLOSE>OPEN,0-VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE和盘:=SMA((SMA((买盘+卖盘),2,1)*6.8),3,1);
TR := SUM(MAX(MAX((HIGH+CLOSE)/2-LOW,ABS((HIGH+CLOSE)/2-REF((CLOSE+LOW)/2,1))),ABS(LOW-REF((CLOSE+LOW)/2,1))),10);
HD :=HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),10);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),10);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
卖盘1:(3*SMA((SMA((买盘+卖盘),2,1)*6.8),3,1)+(PDI-MDI))/4;
IF(卖盘1>-8,卖盘1,-8),COLORF00FF0;
VAR1:=REF((LOW+OPEN+(CLOSE+LOW)/2+(HIGH+CLOSE)/2)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),8,1);
VAR3:=MA(VAR2,13);
VAR4:=LLV(LOW,21);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
洗盘:IF(VAR5STICKLINE(VAR5VAR1C:=EMA(100*((CLOSE+LOW)/2-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)),13)/4;
VAR1D:=EMA((CLOSE+LOW)/2,2)-EMA((CLOSE+LOW)/2,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*5;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR21:=SQRT(SQRT(LOW*HIGH*OPEN*(CLOSE+LOW)/2));
VAR22:=EMA(VAR21*0.97,3);
VAR23:=(HIGH+LOW+(CLOSE+LOW)/2)/3;
VAR24:=(VAR23-MA(VAR23,13))/(0.015*AVEDEV(VAR23,13));
庄拉线:=IF(LOW0.015,VAR20,0)/45;
VAR26:=EMA((CLOSE+LOW)/2,2)-EMA((CLOSE+LOW)/2,120);
VAR27:=EMA(VAR26,89);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF( VAR28>0.1,VAR29,0)*2;
量价线:=((CLOSE+LOW)/2-EMA((CLOSE+LOW)/2,21))/EMA((CLOSE+LOW)/2,21)*100;
庄线:=(量价线+3*黑马线+6*庄拉线)/10;
VAR2E:=IF(FILTER(量价线>0 AND 量价线<2,3)=1,1,0);
涨幅:IF(FILTER(庄线>0 AND 庄线<2 AND VAR2E AND VAR1C<10.38,13)=1,1,0);
选股:IF(FILTER(VAR2E>0 AND VAR1C<10.38 AND 庄线>0 AND 庄线<2 AND VAR2E>0,8)=1,1,0);

{庄拉主升浪}

VAR3:=LLV(HIGH,240);
VAR4:=((100 * (CLOSE - VAR3)) / VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=((100 * (CLOSE - VAR5)) / (VAR6 - VAR5));
VAR8:=(((CLOSE - LLV(CLOSE,981)) / (HHV(CLOSE,981) - LLV(CLOSE,981))) * 100);
VAR9:=(((CLOSE - LLV(CLOSE,393)) / (HHV(CLOSE,393) - LLV(CLOSE,393))) * 100);
VARA:=(((CLOSE - LLV(LOW,981)) / (HHV(HIGH,981) - LLV(LOW,981))) * 100);
VARB:=(((CLOSE - LLV(LOW,393)) / (HHV(HIGH,393) - LLV(LOW,393))) * 100);
VARC:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),5) / 4);
VARD:=IF((DATE < 1031231),IF((VARC > 23.16),VARC,0),0);
VARE:=(VARC < 1);
VARF:=VARD;
VAR10:=((VAR4 < 0) AND (VAR7 < 0));
VAR11:=1;
VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4) * VAR11);
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4) * VAR11);
VAR16:=(((EMA(VAR15,89) - 25) * 1.56) * VAR11);
VAR17:=((EMA(VAR16,5) * 1.22) * VAR11);
VAR18:=(EMA(VAR17,3) * VAR11);
VAR19:=((3 * VAR17) - ((2 * VAR18) * VAR11));
VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0);
VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0);
买点:IF((FILTER(((((VAR8 = 0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),COLORRED;
卖点:IF((FILTER((((VAR8 = 100) AND VARF) AND VAR1B),5) = 1),10,0),COLORGREEN;
VAR1C:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),13) / 4);
VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89));
VAR1E:=EMA(VAR1D,30);
VAR1F:=((2 * (VAR1D - VAR1E)) * 10);
VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2));
VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR22:=EMA((VAR21 * 0.97),3);
VAR23:=(((HIGH + LOW) + CLOSE) / 3);
VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14)));
VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45);
庄拉线:VAR25,COLORYELLOW;
VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150));
VAR27:=EMA(VAR26,100);
VAR28:=(2 * (VAR26 - VAR27));
VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1));
VAR2A:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR2B:=EMA((VAR2A * 0.97),3);
VAR2C:=(((HIGH + LOW) + CLOSE) / 3);
VAR2D:=((VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14)));
黑马线:(IF((VAR28 > 0.1),VAR29,0) * 5),COLORRED;
量价线:(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),COLORFFFFFF;
VAR2E:=IF((FILTER(((量价线 > 0) AND (量价线 < 3)),5) = 1),12,0);
涨幅前兆:=IF((FILTER(((((庄拉线 > 0) AND (庄拉线 < 0.5)) AND VAR2E) AND (VAR1C < 3)),10) = 1),10,0),COLORFFFFFF;
选股利器:=IF((FILTER((((((((VAR2E > 0) AND (VAR1C < 2)) AND (庄拉线 > 0)) AND (庄拉线 < 1)) AND (黑马线 > 0)) AND (黑马线 < 1.5)) AND (VAR2E > 0)),5) = 1),10,0),COLORFF00FF;
DRAWICON((买点 > 0),10,1);
DRAWICON((卖点 > 0),10,2);
DRAWICON((涨幅前兆 > 0),10,1);
DRAWICON((选股利器 > 0),10,1);
量价先行:=(10 * CROSS(量价线,0)),COLORFFFF00;
DRAWICON((量价先行 > 0),10,11);
拉升开始:(15 * (((((((庄拉线 > 0.1) AND (COUNT((庄拉线 > 0.1),2) = 1)) AND (CLOSE >= OPEN)) AND (VOL > REF(VOL,1))) AND ((VOL / CAPITAL) > 0.003)) AND (量价线 > 1)) AND (量价线 > 黑马线))),LINETHICK2,COLOR00FFFF;
DRAWICON((拉升开始 > 0),15,10);
量价主升浪:(20 * FILTER((CROSS(量价线,黑马线) AND (庄拉线 > 0.5)),7)),LINETHICK3,COLORFF00FF;
DRAWICON((量价主升浪 > 0),20,8);
庄拉主升浪:(30 * ((CROSS(庄拉线,黑马线) AND (黑马线 > 0)) AND (量价线 > 0))),LINETHICK3,COLORFF00FF;
DRAWICON((庄拉主升浪 > 0),30,8);

{〖冲天炮〗}

REF(INDEXC,1)1.05
AND REF(C,1)0 AND O<=REF(C,1) AND C>REF(O,1)
AND REF(VOL,1)

{主力仓位 副图含WINNER}

活筹: (100*WINNER(REF(CLOSE,1)*1.1)-100*WINNER(REF(CLOSE,1)*0.9));
死筹: 100*WINNER(CLOSE),  COLORGREEN;
主力筹码: 100*WINNER(CLOSE*0.9), COLORCYAN;
获利3: 100*WINNER(CLOSE*0.97), COLORRED;
获利20: 100*WINNER(CLOSE*0.9*0.9), COLORMAGENTA;
获利30: 100*WINNER(CLOSE*0.9*0.9*0.9), COLORWHITE;
穿透筹码: (100*WINNER(CLOSE)-100*WINNER(REF(CLOSE,1)*1)), COLORWHITE;     
AA: REF(主力筹码<30,1) AND 主力筹码>30;
QW: LOW< COST(4) AND CLOSE>COST(4);
STICKLINE(获利3>85,0,获利3,8,0), COLORRED;
STICKLINE(主力筹码>30,0,主力筹码,8,1), COLORGREEN;
STICKLINE(获利20>20,0,获利20,8,1),COLORMAGENTA;
STICKLINE(获利30>20,0,获利30,8,1),COLORWHITE;

{光棍翻脸 副图}

VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,8);
VARD:=EMA(VARC,5);
频约娇媚: STICKLINE(VARC>0 AND VARC-VARD>=0,79,80,6,0),COLORYELLOW;
连得龙子: STICKLINE(VARC>0 AND VARC-VARD<0,79,80,6,1),COLORBLUE;
只赚不赔: STICKLINE(VARC>0 AND VARC-VARD>=0,19,20,6,0),COLORRED;
STICKLINE(VARC>0 AND VARC-VARD>=0,49,50,6,0),COLORFFFF00;
STICKLINE(VARC>0 AND VARC-VARD<0,49,50,6,1),COLOR9A9A00;
吃么香香: STICKLINE(VARC>0 AND VARC-VARD<0,19,20,6,1),COLOR00FFAA;
游戏玩法: STICKLINE(VARC-VARD>0,VARC,VARD,8,1),COLORFF00FF;
延年益寿: STICKLINE(VARC-VARD<0,VARC,VARD,8,1),COLOR00FF00;

{永不套牢 副图}

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J1:=DIFF;
J2:=DEA;
J3:=K;
J4:=D;
VL:=REF(LOW,1); VH:=REF(H,1);
VAR1:=SMA(ABS(H-VH),13,1)/SMA(MAX(H-VH,0),13,1)*100;
VAR2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
VAR3:=REF(CLOSE,1);
VAR4:=MA(VAR2,13);
VAR5:=LLV(L,34);
VAR6:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;
VAR7:=CROSS(93,VAR6);
VAR8:=EMA(IF(L<=VAR5,VAR4,0),3);
VAR9:=H>LLV(L,0)*7;
VAR10:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
VAR11:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (VAR10 * 10.9);
T:FILTER(IF(VAR11<=VAR10 AND VAR8>REF(VAR8,1),VAR8*8,0),20),LINETHICK4,STICK,COLORFF00FF;
T0:FILTER(IF(CROSS(J4,J3) AND SUM(J1>REF(J1,1),3)>3,CROSS(J4,J3) AND CROSS(J2,J1),0),13),STICK,COLOR5E8262,LINETHICK3;
T1:FILTER(CROSS(J1,J2) AND VOL>REF(SUM(VOL,5),1),3),STICK,COLOR00FFFF,LINETHICK3;
T2:FILTER(VAR7 AND C/(REF(C,1)-1)*100!=5 AND VAR9 AND VOL>REF(SUM(VOL,3),1),5),STICK,COLORFFFF00,LINETHICK3;
T3:FILTER(VAR9 AND CROSS(J4,J3) AND C/(REF(C,1)-1)*100!=5,22),STICK,COLOR00FF00,LINETHICK3;
DRAWTEXT(T0,T0,'注意洗盘'),COLOR5E8262;
DRAWTEXT(T,T*0.90,'洗盘结束'),COLORFF00FF;
DRAWTEXT(T1,T1*0.90,'主力加速'),COLOR00FFFF;
DRAWTEXT(T2,T2*0.90,'庄家逃跑'),COLORFFFF00;
DRAWTEXT(T3,T3*0.90,'风险'),COLOR00FF00;

{九阴真经 副图含CAPITAL}

VAR1:=REF(HIGH,1)*1.1;
VAR2:=REF(HIGH,10)*1.1;
VAR3:=HIGH*1.1;
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9;
VAR6:=LOW*0.9;
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);
VAR9:=EMA(VAR4,30);
VARA:=VAR9-2;
VARB:=IF(CLOSE<=VAR8,VARA,VAR9);
异动: VARB;
预警: VARA,COLORRED;
DRAWICON(异动=预警,预警,6);
异动*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));

{专测大盘  副图}

LC:=REF(CLOSE,1);
动力1:EMA(EMA((SUM(IF(INDEXC>LC,VOL,0),42)/SUM(IF(INDEXC<=LC,VOL,0),42)),5),2)*100,COLORGRAY,LINETHICK2;
动力2:EMA(EMA((SUM(IF(INDEXC>LC,VOL,0),55)/SUM(IF(INDEXC<=LC,VOL,0),55)),5),2)*100,COLORD49D56,LINETHICK2;
STICKLINE(CROSS(250,动力1),350,400,9,0),COLOR00FF00;
STICKLINE(CROSS(400,动力1),300,400,9,0),COLORFF00FF;
关注:IF(动力1<70,70,50),LINETHICK2,COLORFFCC66;
WVAD10:=MA((INDEXC-INDEXO)/(INDEXH-INDEXL)*VOL,10)/1000+50;
真金:IF(CROSS(WVAD10,50) AND 关注>50 AND 动力1<400 AND ZIG(1,19)>REF(ZIG(1,19),1),200,50),LINETHICK2,COLORBLUE;
白银:IF(CROSS(WVAD10,50) AND 动力1<400 AND ZIG(1,19)>REF(ZIG(1,19),1),150,50),LINETHICK2,COLORYELLOW;
铜钱:IF(CROSS(WVAD10,50),100,50),LINETHICK2,COLORRED;
VAR2:=(INDEXC+INDEXH+INDEXL)/3;
VAR3:=EMA(VAR2,10);
VAR4:=REF(VAR3,1);
{持股:}STICKLINE(VAR3>VAR4,258,288,2,0),COLOR0066FF,LINETHICK2;
{持币:}STICKLINE(VAR3大盘:=COUNT(INDEXC>REF(INDEXC,1),3)=3;  {连续N天上涨}
动力:=COUNT(动力1DRAWTEXT(FILTER(大盘 AND 动力,2),动力1,'小心'),COLORFFE900;
DRAWICON(FILTER(大盘 AND 动力,2),动力1+30,8);
50,LINETHICK2,COLORYELLOW;
250,LINETHICK2,COLORFF00FF;
STICKLINE(C>0,400,400,5,0),LINETHICK2,COLORGREEN;

{摇篮 副图含WINNER}

VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
VAR4:=(CLOSE-LLV(CLOSE,N1))/(HHV(CLOSE,N1)-LLV(CLOSE,N1))*100;
VAR5:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR6:=EMA(VAR5,100);
VAR7:=2*(VAR5-VAR6);
VAR8:=POW(VAR7,3)*0.1+POW(VAR7,1);
VAR9:SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VARA:=EMA(VAR9*0.97,3);
VARB:=(HIGH+LOW+CLOSE)/3;
VARC:=(VARB-MA(VARB,14))/(0.015*AVEDEV(VARB,14));
线1:= IF(VAR7>0.1,VAR8,0)*5;
VARD:=LLV(HIGH,240);
VARE:=100*(CLOSE-VARD)/VARD;
VARF:=AMOUNT/VOL;
VAR10:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
VAR11:=INDEXC;
VAR12:=MA(VAR11,5); VAR13:=MA(VAR11,20);
VAR14:=MA(VAR11,30);
VAR15:=VAR14>VAR12*1.08 AND VAR13>VAR12*1.055;
VAR16:=VAR12>VAR11*1.03 AND VAR13>VAR11*1.13;
VAR17:=VAR16;
VAR18:=IF(FILTER(VAR10<6,5)=1,1,0);
VAR19:=VAR10<6 AND VAR17;
VAR1A:=CROSS(线1,2);
VAR1B:=CROSS(线1,4);
VAR1C:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR1D:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR1E:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR1F:=REF(CLOSE,1);
VAR20:=SMA(MAX(CLOSE-VAR1F,0),5,1)/SMA(ABS(CLOSE-VAR1F),5,1)*100;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR1C>=-15.8 AND VAR1C<=-12.2 AND VAR1D<=-20.8 AND VAR1E<=-27.5 AND VAR20<=11.7 AND VAR22<=-145)*100;
VAR24:=VAR4=0;
VAR25:=VAR4=100;
A:=IF(VAR25>0,110,101),STICK,LINETHICK2,COLOR00FF00;
101,STICK,LINETHICK2,COLOR000000;
A1:=IF(VAR23>0,100,90),STICK,LINETHICK3,COLORRED;
90,STICK,LINETHICK3,COLOR000000;
A2:=IF(VAR24>0,-11,0),STICK,LINETHICK2, COLORRED;
0,STICK,LINETHICK2, COLOR000000;
线:线1,STICK ,COLOR008364,LINETHICK3;
发现: (VAR18 AND VARE<-2.5 AND VAR3<5 AND VAR4=0)*60,LINETHICK2 ,COLORYELLOW;
IF(FILTER(VAR19,1)=1,1,0)*80,STICK, LINETHICK2, COLORF0F000;
大: VAR19 AND VAR18*80,STICK ,LINETHICK2, COLORYELLOW;
操盘手: VAR4,COLORF00FF0;
庄拉: IF(FILTER((VAR1A OR VAR1B) AND VAR4<40 AND VAR3<40,5)=1,35,0),LINETHICK2,COLORRED ;
0,LINETHICK1,COLOR000999;
100, COLORFF9966;


突破
VAR1:=HHV(HIGH,25);
VAR2:=LLV(LOW,25);
阻力线:EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20),COLORF0F000,LINETHICK2;
突破线:= EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);
操作线:突破线,COLORRED, LINETHICK2;      操作突破阻力,我们要做的就是买进,等待庄家登门送炒票
{BOLL—%BB}
{N 2,120,20}

BOLL:=MA(CLOSE,N);
UPPER:=BOLL+2*STD(CLOSE,N);
LOWER:=BOLL-2*STD(CLOSE,N);
%BB:(CLOSE-LOWER)/(UPPER-LOWER)*100;
MAWC:MA(%BB,6);
100, POINTDOT;
0, POINTDOT;

以前做过一个主力介入选股,这次一起做了吧。

{乖离试探介入}
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VARA,3,1),COLORYELLOW;
VARB:=SMA(K,3,1);
J:=3*K-2*VARB,COLORGREEN;
试探介入: CROSS(J,VARB) AND COUNT(VAR5<-9,4)>=1;

{乖离果断介入}
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VARA,3,1),COLORYELLOW;
VARB:=SMA(K,3,1);
J:=3*K-2*VARB,COLORGREEN;
果断介入: CROSS(J,VARB) AND COUNT(VAR5<-12,3)>=1;

{乖离主力介入}
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VARA,3,1),COLORYELLOW;
VARB:=SMA(K,3,1);
J:=3*K-2*VARB,COLORGREEN;
主力介入: CROSS(J,VARB) AND COUNT(VAR5<-16,4)>=1,COLORWHITE;

这三个选股公式我试了一下只有试探介入能选出二只股。其它选不出来。
动力线主图
VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2REF(VAR7,1);
VAR9:=VAR5REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2VAR11:=VAR5REF(VAR2,1) AND VAR7VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5VAR14:=LAND (H-L)/REF(C,1)>0.08
AND V>MA(V,135)
AND VAR2<40
AND VAR5>REF(VAR5,1);
VAR15:=HVAR16:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),26)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),26)*100<40
OR 100*((SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26))*2+(SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26)))/((SUM(IF(CLOSEOR SUM(MAX(0,HIGH-REF(CLOSE,1)),26)/SUM(MAX(0,REF(CLOSE,1)-LOW),26)*100<40
OR SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100<40;
VAR17:=CROSS(82,SMA(MAX(C-(REF(C,1)),0),6,1)/SMA(ABS(C-(REF(C,1))),6,1)*100);
VAR18:=CROSS((SMA(MAX(CLOSE-(REF(CLOSE,1)),0),6,1)/SMA(ABS(CLOSE-(REF(CLOSE,1))),6,1)*100),20);
动力线:C*(VAR2/90),COLORBLUE,LINETHICK2;
DRAWICON(VAR14 AND VAR15 OR VAR18,LOW*0.95,9);
DRAWTEXT(VAR16,LOW*0.95,'★底'),COLORRED;
DRAWTEXT(VAR17,HIGH*1.05,'▼顶'),COLOR00FFFF;
STICKLINE(VAR8=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR8=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR9=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR9=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR12=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR12=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR10=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR10=1,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(VAR11=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR11=1,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(VAR13=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR13=1,CLOSE,OPEN,2,0),COLORGREEN;


本人偶见佳文献与众友


脑电波和心电图的综合运用法则
  
  1. 脑电波持续下降,心电图呈现平台。这样的股票象无聊的梦游人,也说明该股无主力关照,主要是散户行情。脑电波下降是无上涨意愿但空头明显占优势的表示,而心电图走平台则是随波逐流的表示。这样的股票一般不会比大盘强,买进就意味着你认可当前的指数有利可图,卖出则意味着你认为行情将继续下跌。如武钢股份(6 00005)1999年8-11月的走势图。武钢股份本来是钢铁股中质地最好的,但由于无大主力关照,该股长期随大盘同步波动,甚至在钢铁股走好的时候也只略做表示。
  
  2. 脑电波逐渐走高,但心电图走平台或走低。这样的股票象喜欢空想不喜欢实干的小青年,也说明该股主力有向上做的意愿,但“心有余而力不足”,可能是资金匮乏,也可能是通过作假使人产生要向上突破的判断,最后却金蝉脱壳。这样的股票只要心电图不明显走好,是坚决不能进的。如铁龙股份(6 00125)1999年6月28日-8月30日。此间,脑电波从23.58上升到29.87,但心电图却只从当时10.96走到到11.16,显示出主力在盘中通过尾盘拉高等手法维持股价, 却无力上走,结果只有将股价维持在18-19元的小区间里。后来主力终于束手就擒,股价滑落到16元以下。
  
  3. 脑电波走平台,但心电图走高。这样的股票象有体力没脑子的武夫,也表示主力心灰意懒,资金不足,没有做大行情的意图,甚至故意盘中做差价,结果,股价虽然有一定的上升幅度,但空间很小。这样的股票不适合激进型的人做,因为买进后也许很长时间只有一点升幅。如美尔雅(6 00107)1999年8月18日-9月20日,其间脑电波从-13.47到-13.65,几乎没有动,但心电图则从9上升到9.81,幅度超过9%,股价也从14.72整整上升了1 元钱,但其间的过程反复不是一般人能承受的。
  
  4.脑电波走平台,但心电图下降。这样的情形很少出现。因为一个人如果心脏供血机能下降,大脑基本上就不会保持原来的状态,所以心电图下降,脑电波多数也是下降的。个别有持平的情况,多在随后不久就跟随下降。因为脑电波的反应一般要快于心电图。
  
  5.脑电波和心电图同时上升,且在均线之上。这是一种最佳配置,犹如初恋的情人,几乎有放电的功效,谁见了谁喜欢。这样的股票是主力发力进入主升浪的特征。例子实在太多,几乎所有的股票在大幅度上涨的时候都有这个过程,因此这里不再举例。操作的时候,最好就是买这样的股票。
  
  6.脑电波和心电图同时下降,且在均线之下。这是一种最恶配置,犹如彻底绝望的人,一天不如一天。碰这样的股票就是掏自己钱包里的钱送人一样。是主力主动出货的信号。虽然此类股票盘中也有反弹,但那就象偶尔出现的回光返照一样,危险更大。几乎所有主力出货的股票都有这种配置,因此也不举例。
  
  7.脑电波上升,但心电图下降。犹如身累心不累的顽童,总想着在睡觉前再玩一分钟。这是一种长庄配置。尽管股票表现不好,但毕竟主力还在,买进或者持有的风险不大。如康达尔(0 048)在1999年5月18日-6月28日,心电图从99下降到72,跌幅不可谓不大,但脑电波则从93上升到112,由此使股价从31元上升到37元,但随后不久,心电图就再次接近1 00,股价也上升到44元左右。此类股票操作需要有耐心。
  
  8.脑电波长期上升,心电图变化较多。犹如耐力很好的马拉松选手,作多是基本目标。这类股票都有长庄在场。弱市此类股票抗跌性比较好,但如果心电图不上升,就说明主力有心无力,行情不大。一旦心电图上升,则可以进入。如北大车行(6 00878)1999年6月29日-7月29日,其脑电波始终上升,心电图在此间走好,股价就从16元走到21元,而这段时间大盘是下跌的。
  
  9.脑电波长期下降,心电图变化较多。犹如植物人,大脑停止活动,心跳变化莫测。此类股票是长期无庄关照的,因此以随大流为主,原则上不能买,但在脑电波间歇走强的时候有一定的行情。如深发展1 998年8月-1999年11月,脑电波从28跌到0附近,处于长期下跌过程中,但1999年6月前后脑电波曾从11上升到20,股价则从12元上升到将近3 0元。除了这段脑电波上升过程之外,其它时间是不能做的。
  
  10.脑电波和心电图从连续下跌转为上涨或横盘,此时有两种情况:一是脑电波上升但心电图平或略跌,这是主力护盘的特征。护盘的主要目的是阻止股价下跌,但并不一定是为了上涨,有的机构护盘发现无效后会放弃,这个时候股价可能就直线下跌。如华西村(0 936)1999年11月12日-11月23日,脑电波从-0.14上升到0.68,但心电图从47.3下降到46.6,这就是典型的护盘行为,股价基本原地踏步。如果护盘是庄家行为,多说明有主力被套,后市还是有机会的,华西村就是这样的例子。另外一种情况是脑电波走平或者下跌,但心电图逐渐上升,这是一种典型的主力初期建仓的特征,短线机会不大。如1 999年11月我们推荐的焦作碱业(0719),当时该股的心电图不断上升,但脑电波基本持平,我们的判断就是主力初期建仓。
  
  11. 脑电波持续下降,心电图上升。如果是在股价上升的中途或者末期,往往是主力预备出货的征兆(参考云南铜业的图形);如果是股价下跌的中途或者末期,往往是主力初期建仓的信号。( 参考深鸿基的走势)脑电波和心电图从连续上升转为下降或横盘,此时也有两种情况:一是脑电波上升但心电图平或略跌,这是护盘式出货的特征或者主力停止拉高但仍在护盘的特征。护盘的主要目的是阻止股价下跌,但并不一定是为了上涨,有的机构纯粹是通过护盘来出货的,这种股票应该及时抛出。如中储股份(6 00787)1999年10月21日-11月12日,脑电波稳定在40,但心电图从14.38下降到13.43,这就是主力护盘式出货,此间股价从21元跌到19元多,后来更进一步跌破1 8元。另外一种情况是脑电波走平或者下跌,但心电图逐渐上升,这是一种典型的主力预备出货或者放弃护盘但尚没有出完货的特征,短线机会不大,应该先出货,防止主力突然出货。如东北热电(6 00795)1999年9月14日-10月21日,脑电波从62跌到60,但心电图从13上升到接近14,而股价则从22元跌到19元多,这是主力放弃护盘的行为,1 个月后,股价就又回到了22元。但港澳实业(0504)就没有这么幸运了,1999年9月21日开始,其心电图逐渐走高,但脑电波在均线下继续向下,构成典型的背离特征,9 月27日开始,股价终于从8.6元开始下跌,2个月不到,跌幅已经接近30%。
  
  
  9.典型的买进特征:脑电波和心电图都从连续下跌转为上升,其中心电图从最低点上升7%以上,而脑电波上升5%以上。心电图连续上升而脑电波从下跌或者走平转为上升,且从最低点上升5 %以上。
  
  10.典型的卖出特征:心电图跌破均线并继续向下。心电图虽然上升,但脑电波越走越低,甚至低于均线,二者出现了背离走势。心电图走平,但脑电波下降并破均线。
  
{庄家运作成本  主图}
{ N,1,100,30 M,1,300,95}
V1:EMA(CLOSE,5),COLORYELLOW;
V2:EMA(EMA(CLOSE,29)*1.01,10),COLORFFCC66;
DRAWICON(CROSS(V1,V2),V2,1);
V3:EMA(CLOSE,10),COLORFF00FF;
V4:EMA(EMA(CLOSE,60)*0.99,10),COLOR0099FF;
DRAWICON(CROSS(V3,V4),V4,1);
VAR1:=AMOUNT/VOL/100;
庄家运作成本: MA(CLOSE,18),COLORWHITE;
庄家平均成本: EMA(EMA(VAR1,2),N),COLOR00FF00;
庄家底仓成本: EMA(EMA(VAR1,13),M),COLORBLUE;
无穷成本均线: DMA(CLOSE,VOL/CAPITAL),COLORBLUE;
{STICKLINE(C>=O,C,O,7,0),COLORRED;}
STICKLINE(C>=O,C,O,4,0),COLOR7070FF{B0B0FF};
{STICKLINE(C>=O,C,O,2,0),COLORYELLOW;}
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
{STICKLINE(C<=O,C,O,7,0),COLORFF2020;}
{STICKLINE(C<=O,C,O,4,0),COLORFF6600;}
STICKLINE(C<=O,C,O,2,0),{COLORCYAN;}COLORFFCC66;
STICKLINE(C<=O,H,L,0,0),{COLORCYAN}COLORFFCC66;
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
STICKLINE(VAR327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(VAR327>90,LOW*0.95,'追涨'),COLORYELLOW;

{底与加速 副图}

VAR1:=((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100);
VAR2:=((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100);
VAR3:=((CLOSE-MA(CLOSE,32))/(MA(CLOSE,32)))*(100);
VAR4:=(VAR1+VAR2+VAR3)/(3);
VAR5:=EMA(VAR4,5);
MACD:(EMA(EMA(VAR1,5),5))*(3),COLORFF00FF,COLORSTICK,LINETHICK2;
VAR6:=IF((VAR4<=(-20)),10,0);
VAR7:=HHV(VAR6,10);
STICKLINE((VAR6=10),20,10,1,0),COLOR0000FF;
底:IF((VAR6=10),10,0);
DRAWTEXT((VAR6=10),LOW,'底'),COLORFFFFFF;
VARA:=IF(VAR7 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:(EMA(VAR5,5))*(2),COLORFFFF00;
D:EMA(K,5),COLOR0000FF;
J:(K)*(3)-(D)*(2),COLOR00FFFF;
VAR8:=(HIGH+LOW+CLOSE)/(3);
VAR9:=(VAR8-MA(VAR8,14))/((0.015)*(AVEDEV(VAR8,14)));
VAR10:=(VAR8-MA(VAR8,70))/((0.015)*(AVEDEV(VAR8,70)));
VAR11:=IF((VAR9>=150) AND (VAR9<200) AND (VAR10>=150) AND (VAR10<200),10,0);
VAR12:=IF((VAR9<=(-150)) AND (VAR9>(-200)) AND (VAR10<=(-150)) AND (VAR10>(-200)),(-10),VAR11);
VAR13:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR14:=100-ABS(VAR13);
VAR15:=IF((VAR14<90),VAR14,100);
VAR16:=IF((VAR10>=200) AND (VAR9>=150),15,IF((VAR10<=(-200)) AND (VAR9<=(-150)),(-15),VAR12))+60;
VAR17:=(VAR16>60) AND (VAR15<150);
加速:IF(VAR17 AND (COUNT(VAR17,20)=1),10,0);
DRAWTEXT(VAR17 AND (COUNT(VAR17,20)=1),10,'加速'),COLORFFFFFF;

{抄底英雄  副图}

L1:=MA(CLOSE,27);
L2:=(CLOSE-L1)/L1*100;
L3:=MA(L2,2);
L4:=BARSLAST(CROSS(-10,L3)=1);
L5:=L3<-10 AND L4>3;
LK:=ABS( IF(L5,L3,0));
金坑:=LK>0;
GSY:=IF(TROUGHBARS(3,15,1)=0 AND H>L+0.01,1,-1)=1;
金坑 AND REF(GSY,1);

{抄底公式----副图}

{N(1,100,12);M(1,100,20)}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(REF(J,7)<0 AND J>1,10,0,10,0),COLOR00FF00;
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
贵:N,COLOR00FF00;
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-
LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3抄底:IF(VAR5,90,1),COLORRED;
{DRAWICON(VAR5,65,1);}
DRAWTEXT(VAR5,30,'抄底'),COLORYELLOW;
备钱:IF(CROSS(10,VAR4),40,1),COLORFF00FF;
{DRAWICON(CROSS(10,VAR4),45,1);}
DRAWTEXT(IF(CROSS(10,VAR4),1,0),20,'$备钱'),COLORWHITE;
危机线: 80,COLORRED,POINTDOT,LINETHICK2;
中间线: 50,COLORFFCCCC,POINTDOT,LINETHICK2;
安全线: 10,COLORFF00FF,POINTDOT,LINETHICK2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
战术线:= VAR9,COLORYELLOW,LINETHICK2;
战略线: EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORBLUE;
STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLOR00FF00;
VARB:=SUM(IF(CLOSE>REF(CLOSE,7),VOL,IF(CLOSEVARC:=SUMBARS(VOL,CAPITAL);
VARD:=IF(CLOSE>LLV(CLOSE,VARC),1,-1);
VARE:=IF(VARB>LLV(VARB,VARC),1,-1);
VARF:=VARD*VARE;
VAR10:=IF(VARF=-1,1,0);
关注:IF(VAR10 AND CLOSE=LLV(CLOSE,20) AND VAR3A1:=EMA(CLOSE,5);
A2:=EMA(CLOSE,10);
A3:=EMA(CLOSE,20);
A4:=EMA(CLOSE,40);
A5:=EMA(CLOSE,60);
上穿月线:IF({CROSS(A1,A2) AND }CROSS(C,A3),50,0),COLORYELLOW,LINETHICK2;
上穿季线:IF({CROSS(A3,A4) AND }CROSS(C,A5),50,0),COLORRED,LINETHICK2;
I:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSER:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
短线逃顶:=IF(I,0,1),COLORGREEN;
DRAWICON(短线逃顶,90,2);

{火山景观A 副图}

VAR1:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR3:=SUM(VAR1,5);
VAR4:=SUM(VAR2,5);
VAR5:=IF(VAR3>VAR4,(VAR3-VAR4)/VAR3,IF(VAR3=VAR4,0,(VAR3-VAR4)/VAR4));
VAR6:=MA(VAR5,5);
VAR8:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR9:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VARA:=SUM(VAR8,3);
VARB:=SUM(VAR9,3);
VARC:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VARD:=MA(VARC,3);
火: BARSLAST(EMA(CLOSE,5)VARE:=HHV(CLOSE,2);
VARF:=BARSLAST(VAREVAR10:=IF(VARF>=1,LLV(VARE,VARF),LOW);
VAR11:=VAR10+VAR10*VARF*0.5/100;
VAR12:=IF(VAR11VAR13:=VAR10+VAR10*(VARF-1)*1.618/100;
山: COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5);
VAR14:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR15:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR16:=SUM(VAR8,3);
VAR17:=SUM(VAR9,3);
VAR18:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR19:=MA(VARC,3);
买入或持股: STICKLINE(山>0,火,0,2,0), , COLORRED;
VAR1A:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR1B:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR1C:=SUM(VAR8,3);
VAR1D:=SUM(VAR9,3);
VAR1E:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR1F:=MA(VARC,3);
下跌→抛出: STICKLINE(山>0,火,山,2,1), , COLORCYAN;
VAR20:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR21:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR22:=SUM(VAR8,3);
VAR23:=SUM(VAR9,3);
VAR24:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR25:=MA(VARC,3);
观望: STICKLINE(山=0 AND 火=0,0,1,4,1), , COLORBLUE;
VAR26:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR27:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR28:=SUM(VAR8,3);
VAR29:=SUM(VAR9,3);
VAR2A:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR2B:=MA(VARC,3);
植被: STICKLINE(山<火,火,山,1,0), , COLORGREEN;
VAR2C:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2D:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR2E:=SUM(VAR8,3);
VAR2F:=SUM(VAR9,3);
VAR30:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR31:=MA(VARC,3);
VAR32:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*10;
K: SMA(SMA(VAR32,2,1),2,1), , ;
D: SMA(SMA(SMA(VAR32,2,1),2,1),3,1), , COLORYELLOW;
J: (3*SMA(SMA(VAR32,2,1),2,1)-2*SMA(SMA(SMA(VAR32,2,1),2,1),3,1)), , COLORMAGENTA;
VAR33:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR34:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR35:=SUM(VAR8,3);
VAR36:=SUM(VAR9,3);
VAR37:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR38:=MA(VARC,3);
STICKLINE(REF(山,1)=0 AND 山>0,0,-1,2,0), , COLORRED;
DRAWTEXT(REF(火,3)>0 AND REF(火,2)>0 AND REF(火,1)>0 AND 火=0 AND REF(火,1)>山,REF(火,1),'调整'), , ;

{火山景观B  副图}
{N 1,250,13(21)}
VAR1:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR3:=SUM(VAR1,5);
VAR4:=SUM(VAR2,5);
VAR5:=IF(VAR3>VAR4,(VAR3-VAR4)/VAR3,IF(VAR3=VAR4,0,(VAR3-VAR4)/VAR4));
VAR6:=MA(VAR5,5);
VAR8:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR9:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VARA:=SUM(VAR8,N);
VARB:=SUM(VAR9,N);
VARC:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VARD:=MA(VARC,3);
中期: ATAN(BARSLAST(EMA(CLOSE,30)VARE:=HHV(CLOSE,2);
VARF:=BARSLAST(VAREVAR10:=IF(VARF>=1,LLV(VARE,VARF),LOW);
VAR11:=VAR10+VAR10*VARF*0.5/100;
VAR12:=IF(VAR11VAR13:=VAR10+VAR10*(VARF-1)*1.618/100;
VAR14:=IF(VAR13短期: ATAN(BARSLAST(EMA(CLOSE,N)VAR15:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR16:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR17:=SUM(VAR8,N);
VAR18:=SUM(VAR9,N);
VAR19:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR1A:=MA(VARC,3);
起点: IF(ASIN(BARSLAST(EMA(CLOSE,N)VAR1B:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR1C:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR1D:=SUM(VAR8,N);
VAR1E:=SUM(VAR9,N);
VAR1F:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR20:=MA(VARC,3);
VAR21:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K: SMA(VAR21,3,1);
D: SMA(K,3,1);
J: 3*K-2*D, , COLORBLUE;
VAR22:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR23:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR24:=SUM(VAR8,N);
VAR25:=SUM(VAR9,N);
VAR26:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR27:=MA(VARC,3);
STICKLINE(REF(ATAN(BARSLAST(EMA(CLOSE,N)0,0,-0.1,3,0), , COLORRED;
DRAWTEXT(REF(中期,3)>0 AND REF(中期,2)>0 AND REF(中期,1)>0 AND 中期=0,REF(中期,1),'调整');

{鲜氏财神}
{N  1,100,6}
VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1341231,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),N);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1341231;
鲜氏财神到: IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),N),100000000);
VAR13:=COST(10)*0;


{绝佳拐点  副图}

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),14,1),COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),14,1),COLORGREEN;

{涨跌停K线 主图}
EMA5:EMA(C,15);
EMA10:EMA(C,10);
EMA30:EMA(C,30);
EMA60:EMA(C,60);
EMA120:EMA(C,120);
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,4,0),COLORGREEN;

{玄黄天神 副图}

VAR1:=1;
VAR2:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=3*VAR3-2*VAR4;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,5);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4)*2;
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
VARA:=3*VAR8-2*VAR9;
VARB:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARC:=POW(MA(LOW,5),2)+MA(LOW,5);
VARD:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARE:=(VARB-LLV(VARC,64))/(HHV(VARD,64)-LLV(VARC,64))*150+65-10;
VARF:=SMA(VARE,3,1)*1.5-100;
VAR10:=SMA(VARF,3,1);
VAR11:=3*VARF-2*VAR10;
VAR12:=(HIGH+LOW+CLOSE*2)/4;
VAR13:=EMA(VAR12,13);
VAR14:=STD(VAR12,13);
VAR15:=(VAR12-VAR13)*100/VAR14;
VAR16:=EMA(VAR15,5);
VAR17:=EMA(VAR16,13);
VAR18:=EMA(VAR16,13)+200-100;
VAR19:=EMA(VAR18,10);
VAR1A:=3*VAR18-2*VAR19;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=VAR5+VARA+VAR11+VAR1A;
VAR1E:=(HIGH+LOW+CLOSE)/3;
VAR1F:=AMOUNT/VOL/100;
VAR20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR21:=(VAR1E-MA(VAR1E,34))/(0.015*AVEDEV(VAR1E,34));
VAR22:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR23:=(HIGH+LOW+CLOSE+VAR1E)/4;
VAR24:=EMA(VAR23,24);
VAR25:=STD(VAR23,24);
VAR26:=(VAR23-VAR24)/VAR25*100;
VAR27:=(VAR1E-MA(VAR1E,24))/(0.015*AVEDEV(VAR1E,24));
VAR28:=EMA(VAR26,5);
VAR29:=(VAR1F-MA(VAR1F,21))/(0.015*AVEDEV(VAR1F,21));
VAR2A:=(VAR20-MA(VAR20,90))/(0.015*AVEDEV(VAR20,90));
VAR2B:=((VAR2A+VAR29+VAR28+VAR27+VAR21)/5+165)/4*VAR1;
VAR2C:=(EMA(EMA(EMA(VAR2B,15),10),5)-25)*2+VAR22*VAR1;
VAR2D:=(VAR1B+VAR1C+VAR1D*30)/32/5-15*VAR1;
VAR2E:=EMA(VAR2D,13)*VAR1;
VAR2F:=(VAR2B+VAR2D)/2/1.1*VAR1;
天神: VAR2F*VAR1,COLOR00FF00,,LINETHICK2;
MMA1: (VAR2C+VAR2E)/2*VAR1,COLORRED,LINETHICK2;
0,CROSSDOT,COLOR00FF00;
100,CROSSDOT,COLORRED;
50,POINTDOT;
DRAWTEXT(CROSS(MMA1,天神) AND 天神>50  ,天神+2,'风险加大'),COLORYELLOW;
DRAWICON(CROSS(MMA1,天神) AND 天神>50,天神,2);
DRAWTEXT(CROSS(天神,0) ,天神+2,'机遇来临'),COLORF00FF0;
DRAWICON(CROSS(天神,0) ,天神,1);


{Z玄黄中期 副图}

VAR1:=COST(10);
S: (CLOSE-VAR1)/VAR1*100,COLORRED,,LINETHICK2;
VAR2:=COUNT(S<-2.05,3);
中期底部: IF(VAR2>=3,50,0),COLORBLUE,,LINETHICK2;
DRAWICON( FILTER(CROSS(S,中期底部),20),S ,5 );
DRAWICON( FILTER(CROSS(中期底部,S),20),S ,2);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
R:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(((B / 2) + 40) * 1.1);
落袋为安D:=SMA(CCC,3,1);
落袋为安:IF(CROSS(落袋为安D,RSI5),58,0);
RSV:=(((CLOSE - LLV(LOW,29)) / (HHV(HIGH,29) - LLV(LOW,29))) * 100);
K:=MA(RSV,5);
D:=MA(K,2);
J:=((3 * K) - (2 * D));
海底火山:IF((J < 5),75,0),;

{Z玄黄寻底 副图 含WINNER、CAPITAL}
{N1  1,100,50}

HLP:=WINNER(CLOSE);{以今天收盘价计算的获利盘比例}
CJ:=VOL/CAPITAL;{今日换手率}
CM:=CJ/HLP;{今日换手率/以今天收盘价计算的获利盘比例,意义是在当前比例获利盘的前提下,换手是在增大还是减小}
寻底指标:IF(HLPDRAWTEXT(寻底指标,0.2,'关注!!!'),COLORBLUE;

{彩虹 副图}

虹1: 100*(EMA(CLOSE,21)-EMA(CLOSE,60)-EMA(EMA(CLOSE,21)-EMA(CLOSE,60),13)),COLORRED;
虹2: 100*(EMA(CLOSE,18)-EMA(CLOSE,45)-EMA(EMA(CLOSE,18)-EMA(CLOSE,45),11)),COLORMAGENTA ;
虹3: 100*(EMA(CLOSE,15)-EMA(CLOSE,34)-EMA(EMA(CLOSE,15)-EMA(CLOSE,34),9)),COLORYELLOW ;
虹4: 100*(EMA(CLOSE,12)-EMA(CLOSE,26)-EMA(EMA(CLOSE,12)-EMA(CLOSE,26),6)),COLORGREEN ;
虹5: 100*(EMA(CLOSE,5)-EMA(CLOSE,10)-EMA(EMA(CLOSE,5)-EMA(CLOSE,10),5)), COLORBLUE ;
VAR2:=(CLOSE-MA(CLOSE,10))/STD(CLOSE,35)*20;
多空: EMA(VAR2,18),COLORFFFFDD;
争持位: 0,COLORFF9966;
强弱A: EMA(VAR2,55),COLOR0066FF;

{杀庄武器  副图 含DYNAINF0}

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
{(趋势>80);}
DRAWICON(CROSS(趋势,0),0,1);
{((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;}
大庄建仓区:=0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'准备数钱'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,3,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'明天买进'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,3,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'小心'),COLOR00FF00;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
五指山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(五指山>0,0 ,五指山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线:趋势,COLORFF00FF;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
分水岭:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17VAR18:=MA(趋势线,8);
{IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;}
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'全仓买进'),COLORYELLOW;

给你一个精品,A:=IF((BARSCOUNT(C) > 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) - 1),1);
N:=IF((A > 0.35),6,65);
B:((-((100)*(HHV(H,N) - C))/(HHV(HIGH,N) - LLV(L,N))));
N1:(CROSS(B,(-2)));
DRAWTEXT(N1,L,'涨停'),COLORYELLOW;只追涨停
初涨强势---选股
A1:=C>MA(C,2);
A2:=C=HHV(C,3);
A3:=MA(V,2)>MA(V,40)*N;
A4:=MA(V,2)=HHV(MA(V,2),30);
B4:=V=HHV(V,21);
A5:=V>REF(V,1) AND C>REF(C,1);
A05:=MA(A5,21);
XG:(A1 AND A2 AND A3 AND A4 AND A5)*2;
{回调找支撑 主图}
MA3:MA(CLOSE,3),COLORYELLOW,LINETHICK2;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
HTR1:EMA(X,3),COLORFF00FF;
HTR2:EMA(X,8),COLOR0000FF;
HTR3:EMA(X,13),COLOR00FFFF,LINETHICK2;
HTR4:EMA(X,21),COLOR00FF00;
HTR5:EMA(X,34),COLORFFFF00;
HTR6:EMA(X,55),COLORFF0000;
HTR7:EMA(X,88),COLORFF99FF;
HTR8:EMA(X,144),COLORFF0099;
HTR9:EMA(X,225),COLOR9900FF;

{成交天机}

{STICKLINE(HOUR>=9  AND HOUR<10 ,0, VOL/((TIME-93000)/100)*240,4.5,1),COLORWHITE;
STICKLINE(HOUR>=10 AND HOUR<11 ,0, VOL/((TIME-100000)/100+30)*240,4.5,1),COLORWHITE;
STICKLINE(HOUR>=11 AND HOUR<12 ,0, VOL/((TIME-110000)/100+90)*240,4.5,1),COLORWHITE;
STICKLINE(HOUR>=13 AND HOUR<=14,0, VOL/((TIME-130000)/100+120)*240,4.5,1),COLORWHITE;
STICKLINE(HOUR>=14 AND HOUR<=15,0, VOL/((TIME-140000)/100+180)*240,4.5,1),COLORWHITE;}
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSESTICKLINE(CLOSE>OPEN,0,VOL,3.5,1),COLORRED;
STICKLINE(CLOSESTICKLINE(CLOSE=OPEN AND CLOSESTICKLINE(CLOSE=OPEN AND CLOSE>REF(CLOSE,1),0,VOL,3.5,1),COLORRED;
STICKLINE(主动买盘>0,0,主动买盘,3.5,0),COLORRED;
STICKLINE(主动卖盘<0,0,主动卖盘,3.5,0),COLOR00FF00;
换手: VOL/CAPITAL*100,POINTDOT,COLORWHITE;
STICKLINE(换手>=3 AND 换手<8,0, 主动买盘,2,0),COLORYELLOW;
STICKLINE(换手>=8,0, 主动买盘, 2,0) ,COLORGREEN;
MA5:MA(VOL,5),COLORYELLOW;
MA13:MA(VOL,13),COLORWHITE;
资金异动:主动买盘+主动卖盘;
DRAWTEXT(CROSS(MA5,MA13),CROSS(MA5,MA13),'★'),COLORFF88FF;

{黑武器 副图含CAPITAL、PWINNER}

HH:=V*100/CAPITAL;
AA:=(C-REF(C,1))*100/REF(C,1);
JJ:=AMOUNT/100*V;
TT:=COUNT(HH>=2.6 AND AA>0 AND C>=JJ,91);
TT1:=COUNT(HH>=2.6 AND AA>0 AND C>=JJ,34);
TT2:=COUNT(HH>=2.6 AND AA>0 AND C>=JJ OR AA>=HH-0.8 AND AA>=2.2,34);
TT3:=COUNT(HH>=1.5 AND AA>1.5 AND AA>=HH-0.6,34);
YA:=IF(AA>0.8,HH,0);
YI:=IF(AA<-0.8,-(1*HH),0);
BB:=YA+YI;
BS:=SUM(BB,34);
T1:=TT2;
MT:=MA(T1,7);
T2:=BS/2;
T3:=T1+T2;
M1:=EMA(T3,7);
Z:=INDEXC;
A:=(Z-REF(Z,1))*100/Z;
B:=(C-REF(C,1))*100/C;
CC:=B-A;
GD:=SUM(CC,13);
GD1:=SUM(CC,10);
Q13:=IF(GD>0,GD+5,GD);
Q10:=IF(GD1>0,GD1+5,GD1);
MQ1:=IF(EMA(Q13,13)>3,EMA(Q13,13)+1.5,EMA(Q13,13));
MA34:=EMA(C,34);
SD1:=100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34));
M11:=MA(SD1,3)/4;
SD2:=100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34));
M2:=MA(SD2,3)/4;
HLP:=PWINNER(1,C)*100;
D21:=LLV(C,21);
D18:=LLV(C,18);
AAD:=(C-D21)*100/D21;
SSS:=IF(LLV(HLP,6)<=6 AND AA>=7.3 AND C+0.04>=H AND AAD<=16 AND D18<=LLV(C,58)
AND C>REF(H,1) AND COUNT(AA<=1,5)>=2 AND HLP<=68 AND LLV(C,13)=LLV(C,21) AND
HH>=0.4 AND (COUNT(C>EMA(C,34),9)<=0 OR COUNT(C>=EMA(C,34),9)<=1 AND C>=EMA(C,34)),1,0);
EQ:IF(C<=1000,T3+Q13,0),LINETHICK2;
STICKLINE(Q10>13.6,7,15,6,0),;
STICKLINE(M11>=19 AND C<=250,0,7,6,0),;
MID:=EMA(EQ,26);
上线:MID+2*STD(EQ,26),;
LOWER:=MID-2*STD(EQ,26);
下线:IF(C<=4000,EMA(EQ,13),0),;
OO2:20,;
OO3:34,;
DRAWICON(C<=1000 AND SSS=1,0,1);

{蓄势待发 副图含WINNER}

VAR1:=HHV(HIGH,3);
VAR2:=(IF(WINNER(1.1*CLOSE)<0,0,WINNER(1.1*CLOSE))-IF(WINNER(0.9*CLOSE)
<0,0,WINNER(0.9*CLOSE)))*100;
VAR3:=IF(VAR1<0,0,VAR1);
VAR4:=IF(VAR2<0,0,VAR2);
主力动向:PWINNER(10,VAR3),COLORFF00FF;
主力震仓:PWINNER(10,VAR4),COLORWHITE;
VAR5:=COST(10);
VAR6:=(CLOSE-VAR5)/VAR5*100;
VAR7:=COUNT(VAR6<-2.05,3);
主力蓄势待发: IF(VAR7>=3,0.20,0),COLORFFCC66;
风险区域: 1,COLORRED,POINTDOT;
0.9,COLOR0099FF,POINTDOT;
VAR8:=(CLOSE-MA(CLOSE,10))/STD(CLOSE,35)*0.3;
强弱动向: EMA(VAR8,18),COLOR00FF00;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1),COLOR0000FF;
VAR12:=SMA(VAR11,3,1),COLOR00FFFF;
金叉:IF(CROSS(VAR11,VAR12) AND (VAR11<40),0.9,0),COLOR0000FF,LINETHICK2;
STICKLINE(金叉,0,0.5,8,0),COLORRED;
STICKLINE(金叉,0.45,0.6,2,0),COLORRED;

{主力吃货 副图}
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
STICKLINE(VAR12STICKLINE(VAR9STICKLINE(VAR8>REF(VAR8,1),0,VAR8,4,1),COLOR10FFFF,LINETHICK0;
STICKLINE(VAR11>REF(VAR11,1),0,VAR11,4,1),COLORFFF810;
增减力度:VAR10*5,COLORWHITE;
DRAWTEXT(CROSS(0,增减力度),-0.5,'涨'),COLOR006EFF;
DRAWTEXT(CROSS(0,增减力度),-1.8,'啦'),COLOR006EFF;
DRAWICON(CROSS(0,增减力度),1.5,1),COLORWHITE;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)STICKLINE(XL3,0,VAR8*3,4,0),COLOR006EFF;
DRAWTEXT(XL3,VAR8*2,'买'),COLOR006EFF;

{主力洗盘进场 副图}
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,0 ),COLORRED;
洗盘:STICKLINE(VAR5主力进场阳:STICKLINE(VAR5>REF(VAR5,1) AND C>O,0,VAR5,7,0 ),COLORYELLOW;
洗盘阴:STICKLINE(VAR50,COLORBLUE;

{专吸庄血}
N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),50,0),STICK,COLOR0000CC,LINETHICK2;
专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWICON(CROSS(VAR1,VAR2),8,1);
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
DRAWICON(CROSS(100,VAR1),100,2);
DRAWICON((100-VAR1<3 AND 100-VAR1>0),100,2);
DRAWTEXT(CROSS(85,VAR1),85,'▼'),COLORGREEN;
DRAWTEXT(CROSS(VAR1,35),35,'▲'),COLORRED;
DRAWTEXT(CROSS(VAR1,104),104,'◆'),COLORBLUE;
DRAWTEXT(CROSS(VAR1,110) OR CROSS(VAR1,120),115,'○'),COLORWHITE;
强弱分界线:55,COLORRED;
Y:=IF((55-VAR1)>=0,-1,1),COLORGREEN;
持有:Y=1,COLORRED;
观望:Y=-1,COLORGREEN;

{逃离苦海 副图含WINNER}
AA:MA(WINNER(C*0.95)*100,3),COLORYELLOW;
AA,STICK,COLORYELLOW,LINETHICK2;
VAR1:=1/WINNER(CLOSE);
VAR2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR3:=100-ABS(VAR2);
VAR4:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR6:=100-VAR5;
VAR7:=100-VAR4;
VAR8:=MA(WINNER(CLOSE*0.95)*100,3);
VAR9:=IF(VAR1>5,IF(VAR1<100,VAR1,VAR3-10),0);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:=SMA(VARA,3,1);
VARC:=SMA(VARB,3,1);
探索: EMA(3*VARB-2*VARC,3),COLORWHITE;
主力: (-1)*(EMA(VAR7,1)-50)+50,COLORYELLOW,LINETHICK2;
Z1: MA(主力,9),COLORRED,LINETHICK2;
VARD:=(-1)*(EMA(VAR7,1)-50)+50;
VARE:=(-1)*(EMA(VAR7,12)-50)+50;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
天涯:IF(RSI1>93 OR (AA>90 AND RSI1>80),80,100),;
海角: 0,COLORGREEN;
苦海: EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6),LINESTICK,;
ZS: MA(探索,3),COLORYELLOW;
ZM: MA(MA(探索,3),3),COLORGREEN,;

{吴氏操盘圣手 主图含未来函数ZIG}
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
{利多方舟}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
年:MA(CLOSE,22),COLORGREEN;

{猛虎捕食 副图}

猛虎: 600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
风险:EMA(猛虎,7),COLORRED;
笼顶:(WINNER(120*C/100)-WINNER(100*C/100))*100,COLORGREEN;
笼底:-100*(WINNER(120*C/100)-WINNER(100*C/100))+5,COLORF00FF0;
底部区:=猛虎<笼顶 AND 猛虎<笼底;
打压吸筹区:STICKLINE(底部区,猛虎+10,猛虎-10,2,0),COLOR669933;
底成:=(CLOSE-MA(CLOSE,28))/MA(CLOSE,28)*100<-23;{平均成功率:78.22%, 成功率达到50%的股票有:42.3%}
STICKLINE(底成,笼底+40,笼底-50,3,0),COLOR00FF00;
DRAWTEXT(底成,笼底-40,'★:底成'),COLOR00FF00;
VARX:=LLV(LOW,75);
VARX1:=HHV(HIGH,75);
VARX2:=(VARX1-VARX)/100;
VARX3:=SMA((CLOSE-VARX)/VARX2,20,1);
VARX4:=3*VARX3-2*SMA(VARX3,15,1);
VARX5:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARX6:=SMA(VARX5,3,1);
VARX7:=SMA(VARX6,3,1);
DBX:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
要涨:=(CROSS(DBX,-5.4) AND (8+DBX)*10>=29 AND (100-VARX4)>49 AND (VARX4>SUM(VARX4,20)/20 AND VARX7>REF( VARX7,1)))*10;
STICKLINE(要涨,笼底-10,笼底+50,4,0),COLORBLUE;
DRAWTEXT(要涨,笼底+40,'★:要涨'),COLORBLUE;

{上出下进  主图}

A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)PMA:=分水岭;
DD:=分水岭IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
S:=(PMA>操作线);
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
PM:MA(C,5),COLORFFFFCC,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;
IF(PMDRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1>0,L-0.02,'★M'),COLOR00FFFF;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,L-0.10,'◎K'),COLORFF00FF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3>0,L-0.18,'◆R'),COLOR0000FF;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1>0,H+0.16,'★M'),COLOR00FF00;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2>0,H+0.08,'◎K'),COLORFFFFCC;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3>0,H+0.04,'◆R'),COLORFF9900;

{闲看落花  主图}
{N1=14,N2=34,N3=55,N4=5}
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
MA5:MA(CLOSE,55);
MA8:MA(CLOSE,125);
MA6:=MA(VOL,5);
MA7:=MA(VOL,40);
VAR1:=EMA(AMOUNT/VOL/100,3);
天际:=EMA(VAR1,240);
水平面:= EMA(VAR1,88)*0.85;
海底:=EMA(VAR1,88)*0.74;
VAR22:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR33:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARF:=(HIGH+LOW+CLOSE)/3;
VAR10:=(VARF-MA(VARF,14))/(0.015*AVEDEV(VARF,14));
VAR11:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=3*VAR12-2*VAR13;
VAR15:=CLOSE< REF(CLOSE,1);
VAR16:=OPEN< REF(CLOSE,1);
VAR17:=(VAR13< 10 AND VAR33< -30 AND VAR22>6 AND VAR10<-107);
Q:= VAR17 OR COUNT(VAR17,10) AND VAR15 OR COUNT(VAR17,10) AND VAR16;
AA:=FILTER(Q,20);
RSV:= (CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
FASTK:=SMA(RSV,3,1);
K:=SMA(FASTK,3,1);
D:=SMA(K,5,1);
A1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
A2:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
WR1:= -100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
WR2:= -100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));
WR3:= -100*(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89));
B:=SMA((3*H+2*C+O+L)/7,10,1);
W1:=-100*(HHV(HHV(B,1),N1)-B)/(HHV(HHV(B,1),N1)-LLV(LLV(B,1),N1));
W2:=-100*(HHV(HHV(B,1),N2)-B)/(HHV(HHV(B,1),N2)-LLV(LLV(B,1),N2));
W3:=-100*(HHV(HHV(B,1),N3)-B)/(HHV(HHV(B,1),N3)-LLV(LLV(B,1),N3));
W4:=-100*(HHV(HHV(B,1),N4)-B)/(HHV(HHV(B,1),N4)-LLV(LLV(B,1),N4));
价格:=(W1+W2+W3+W4)/4;
A:=SMA(VOL,10,1);
WR00:=-100*(HHV(HHV(A,1),N1)-A)/(HHV(HHV(A,1),N1)-LLV(LLV(A,1),N1));
W11:=-100*(HHV(HHV(A,1),N2)-A)/(HHV(HHV(A,1),N2)-LLV(LLV(A,1),N2));
W22:=-100*(HHV(HHV(A,1),N3)-A)/(HHV(HHV(A,1),N3)-LLV(LLV(A,1),N3));
W33:=-100*(HHV(HHV(A,1),N4)-A)/(HHV(HHV(A,1),N4)-LLV(LLV(A,1),N4));
量:=(WR00+W11+W22+W33)/4;
WR:=-100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));
关注买:= CROSS(WR,-45) AND CLOSE>MA5 AND MA3>REF(MA3,1) AND K>REF(K,1);
DRAWTEXT(关注买 ,LOW-LOW*0.02,'▲关注买'),COLORRED;
量价齐升:=((CROSS(量,-45)) OR (CROSS(量,-50))) AND ((CROSS(WR,-45)) OR (CROSS(WR,-50))) AND CROSS(CLOSE,MA4) AND CROSS(CLOSE,MA5);
DRAWTEXT(量价齐升,LOW-LOW*0.02,'▲量价齐升'),COLORYELLOW;
BB:=CLOSE=HIGH AND  CLOSE>REF(HIGH,1) AND WR>=REF(WR,1) AND ((REF(CLOSE,1)半仓买:=FILTER(BB,5);
DRAWICON(半仓买,LOW-LOW*0.01,1),COLORRED;
DRAWTEXT(半仓买,LOW-LOW*0.01,'半仓买'),COLORRED;

M:= WR1=WR2 AND WR1=WR3 ;
VAR2:=VOL*CLOSE;
VAR3:=EMA(VAR2,11)/EMA(VOL,11);
VAR4:=(EMA(CLOSE,5)-VAR3)/VAR3*100;
VAR5:=EMA(VAR4,5);
卖出:= CROSS(VAR5,VAR4) AND VAR5>2;
DRAWTEXT(卖出,HIGH*1.03,'▼卖出'),COLORGREEN;
D1:= CROSS(VAR4,VAR5) AND VAR5<-2 AND VAR3>REF(VAR3,1) AND (LOW<海底 OR CLOSE<海底) AND K<20 AND K>REF(K,1) AND LOW(COST(1)) AND CLOSE>REF(HIGH,1);
D2:=(( CLOSE<海底)OR(LOW <海底)) AND CLOSE>LOW AND K<20 AND K>REF(K,1) AND LOW<(COST(1)) AND CLOSE>(COST(1)) AND M AND CLOSE>REF(HIGH,1);
D3:= CROSS(VAR4,VAR5) AND VAR5<-6.3 AND CLOSE>REF(HIGH,1) AND (LOW<海底 OR CLOSE<海底) AND K<20 AND K>REF(K,1) AND LOW(COST(1));
D4:=AA;
全仓买:=D1 OR D2 OR D3 OR D4;
{DRAWICON(全仓买,LOW-LOW*0.1,1),COLORYELLOW;}
DRAWTEXT(全仓买,LOW-LOW*0.09,'全仓买'),COLORYELLOW;
卖:=CLOSE>REF(CLOSE,1)AND WR/1.5DRAWTEXT(卖,HIGH*1.03,'▼绝顶2'),COLORGREEN;
绝顶:=WR=0 AND 量=0 AND 价格>-10;
DRAWTEXT(绝顶,HIGH*1.03,'▼绝顶1'),COLORGREEN;
VAR7:=REF(CLOSE,1);
VAR8:=SMA(MAX(CLOSE-VAR7,0),7,1)/SMA(ABS(CLOSE-VAR7),7,1)*100;
VAR9:=CROSS(69,VAR8);
VARA:=FILTER(VAR9,4);
DRAWICON(VARA,HIGH*1.035,2);
DRAWTEXT(VARA,HIGH*1.04,'绝卖出');

{买入易涨停  主图含未来函数ZIG、TROUGHBARS}

{参数:N 5 100 9  LC 5 100 24}
MA5:MA(C,5),COLOR00FF00;
MA10:MA(C,10),COLORFFFFFF;
ZX:=(MA5+MA10)/2;
MA24:MA(C,24),COLORFF00FF; {24日指数平滑均线,是真正大资金运作的主要参考和支撑线}
MA30:MA(C,30),COLORYELLOW;
QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)YB:=C>REF((O-C)/2+C,2);
买:=CROSS(C,ZX) AND (GD OR YB) AND QSXS,COLOR00FF00,POINTDOT,LINETHICK0;
买入易涨停:=买 AND MA5>REF(MA5,1),COLORYELLOW,POINTDOT,LINETHICK0;
STICKLINE(买,H,L,0,0),COLOR00FF00,LINETHICK2;
STICKLINE(买,O,C,0,0),COLOR00FF00,LINETHICK2;
STICKLINE(买入易涨停,H,L,0,0),COLORYELLOW,LINETHICK2;
STICKLINE(买入易涨停,O,C,4,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(买,L*0.99, '买'),COLOR00FF00;
DRAWICON(买入易涨停,L,1);
上线:=SMA(C,6.5,1);
下线:=SMA(C,13.5,1);
上线1:=SMA(C,3,1);
下线1:=SMA(C,8,1);
DRAWTEXT( CROSS(上线,下线),LOW *0.98,'▲全仓买' ),COLOR00FF00;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
VA1:=EMA(上收,8);
VA2:=EMA(上收,28);
DRAWTEXT(CROSS(VA2,VA1),VA1*1.05,'▼全仓卖'),COLORYELLOW;
X1:=(3*C+H+L+O)/6;
X2:=EMA(X1,10);
X3:=REF(X2,1);
X4:=(REF(HIGH,1)+REF(LOW,1))/2;
X5:=MA(CLOSE,21)+2*STD(CLOSE,21);
X6:=REF(CLOSE,1);{出货}
X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);{40}
XL11:=EMA(CLOSE,10)/100;{70}
XL2:= MA((XL11-REF(XL11,10))/REF(XL11,10),3)*100;
XL3:= MA(XL2,3);
XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DRAWTEXT((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),L-0.4,'买'),COLORRED;
DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/
4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0) AND X2>X3,L-0.4,'▲加仓'),COLORFF5ED8;{80}
VAR11:=(ZIG(3,10) < REF(ZIG(3,10),1)) AND (REF(ZIG(3,10),1) > REF(ZIG(3,10),2));
VAR22:=(ZIG(3,10) > REF(ZIG(3,10),1)) AND (REF(ZIG(3,10),1) < REF(ZIG(3,10),2));
DRAWTEXT(VAR11,HIGH*1.02,'逃▼顶'),COLORF0F000, LINETHICK4;

{包杨逃顶  主图} 
   
MA1:MA(C,5);
MA2:MA(C,10);
MA3:MA(C,20);
MA4:MA(C,30);
MA5:MA(C,60);
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,7)/VAR1/100;
VAR4:=DMA(VAR2,VOL/VAR3);
VAR5:=(CLOSE-VAR4)/VAR4*100;
VAR6:=MA(VAR5,20)+STD(VAR5,20);
VAR7:=MA(VAR5,20)+1.732*STD(VAR5,20);
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR8:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K1:=SMA(VAR8,3,1);
VAR9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(VAR9,3,1);
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR6,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79,HIGH,LOW,0.5,0),COLOR00FF00;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR6,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79,OPEN,CLOSE,8,1),LINETHICK2,COLOR00FF00;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR7,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79 ,HIGH,LOW,0.5,0),COLOR00FF00;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR7,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79 ,OPEN,CLOSE,8,1),LINETHICK2,COLOR00FF00;
DRAWICON(REF(BIAS21,1)>=5 AND CROSS(VAR7,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79 ,HIGH,2);
DRAWICON(REF(BIAS21,1)>=5 AND CROSS(VAR6,VAR5) AND REF(K1,1)>78 AND REF(K2,1)>79,HIGH,2);

金蛤蟆指标如副图所示!(不要把这个指标加入选股公式,因为准确率不高,要结合K线和KDJ线分析才行!)

参数名 最小 最大 省缺
n              1    50    6
p1            1    50    2
p2            1    50    2

RSV:=(((CLOSE - LLV(LOW,N)) / (HHV(HIGH,N) - LLV(LOW,N))) * 100);
K:=(POW(SMA(RSV,P1,1),5) / POW(10,8));
D:=(POW(SMA(RSV,P2,1),5) / POW(10,10));
蛤:((K+D)/2);
蟆:(0-蛤);
J:=1;
选股:CROSS(蛤,J);
在前1-2天"一品抄底"和"提前买入"都将同时出现,
在第3天,"千载难逢"一但出现,即刻跟进。

一品抄底:
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=(C/MA(C,5)-1)*100<-10;
A2:=(C/MA(C,13)-1)*100<-10;
A3:=(C/MA(C,34)-1)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
底部:A1 AND A2 AND A3 AND A4 AND A5 AND A6,COLOR00FFFF,LINETHICK2;

提前买入:
VAR11:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR11*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR11*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR11*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
AA3:=( EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10) ;
BB:=AA3>REF(HHV(AA3,60),1);
CC:=HHV(AA3,60);
大底:=FILTER(AA3>10 ,1) ;
VA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买1:=IF(CLOSE>OPEN,VA1*(HIGH-LOW),IF(CLOSE主卖1:=IF(CLOSE>OPEN,0-VA1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE

AA6:=(主买1-(-主卖1))/主买1;
STICKLINE(大底>0  AND C

千载难逢:
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),18,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR3:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),20,1)*100;
VAR4:=BARSLAST(VAR3<48)<=3 AND CROSS(VAR2,VAR3);
VAR5:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<-12.5;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,10);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4);
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
低吸:0-(-1)*VAR4 AND VAR5 AND CROSS(VAR8,VAR9) AND VAR8<=25;
DRAWTEXT(低吸>0,0.9,'★低吸');
IF(低吸>0,1,0);
VARC:=REF(CLOSE,1);
VARD:=SMA(MAX(CLOSE-VARC,0),7,1)/SMA(ABS(CLOSE-VARC),7,1)*100;
VARE:=SMA(MAX(CLOSE-VARC,0),13,1)/SMA(ABS(CLOSE-VARC),13,1)*100;
VARF:=BARSLAST(VARE<43)<=3 AND CROSS(VARD,VARE);
VAR10:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR11:=LLV(LOW,5);
VAR12:=HHV(HIGH,10);
VAR13:=EMA((CLOSE-VAR11)/(VAR12-VAR11)*100,4);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2);
枯木逢春: 0-(-1)*VARF AND VAR10 AND CROSS(VAR13,VAR14) AND VAR13<=25;
DRAWTEXT(枯木逢春>0,1.7,'★枯木逢春');
IF(枯木逢春>0,2,0);
VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100;
VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100;
VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR1C:=LLV(LOW,5);
VAR1D:=HHV(HIGH,10);
VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4);
VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2);
难得一遇: 0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25;
DRAWTEXT(难得一遇>0,2.5,'★难得一遇');
IF(难得一遇>0,3,0);
VAR22:=REF(CLOSE,1);
VAR23:=SMA(MAX(CLOSE-VAR22,0),7,1)/SMA(ABS(CLOSE-VAR22),7,1)*100;
VAR24:=SMA(MAX(CLOSE-VAR22,0),13,1)/SMA(ABS(CLOSE-VAR22),13,1)*100;
VAR25:=BARSLAST(VAR24<23)<=3 AND CROSS(VAR23,VAR24);
VAR26:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5;
VAR27:=LLV(LOW,5);
VAR28:=HHV(HIGH,10);
VAR29:=EMA((CLOSE-VAR27)/(VAR28-VAR27)*100,4);
VAR2A:=EMA(0.667*REF(VAR29,1)+0.333*VAR29,2);
千载难逢:0-(-1)*VAR25 AND VAR26 AND CROSS(VAR29,VAR2A) AND VAR29<=25;
DRAWTEXT(千载难逢>0,3.3,'★千载难逢');
IF(千载难逢>0,4,0);

帮忙改成预警公式,谢谢!
{支撑@阻力}

5日:MA(CLOSE,5);
10日:MA(CLOSE,10);
20日:MA(CLOSE,20);
30日:=MA(CLOSE,30);
60日:MA(CLOSE,60);
125日:MA(CLOSE,125);
250日:=MA(CLOSE,250);
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
P1:=IF(CLOSEP2:=IF(CLOSESTICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,3,0),COLORAAAAAA;
CLOSE3:=REF(CLOSE,3);
CLOSE5:=REF(CLOSE,5);
CLOSE7:=REF(CLOSE,7);
CLOSE8:=REF(CLOSE,8);
CLOSE13:=REF(CLOSE,13);
CLOSE21:=REF(CLOSE,21);
JC:=(REF(CLOSE,3)+REF(CLOSE,5)+REF(CLOSE,7)+REF(CLOSE,8)+REF(CLOSE,13)+REF(CLOSE,21))/6;
AA:=IF(CLOSE>=REF(CLOSE,3),1,0);
BB:=IF(CLOSE>=REF(CLOSE,5),1,0);
CC:=IF(CLOSE>=REF(CLOSE,7),1,0);
DD:=IF(CLOSE>=REF(CLOSE,8),1,0);
EE:=IF(CLOSE>=REF(CLOSE,13),1,0);
FF:=IF(CLOSE>=REF(CLOSE,21),1,0);
GZ2:=AA+BB+CC+DD+EE+FF;
KK:=REF(GZ2,1)+REF(GZ2,2)+REF(GZ2,3)+REF(GZ2,4);
KKK:=KK/4;
DRAWTEXT(KKK=0 AND GZ2>0 AND CLOSE>REF(CLOSE,1),LOW*0.994,'☆---买'),COLORGREEN;
DRAWTEXT(KKK=6 AND GZ2<6 ,HIGH*1.02,'卖---☆'),COLORRED;
GJ:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
明日阻力:=IF(CLOSE=INDEXC,GJ+INDEXC-INDEXL,GJ+(CLOSE-LOW)),NODRAW;
明日支撑:=IF(CLOSE=INDEXC,INDEXL+INDEXC-GJ,LOW+(CLOSE-GJ)),NODRAW;
今日阻力:REF(明日阻力 , 1),NODRAW;
今日支撑:REF(明日支撑 , 1),NODRAW;

选股:

AA:=IF(CLOSE>=REF(CLOSE,3),1,0);
BB:=IF(CLOSE>=REF(CLOSE,5),1,0);
CC:=IF(CLOSE>=REF(CLOSE,7),1,0);
DD:=IF(CLOSE>=REF(CLOSE,8),1,0);
EE:=IF(CLOSE>=REF(CLOSE,13),1,0);
FF:=IF(CLOSE>=REF(CLOSE,21),1,0);
GZ2:=AA+BB+CC+DD+EE+FF;
KK:=REF(GZ2,1)+REF(GZ2,2)+REF(GZ2,3)+REF(GZ2,4);
KKK:=KK/4;
买:KKK=0 AND GZ2>0 AND CLOSE>REF(CLOSE,1);

仅用于通达信高速行情系统v6.04版

{龙腾四海 副图}

A1:=1;
A2:=((EMA(CLOSE,12)) - (EMA(CLOSE,26))) * 10;
A3:=EMA(A2,27);
A4:=2 * (A2 - A3);
A5:=((CLOSE - (LLV(LOW,9))) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100;
A6:=SMA(A5,3,1);
A7:=SMA(A6,3,1);
A8:=(3 * A6) - (2 * A7);
A9:=((MA(CLOSE,3)));
A10:=MA(CLOSE,5);
A11:=MA(CLOSE,10);
A12:=((MA(CLOSE,13)));
A13:=MA(CLOSE,30);
A14:=MA(CLOSE,34);
A15:=MA(CLOSE,55);
A16:=MA(CLOSE,60);
A17:=MA(CLOSE,90);
A18:=MA(CLOSE,120);
A19:=MA(CLOSE,250);
A20:=((CLOSE - A10) / A10) * 100;
A21:=((CLOSE - A11) / A11) * 100;
A22:=((CLOSE - A12) / A12) * 100;
A23:=((CLOSE - A13) / A13) * 100;
A24:=((CLOSE - A14) / A14) * 100;
A25:=((CLOSE - A16) / A16) * 100;
A26:=((CLOSE - A17) / A17) * 100;
A27:=((CLOSE - A18) / A18) * 100;
A28:=((CLOSE - A19) / A19) * 100;
A29:=MA(CLOSE,4);
A30:=MA(CLOSE,25);
A31:=MA(CLOSE,45);
A32:=MA(CLOSE,74);
A33:=MA(CLOSE,99);
A34:=MA(CLOSE,144);
A35:=MA(CLOSE,165);
A36:=MA(CLOSE,200);
A37:=MA(CLOSE,318);
A38:=MA(CLOSE,453);
A39:=EMA(CLOSE,17);
A40:=EMA(CLOSE,50);
A41:=(100 * (CLOSE - A13)) / A13;
龙腾四海:(100 - ((100 * ((HHV(HIGH,40)) - CLOSE)) / ((HHV(HIGH,40)) - (LLV(LOW,40))))) * A1,COLORFFFFCC;
A42:=(((((CLOSE / (REF(CLOSE,1))) <= 0.97) AND ((OPEN / CLOSE) >= 1.02)) OR (((CLOSE / (REF(CLOSE,1))) <= 0.95) AND (OPEN != CLOSE))));
A43:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),9,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),9,1))) * 100;
A44:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),14,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),14,1))) * 100;
A45:=(((ABS((A44 - A43)) < 9) AND (A44 < 20)) AND (A43 > 9.5)) AND (A43 < 12);
A46:=((((A45 AND (A20 < -9)) AND A42) AND (VOL < ((REF(VOL,1)) * 3))) * VOL) * 1.5;
A47:=REF(A46,1);
A48:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),7,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),7,1))) * 100;
A49:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),13,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),13,1))) * 100;
A50:=(REF(("CCI.CCI"),1)) > -180;
A51:=CROSS(("KDJ.J"),0);
A52:=(((CLOSE / (REF(CLOSE,1))) >= 1.066) AND ((HIGH / CLOSE) < 1.005)) AND (((MA(CLOSE,46)) / CLOSE) >= 1.19);
A53:=(VOL / (REF(VOL,3))) >= 1.29;
A54:=(((A48 < 19) AND (A49 < 23)) AND A51) AND A50;
A55:=A52 AND ((COUNT(A52,10)) = 1);
A56:=(A54 >= 1) AND A53;
A57:=(A56 AND ((COUNT(A56,20)) = 1)) AND (FINANCE(7) <= 13000);
A58:=A57 OR A55;
A59:=(((((((((REF(CLOSE,1)) / (REF(CLOSE,2))) <= 0.97) AND (A4 > -2.5)) AND ((REF(A7,1)) < 20)) AND (CLOSE >= OPEN)) AND (CLOSE < A18)) AND ((REF(A8,1)) < 10)) AND (HIGH < (REF(OPEN,1)))) AND (LOW >= (REF(CLOSE,1)));
A60:=((((((REF(CLOSE,1)) / (REF(CLOSE,2))) <= 0.97) AND (CLOSE > (REF(HIGH,1)))) AND (CLOSE < A18)) AND (A6 > (REF(A6,1)))) AND (A8 < 30);
A61:=(((REF(A60,1)) AND (A7 < 30)) AND ((CLOSE / (REF(CLOSE,1))) < 0.98)) AND (VOL < (REF(VOL,1)));
A62:=((((((A8 < -3) AND (A7 < 25)) AND ((CLOSE / (REF(CLOSE,1))) <= 0.97)) AND ((OPEN / CLOSE) >= 1.02)) AND (VOL < ((REF(VOL,1)) * 2.5))));
A63:=(((REF(A62,1)) AND (CLOSE > OPEN)) AND ((A7 - A6) > 3.5)) AND (A8 > (REF(A8,1)));
A64:=((A59 OR A61) OR A63) * 2;
买一:(((((((((((((((BETWEEN(CLOSE,A15,A14)) AND (A12 > A14)) AND (A14 > A15)) AND (A14 > (REF(A14,1)))) AND (A15 > (REF(A15,1)))) AND (CLOSE < (REF(CLOSE,1)))) AND (CLOSE < OPEN)) AND ((REF(CLOSE,1)) < (REF(CLOSE,2)))) AND (A24 < -3)) AND (A27 < 10)) AND (A6 < 20)) AND (A8 < 0)) AND (OPEN != CLOSE)) AND (VOL < ((REF(VOL,1)) * 3))) * 60) * A1,STICK,LINETHICK3,COLORGREEN;
买二:(((FILTER(((((((((((((((A4 > (REF(A4,1))) AND ((REF(A4,2)) > (REF(A4,3)))) AND ((REF(A4,1)) < (REF(A4,2)))) AND (((HIGH / CLOSE) < 1.006) OR ((CLOSE / OPEN) > 1.02))) AND (A2 > 0)) AND (A2 < 2)) AND (A8 > (REF(A8,1)))) AND (A8 > 70)) AND (A12 > (REF(A12,1)))) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) < 0.987)) AND ((CLOSE / OPEN) > 1.01)) AND ((MA(VOL,10)) > (REF((MA(VOL,10)),1)))) AND (VOL < ((REF(VOL,1)) * 2.5))) AND (VOL > (MA(VOL,40)))),3)) OR ((((((((((REF(CLOSE,1)) / (REF(CLOSE,2))) <= 0.97) AND ((REF(HIGH,1)) >= (REF(LOW,2)))) AND ((HIGH - CLOSE) <= 0.029)) AND ((OPEN - LOW) <= 0.039)) AND ((REF(A22,1)) < -2)) AND (A4 < 2)) AND (A4 > -4)) AND ((((REF(A7,1)) < 20) AND ((CLOSE / (REF(CLOSE,1))) >= 1.01)) OR (((REF(A7,1)) < 30) AND ((CLOSE / (REF(CLOSE,1))) >= 1.02))))) * 60) * A1,STICK,LINETHICK3,COLORYELLOW;
A65:=(CROSS(("KDJ.K"),("KDJ.D"))) * 60;
A66:=(((REF(CLOSE,1)) / (REF(CLOSE,2))) <= 0.97) AND (((REF(OPEN,1)) / (REF(CLOSE,1))) >= 1.02);
A67:=(((CLOSE / (REF(CLOSE,1))) <= 0.96) AND ((OPEN / CLOSE) >= 1.02)) OR (((CLOSE / (REF(CLOSE,1))) <= 0.95) AND (OPEN != CLOSE));
A68:=(1);
A69:=IF(((((((EMA(CLOSE,5)) / (EMA((EMA(CLOSE,9)),16))) <= 0.85) AND ((CLOSE / (REF(CLOSE,1))) > 0.905)) AND ((CLOSE / (REF(CLOSE,1))) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
A70:=((-100 * ((HHV(HIGH,34)) - CLOSE)) / ((HHV(HIGH,34)) - (LLV(LOW,34)))) + (100 * A68);
A71:=((-100 * ((HHV(HIGH,50)) - CLOSE)) / ((HHV(HIGH,50)) - (LLV(LOW,50)))) + 100;
A72:=((-100 * ((HHV(HIGH,70)) - CLOSE)) / ((HHV(HIGH,70)) - (LLV(LOW,70)))) + (100 * A68);
A73:=(A24 + 10) * 5;
A74:=((((CLOSE - (MA(CLOSE,50))) / (MA(CLOSE,50))) * 100) + 10) * 5;
A75:=((((CLOSE - (MA(CLOSE,70))) / (MA(CLOSE,70))) * 100) + 10) * 5;
A76:=((((((A70 + A71) + A72) + A73) + A74) + A75) / 6) * A68;
A77:=EMA(A76,3);
A78:=ABS((A73 - A75));
A79:=(A76 + A78) / 2;
A80:=(-1 * ((EMA((100 * (1 - WINNER(CLOSE))),1)) - 50)) + 50;
A81:=A80 + A79;
A82:=(IF(((A69 > 0) AND (A81 < 0)),200,0)) * A68;
A83:=IF((((((A79 < 0) AND (CLOSE = (LLV(CLOSE,5)))) AND ((CLOSE / (REF(CLOSE,1))) > 0.905)) AND ((CLOSE / (REF(CLOSE,1))) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),-50,0);
A84:=(IF(((A81 < 0) AND (A83 = -50)),100,0)) * A68;
A85:=(REF(CLOSE,2)) * 0.865;
A86:=(REF(CLOSE,13)) * 0.772;
A87:=MIN(A85,A86);
A88:=((100 * VOL) / CAPITAL) * A68;
A89:=IF(((((CLOSE - A87) / CLOSE) < (3 / 100)) AND (((SUM(A88,5)) / 5) < 1.8)),1,0);
A90:=IF(((A89 > 0) AND ((A83 < 0) OR (A69 > 0))),100,0);
A91:=IF((((((A82 > 0) AND (A84 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((A89 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902))) OR ((((((A82 > 0) AND (A84 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (A89 > 0)) AND ((A83 < 0) OR (A69 > 0))) AND (A90 < 10))),50,0);
A92:=(((((A82 > 0) AND (A84 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (A89 > 0)) AND ((A83 < 0) OR (A69 > 0))) OR ((((A82 > 0) AND (A84 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((A89 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902)));
A93:=A90 OR A92;
A94:=(A90);
A95:=(MA(CLOSE,80)) - ((A11 / 3) * A68);
中:((((A94 > 0) AND (A7 < 30)) AND ((A7 - A6) < 11)) AND (VOL <= ((REF(VOL,1)) * 3))) * 65,STICK,LINETHICK4,COLORYELLOW;
A96:=AMOUNT / VOL;
A97:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),5);
A98:=VOL * CLOSE;
A99:=(EMA(A98,5)) / (EMA(VOL,5));
A100:=((CLOSE - A99) / A99) * 100;
A101:=A96 / 100;
A102:=MA(A101,5);
A103:=MA(A101,20);
A104:=MA(A101,30);
A105:=MA(CLOSE,27);
A106:=((CLOSE - A105) / A105) * 100;
A107:=(MA(A106,3)) * A1;
A108:=(A100 < -2) AND ((A102 > (A101 * 1.03)) AND (A103 > (A101 * 1.13)));
A109:=(((2 * CLOSE) + HIGH) + LOW) / 4;
A110:=EMA((((((EMA(A109,3)) + (EMA(A109,6))) + (EMA(A109,12))) + (EMA(A109,24))) / 4),2);
A111:=(1 + (100 / 1000)) * A110;
A112:=((CLOSE - COST(10)) / CLOSE) * 100;
A113:=(1 + (-120 / 1000)) * A110;
A114:=IF((((LOW < A113) AND (CLOSE < OPEN)) AND ((A112 < -13) = 1)),65,0);
{A42:=(((((CLOSE / (REF(CLOSE,1))) <= 0.97) AND ((OPEN / CLOSE) >= 1.02)) OR (((CLOSE / (REF(CLOSE,1))) <= 0.95) AND (OPEN <> CLOSE))));
A9:=((MA(CLOSE,3)));}
A212:=(((MA(CLOSE,13)) * A68));
双买:(((((((((((((((A102 > (A101 * 1.03)) AND (A103 > (A101 * 1.13))) AND (A97 < 11)) AND (A43 < 20)) AND (A20 < -9)) AND (A22 < -16)) AND (A22 > -23)) AND (A107 < -15)) AND (A7 < 30)) AND (A22 > -23)) AND A42) AND (VOL <= ((REF(VOL,1)) * 3))) OR (((((((((((((A102 > (A101 * 1.03)) AND (A103 > (A101 * 1.13))) AND (A97 < 12)) AND (A43 < 20)) AND (A7 < 30)) AND A114) AND (A23 < -19)) AND (A22 < -16)) AND (A22 > -23)) AND (A20 < -9)) AND (A20 > -14)) AND A42) AND (VOL <= ((REF(VOL,1)) * 3)))) OR (((((((((((A102 > (A101 * 1.03)) AND (A103 > (A101 * 1.13))) AND (A97 < 12)) AND (A114 > 0)) AND (A43 > 20)) AND (A8 > (REF(A8,1)))) AND (A20 < -9)) AND (A22 < -15)) AND A66) AND A67) AND (VOL <= ((REF(VOL,1)) * 3)))) * 60) * A1,COLORRED;
屠龙刀:((((((((((A97 < 6) AND A108) AND (A107 < -15)) AND (A20 < -6)) AND (A22 > -28)) AND A42) AND ((REF(VOL,1)) < ((REF(VOL,2)) * 3))) AND (VOL <= ((REF(VOL,1)) * 3))) OR (((((((((A97 < 8) AND (A97 > 6)) AND (A100 > -8)) AND (A43 > 8)) AND ((A102 > (A101 * 1.03)) AND (A103 > (A101 * 1.13)))) AND (A107 < -14)) AND (A22 < -16)) AND A67) AND (VOL < ((REF(VOL,1)) * 2.5)))) * 70) * A1,STICK,LINETHICK2,COLORMAGENTA;
金针:(IF(((FILTER(A58,5)) = 1),65,0)) * A1,LINETHICK2,COLORRED;
A115:=(SUM((VOL / CAPITAL),13)) * 100;
A116:=(((REF(CLOSE,13)) - CLOSE) / (REF(CLOSE,13))) * 100;
A117:=(((A115 <= 30) AND (A115 >= 2)) AND (((VOL / CAPITAL) * 100) < 2)) AND (((((REF(CLOSE,1)) - CLOSE) / (REF(CLOSE,1))) * 100) < 6);
银针:((((((((((A116 >= 18) AND ((CLOSE / (REF(CLOSE,1))) <= 0.98)) AND (A4 > -4)) AND (HIGH >= (REF(LOW,1)))) AND (A22 > -13)) AND ((VOL / CAPITAL) > 0.01)) AND A117) AND (VOL < ((REF(VOL,1)) * 2))) OR ((((((((CLOSE / (REF(CLOSE,1))) <= 0.975) AND (A4 > -4)) AND (A8 > (REF(A8,1)))) AND (A8 < 20)) AND (HIGH >= (REF(LOW,1)))) AND (A22 < -9)) AND (VOL < ((REF(VOL,1)) * 2)))) * 65) * A1,LINETHICK2,COLORWHITE;
A118:=MA(CLOSE,44);
A119:=(CLOSE - A118) / A118;
A120:=((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7;
A121:=((SUM(AMOUNT,13)) / A101) / 100;
A122:=DMA(A120,(VOL / A121));
A123:=((CLOSE - A122) / A122) * 100;
买十:((((((((((A123 < (-9 - 13)) AND (A22 < -16)) AND (A22 > -24)) AND (A20 < -7.5)) AND (A20 > -13)) AND (A7 < 20)) AND (A43 < 20)) AND A42) AND (VOL < ((REF(VOL,1)) * 3))) * 85) * A1,COLORMAGENTA;
A124:=(9999);
A125:=CLOSE - (REF((MA(CLOSE,20)),11));
A126:=(IF(((A69 > 0) AND (A81 < 0)),200,0)) * A125;
A127:=(IF(((A81 < 0) AND (A83 = -50)),100,0)) * A125;
A128:=((100 * VOL) / CAPITAL) * A125;
A129:=IF(((((CLOSE - A87) / CLOSE) < (3 / 100)) AND (((SUM(A128,5)) / 5) < 1.8)),1,0);
A130:=IF(((A129 > 0) AND ((A83 < 0) OR (A69 > 0))),100,0);
A131:=IF((A130 > 0),60,0);
A132:=IF((((((A126 > 0) AND (A127 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((A129 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902))) OR ((((((A126 > 0) AND (A127 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (A129 > 0)) AND ((A83 < 0) OR (A69 > 0))) AND (A130 < 10))),50,0);
A133:=(((((A126 > 0) AND (A127 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR (A129 > 0)) AND ((A83 < 0) OR (A69 > 0))) OR ((((A126 > 0) AND (A127 > 0)) AND (((SUM(((VOL / CAPITAL) * 100),5)) / 5) < 1)) OR ((A129 > 0) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) > 0.902)));
A134:=A131 OR A133;
A135:=(A130);
A136:=(MA(CLOSE,80)) - ((A11 / 3) * A125);
A312:=(((MA(CLOSE,13)) * A125));
中一:(((((((A135 > 0) AND (中 = 0)) AND (A7 < 20)) AND (A22 > -23)) AND (VOL <= ((REF(VOL,1)) * 2))) OR ((((((A135 > 0) AND (中 = 0)) AND (A7 < 30)) AND (A8 > (REF(A8,1)))) AND (A22 > -23)) AND (VOL <= ((REF(VOL,1)) * 2)))) * 40) * A1,STICK,LINETHICK3,COLORYELLOW;
金叉:(((CROSS(A44,20)) AND A47) * 45) * A1,LINETHICK2,COLORYELLOW;
DRAWTEXT((中一 > 0),25,'中一'),COLORYELLOW;
注意:((((A102 > (A101 * 1.03)) AND (OPEN != CLOSE)) AND (A103 > (A101 * 1.13))) * 35) * A1,LINETHICK2,COLORFF99FF;
A137:=(REF(("KDJ.J"),1)) < ("KDJ.J");
A138:=((((CLOSE / (REF(CLOSE,1))) < 0.98) AND (OPEN != CLOSE)));
A139:=(((A137 AND A138) AND (注意 > 0)) AND (A22 < -15)) * 50;
DRAWTEXT((A139 > 0),注意,'J'),COLORYELLOW;
买三:(((((((((((((A8 < 0) AND (A43 < 30)) AND (CLOSE != OPEN)) AND (HIGH >= (REF(LOW,1)))) AND (A4 > -2)) AND (A7 < 45)) AND (A2 > -1)) AND (CLOSE < A18)) AND (A22 < -8)) AND ((CLOSE / (REF(CLOSE,1))) <= 0.985)) AND (VOL < ((REF(VOL,1)) * 2))) OR (((((((注意 AND (HIGH >= (REF(LOW,1)))) AND ((CLOSE / (REF(CLOSE,1))) <= 0.972)) AND (A22 < -11)) AND ((REF(VOL,1)) < ((REF(VOL,2)) * 3))) AND (VOL < ((REF(VOL,1)) * 3))) AND ((VOL / CAPITAL) < 0.06)) AND (((((A8 < 0) AND (A8 > -10)) AND (A8 > (REF(A8,1)))) AND (A22 > -18)) OR ((((((((REF(CLOSE,1)) / (REF(CLOSE,2))) <= 0.97) AND ((REF(A8,1)) < 0)) AND (A8 > (REF(A8,1)))) AND (A8 < 5)) AND (A8 > -6)) AND (A22 > -16))))) * 50) * A1,STICK,LINETHICK3,COLORMAGENTA;
A140:=SMA((SMA((((CLOSE - (LLV(LOW,55))) / ((HHV(HIGH,55)) - (LLV(LOW,55)))) * 100),18,1)),12,1);
A141:=SMA((((CLOSE - (LLV(LOW,55))) / ((HHV(HIGH,55)) - (LLV(LOW,55)))) * 100),12,1);
A142:=IF((CROSS(A141,A140)),30,0);
A143:=((HIGH + LOW) + CLOSE) / 3;
A144:=(A143 - (MA(A143,14))) / (0.015 * (AVEDEV(A143,14)));
A145:=(A143 - (MA(A143,85))) / (0.015 * (AVEDEV(A143,85)));
A146:=IF(((A145 >= 200) AND (A144 >= 150)),10,0);
A147:=((SMA((MAX((CLOSE - (REF(CLOSE,1))),0)),6,1)) / (SMA(ABS((CLOSE - (REF(CLOSE,1)))),6,1))) * 100;
A148:=IF((CROSS(80,A147)),30,0);
卖点:(IF((A148 AND (A146 OR A142)),40,0)) * A1,COLORFF0000;
DRAWTEXT((IF((A148 AND (A146 OR A142)),30,0)),40,'卖信号'),COLORFF0000;
A149:=BARSLAST(((CROSS(-10,A107)) = 1));
A150:=BARSLAST(((CROSS(A107,10)) = 1));
A151:=((A107 < -10) AND (A149 > 3)) * A1;
A152:=((A107 > 10) AND (A150 > 3)) * A1;
安全:(((IF(A151,A107,0)) < 0) * -10) * A1,COLORGREEN;
上叉:((((((A65 AND 安全) AND ((A6 - A7) > 1.5)) AND (OPEN != HIGH)) AND (A26 < -10)) OR (安全 AND (CROSS(A6,A7)))) * 50) * A1,STICK,LINETHICK3,COLORRED;
DRAWTEXT((上叉 > 0),55,'上叉'),COLORRED;
A238:=((CLOSE / REF(CLOSE,1)) < 0.98 AND (OPEN != CLOSE));
A239:=((((A8 > (REF(A8,1))) AND A238) AND (注意 > 0)) AND (A22 < -10)) * 50;
DRAWTEXT((A239 > 0),注意,'J'),COLORYELLOW;
安全区:STICKLINE(((IF(A151,A107,0)) < 0),-10,0,10,1),COLORGREEN;
风险区:STICKLINE(((IF(A152,A107,0)) > 0),110,100,10,1),COLORRED;
买十一:(((((((A13 > (REF(A13,1))) AND (A2 > A3)) AND (A2 > 0)) AND ((((A6 > A7) AND (A6 < 85)) OR ((A6 < A7) AND (A8 > (REF(A8,1))))) OR (A8 < 30))) AND (CLOSE > A16)) AND (CROSS(A13,A16))) * 25) * A1,LINETHICK1,COLORYELLOW;
买十二:(((((((A6 > A7) AND (A6 < 80)) AND (A8 < 90)) OR (A8 < 30)) AND (CLOSE > A17)) AND (CROSS(A13,A17))) * 25) * A1,LINETHICK1,COLORYELLOW;
买十三:(((((((A6 > A7) AND (A8 > (REF(A8,1)))) AND (A23 < 15)) OR (A8 < 30)) AND (CLOSE > A18)) AND (CROSS(A13,A18))) * 25) * A1,LINETHICK1,COLORYELLOW;
A262:=(((MAX(MAX(A16,A17),A18) / (MIN(MIN(A16,A17),A18))) < 1.03));
买十四:((((((((((A6 > A7) AND (A6 < 85)) AND (A8 > (REF(A8,1)))) AND (A8 < 90)) OR (A8 < 30)) AND A62) AND (CLOSE > A13)) AND (A23 < 10)) AND (CROSS(A13,A19))) * 25) * A1,LINETHICK1,COLORYELLOW;
买十五:(((((((((A6 > A7) AND (A6 < 85)) AND (A8 > (REF(A8,1)))) OR (A8 < 30)) AND (CLOSE > A16)) AND (CLOSE < A19)) AND (A27 < 6)) AND (CROSS(A16,A17))) * 25) * A1,LINETHICK1,COLORYELLOW;
买十六:((((((((A6 > A7) AND (A8 > (REF(A8,1)))) OR (A8 < 30)) AND (A27 < 10)) AND (CLOSE > A18)) AND (A13 > (REF(A13,1)))) AND (CROSS(A16,A18))) * 25) * A1,LINETHICK1,COLORYELLOW;
买十七:((((((((((A6 > A7) OR (A8 < 30)) AND (A23 < 6)) AND (A13 > A16)) AND (A16 > A17)) AND (A13 > (REF(A13,1)))) AND (A4 > 0)) AND (A8 > (REF(A8,1)))) AND (CROSS(A16,A19))) * 25) * A1,LINETHICK1,COLORYELLOW;
{DRAWTEXT((买十一 > 0),30,'30X60'),COLORYELLOW;
DRAWTEXT((买十二 > 0),30,'30X90'),COLORYELLOW;
DRAWTEXT((买十三 > 0),30,'30X120'),COLORYELLOW;
DRAWTEXT((买十四 > 0),30,'30X250'),COLORYELLOW;
DRAWTEXT((买十五 > 0),30,'60X90'),COLORYELLOW;
DRAWTEXT((买十六 > 0),30,'60X120'),COLORYELLOW;
DRAWTEXT((买十七 > 0),30,'60X250'),COLORYELLOW;}
Y30X60:(((((CROSS(A13,A16)) OR (CROSS(A16,A13))) AND (((((OPEN < A16) OR ((OPEN / A16) < 1.01)) AND (CLOSE > A13)) AND ((CLOSE / A16) < 1.03)) AND ((CLOSE / OPEN) > 1.01))) AND ((VOL / (REF(VOL,1))) > 1.1)) * 30) * A1,COLORWHITE;
Y30X90:((((((A16 / (REF(A16,1))) >= 1) AND (CROSS(A13,A17))) AND (((((OPEN < A17) OR ((OPEN / A17) < 1.01)) AND (CLOSE > A13)) AND ((CLOSE / A17) < 1.03)) AND ((CLOSE / OPEN) > 1.01))) AND ((VOL / (REF(VOL,1))) > 1.1)) * 30) * A1,COLORWHITE;
Y30X120:((((CROSS(A13,A18)) AND (((((OPEN < A18) OR ((OPEN / A18) < 1.01)) AND (CLOSE > A13)) AND ((CLOSE / A18) < 1.03)) AND ((CLOSE / OPEN) > 1.01))) AND ((VOL / (REF(VOL,1))) > 1.1)) * 30) * A1,COLORWHITE;
Y30X250:((((CROSS(A13,A19)) AND (((((OPEN < A19) OR ((OPEN / A19) < 1.01)) AND (CLOSE > A13)) AND ((CLOSE / A19) < 1.03)) AND ((CLOSE / OPEN) > 1.01))) AND ((VOL / (REF(VOL,1))) > 1.1)) * 30) * A1,COLORWHITE;
DRAWTEXT((Y30X60 > 0),15,'30X60阳'),COLORWHITE;
DRAWTEXT((Y30X90 > 0),15,'30X90阳'),COLORWHITE;
DRAWTEXT((Y30X120 > 0),15,'30X120阳'),COLORWHITE;
DRAWTEXT((Y30X250 > 0),15,'30X250阳'),COLORWHITE;
启动:((((((CROSS(A29,A30)) AND ((CLOSE / A30) <= 1.05)) AND (CLOSE >= A39)) AND (CLOSE > A29)) AND (A29 > (REF(A29,2)))) * 20) * A1,LINETHICK1,COLORRED;
扬升:(((((CROSS(A30,A33)) AND (CLOSE >= A40)) AND (CLOSE > A30)) AND ((LOW / A30) <= 1.01)) * 40) * A1,STICK,LINETHICK3,COLORWHITE;
A153:=(MAX(MAX(MAX(A39,A40),A30),MAX(A33,A36))) / (MIN(MIN(MIN(A39,A40),A30),MIN(A33,A36))) < 1.05;
五彩开花:((CLOSE > A39 AND A39 >MAX(MAX(A40,A30),MAX(A33,A36)) AND CROSS(A39,A36) AND A153) * 70) * A1,LINETHICK2,COLORMAGENTA;
DRAWTEXT((启动 > 0),25,'关注'),COLORRED;
DRAWTEXT((扬升 > 0),50,'扬升'),COLORWHITE;
DRAWTEXT((五彩开花 > 0),75,'五彩开花'),COLORMAGENTA;
A154:=((((((((CLOSE < A17) AND (CROSS(A6,A7))) AND ((REF(A2,1)) < 1)) AND (A2 > A3)) AND (A8 > (REF
(A8,4)))) AND ((REF(A4,1)) < (REF(A4,2)))) AND (A4 > (REF(A4,1)))) * 55) * A1;
A155:=((FILTER(((((((REF(A40,1)) < (REF(A40,2))) AND (CLOSE > A33)) AND (A40 > (REF(A40,1)))) AND (A2
> A3)) AND (A8 > (REF(A8,1)))),5)) * 45) * A1;
A156:=((((((((((((((((MAX(A40,A39)) / (MIN(A40,A39))) > 1.01) AND (((MAX(A40,A39)) / (MIN(A40,A39)))
< 1.03)) AND (A39 > (REF(A39,1)))) AND (A39 > (REF(A39,5)))) AND (A8 < 50)) AND (A30 > A40)) AND (A30
< A39)) AND (A39 > A40)) AND (CLOSE < (REF(CLOSE,1)))) AND (CLOSE > A40)) AND (CLOSE > A36)) AND
(CLOSE < OPEN)) AND ((CLOSE - LOW) <= 0.04)) * 55) * A1;
低吸:(((A154 OR A155) OR A156) * 45) * A1,STICK,LINETHICK3,COLOR0099FF;
DRAWTEXT((低吸 > 0),55,'低吸'),COLOR0099FF;
A157:=((MAX(MAX(MAX(A13,A16),A17),MAX(A18,A19))) / (MIN(MIN(MIN(A13,A16),A17),MIN(A18,A19)))) < 1.05;
A158:=((MAX(MAX(A13,A16),MAX(A17,A18))) / (MIN(MIN(A13,A16),MIN(A17,A18)))) < 1.05;
大开花:(((((CLOSE > A13) AND (A13 > (MAX(MAX(A16,A17),MAX(A18,A19))))) AND (CROSS(A13,A19))) AND A157) * 70) *
A1,LINETHICK2,COLORRED;
小开花:((((((((CLOSE > A13) AND (A13 > (MAX(MAX(A16,A17),A18)))) AND (A13 < A19)) AND (CLOSE < A19)) AND
(CROSS(A13,A18))) AND A158) AND (A23 < 10)) * 60) * A1,LINETHICK2,COLORGREEN;
三线合一:((((((((((CROSS(A13,A17)) AND (CROSS(A16,A17))) OR ((CROSS(A17,A13)) AND (CROSS(A16,A17))))
OR ((CROSS(A13,A18)) AND (CROSS(A16,A18)))) OR ((CROSS(A16,A13)) AND (CROSS(A16,A17)))) OR ((CROSS
(A18,A13)) AND (CROSS(A16,A18)))) OR ((CROSS(A16,A17)) AND (CROSS(A16,A13)))) AND (A23 < 15)) AND
(CLOSE > A13)) * 30) * A1,STICK,LINETHICK3,COLORWHITE;
{DRAWTEXT((金叉 > 0),50,'金叉'),COLORYELLOW;
DRAWICON(金针,75,7);
DRAWTEXT((金针 > 0),65,'金针'),COLORRED;
DRAWICON(银针,75,7);
DRAWTEXT((银针 > 0),65,'银针'),COLORWHITE;
DRAWTEXT((买一 > 0),70,'买一'),COLORGREEN;
DRAWTEXT((买二 > 0),70,'买二'),COLORYELLOW;
DRAWTEXT((买三 > 0),50,'买三'),COLORMAGENTA;
DRAWTEXT((中 > 0),75,'中'),COLORYELLOW;
DRAWTEXT((屠龙刀 > 0),85,'屠龙刀'),COLORMAGENTA;
DRAWTEXT((买十 > 0),90,'买十'),COLORMAGENTA;
DRAWTEXT((双买 > 0),70,'双买'),COLORRED;
DRAWTEXT((中一 > 0),25,'中一'),COLORYELLOW;
DRAWTEXT((大开花 > 0),75,'大开花'),COLORRED;
DRAWTEXT((小开花 > 0),65,'小开花'),COLORGREEN;
DRAWTEXT((三线合一 > 0),40,'三线合一'),COLORWHITE; };

这样的思路,编写一个公式,如何


在长期的操作经验中,发现一个规律。就是当二条均线双双穿越第三条均线时,必然会产生出一个升幅翻番的黑马。选择5日均线、20日均线和90日均线为三个重要指标,以5日均线为短线指标,20日均线为中线指标,90日均线为长线指标,在选定这三条均线指标后,发觉其波动的变化比任何其它参数所显示的均线预示更准确、更及时。
  事实表明,这一选择是十分有效的,能够在黑马的寻找中获得了极为宝贵的时机。
  从实例中,可以总结出一些规律性,这就是:
  1、在5日均线领先穿越90日均线时,应密切关注;
  2、当20日均线随后穿越90日均线时,必须坚决及时地建仓;
  3、当5日均线与20日均线双双穿越90日均线时,意味着一个“黑马”股即将腾飞。但这仅仅属于黑马穿越的表现之一。
  如果我们再精选一种在90日均线上产生两个立足点,当第二个支撑点确立后,一个在90日均线上所构成的三角形已形成了。这时好似一匹黑马,在奔腾之前的一次双蹄腾起,随之将会出现一个马不停蹄的奔腾过程。其强势将更为显现,其升幅将更为惊人。
MACD+KD解盘
{MACD+KD解盘  副图}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK;
MAC := DIFF>REF(DIFF ,1);
DIF:2*DIFF;
VAR1:=EMA(CLOSE,34)-EMA(CLOSE,5);
VAR2:=EMA(VAR1,5);
趋势:=(-3)*(VAR1-VAR2);
趋势,COLORRED;
长期趋势:EMA(VAR1,10)*(-1);
JM:=CROSS(DIFF,DEA)*0.2;
JMCOUNT:COUNT(JM=0.2,BARSLAST(DEA>0)),LINETHICK0;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWTEXT(CROSS(K,D)AND(COUNT(VOL>REF(VOL,1),30)>3 AND
(VOL/CAPITAL<=(10/100)))  AND((K<=20 AND D<=20)) ,0.40,
'短线KD金叉'),COLORYELLOW;
DRAWTEXT(CROSS(K,D)AND(COUNT(VOL>REF(VOL,1),30)>3 AND
(VOL/CAPITAL<=(10/100)))AND(BARSLAST(CROSS(K,D)AND(COUNT(VOL>REF(VOL,1),30)>3 AND (VOL/CAPITAL<=(10/100))) AND ((K<=20 AND D<=20)))>=1)AND(BARSLAST(CROSS(K,D) AND (COUNT(VOL>REF(VOL,1),30)>3 AND (VOL/CAPITAL<=(10/100))) AND ((K<=30 AND D<=20)))<=7) ,0.40,
'短线KD二次金叉'),COLOR00FFFF,LINETHICK2;
B:=CROSS(D,K) AND K>60 AND D>60;
B1:=COUNT(B,BARSLAST( D<60));
DRAWTEXT(B AND B1=1,0.50, '短线KD死叉'),COLORFFFFFF,LINETHICK2;
DRAWTEXT(B AND B1=2,0.70, '短线KD二次死叉'),COLORFFFFFF,LINETHICK2;

{ 动力KDJ  副图  仅用于通达信v6.04版}
{ GLL  -20,10,-12 }
VAR1:=MA(C,20);
布林极限:=100*(C-VAR1)/STD(C,20);
布林K值:=EMA(布林极限,10);
VAR2:=EMA(布林极限,5);
VAR3:=EMA(布林K值,5);
STICKLINE(布林极限>=布林K值,100,102,2,0),COLOR0000FF;
STICKLINE(布林极限<=布林K值,100,102,2,0),COLORFF0000;
STICKLINE(VAR2>=VAR3,102,104,2,0),COLOR00FFFF;
STICKLINE(VAR2VAR1K:=(L+H+2*C)/4;
VAR2K:=REF(VAR1K,1);
VAR3K:=SMA(VAR1K-VAR2K,6,1)/SMA(ABS(VAR1K-VAR2K),6,1)*100;
MMS:=MA(VAR3K,1)+50;
MMM:=EMA(MMS,8);
MML:=EMA(MMS,24);
MMC:=EMA(MMM,40);
STICKLINE(MMS>=100,105,107,6,0),COLORFFFFFF;
DRAWICON(REF(MMS,1)>=100 AND MMS<100,100,9);
DRAWTEXT(REF(MMS,1)>=100 AND MMS<100,90,'--M');
STICKLINE(MMS<0,40,50,2,0),COLOR00FF00;
MAV:=(C*2+H+L)/4;
SK:=EMA(MAV,1)-EMA(MAV,40);
SD:=EMA(SK,5);
B:=(SK-SD)*100;
T:=(C-LLV(1.02*L,20))/(HHV(H,20)-LLV(L,20))*100;
Q1:=(HHV(H,13)-C)/(HHV(H,13)-LLV(L,13))*120;
卖:=IF(Q1>100,100,Q1);
买:=IF(T>100,100,IF(T<0,0,T));
A:=(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5))*20;
A1:=(3*A-2*SMA(A,3,1))*1;
短线阻力:=IF(A1>100,100,IF(A1<-5,-5,A1));
短线能量:=IF(B<-20,-20,IF(B>100,100,B));
STICKLINE(短线能量>=短线阻力,0,短线能量+10,2,0),COLOR0000FF;
STICKLINE(短线能量>=短线阻力 AND 短线能量-REF(短线能量,1)<0,0,短线能量/2+10,2,0),COLOR00FF00;
STICKLINE(短线能量<短线阻力,0,短线能量+10,2,0),COLORFF0000;
BIAS1W:=(C-MA(C,6))/MA(C,6)*100;
BIAS2W:=(C-MA(C,12))/MA(C,12)*100;
BIAS3W:=(C-MA(C,24))/MA(C,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
STICKLINE(MNSTICKLINE(MN<-9,-10,-15,2,0),COLOR0000FF;
STICKLINE(MN<-12,-10,-15,2,0),COLOR00FFFF;
20,CIRCLEDOT,LINETHICK2,COLORFF00FF;
80,CIRCLEDOT,LINETHICK2,COLOR00FF00;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1),COLORFF0000;
D:SMA(K,3,1),COLORFF0000;
J:3*K-2*D,COLOR00FF00;
DRAWICON(CROSS(J,D) AND D<=20,18,12);
IF(J动力KDJ:IF(J>K,J,DRAWNULL),COLOR00FFFF;
IF(J>K AND JIF(J>K,K,DRAWNULL),COLOR0000FF;
IF(J>K AND KIF(J>K,D,DRAWNULL),COLOR00FF00;
0,COLOR00FF00;
LC:=REF(C,1);
RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100;
DRAWICON(CROSS(76,RSI1),110,9);
DRAWTEXT(CROSS(76,RSI1),120,'--R');

仅用于通达信v5.58版
{ 短线必赢法  副图 }
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17>0 AND VAR17-VAR18>=0,79,80,6,0),COLORRED ;
STICKLINE(VAR17>0 AND VAR17-VAR18<0,79,80,6,1),COLOR00FF00 ;
STICKLINE(VAR17>0 AND VAR17-VAR18>=0,19,20,6,0),COLORRED, ;
STICKLINE(VAR17>0 AND VAR17-VAR18<0,19,20,6,1),COLOR00FF00 ;
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),COLORRED ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),COLOR00FF00 ;
VAR22:=REF(LOW,1);
VAR23:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR24:=EMA(IF(CLOSE*1.3,VAR23*10,VAR23/10),3);
VAR25:=LLV(LOW,30);
VAR26:=HHV(VAR24,30);
VAR27:=IF(MA(CLOSE,58),1,0);
VAR28:=EMA(IF(LOW<=VAR25,(VAR24+VAR26*2)/2,0),3)/618*VAR27;
VAR29:=IF(VAR28>100,100,VAR28);
STICKLINE(VAR29>-150,0,VAR29,3,0), , COLORFF00FF;
吸筹:(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, COLOR00FF00,LINETHICK2;
STICKLINE(CROSS(吸筹,-24),100,90,6,0),COLORFFFFFF;
MA吸筹:MA(吸筹,5),COLORWHITE;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
K27:=SMA(VARK1,3,1);
D27:=SMA(K27,3,1),COLORRED,LINETHICK2;
D27A:=SMA(D27,2.5,1),COLORYELLOW,LINETHICK2;
J27: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)
,COLORYELLOW,LINETHICK2;
VVV:=CROSS(D27,K27) AND D27>65;
STICKLINE(VVV,90,100,8,1),COLORFFFF00;
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);
DK1:=K1-REF(K1,1),COLORSTICK;
VV:=IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0),STICK,COLORYELLOW;
STICKLINE( CROSS(J27,10),0,20,6,0), COLOR3366FF,;

注:可在指标公式编辑器的坐标线位置栏内填上: 0;20;50;80;100;标明坐标。

{ 极低买进大涨  副图 }

VA1:=HHV(HIGH,9)-LLV(LOW,9);     
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
生命线:EMA(VARD,1), COLORFF00FF,LINETHICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:EMA(B1,5),COLORFF7000;
STICKLINE(B1-B2>0,B1,B2,8,0),COLORFFFFFF;
STICKLINE(B1-B2<0,B1,B2,8,0),COLOR00FF00;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
STICKLINE(V1 AND V2 AND V3 AND V4,100,110,8,0),COLOR00FF00;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1STICKLINE(A3 AND A4,100,110,8,0),COLOR00FF00;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全位:=20;
低位转强:IF(CROSS(A5,安全位),50,0),COLORRED,POINTDOT;
开始拉升:IF(CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O,50,0),COLORBLUE,POINTDOT;
A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);
极低大涨:IF(A6,50,0),COLORYELLOW,POINTDOT;
STICKLINE(开始拉升>0,15,开始拉升*1.1,1,0),POINTDOT,COLORBLUE;
STICKLINE(开始拉升>0 AND 开始拉升<400,0,开始拉升,2,0),COLORBLUE,LINETHICK3;
STICKLINE(低位转强>0,15,低位转强*1.1,1,0),POINTDOT,COLORWHITE;
STICKLINE(低位转强>0 AND 低位转强<400,0,低位转强,2,0),COLORRED,LINETHICK3;
STICKLINE(极低大涨>0,15,极低大涨*1.1,1,0),POINTDOT,COLORYELLOW;
STICKLINE(极低大涨>0 AND 极低大涨<400,0,极低大涨,2,0),COLORYELLOW,LINETHICK3;


{ 青翼蝠王  主图 }

{ N 1,50,18; M 1,50,14; I 1,100,26 }

VAR01:=REF(CLOSE,5);
VAR02:=MA(CLOSE,30);
VAR03:=((VOL)/(CAPITAL))*(100);
XJYY1:=(VAR01XJYY2:=(((CROSS(MA(CLOSE,3),MA(CLOSE,10)) AND CROSS(CLOSE,VAR02) OR CROSS(MA(CLOSE,5),MA(CLOSE,20)) AND CROSS(CLOSE,VAR02)) OR (MA(CLOSE,5)>MA(CLOSE,20)) AND CROSS(CLOSE,VAR02)) OR (MA(CLOSE,3)>MA(CLOSE,10)) AND CROSS(CLOSE,VAR02));
XJYY3:=((HIGH-OPEN)/(ABS(OPEN-CLOSE))>5) AND (VAR03>2.5) AND (CLOSE>MA(CLOSE,5)) AND (CLOSE>VAR02);
XJYY4:=(((CLOSE-MA(CLOSE,10))/(MA(CLOSE,10)))*(100)>15);
XJYY5:=(((VAR03>3.5) AND (((OPEN-CLOSE)/(CLOSE))*(100)>4) OR (((CLOSE-MA(CLOSE,5))/(MA(CLOSE,5)))*(100)>20)) OR (VAR03>10) AND (((OPEN-CLOSE)/(CLOSE))*(100)>8));
STICKLINE(XJYY1,OPEN,CLOSE,3,0),COLOR00FFFF;
STICKLINE(XJYY2,OPEN,CLOSE,3,0),COLOR0000FF;
STICKLINE(XJYY3,OPEN,CLOSE,3,0),COLORFF0000;
STICKLINE(XJYY4,OPEN,CLOSE,3,0),COLORFFFFFF;
STICKLINE(XJYY5,OPEN,CLOSE,3,0),COLOR00FF00;
MA13:MA(CLOSE,13),COLOR00FF00;
MA55:MA(CLOSE,55),COLOR0000FF;
MA120:MA(CLOSE,120),COLORF0F000;
MA250:MA(CLOSE,250),COLORF00FF0;
VAR1:=('H000001$VOL')*('H000001$CLOSE');
VAR2:=(EMA(VAR1,5))/(EMA('H000001$VOL',5));
VAR3:=(('H000001$CLOSE'-VAR2)/(VAR2))*(100);
VAR4:=(VAR3<=(-1.5)) AND (VAR3>(-100));
VAR5:=(SUM((VAR4>0),N))/(SUM((VAR4=0),N));
VAR6:=(VAR5<5) AND (VAR5>=0.25);
VAR7:=(LOW+HIGH+CLOSE)/(3);
VAR8:=(VAR7-MA(VAR7,M))/((0.015)*(AVEDEV(VAR7,M)));
VAR9:=EMA(VAR8,3);
VARA:=(HIGH+LOW+CLOSE)/(3);
VARB:=((SUM(MAX(0,HIGH-REF(VARA,1)),I))/(SUM(MAX(0,REF(VARA,1)-LOW),I)))*(100);
VARC:=REF(MA(VARB,3),2.2);
VARD:=REF(MA(VARB,13),6.2);
VARE:=REF(MA(VARB,89),36.6);
VARF:=CROSS(VARC,VARB) AND (VARB>150);
DRAWTEXT(VAR6 AND CROSS(VAR8,VAR9),LOW,'抄底'),COLOR00FFFF;
DRAWTEXT(VARF,HIGH,'逃顶'),COLORFF00FF;
VAR10:=MA(CLOSE,5);
VAR11:=MA(CLOSE,10);
VAR12:=((VAR10-CLOSE)/(CLOSE)>0.03);
VAR13:=((VAR11-VAR10)/(VAR10)>0.03);
VAR14:=(LLV(CLOSE,30)=LLV(CLOSE,120));
DRAWICON(VAR12 AND VAR13 AND VAR14,(LOW)*(0.99),5),COLOR00FF00;
VAR15:=(LLV(LOW,5)=LLV(LOW,45)) AND (CLOSE>=(OPEN)*(1.04));
VAR16:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR17:=VAR15 AND VAR16;
DRAWTEXT(VAR17,LOW,' 买点 '),COLORFFFFFF;
DRAWICON(CROSS((REF(HIGH,1)+REF(LOW,1))/(2),MA(CLOSE,20)+(2)*(STD(CLOSE,20))),(HIGH)*(1.015),4),COLORFFFF00;

{ 变色龙  副图 }
参1:MA(CLOSE,7),COLORYELLOW,LINETHICK2;
参2:MA(CLOSE,20),COLORBLUE,LINETHICK2;
A:MA(C,4),COLORRED,LINETHICK2;
B:=A>REF(A,1);
IF(B-1,A,DRAWNULL)COLORGREEN,LINETHICK2;
SG:IF(C<"SAR.SAR","SAR.SAR",DRAWNULL),COLORGREEN,CIRCLEDOT;
XG:IF(C>"SAR.SAR","SAR.SAR",DRAWNULL),COLORRED,CIRCLEDOT;

{ 操盘线  副图 }

VAR1:=LLV(LOW,75);
VAR2:=HHV(HIGH,75);
VAR3:=(VAR2-VAR1)/(100);
VAR4:=(3)*(SMA((CLOSE-VAR1)/(VAR3),20,1))-(2)*(SMA(SMA((CLOSE-VAR1)/(VAR3),20,1),15,1));
庄家:(100-VAR4),LINETHICK2,COLOR9D9DFF;
VAR5:=SMA(((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10,21,8);
VAR6:=MA(CLOSE,80)-(MA(CLOSE,10))/(7);
VAR7:=EMA(CLOSE,5);
VAR8:=MA((LLV(CLOSE,9))*(1.1),14);
VAR9:=(2)*(VAR8)-VAR7-(CLOSE)*(0.1);
VAR10:=IF(((VAR7-VAR9)*(5)>0),(POW((VAR7-VAR9)*(5),2))/(10),(((-1))*(POW((VAR7-VAR9)*(5),2)))/(10));
VAR11:=IF((VAR10>0),VAR10-0,12);
VAR12:=((SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1))/(SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)))*(100);
VAR13:=SMA(((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100),13,8);
散户:SMA(VAR13,13,8),LINETHICK1,COLOR0000AA;
IF((散户-VAR5<(-65)),1,6),COLORFF00FF;
IF((散户-VAR5>85),95,100),COLORF0F000;
操盘线1:=MA((3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA
(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1)),5);
主力:MA((((-100))*(HHV(HIGH,34)-CLOSE))/(HHV(HIGH,34)-LLV(LOW,34))+100,5),LINETHICK2,COLORFF0000;
STICKLINE(FILTER(((散户75) OR CROSS(散户,操盘线1) AND (散户(操盘线1>60)),5),100,60,3,1),COLORFFFF00;
STICKLINE(FILTER((CROSS(散户,VAR11) AND (散户REF(CLOSE,1)) OR (散户>REF(散户
,1)) AND (散户<35) AND (CLOSE>REF(CLOSE,1))),5),5,50,3,1),COLOR0000FF;
底部吸筹指标:=((CLOSE-MA(CLOSE,40))/(MA(CLOSE,40)))*(100);
STICKLINE(CROSS(操盘线1,10),0,58,6,0),COLOR3366FF;
DRAWTEXT(IF(CROSS(操盘线1,10),100,0),68,'抄底'),COLORFF0000;
DRAWTEXT(IF(CROSS(10,操盘线1),1,0),10,'$备钱'),COLOR33FFCC;
DRAWTEXT(CROSS(底部吸筹指标,(-24)),80,'抄底'),COLOR008000;
STICKLINE(CROSS(底部吸筹指标,(-24)),0,40,6,0),COLOR008000;
操盘线2:=SMA(((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)))*(100),2,1);
JV1:=SMA(操盘线2,2,1);
抄底:IF((操盘线2>REF(操盘线2,1)) AND (REF(操盘线2,1){IF((操盘线2>REF(操盘线2,1)) AND CROSS(操盘线2,JV1) AND (JV1<50),20,0),COLOR0000FF;
IF((操盘线2REF(操盘线2,2)) AND (操盘线2>77),80,100),LINETHICK2,COLOR00FF00;}
DRAWICON((操盘线2>REF(操盘线2,1)) AND CROSS(操盘线2,JV1) AND (JV1<50),20,1),COLOR0000FF;
DRAWICON((操盘线2REF(操盘线2,2)) AND (操盘线2>77),80,2),LINETHICK2,COLOR00FF00;

{黄金短战均线  主图}
{P1 1,50,3; P2 1,50,8; P3 1,100,13; P4 1,100,34; P5 1,300,120;P6 1,300,250;}
MA1:MA(CLOSE,P1),COLOR00FFFF;
MA2:MA(CLOSE,P2),COLORFF00FF;
MA3:MA(CLOSE,P3),COLOR00FF00;
MA4:MA(CLOSE,P4),COLORFFFFFF;
MA5:MA(CLOSE,P5),COLORFFFF00;
MA6:MA(CLOSE,P6),COLOR0000FF;
VAR2:=EMA((SLOPE(EMA(CLOSE,20),10))*(34)+CLOSE,30);
VAR3:=EMA(VAR2,3);
VAR4:=EMA(VAR3,3);
A1:=COST(95);
A2:=COST(5);
LY:=((A1-A2)*(100))/(A1+A2);
DRAWICON((LY>REF(LY,1)),(LOW)*(0.98),8),COLOR008000;
DRAWTEXT((VAR4>90),(LOW)*(0.95),'★加仓'),COLOR00FFFF;
DRAWTEXT((VAR4>90),(LOW)*(0.99),'★'),COLOR00FFFF;
VAR1:=(HIGH+LOW+OPEN+(2)*(CLOSE))/(5);
HY3:=IF((COUNT((VAR3<20),5)>=1) AND (COUNT((VAR1=LLV(VAR1,10)),10)>=1) AND (CLOSE>=(OPEN)*(1.038)) AND (VOL>(MA(VOL,5))*(1.2)),1,0);
DRAWTEXT(HY3,LOW,'▲买入'),COLOR00FFFF;
VARR1:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)))*(100);
DRAWICON(CROSS(82,VARR1),HIGH,2),COLOR00FFFF;
DRAWTEXT(CROSS(82,VARR1),HIGH,'▲风险↓'),COLOR00FFFF;
EL1:=EMA(LOW,6);
EL2:=EMA((EMA(LOW,34))*(1),2)-0.16;
DRAWICON(CROSS(EL1,EL2),EL1,10),COLOR00FF00;
V1:=REF(CLOSE,1);
V2:=((SMA(MAX(CLOSE-V1,0),6,1))/(SMA(ABS(CLOSE-V1),6,1)))*(100);
DRAWICON(IF(CROSS(81,V2),1,0),(HIGH)*(1.01),11),COLORFFFFFF;
VAR41:=EMA(((100)*(CLOSE-LLV(LOW,34)))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR42:=EMA(((100)*(INDEXC-LLV(INDEXL,34)))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
VAR4A:=(REF(VAR41,1)>92) AND (VAR41<92);
DRAWTEXT(VAR4A,HIGH+0.12,'短卖'),COLOR00FF00;
DRAWTEXT(VAR4A,HIGH+0.05,'●'),COLOR00FF00;

{ 鱼网钓饵  主图 }
鱼1:=EMA((CLOSE+LOW+HIGH)/3, 3);
VAR1:=EMA(CLOSE, 26);
钓1:=(VAR1+2*STD(CLOSE, 26)+VAR1+2*STD(CLOSE, 49))/2;
VAR2:=EMA(CLOSE, 26);
VAR3:=VAR2+2*STD(CLOSE, 9);
VAR4:=VAR2+2*STD(CLOSE, 12);
VAR5:=VAR2+2*STD(CLOSE, 17);
VAR6:=VAR2+2*STD(CLOSE, 21);
VAR7:=VAR2+2*STD(CLOSE, 26);
VAR8:=VAR2+2*STD(CLOSE, 34);
VAR9:=VAR2+2*STD(CLOSE, 50);
VAR10:=ABS(EMA(CLOSE, 100)-EMA(CLOSE, 10))/EMA((CLOSE+LOW+HIGH)/3, 3)*CLOSE*2+EMA((CLOSE+LOW+HIGH)/3, 3);
VAR11:=ABS(EMA(CLOSE, 100)-EMA(CLOSE, 10))/EMA((CLOSE+LOW+HIGH)/3, 3)*CLOSE+EMA((CLOSE+LOW+HIGH)/3, 3);
海底1:=EMA(EMA((CLOSE+LOW+HIGH)/3, 3), 26)*0.880;
超跌区:IF(LOW<海底1 ,LOW,LOW-1 ),POINTDOT,LINETHICK7,COLORYELLOW;LOW-1,POINTDOT,LINETHICK7,COLOR000000;
超涨区:IF(HIGH>钓1 ,HIGH,HIGH+1 ),POINTDOT,LINETHICK7,COLOR00FF00;HIGH+1,POINTDOT,LINETHICK7,COLOR000000;
鱼:鱼1,COLORWHITE,LINETHICK2;
钓:钓1,LINETHICK2, COLORRED;
饵:VAR10,LINETHICK2, COLORYELLOW;
网:EMA(CLOSE, 10), COLORGREEN;
海底:海底1,LINETHICK5, COLORFFBB44;
EMA(CLOSE, 14), COLOR00FE00;
EMA(CLOSE, 21), COLOR00ED00;
EMA(CLOSE, 30), COLOR00EC00;
EMA(CLOSE, 49), COLOR00CA00;
EMA(CLOSE, 70), COLOR00C900;
EMA(CLOSE, 100), COLOR00B800;
EMA(CLOSE, 150), COLOR00B700;

{江恩轮轮  副图}
V1:=((BARSCOUNT(CLOSE))*(3.142))/(180);
A2:(SIN((V1)*(8)))*(100),COLOR00FFFF;
A3:(COS((V1)*(8)))*(100),COLORFF00FF;
X1:0,COLOR00FF00;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/(4);
VAR6:=((VAR5-REF(VAR5,5))/(REF(VAR5,5)))*(1500);
VAR7:=((VAR5-REF(VAR5,5))/(REF(VAR5,5)))*(1500);
VAR8:=EMA(VAR6,8);
底部注意:STICKLINE((VAR6>REF(VAR6,1)) AND (VAR6<0) AND (VAR6低位转强:STICKLINE((VAR8>REF(VAR8,1)) AND (VAR6<0) AND (VAR6>VAR8),VAR8,0,5,0),COLOR00FFFF;
买点:STICKLINE((VAR6>REF(VAR6,1)) AND (VAR6>0) AND (VAR8<0),VAR6,VAR8,4,0),COLOR0099FF;
DRAWICON(FILTER((VAR6>REF(VAR6,1)) AND (VAR6>0) AND (VAR8<0),30),(-140),4),COLOR008000;
DRAWTEXT(FILTER((VAR6>REF(VAR6,1)) AND (VAR6>0) AND (VAR8<0),30),(-40),'->买点'),COLOR0000FF;
STICKLINE((CROSS(A3,0) OR CROSS(0,A3)),(-100),100,5,0),COLORFF80FF;
STICKLINE((CROSS(A2,0) OR CROSS(0,A2)),(-100),100,5,0),COLOR80FF80;
坚定持股:STICKLINE((VAR8>REF(VAR8,1)) AND (VAR8>0),VAR6,0,5,0),COLOR0000FF;
谨慎观望:STICKLINE((VAR6REF(VAR8,1)) AND (VAR6>0),VAR6,VAR8,4,0),COLOR00FF00;
果断持币:STICKLINE((VAR6

{喇叭花  副图}
{N 1,100,12; N2 1,100,26; N3 1,100,7; N4 -50,0,-24;}
O2:0,COLORFF00FF;
VAR1:=((CLOSE-REF(OPEN,29))/(REF(OPEN,29)))*(100);
VAR2:=((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100);
VAR3:=((CLOSE-REF(OPEN,29))/(REF(OPEN,29)))*(100);
VAR4:=((VOL)/(CAPITAL))*(100);
上轨道:SUM(VAR4,30),COLOR00FF00;
下轨道:REVERSE(SUM(VAR4,30)),COLORFFFFFF;
VAR5:=(VAR1)/(下轨道);
DIFF:(EMA(CLOSE,N)-EMA(CLOSE,N2))*(100),COLORFFFF00;
DEA:EMA(DIFF,N3),COLOR0000FF;
VAR6:=(2)*(DIFF-DEA);
DIFF2:(REVERSE(EMA(CLOSE,N)-EMA(CLOSE,N2)))*(100),COLOR008000;
DEA2:EMA(DIFF2,N3),COLORFF0000;
VAR7:=(2)*(DIFF2-DEA2);
STICKLINE(CROSS(DIFF,DEA) AND (VAR378),DEA,DEA2,10,0),COLOR000080;
STICKLINE(CROSS(DIFF,DEA) AND (VAR3STICKLINE((DIFF<0),DIFF,DEA,1,0),COLOR00FFFF;
STICKLINE((DIFF<0),DIFF2,DEA2,1,0),COLORFF00FF;
STICKLINE((DIFF2STICKLINE((DIFF>DEA),DIFF,DEA,5,0),COLORFFFFFF;
STICKLINE((DIFF>DEA),DIFF2,DEA2,5,0),COLORFFFF00;
提示:STICKLINE((VAR5>1) AND (VAR1DRAWICON((VAR2>N3) AND (DIFF<(-48)) AND (VAR3<(-15)),DEA,1),COLOR008000;

{绝代双骄  副图 含函数WINNER}

VAR1B:=((((HHV(HIGH,60) - CLOSE) / (HHV(HIGH,60) - LLV(LOW,60))) * 100) - 10);
VAR1C:=(((CLOSE - LLV(LOW,60)) / (HHV(HIGH,60) - LLV(LOW,60))) * 100);
VAR1D:=SMA(VAR1C,13,3);
VAR1E:=SMA(VAR1B,21,8);
花无缺:SMA(VAR1D,13,8),COLORFF8A15;
IF((花无缺 < REF(花无缺,1)),花无缺,DRAWNULL),COLORFF1A1A;
盘整:STICKLINE(((花无缺 - VAR1E) < (0 - 85)),0,5,15,1),COLORFFFFFF;
VAR1F:=(WINNER(((((CLOSE + OPEN) + HIGH) + LOW) / 4)) * 1000);
临界1:=IF((VAR1F > 30),0,(0 - 15));
VAR0:=((OPEN - REF(LOW,3)) / REF(OPEN,3));
VAR1:=((CLOSE - REF(OPEN,5)) / REF(CLOSE,5));
VAR2:=((LOW - REF(CLOSE,10)) / REF(LOW,10));
VAR3:=((HIGH - REF(HIGH,23)) / REF(HIGH,23));
Y1:=EMA(VAR0,3);
Y2:=EMA(VAR1,5);
Y3:=EMA(VAR2,10);
Y4:=EMA(VAR3,23);
小鱼儿:(MA((((((2 * Y1) + Y2) + Y3) + Y4) / 5),1) * 1000),COLOR00FF00;
IF((小鱼儿 < REF(小鱼儿,1)),小鱼儿,DRAWNULL),COLORFF0000;
临界:IF((小鱼儿 < (0 - 45)),(0 - 10),(0 - 20)),COLORFFFFFF;
DRAWICON(((小鱼儿 > REF(小鱼儿,1)) AND (花无缺 > REF(花无缺,1))),(小鱼儿 - 5),4);
运气:STICKLINE(((((临界1 <= (0 - 10)) AND (临界 = (0 - 10))) AND (花无缺 > REF(花无缺,1))) AND (小鱼儿 > REF(小鱼儿,1))),(0 - 10),(0 - 20),3,0);
出招:STICKLINE(CROSS(临界1,临界),15,(0 - 15),1,0);
拔剑:STICKLINE(CROSS(临界,临界1),15,(0 - 15),1,0);

{红绿灯  副图}
VAR1:=50-((WINNER(CLOSE))*(100))/(WINNER(INDEXC));
VAR2:=((EMA(VAR1,5))*(3)+(EMA(VAR1,10))*(7))/(10);
VAR3:=50-((WINNER(OPEN))*(100))/(WINNER(INDEXO));
VAR4:=((EMA(VAR3,5))*(3)+(EMA(VAR3,10))*(7))/(10);
VAR5:=50-((WINNER(HIGH))*(100))/(WINNER(INDEXH));
VAR6:=((EMA(VAR5,5))*(3)+(EMA(VAR5,10))*(7))/(10);
VAR7:=50-((WINNER(LOW))*(100))/(WINNER(INDEXL));
VAR8:= ((EMA(VAR7,5))*(3)+(EMA(VAR7,10))*(7))/(10);
STICKLINE((VAR2>=VAR4),VAR2,VAR4,8,0),COLORAA9911;
STICKLINE((VAR2>=VAR4),VAR6,MAX(VAR2,VAR4),0,1),COLOR8A2345;
STICKLINE((VAR2>=VAR4),MIN(VAR2,VAR4),VAR8,0,1),COLORFF1111;
STICKLINE((VAR2<=VAR4),VAR2,VAR4,8,0),COLOR1100FF;
STICKLINE((VAR2<=VAR4),VAR6,MAX(VAR2,VAR4),0,1),COLOREA4598;
STICKLINE((VAR2<=VAR4),MIN(VAR2,VAR4),VAR8,0,1),COLORFFFFFF;
收盘:VAR1,COLOR11AAAA;
红绿灯:SMA(VAR2,3,1),COLOR0000FF;
红绿灯线:((EMA(VAR2,5))*(3)+(EMA(VAR2,10))*(7))/(10),COLOR00FFFF;
DRAWICON(CROSS(红绿灯,红绿灯线) AND (红绿灯线<(-47)),LOW,2),COLOR00FFFF;
DRAWICON(CROSS(红绿灯线,红绿灯) AND (红绿灯线>46),HIGH,1),COLORFF00FF;
STICKLINE((红绿灯线

自创-----超级筹码引力


套牢盘:(1-WINNER(C))*-100,STICK,COLORFFFF00,LINETHICK1;
获利盘:WINNER(C)*100,STICK,COLORRED,LINETHICK1;
M5:MA(获利盘,5),LINETHICK1,COLORWHITE;
M13: MA(套牢盘,13), ,LINETHICK1,COLORYELLOW,;
DIFF: M5+M13,LINETHICK1,COLORRED,;


{DMI技术精华 副图}
{ N   14   2   100  ;   M  5    2    20}
TR1 := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:=DMP*100/TR1;
MDI:=DMM*100/TR1;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1);
DX:(ADX*14-REF(ADX,1)*13)*IF(PDI>MDI,1,-1);
EMADX:EMA(DX,M);
{60;35;0;-35;-60;100;}
DRAWTEXT(ISLASTBAR,60,'清仓'),COLORRED;
DRAWTEXT(ISLASTBAR,35,'减仓'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,0,'控盘'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-35,'回补'),COLORGREEN;
DRAWTEXT(ISLASTBAR,-60,'吸筹'),COLORBLUE;
其中60;35;0;-35;-60;100;几个坐标放在指标公式编辑器的坐标位置栏内。

原帖由 几乎为零 于 2008-9-19 20:15 发表
江南兄,能不能将前两天有个人发的说是用这个公式,今年就没赔过钱的公式改成通达信的:
主图源码:

PC:=(H+L+C)/3;
M1:MA(PC,5);
生命线:MA(PC,25);//殷氏2号线
M2线:MA(PC,68);//相当于殷氏辅助线
M3:MA(P ... 这个公式的函数基本上没有什么特别之处,只有一个输出解盘文字函数EXPLAIN 是通达信没有的,但不妨碍改编。只要把那EXPLAIN 语句中的解盘文字放到公式编辑器里的用法注释中就行了。

PC:=(H+L+C)/3;
M1:MA(PC,5);
生命线:MA(PC,25);{//殷氏2号线}
M2线:MA(PC,68);{//相当于殷氏辅助线}
M3:MA(PC,99);{//殷氏9号线}
M4:MA(PC,203);{//相当于殷氏1号线}
成本:COST(5),COLOR0099FF,POINTDOT;{//获利盘}
{//彩色K线}
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(CP1:=今小昨;
今小前:=IF(CP2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,3,0),COLORBLUE;

以下文字放到指标公式编辑器的用法注释里:

(A)上冲时第一次碰(过)2号密码线时(强庄股除外),先退出;
(B)股价再突破2号密码线后四天内阴线碰2号密码线时买入,万一下跌破2号密码线,反抽离场。
(C)第一目标是辅助线,然后碰9号线时(不能放量)同理先退出。等回到2号密码线再介入【必胜模式】持有到1号线再退出。回抽9号线是最后买入机会,一直到ADX,boll,cci指标到位再全部退出。

【必胜模式】
   股价上穿2号密码线和操盘线,即将与9号密码线形成"必胜模式"后期只要股价回到2号密码线。就形成一个"想不赚钱也难"的"秘密买点"。


操盘铁律{主图}
{DRAWGBK(CLOSE>0,COLORRGB(95,95,95),COLORRGB(0,0,0),1);}
操盘线:EMA(CLOSE,13),COLORRED;
M5:MA(CLOSE,5),COLORWHITE;
黄金线:COST(24),COLORYELLOW,POINTDOT,LINETHICK4;
底线:COST(5),COLORGREEN;
1号线:MA(CLOSE,144),COLORWHITE,LINETHICK2;
4号线:EMA(CLOSE,453),COLORRED,LINETHICK2;
VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD:=EMA(AK,2);
AJ:=3*AK-2*AD;
STICKLINE(CROSS(AK,AD),LOW,LOW-0.09,4,0),COLORRED;{短线买}
{AC:=CLOSE;
AH:=HIGH;
AL:=LOW;
AO:=OPEN;}
{STICKLINE(AC>=AO,AH,AC,1,0),COLOR008899;
STICKLINE(AC>=AO,AH,AC,0,0),COLOR77FFEE;
STICKLINE(AC>=AO,AO,AL,1,0),COLOR008899;
STICKLINE(AC>=AO,AO,AL,0,0),COLOR77FFEE;
STICKLINE(AC>AO,AC,AO,8,0),COLOR008899;
STICKLINE(AC>AO,AC,AO,7,0),COLOR1199AA;
STICKLINE(AC>AO,AC,AO,6,0),COLOR22AABB;
STICKLINE(AC>AO,AC,AO,5,0),COLOR33BBCC;
STICKLINE(AC>AO,AC,AO,4,0),COLOR44CCDD;
STICKLINE(AC>AO,AC,AO,3,0),COLOR55DDEE;
STICKLINE(AC>AO,AC,AO,2,0),COLOR66EEEE;
STICKLINE(AC>AO,AC,AO,1,0),COLOR77FFEE;
STICKLINE(AC<=AO,AH,AC,1,0),COLORFF8800;
STICKLINE(AC<=AO,AH,AC,0,0),COLORFFFF33;
STICKLINE(AC<=AO,AO,AL,1,0),COLORFF8800;
STICKLINE(AC<=AO,AO,AL,0,0),COLORFFFF33;
STICKLINE(AC<=AO,AC,AO,8,0),COLORFF8800;
STICKLINE(AC<=AO,AC,AO,7,0),COLORFF9900;
STICKLINE(AC<=AO,AC,AO,6,0),COLORFFAA11;
STICKLINE(AC<=AO,AC,AO,5,0),COLORFFBB11;
STICKLINE(AC<=AO,AC,AO,4,0),COLORFFCC22;
STICKLINE(AC<=AO,AC,AO,3,0),COLORFFDD22;
STICKLINE(AC<=AO,AC,AO,2,0),COLORFFEE33;
STICKLINE(AC<=AO,AC,AO,1,0),COLORFFFF33;}
{//短线试买}
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSEP1:=今小昨;
今小前:=IF(CLOSEP2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLORRED;{短线进}
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1  AND REF(P2,1)=0,OPEN,CLOSE,3,0),COLORBLUE;{短线出}
{//买卖规则}{该部分因语句输出原因可全部舍去}
{P3:=SYSPARAM(1);}
{YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;}
{DRAWTEXTEX(CLOSE,1,20,0,'★ ======================'),COLORRED;
DRAWTEXTEX(CLOSE,1,20,80,'操 ----------------------'),COLORRED;
DRAWTEXTEX(CLOSE,1,20,160,'盘 ----------------------'),COLORRED;
DRAWTEXTEX(CLOSE,1,20,240,'铁 ----------------------'),COLORRED;
DRAWTEXTEX(CLOSE,1,20,320,'律 ======================'),COLORRED;
DRAWTEXTEX(CLOSE,1,20,40,'   买入条件  |  E13 CCI'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,120,'   买入时间  |  2:30以后'  ),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,200,'   止损价位  |  '+NUMTOSTR(止损价位[P3] ,2 )+'元'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,280,'   线上:工作 |  线下:休息'),COLOR00FFFF;}
{GJ:=AMOUNT/VOL/100;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);}
{DRAWTEXTEX(CLOSE,1,20,500,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,580,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,660,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,740,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,820,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,900,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,990,'-----------------'),COLORFFFFFF;
DRAWTEXTEX(CLOSE,1,20,540,'今日阻力=:'+NUMTOSTR(今日阻力[P3] ,2 )+''),COLOR00FFFF;
DRAWTEXTEX(CLOSE,1,20,620,'今日支撑=:'+NUMTOSTR(今日支撑[P3] ,2 )+''),COLOR00FF00;
DRAWTEXTEX(CLOSE,1,20,700,'明日突破=:'+NUMTOSTR(明日突破[P3] ,2 )),COLORFF00FF;
DRAWTEXTEX(CLOSE,1,20,780,'明日阻力=:'+NUMTOSTR(明日阻力[P3] ,2 )),COLORFFFF00;
DRAWTEXTEX(CLOSE,1,20,860,'明日支撑=:'+NUMTOSTR(明日支撑[P3] ,2 )),COLORRED;
DRAWTEXTEX(CLOSE,1,20,940,'明日反转=:'+NUMTOSTR(明日反转[P3] ,2 )),COLORGREEN;}
{//箱体}
N:=13;
A:=HHV(HIGH,N)=HIGH AND HIGH>REF(HIGH,1);
A1:=FILTER(A,N-1);
B:=LLV(LOW,N)=LOW AND LOWB1:=FILTER(B,N-1);
TS1:=BARSLAST(A1);
箱顶:REF(HIGH,TS1)  ,COLORFF00FF, LINETHICK1; 
STICKLINE(1,箱顶,箱顶,4,0),COLORFF00FF;
TS11:=BARSLAST(B1);
箱底:REF(LOW,TS11)  ,COLORFF8080, LINETHICK1;
STICKLINE(1,箱底,箱底,4,0),COLORFF8080;
DRAWICON(CROSS(CLOSE,箱顶),HIGH*1.01,1);
DRAWICON(CROSS(箱底,CLOSE),LOW*0.99,2);
DRAWICON(CROSS(箱顶,CLOSE) AND REF(CLOSE,1)>=箱顶,箱顶,12);

{副图}
{DRAWGBK((DATE > 0),COLORRGB(40,40,173),COLORRGB(1,1,14),1);}
LC:=REF(CLOSE,1);
止损价位:(LC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
D:=SMA(CCC,3,1);
【回抽】:IF(CROSS(D,RSI5),50,0),STICK,COLORRED;
【逃命】:IF(CROSS(80,RSI5),-50,0),STICK,COLORGREEN;
STICKLINE(CROSS(D,RSI5),50,0,8,0),COLORRED;
STICKLINE(CROSS(80,RSI5),-50,0,8,0),COLORGREEN;
RR8:=MA(CLOSE,27);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
【黄金坑】:IF(RRD,-120,0),COLORYELLOW,LINETHICK2;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORMAGENTA,LINETHICK2;
{EXPLAIN(1,'(一)长期下跌后第一次碰-100不能买,第二次碰-100在即将上穿之时买入(必须底背离,成功率才100%)。'),COLORYELLOW,ALIGN2;}
{EXPLAIN(1,'(二)股价到+100时“加码”买入,在+100以上开始回头时跌破+100应该卖出,然后按照支撑位置可以买入,第二次穿过+100之时股价一般会创新高,但是指标如果背离时,再次跌破+100,坚决抛光!'),COLORYELLOW,ALIGN2;}
{EXPLAIN(1,'(三)再次到-100以下时,就重复上面的方法。'),COLORYELLOW,ALIGN2;}

底部:-200,POINTDOT;
关注:-150,COLORGREEN,POINTDOT;
买入:-100,POINTDOT,COLORGRAY;
卖出:100,POINTDOT;

在用法注释里加入以下内容:
(一)长期下跌后第一次碰-100不能买,第二次碰-100在即将上穿之时买入(必须底背离,成功率才100%)。
(二)股价到+100时“加码”买入,在+100以上开始回头时跌破+100应该卖出,然后按照支撑位置可以买入,第二次穿过+100之时股价一般会创新高,但是指标如果背离时,再次跌破+100,坚决抛光!
(三)再次到-100以下时,就重复上面的方法。

{★资金进出★ 副图}
K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
当日买量:VOL*K1/(K1+K2),NODRAW;
当日卖量:VOL-当日买量,NODRAW;
N日买量:SUM(当日买量,N),COLOR0000FF;
N日卖量:-SUM(当日卖量,N),COLORFFFF00;
STICKLINE(1,N日买量,0,3,1),COLOR0078FF;
STICKLINE(1,N日卖量,0,3,1),COLOR004800;

进出量:N日买量+N日卖量,POINTDOT,COLOR00FFFF;
净量换手:100*进出量/CAPITAL,POINTDOT,COLOR00FF33;
STICKLINE(进出量>=0,0,进出量,6,1),COLOR0000FF;
STICKLINE(进出量<0,0,进出量,6,1),COLORFFFF00;

注:当N=5时为5日均量,当N=10时为10日均量,以此类推。

《多空买卖提示》只能用6.04以上的版本了。

平衡:EMA(C,20),CIRCLEDOT,COLORWHITE;
上轨:平衡 + 2*STD(C,20),LINETHICK2,COLORFF00FF;
下轨:平衡 - 2*STD(C,20),LINETHICK2,COLOR00FF00;
STICKLINE((CLOSE >平衡),平衡,平衡,1,0),LINETHICK6,COLOR0000FF;
STICKLINE((平衡 > CLOSE),平衡,平衡,1,0),LINETHICK6,COLORFF6600;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0 ,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFEE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFFF00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
红持:VAR9Q,COLOR0000FF,LINETHICK0;
     STICKLINE(VAR9Q,C,(O+C)/2,4,0),COLOR000055;
     STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000DD;
     STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
粉变:VARAQ,COLORFF99FF,LINETHICK0;
     STICKLINE(VARAQ,C,(O+C)/2,4,0),COLORFF11FF;
     STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFFBBFF;
     STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)灰跌:VARBQ,COLOR888888,LINETHICK0;
     STICKLINE(VARBQ,C,(O+C)/2,4,0),COLOR333333;
     STICKLINE(VARBQ,C,(O+C)/2,2,0),COLORDDDDDD;
     STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)=REF(C,1);
绿买:VARCQ,COLOR00FF00,LINETHICK0;
     STICKLINE(VARCQ,O,(O+C)/2,4,0),COLOR003300;
     STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00DD00;
     STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4) AND CREF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C蓝抛:VARDQ,COLORFF9900,LINETHICK0;
STICKLINE(VARDQ,O,(O+C)/2,4,0),COLORFF1100;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFFBB00;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFDD00;

Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9),3),1);
DRAWTEXT(CROSS(CLOSE,Y1),LOW,'[买进]'),COLORYELLOW;
STICKLINE(CROSS(Y1,CLOSE),H*1.05,H,0,0),COLORWHITE;
DRAWTEXT(CROSS(Y1,CLOSE),HIGH*1.05,'[卖出]'),COLORWHITE;

VAR1W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3W:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWTEXT(CROSS(VAR2W,MA(VAR3W,6)),LOW -0.6,'(买)'),COLORFF99FF;
DRAWTEXT(CROSS(MA(VAR3W,6),VAR1W),HIGH +0.9,'(卖)'),COLORCCFF13;

VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
STICKLINE(VAR3P>90,L,L*0.92,0,0),COLORFF00FF;
DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)SC:=LHHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1)),COLORYELLOW;
STICKLINE(买,L,L*0.95,0,0),COLORRED;
DRAWTEXT(买,L*0.95, '必涨'),COLORRED;

多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
STICKLINE(CROSS(78.89,多方),H+1.5,H,0,0),COLOR00FF00;
DRAWTEXT(CROSS(78.89,多方),H+1.5,'(逃顶)'),COLOR00FF00;

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1,EMA(A1,5))AND EMA(A1,5)

VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;
VAR2:=SMA(VAR1,3,1)*100;
趋势线:=SMA((SMA(VAR2,3,1)*VAR1),3,1)*1;
VAR9:=CROSS(趋势线,(SMA(VAR2,3,1)*VAR1)) AND (SMA(VAR2,3,1)*VAR1)>8;
DRAWTEXT(VAR9 AND COUNT(VAR9,1)=1,H+0.6,'逃'), LINETHICK2,COLORYELLOW;
DRAWICON(FILTER(CROSS(-"WR.WR1"(14,14),(0 - 81)),10),L-0.2,1);
DRAWICON(FILTER(CROSS((0 -19),-"WR.WR1"(14,14)),10),H,2);

{超买超卖 副图}
A1:=REF(C,1);
A2:=SMA(MAX(C-A1,0),5,1)/SMA(ABS(C-A1),5,1)*1000;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
A4:=A2-LLV(A2,10);
A5:=(MA(A4,2)*3+A4*13)/16;
A6:=IF(A5>13,MA(A5,2),A5)/6;
RSI1:=SMA(MAX(C-A1,0),6,1)/SMA(ABS(C-A1),6,1)*100;
RSI2:=SMA(MAX(C-A1,0),12,1)/SMA(ABS(C-A1),12,1)*100;
RSI3:=SMA(MAX(C-A1,0),24,1)/SMA(ABS(C-A1),24,1)*100;
压力:=HHV(MA(RSI2,3),12);
支撑:=LLV(MA(RSI2,3),12);
中间:(HHV(MA(RSI2,3),12)+LLV(MA(RSI2,3),12))/2,COLORRED,LINETHICK2;
STICKLINE(RSI2<支撑,中间,RSI2,2,0)COLORGREEN;
STICKLINE(RSI2>=支撑 AND RSI2<中间,中间,RSI2,2,0)COLORLIBLUE;
STICKLINE(RSI2>=中间 AND RSI2<压力,中间,RSI2,2,0)COLORLIRED;
STICKLINE(RSI2>=压力,中间,RSI2,2,0)COLORRED;
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWTEXT(B3,RSI2,'底背');
B1:=RSI1>=RSI2 AND RSI2>=RSI3;
S1:=RSI1BS1:=NOT(RSI1>=RSI2 AND RSI2>=RSI3)AND NOT(RSI1STICKLINE(B1,80,82,2,1)COLORRED;
STICKLINE(S1,80,82,2,1)COLORGREEN;
STICKLINE(BS1,80,82,2,1)COLORYELLOW;
短线:IF(CROSS(A6,1) AND (A6<30)AND RSI2<35 AND RSI2>=支撑 AND RSI2<中间,30,20),COLORMAGENTA,LINETHICK2;
老师能不能帮我编一个,能把一只股票的所有涨停K线用黄颜色显示  谢谢老师~~~ STICKLINE(C/REF(C,1)>1.097,C,O,3,0),COLORYELLOW;
STICKLINE(C/REF(C,1)>1.097,H,L,0,0),COLORYELLOW;
{n1 2,30,5}
OBVG:SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE

压力:HHV(MA(OBVG,3),13),COLORGREEN;
中轴:MA(OBVG,13),COLORCYAN,POINTDOT;
支撑:LLV(MA(OBVG,3),13),COLORYELLOW;

AA:=REF(OBVG,N1)=HHV(OBVG,2*N1+1);
BB:=BACKSET(AA,N1+1);
CC:=FILTER(BB,N1) AND BVG=HHV(OBVG,N1+1);
A1:=BARSLAST(REF(CC,1));
顶背离:=REF(H,A1+1)OBVG AND CC;
DRAWTEXT(顶背离,OBVG*1.2,'顶背离'),COLORMAGENTA;
STICKLINE(FILTER(顶背离>0,5),支撑,OBVG,10,0),COLORMAGENTA;
DRAWLINE(CC,OBVG,FILTER(顶背离>0,5),OBVG,0),COLORWHITE;
DRAWICON(顶背离,OBVG*1.1,2);

AA2:=REF(OBVG,N1)=LLV(OBVG,2*N1+1);
BB2:=BACKSET(AA2,N1+1);
CC2:=FILTER(BB2,N1) AND BVG=LLV(OBVG,N1+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(L,A2+1)>L AND REF(OBVG,A2+1)DRAWTEXT(底背离,OBVG*1.2,'底背离'),COLORMAGENTA;
STICKLINE(FILTER(底背离>0,5),压力,OBVG,10,0),COLORMAGENTA;
DRAWLINE(CC2,OBVG,FILTER(底背离>0,5),OBVG,0),COLORWHITE;
DRAWICON(底背离,OBVG*0.98,1);
烟王酒霸主图
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;
k2:EMA(CLOSE,6),colorffff00;
k3:EMA(CLOSE,9),colorffff00;
k5:EMA(CLOSE,12),colorffff00;
k7:EMA(CLOSE,15),colorffff00;
k10:EMA(CLOSE,18),colorffff00;
k13:EMA(CLOSE,21),colorffff00;
k16:EMA(CLOSE,24),colorffff00;
IF (k2>REF(k2,1),k2,k2),colorred;
IF (k3>REF(k3,1),k3,k2),colorred;
IF (k5>REF(k5,1),k5,k2),colorred;
IF (k7>REF(k7,1),k7,k2),colorred;
IF (k10>REF(k10,1),k10,k2),colorred;
IF (k13>REF(k13,1),k13,k2),colorred;
IF (k16>REF(k16,1),k16,k2),colorred;
hhv(h,20),colorccffff,linethick2;
llv(l,20),coloryellow,linethick2;
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),colorffcc66;
STICKLINE(C<=O,H,L,0,0),colorffcc66;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)
<"macd.diff"(12,26,9) and cross
("macd.diff"(12,26,9),"macd.dea"(12,26,9));
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)
<"RSI.RSI1"(6,12,24) and cross
("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)>"macd.diff"(12,26,9) and cross
("macd.dea"(12,26,9),"macd.diff"(12,26,9));
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)>"RSI.RSI1"(6,12,24) and cross
("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(ref(cross(mdi,pdi),1));
D4:=ref(c,C4+1)mdi and cross(mdi,pdi);
A4:=BARSLAST(ref(cross(PDI,MDI),1));
B4:=ref(c,A4+1)>c and ref(pdi,A4+1)STICKLINE(B4,l,l-0.06,4,0),COLORFFCCFF;
DRAWTEXT(B4,L-0.09,'DMI底背'),COLORFFCCFF;
STICKLINE(D4,H,H+0.06,4,0),COLORWHITE;
DRAWTEXT(D4,H+0.09,'DMI顶背'),COLORWHITE;
STICKLINE(B1,l,l-0.06,4,0),COLORFF00FF;
DRAWTEXT(B1,l-0.09,'MACD底背'),COLORFF00FF;
STICKLINE(B2,l,l-0.06,4,0),COLORYELLOW;
DRAWTEXT(B2,L-0.09,'KDJ底背'),COLORYELLOW;
STICKLINE(B3,L,L-0.04,4,0),COLORRED;
DRAWTEXT(B3,L-0.09,'RSI底背'),COLORRED;
STICKLINE(D1,H,H+0.06,4,0),COLORFFCC66;
DRAWTEXT(D1,H+0.09,'MACD顶背'),COLORFFCC66;
STICKLINE(D2,H,H+0.06,4,0),COLORC0A8FF;
DRAWTEXT(D2,H+0.09,'KDJ顶背'),COLORC0A8FF;
STICKLINE(D3,H,H+0.06,4,0),COLORFFCCCC;
DRAWTEXT(D3,H+0.09,'RSI顶背'),COLORFFCCCC;
ma13:=ma(c,13),colorwhite,linethick2;
vll:=cross(ma(c,13),ma(c,21));
DRAWTEXT(vll,ma13,'●'),colorwhite;
DRAWTEXT(vll,ma13-0.09,'圆弧底'),colorwhite;
国庆再次向全体网友发布经典指标(通达信筹码分布)源码
参数{TS:1 1000 350/N:1 1000 95}
如果自己喜欢可以修改参数

DA1:=IF(TS>TOTALBARSCOUNT,TOTALBARSCOUNT,TS);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);{最高价}
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/15); {对数格值}
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(HI/POW(GZ,9)) AND C1LH10:=SUM(IF(C1>=(LO*POW(GZ,5)) AND C1LH11:=SUM(IF(C1>=(LO*POW(GZ,4)) AND C1LH12:=SUM(IF(C1>=(LO*POW(GZ,3)) AND C1LH13:=SUM(IF(C1>=(LO*POW(GZ,2)) AND C1LH14:=SUM(IF(C1>=(LO*GZ) AND C1LH15:=SUM(IF(C1>=LO AND C1L1:=REFDATE(HHV(LH1,DA),DATE);
L2:=REFDATE(HHV(LH2,DA),DATE);
L3:=REFDATE(HHV(LH3,DA),DATE);
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
L11:=REFDATE(HHV(LH11,DA),DATE);
L12:=REFDATE(HHV(LH12,DA),DATE);
L13:=REFDATE(HHV(LH13,DA),DATE);
L14:=REFDATE(HHV(LH14,DA),DATE);
L15:=REFDATE(HHV(LH15,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10+L11+L12+L13+L14+L15);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,
HI*N/100,HI/GZ,0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,1)*N/100,HI/POW(GZ,2),0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,2)*N/100,HI/POW(GZ,3),0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,3)*N/100,HI/POW(GZ,4),0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,4)*N/100,HI/POW(GZ,5),0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,5)*N/100,HI/POW(GZ,6),0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,
HI/POW(GZ,6)*N/100,HI/POW(GZ,7),0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,7),LO*POW(GZ,8)*N/100,0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,6),LO*POW(GZ,7)*N/100,0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,5),LO*POW(GZ,6)*N/100,0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L11/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,4),LO*POW(GZ,5)*N/100,0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L12/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,3),LO*POW(GZ,4)*N/100,0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L13/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,2),LO*POW(GZ,3)*N/100,0.1,1)COLORA5555A;
STICKLINE(CEILING(DA*L14/SS)*3>=CURRBARSCOUNT,
LO*POW(GZ,1),LO*POW(GZ,2)*N/100,0.1,1)COLORA7777A;
STICKLINE(CEILING(DA*L15/SS)*3>=CURRBARSCOUNT,
LO,LO*POW(GZ,1)*N/100,0.0001,1)COLORA5555A;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=MA(CLOSE,60);
F1:=VAR1>REF(VAR1,1);
F2:=VAR2>REF(VAR2,1);
F3:=VAR2>REF(VAR2,1);

PARTLINE(Var1,F1,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
PARTLINE(Var2,F2,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
PARTLINE(Var3,F3,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
PARTLINE(Var4,F3,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
PARTLINE(Var5,F3,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK5;
x1:=EMA(C,7);
drawtext(filter(var3 and var2 and count(x12 and x1>ref(x1,1),3),l-0.01,'★短进'),ColorFFFFFF;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(75,RSI) , HIGH,'★ 快跑 '),Color00FF00;
DRAWGBKLAST(VAR1DRAWGBKLAST(VAR1>VAR2,'2');
B1:=REF(CLOSE,1);B2:=REF(CLOSE,2);B3:=REF(CLOSE,3);B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);
STICKLINE(CLOSE=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE>=B2 OR
B2=CMAX AND B3=CMIN AND CLOSE>=B1 OR B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2,B1,CLOSE,8,0),COLOR000099;
STICKLINE(CLOSE=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE>=B2 OR
B2=CMAX AND B3=CMIN AND CLOSE>=B1 OR B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2,B1,CLOSE,5,0),COLOR0000BB;
STICKLINE(CLOSE=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE>=B2 OR
B2=CMAX AND B3=CMIN AND CLOSE>=B1 OR B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2,B1,CLOSE,3,0),COLOR0000FF;
STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,8,0),COLOR000099;
STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,5,0),COLOR0000BB;
STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,3,0),COLOR0000FF;
STICKLINE(CLOSE=CMIN AND (B1B2=CMIN AND B3=CMAX AND CLOSESTICKLINE(CLOSE=CMIN AND (B1B2=CMIN AND B3=CMAX AND CLOSESTICKLINE(CLOSE=CMIN AND (B1B2=CMIN AND B3=CMAX AND CLOSESTICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,8,0),COLOR009900;
STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,5,0),COLOR00BB00;
STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,3,0),COLOR00FF00;
STICKLINE(B1=CMIN AND CLOSE>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2=B1,B1,B2,8,0),COLORFF9900;
STICKLINE(B1=CMIN AND CLOSE>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2=B1,B1,B2,5,0),COLORFFBB00;
STICKLINE(B1=CMIN AND CLOSE>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2=B1,B1,B2,3,0),COLORFFFF00;
STICKLINE(B1=CMAX AND CLOSEB3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSESTICKLINE(B1=CMAX AND CLOSEB3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSESTICKLINE(B1=CMAX AND CLOSEB3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSETY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); vB1:=FILTER(A1,10); C1:=BACKSET(vB1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); vB2:=FILTER(A2,10); C2:=BACKSET(vB2,10+1); LD:=FILTER(C2,10);
A:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));
t1:=BARSLAST(HD)t2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(t1,A,A) ,POINTDOT ,Color00FFFF;
STICKLINE(t1,A,A,5,0),ColorFF00FF;
波谷:IF(t2,B,B),POINTDOT,Color80FF00;
STICKLINE(t2,B,B,5,0),Color80FF00

 

把指标公式改成选股公式的方法我来简单说一下吧。

在选股公式中只允许有一条输出语句,因此在改之前要把所有的STICKLINE语句、DARWICON语句及DARWTEXT语句全部删除。再把所有的画线语句如该公式中的“指导线:EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),,COLORFFFFFF;”要加上“=”号即改成:“指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),,COLORFFFFFF; ”。
最后仅保留所需要的选股语句,如该公式中的“B买:IF(CROSS(指导线,界) OR CROSS(买线,卖线),C,DRAWNULL),COLORMAGENTA,NODRAW;”但这条语句是一个选择语句要改一下,变成:“B买:(CROSS(指导线,界) OR CROSS(买线,卖线);”就是说仅留下这个语句中的条件部分就可以了。整个公式就成了如下的样子:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),,COLORFFFFFF;
界:=MA(CLOSE,27),COLOR00FFFF;
B买:CROSS(指导线,界) OR CROSS(买线,卖线);
今天选项了一下选出的股票有100多只太多;
再改一下:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),,COLORFFFFFF;
界:=MA(CLOSE,27),COLOR00FFFF;
B买:CROSS(指导线,界) AND CROSS(买线,卖线);
经试用仅选了一只股票:600991长丰汽车。
如再不满意再设法去改一下。
不知大家明白了没有?


{猎狐雷达}

猎狐雷达:100*(WINNER(CLOSE)-REF(WINNER(CLOSE),1));
VAR1:=(WINNER(AMOUNT/VOL)-WINNER(REF(AMOUNT/VOL,5)))*100;
雷达1: IF(猎狐雷达>20,50,0) COLORRED;
雷达2: IF(REF(猎狐雷达,1)<-25 AND CROSS(猎狐雷达,0),50,0) COLORGREEN;
雷达3: IF(FILTER(BARSLAST(CROSS(0,猎狐雷达)) AND CROSS(猎狐雷达,0),21),50,0) COLORBLUE;
天线: 20;
地线: -20;

无中生有
无中生有:0,COLOR00AA00;
有戏:(EMA(CLOSE,30)-EMA(CLOSE,34))/EMA(CLOSE,34)*100,COLORRED;
无戏:(EMA(C,34)-EMA(C,30))/EMA(C,30)*100,COLORCYAN;
XYZ1:(有戏-无戏),COLORMAGENTA;
XYZ2:MA(XYZ1,3),COLORYELLOW;
STICKLINE( XYZ1>XYZ2,无戏 ,有戏 ,0.8 ,0 ),COLORRED;
STICKLINE( XYZ1

 

多周期KDJ
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
周K:MA("KDJ.K"(9,3,3) ,5),POINTDOT,LINETHICK1,COLORWHITE;
周D:MA("KDJ.D"(9,3,3) ,5),POINTDOT,LINETHICK1,COLOR33FF99;
周J:MA("KDJ.J"(9,3,3) ,5),POINTDOT,LINETHICK1,COLOR00FF00;
周金▲:DRAWTEXT(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)) ,8,'▲'),COLORRED;
周死▼:DRAWTEXT(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)) ,92,'▼'),COLORGREEN;
月金▲:DRAWTEXT(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)) ,0,'▲'),COLOR00FF00;
月死▼:DRAWTEXT(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)) ,100,'▼'),COLORYELLOW;

 

梅子雷达
V1:=(C/REF(C,1)-INDEXC/REF(INDEXC,1))*200;
动力:SUM(V1,0),COLORRED,LINETHICK2;
月动力:MA(动力,20),COLORYELLOW ;      动力上穿月动力,表明该股开始强于大盘走势
多空交锋
SK:(SLOPE(EMA(MAV,2),7)*15+MAV)*0.8*0.0001,COLORRED;
SD:EMA(SK,2),COLORGREEN;
SJ:2.8*SK-1.8*SD,COLORYELLOW;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:2*(S2-S6)*15*4*1.5, COLORSTICK;
STICKLINE(SK>SD AND DKSTICKLINE(DK>0 AND SK>SD ,RC,RC+DK,1,0),COLOR6633CC;
STICKLINE(DK>0 AND SKSTICKLINE(DK>0 AND 多方<空方,RC,RC+DK,1,0),COLORGREEN;
STICKLINE(CROSS(多方,空方),RC,RC+DK,1,0),COLORYELLOW;         红柱代表趋强,黄柱代表转强,橙柱代表强势,蓝柱代表趋弱,绿柱为弱势.初现黄柱子买入,黄柱子越小越好,负的更好 !
STICKLINE(CROSS(空方,多方),RC,RC+DK,1,0),COLORGREEN;
STICKLINE(DK<0 AND 多方<空方 AND SKVAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR25:=IF(YEAR<2058 AND VAR1F>0.015,VAR20,0)/45/4;
JJ :=(C*2+H+L)/4;
SKK :( EMA(JJ,13) - EMA(JJ,21))*180,COLORGRAY;
SDD : EMA(SKK,2),COLORGRAY;
多方:(SKK-SDD)*0.000000001,COLORRED,LINETHICK0;
空方:-1*(SKK-SDD)*0.000000001,COLORGREEN,LINETHICK0;
RC:=DYNAINFO(3);
RC,COLORWHITE;
MAV:=(2*C+H+L)/4;
SK:(SLOPE(EMA(MAV,2),7)*15+MAV)*0.8*0.0001,COLORRED;
SD:EMA(SK,2),COLORGREEN;
SJ:2.8*SK-1.8*SD,COLORYELLOW;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:2*(S2-S6)*15*4*1.5, COLORSTICK;
STICKLINE(SK>SD AND DKSTICKLINE(DK>0 AND SK>SD ,RC,RC+DK,1,0),COLOR6633CC;
STICKLINE(DK>0 AND SKSTICKLINE(DK>0 AND 多方<空方,RC,RC+DK,1,0),COLORGREEN;
STICKLINE(CROSS(多方,空方),RC,RC+DK,1,0),COLORYELLOW;
STICKLINE(CROSS(空方,多方),RC,RC+DK,1,0),COLORGREEN;
STICKLINE(DK<0 AND 多方<空方 AND SK

{游击高手 主图}

中短:MA(CLOSE,23);
中:MA(CLOSE,33);
中长:MA(CLOSE,60);
RSV:=(((CLOSE - LLV(LOW,5)) / (HHV(HIGH,5) - LLV(LOW,5))) * 100);
短主:=SMA(RSV,3,1);
短空:=SMA(短主,3,1);
RSV12:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
中主:=SMA(RSV12,3,1);
中空:=SMA(中主,3,1);
RSV24:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
长主:=SMA(RSV24,3,1);
长空:=SMA(长主,3,1);
DRAWTEXT((((CROSS(REF(短主,1),REF(短空,1)) OR CROSS(短主,短空)) AND CROSS(长主,长空)) AND ((CROSS(REF(中主,1),REF(中空,1)) OR CROSS(中主,中空)) AND CROSS(长主,长空))),LOW,'游击高手');
箱顶:HHV(MA(((((LOW + HIGH) + CLOSE) + OPEN) / 4),5),58),COLOR00AAFF;
箱底:LLV(MA(((((LOW + HIGH) + CLOSE) + OPEN) / 4),6),58),COLOR00FF00;
MA3:=MA(CLOSE,3);
MA34:=MA(CLOSE,34);
DRAWTEXT(CROSS(MA3,箱底),LOW,'试'),COLOR0000FF;
DRAWTEXT(CROSS(MA3,MA34),LOW,'买'),COLOR00FFFF;
DRAWTEXT((CROSS(MA3,箱顶) AND (CLOSE > 箱顶)),箱顶,'追'),COLOR00EEAA;


骑牛
上轨:MA(C,20)+2*STD(C,20),COLOR0099CC,LINETHICK2;
中轨:MA(C,20),COLORWHITE,LINETHICK1;
下轨:MA(C,20)-2*STD(C,20),COLOR006699,LINETHICK2;
牛势:HHV(MA((L+H+C)/3,3),1),COLORFF00FF,LINETHICK2;
VAR1:=HHV(MA((L+H+C)/3,5),1);
VAR2:=EMA((H+L+C)/3*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5))*20/10+(L+H+C)/3,1);
VAR3:=(3*VAR2-2*SMA(VAR2,5,1))*0.3;
VAR4:=IF(VAR3>1.03*VAR1,1.03*VAR1,IF(VAR3<0.98*VAR1,0.98*VAR1,VAR3));
VAR5:=(C-MA(C,4))/MA(C,4)*(-100);
VAR6:=EMA(VAR5/10+EMA(C,N),1);
骑牛风险线: IF(VAR6 HHV(((L+H+C)/3),1),1.03*VAR4,VAR6)),COLORYELLOW;
骑牛中轨:LLV(MA((L+H+C)/3,3),10),COLORBLUE,LINETHICK2;  n 1.100.6


转强
VA1:=HHV(HIGH,9)-LLV(LOW,9);      
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
生命线:EMA(VARD,1), COLORFF00FF,LINETHICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:EMA(B1,5),COLORFF7000;
STICKLINE(B1-B2>0,B1,B2,8,0),COLORFFFFFF;
STICKLINE(B1-B2<0,B1,B2,8,0),COLOR00FF00;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
STICKLINE(V1 AND V2 AND V3 AND V4,100,110,8,0),COLOR00FF00;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1STICKLINE(A3 AND A4,100,110,8,0),COLOR00FF00;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1) ;
安全位:=20;
低位转强:IF(CROSS(A5,安全位),50,0),COLORRED,POINTDOT;
开始拉升:IF(CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O,50,0),COLORBLUE,POINTDOT;
A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);
极低大涨:IF(A6,50,0),COLORYELLOW,POINTDOT;
STICKLINE(开始拉升>0,15,开始拉升*1.1,1,0),POINTDOT,COLORBLUE;
STICKLINE(开始拉升>0 AND 开始拉升<400,30,开始拉升,1,0),COLORRED,LINETHICK3;
STICKLINE(开始拉升>0,15,开始拉升*0.6,5,0),COLORBLUE,LINETHICK5;
STICKLINE(开始拉升>0,15,开始拉升*0.4,5,0),COLOR00FF00,LINETHICK7;
STICKLINE(开始拉升>0,15,开始拉升*0.2,5,0),COLOR0099CC,LINETHICK7;


捕捉暴涨
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),5);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),5);
PDI: DMP*100/TR;
MDI: DMM*100/TR,LINETHICK2;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,3)COLORRED;
ADXR:EXPMEMA(ADX,3),COLORGREEN;注意: 5
,LINETHICK2;DRAWTEXT(CROSS(ADX,ADXR),50,'变')COLORRED ;用法:市场行情趋向明显时,指标效果理想。

PDI(上升方向线)    MDI(下降方向线)  ADX(趋向平均值)

1.PDI线从下向上突破MDI线,显示有新多头进场,为买进信号;

2.PDI线从上向下跌破MDI线,显示有新空头进场,为卖出信号;

3.ADX值持续高于前一日时,市场行情将维持原趋势;

4.ADX值递减,降到20以下,且横向行进时,市场气氛为盘整;

5.ADX值从上升倾向转为下降时,表明行情即将反转。


量能度----非常好用
实量:VOL,VOLSTICK;
V1:=V/CAPITAL*100;
MAV5:=EMA(V/CAPITAL*100,5);
MAV10:=EMA(V/CAPITAL*100,10);
量能:((V1-MAV5)/MAV5*2+(V1-MAV10)/MAV10)*10;


主力动向+控盘筹码+庄筹+散筹
庄筹线:WINNER(C)*130 ,COLORRED,LINETHICK2;
散筹线:(WINNER(C*1.1)-WINNER(C*0.9))*100 ,COLORGREEN ,LINETHICK2;
VAR2:=MA(CLOSE,60);
VAR3:=MA(CLOSE,2);
VAR6:=100*(WINNER(VAR2*1.1)-WINNER(VAR2*0.9));
VAR7:=100*(WINNER(VAR2*1.1)-WINNER(VAR3*0.85));
主力动向:IF((VAR6-VAR7)*2>0,(VAR6-VAR7)*2,0),STICK,COLORRED;
控盘筹码:IF((0.1-WINNER(C/1.1))*100<0,(0.1-WINNER(C/1.1))*100,0),STICK,COLORYELLOW;
容易买涨
MA3:MA(C,3),COLOR00FF00;
MA5:MA(C,5),COLORFFFFFF;
ZX:=(MA3+MA5)/2;
MA20:MA(C,20),COLORFF00FF;
MA30:MA(C,30),COLORYELLOW;
QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)YB:=C>REF((O-C)/2+C,2);
买:CROSS(C,ZX) AND (GD OR YB) AND QSXS,COLOR00FF00,POINTDOT,LINETHICK0;
优:买 AND MA5>REF(MA5,1),COLORYELLOW,POINTDOT,LINETHICK0;
{以下设置主图显示方式}
STICKLINE(买,H,L,0,1),COLOR00FF00,LINETHICK2;
STICKLINE(买,O,C,4,1),COLOR00FF00,LINETHICK2;
STICKLINE(优,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(优,O,C,4,1),COLORYELLOW,LINETHICK2;
DRAWTEXT(买,L*0.99, '买'),COLOR00FF00;
DRAWICON(优,L,1);
大盘目前已基本启稳,可以适当作些短线,高抛低吸,赚些小钱。应该还有两次探底的要求。发些条件选股的公式供大家使用。

{短线通道 选股}
VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4;
VAR2B:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2C:=(VAR2A+VAR2B)/2/1.1;
短线:=VAR2C;
MID:=MA(短线,26);
UPPER:=MID+2*STD(短线,26);
LOWER:=MID-2*STD(短线,26);
{LCJ2:=IF(短线>MID,MID,短线); }
{买点: DRAWICON(CROSS(短线,MID),MID*0.97,1); }
{DRAWICON(CROSS(短线,LOWER),LOWER*0.97,3); }
{卖点: DRAWICON(CROSS(UPPER,短线),UPPER*0.97,2);
MID, , COLORYELLOW;}

{多头买入} ENTERLONG:CROSS(短线,MID) AND UPPER-MID>50;


{出手就赢1  选股}
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
CROSS(K,D) AND D<30;
{出手就赢2  选股}
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
CROSS(K,D) AND D<80;
{套利狐狸  选股}
VAR1:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR2:=REF(HIGH,10)/CLOSE>1.35;
V3: (CLOSE-VAR1)/VAR1*100<-30 AND VAR2;
{乘胜追击  选股}
VAR1:=WINNER(CLOSE)-WINNER(OPEN);
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),5,1)/SMA(ABS(CLOSE-VAR2),5,1)*100;
VAR4:=CLOSE/MA(CLOSE,3)>=1.05;
VAR5:=MA(VOL,8)/MA(VOL,45)>=2.5;
VAR6:=WINNER(CLOSE)-WINNER(OPEN);
VAR7:=REF(CLOSE,1);
VAR8:=SMA(MAX(CLOSE-VAR7,0),5,1)/SMA(ABS(CLOSE-VAR7),5,1)*100;
VAR9:=VAR6>=0.3 AND MA(VOL,6)/MA(VOL,26)>=1.9 AND VOL>REF(VOL,1) AND COUNT(VAR8<20,20)>=1 AND  CLOSE/MA(CLOSE,3)>=1.07;
VARA:=VAR1>=0.4 AND VAR5 AND COUNT(VAR3<20,20)>=1 AND VAR4 AND CLOSE>MA(CLOSE,85) AND VOL>REF(VOL,1);
(VARA OR VAR9);
{逆势操作 选股}
VAR1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2:=DMA(CLOSE,VOL/MA(VOL,32)/32);
VAR3:=(CLOSE-VAR1)/VAR1*100<-8;
VAR4:=(VAR1-VAR2)/VAR2*100<-21;
VAR5:=VAR3 AND VAR4 AND (OPEN>CLOSE OR OPEN-0.05  AND  (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)REF(CLOSE,2) OR REF(OPEN,2)REF(CLOSE,3) OR REF(OPEN,3)REF(CLOSE,4) OR REF(OPEN,4)REF(CLOSE,5) OR REF(OPEN,5)REF(CLOSE,6) OR REF(OPEN,6)REF(CLOSE,7) OR REF(OPEN,7)VAR6:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-23;
VAR7:=(INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100;
VAR8:=SMA(VAR7,50,1);
VAR9:=SMA(VAR8,40,1);
VARA:=VAR6 AND VAR9<23 AND COUNT(VAR6,2)=1 AND (OPEN>CLOSE OR OPEN0.96 ;
(VAR5 OR VARA) ;


{牛市专利  选股}
VAR1:=REF(CLOSE,3)*0.844;
VAR2:=REF(CLOSE,13)*0.767;
VAR3:=INDEXC;
VAR4:=INDEXV;
VAR5:=MIN(VAR1,VAR2);
VAR6:=100*VOL/CAPITAL;
VAR7:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
VAR8:=(CLOSE-VAR5)/CLOSE<0.07 AND SUM(VAR6,3)/3<2.345 AND VAR3>MA(VAR3,450) AND MA(VAR4,61)/MA(VAR4,80)>0.923 AND CLOSE>MA(CLOSE,190);
VAR9:=VAR3>MA(VAR3,450) AND VAR7<-16.5 AND MA(VAR4,61)/MA(VAR4,80)>0.92 AND CLOSE>MA(CLOSE,215)  AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)REF(CLOSE,2) OR REF(OPEN,2)REF(CLOSE,3) OR REF(OPEN,3)REF(CLOSE,4) OR REF(OPEN,4)REF(CLOSE,5) OR REF(OPEN,5)(VAR8 OR VAR9);
{同时金叉 选股}
DIF:=EMA(CLOSE,9)-EMA(CLOSE,17);
DEA:=EMA(DIF,8);
MACD:=(DIF-DEA)*2;
RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
选股:CROSS(DIF,DEA) AND CROSS(J,D) AND CROSS(RSI1,RSI3);
{带量突破 选股}
VAR1:=EMA(COST(80),10);
COUNT(CROSS(CLOSE,VAR1),2)>=1 AND VOL/CAPITAL>=0.1;
{攻击箱顶 选股}
VAR1:=HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58);
BETWEEN(CLOSE,VAR1*1.001,VAR1) AND REF(VAR1,3)=VAR1 AND VOL>REF(VOL,2);


{果断介入  选股}
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VAR6:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR7:=SMA(VAR6,3,1);
VAR8:=SMA(VAR7,3,1);
VAR9:=3*VAR7-2*VAR8;
CROSS(VAR9,VAR8) AND COUNT(VAR5<-12 AND VAR5>-14,3)>=1;


{暴裂旋风 选股}
VAR1:=ABS(HIGH-LOW);
SUM(VAR1,7)/CLOSE>0.5 AND SUM(VAR1,7)/CLOSE<0.8 AND CLOSE>7 AND CLOSE<11;
{稳赢剑抄底 N:1 100 12}
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3抄底:VAR5
{结合稳赢剑指标使用};
{领头羊选股}
白色:=SMA(HIGH,21,2)*1.05,;
黄色:=SMA(LOW,21,2)*0.95;
粉色:=SMA(LOW,5,1);
绿色:=SMA(CLOSE,2,1),;
波段买入:=IF(CROSS(绿色,粉色),白色*1.05,粉色);
领头羊:=IF(CROSS(绿色,白色),白色*1.10,黄色);
领头羊>黄色 OR 波段买入>粉色
{ 绿线上穿紫线时,可作波段买入,绿线上穿白线时很可能是大牛股。
可作为预警选股公式}
{结合寻找领头羊指标使用};
{天堂星踏金浪1  选股}
VARC:=(2*CLOSE+HIGH+LOW)/4;
VARD:=LLV(LOW,34);
VARE:=HHV(HIGH,34);
VARF:=LLV(LOW,13);
VAR10:=HHV(HIGH,13);
VAR11:=EMA((VARC-VARF)/(VAR10-VARD)*100,5);
VAR12:=EMA((VARC-VARD)/(VARE-VARD)*100,8);
金浪:= VAR11;
AA:=EMA(VAR11,7);
海浪:= VAR12;
IF(CROSS(金浪,AA) AND AA<=25 ,1,0);
{黑马绝技选股}
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
EMA60:=EMA(C,60);
EMA90:=EMA(C,90);
EMA120:=EMA(C,120);
EMA250:=EMA(C,250);
F1:=EMA30-EMA60<130/1000 AND EMA30-EMA90<230/1000 AND EMA30-EMA120<330/1000;
F2:=EMA60-EMA30<130/1000 AND EMA60-EMA90<230/1000 AND EMA60-EMA120<330/1000;
F3:=EMA90-EMA30<130/1000 AND EMA90-EMA60<230/1000 AND EMA90-EMA120<330/1000;
F4:=EMA120-EMA30<130/1000 AND EMA120-EMA60<230/1000 AND EMA120-EMA90<330/1000;
F5:=EMA30-EMA60<100/1000 AND EMA30-EMA90<200/1000;
FF1:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA30,EMA60);
FF2:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA(C,13),EMA30);
FF3:=F5 AND C>EMA250 AND CROSS(EMA30,EMA60);
G1:=EMA60-EMA90<220/1000 AND EMA60-EMA120<320/1000 AND EMA60-EMA250<420/1000;
G2:=EMA90-EMA30<220/1000 AND EMA90-EMA60<320/1000 AND EMA90-EMA250<420/1000;
G3:=EMA120-EMA60<220/1000 AND EMA120-EMA90<320/1000 AND EMA120-EMA250<420/1000;
G4:=EMA250-EMA60<220/1000 AND EMA250-EMA90<320/1000 AND EMA250-EMA120<420/1000;
GG1:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA13,EMA30);
GG2:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA30,EMA60);
FF1 OR FF2 OR FF3 OR GG1 OR GG2;


{黑马起步选股 }
A1:=VOL=HHV(VOL,120);
A2:=CLOSE/OPEN>1.05;
TJ:=A1 AND A2;
TJ AND (REF(BARSLAST(TJ),1)>80 OR BARSSINCE(TJ)=0);
{底背离 选股}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
底背离:B1>0 OR B2>0 OR B3>0;
{集成了MACD、KDJ、RSI三个指标的底背离};


{蓄势待发 选股}
V0:=EMA(C,5);
EMA10:=EMA(C,10);
EMA20:=EMA(C,20);
EMA30:=EMA(C,30);
EMA60:=EMA(C,60);
M1:=1000*EMA10/EMA60<=1015 AND 1000*EMA10/EMA60>=975;
M2:=1000*EMA20/EMA60<=1020 AND 1000*EMA20/EMA60>=980;
M3:=1000*EMA30/EMA60<=1015 AND 1000*EMA30/EMA60>=985;
M4:=M1 AND M2 AND M3 AND CROSS(V0,EMA10);
M5:=M1 AND M2 AND M3 AND CROSS(V0,EMA30);
T1:=1000*EMA10/EMA30<=1010 AND 1000*EMA10/EMA30>=990;
T2:=1000*EMA20/EMA30<=1010 AND 1000*EMA20/EMA30>=990;
T3:=T1 AND T2 AND CROSS(V0,EMA10);
T4:=T1 AND T2 AND CROSS(V0,EMA30);
M4 OR M5 OR T3 OR T4;


{突破指标 选股}
{一是突破盘整;二是突破前高;三是突破平台}
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
W4 AND COUNT(W4,5)=1;


{四线粘合 选股}
V0:=EMA(C,5);
V1:=EMA(C,10);
V2:=EMA(C,15);
V3:=EMA(C,30);
V4:=EMA(C,60);
M1:=1000*V1/V4<=1015 AND 1000*V1/V4>=975;
M2:=1000*V2/V4<=1020 AND 1000*V2/V4>=980;
M3:=1000*V3/V4<=1015 AND 1000*V3/V4>=985;
M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);
M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);
M4 OR M5;


{拉升在即 选股}
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSEM1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
拉升在即:SMML AND ABV>M1 AND CROSS(S,Y);


{前导选股涨 }
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
QDBTMP1:=(2*SUM(CLOSE,M1)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,M2))/M1;
QDBTMP2:=(2*SUM(CLOSE,M2)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,(2*M2-M1)))/M2;
QDBTMP:=QDBTMP1-QDBTMP2;
TMP1:=(LFMTMPTMP2:=((LFMTMP>=LOW)AND(LFMTMP<=HIGH));
TMP3:=BARSLAST(TMP2);
TMP4:=REF(TMP3,1);
TMP5:=(LFMTMPTMP6:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP7:=((QDBTMP>REF(QDBTMP,1))AND(REF(QDBTMP,1)TMP8:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<=(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP9:=(OPEN前导选股:((TMP1)AND(TMP8)AND(TMP9))OR((TMP2)AND(TMP5)AND(TMP6)AND(TMP7)AND(TMP9));


{前导选股跌}
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
QDBTMP1:=(2*SUM(CLOSE,M1)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,M2))/M1;
QDBTMP2:=(2*SUM(CLOSE,M2)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,(2*M2-M1)))/M2;
QDBTMP:=QDBTMP1-QDBTMP2;
TMP1:=(LFMTMP>HIGH);
TMP2:=((LFMTMP>=LOW)AND(LFMTMP<=HIGH));
TMP3:=BARSLAST(TMP2);
TMP4:=REF(TMP3,1);
TMP5:=(LFMTMP>REF(LFMTMP,(TMP4+1)));
TMP6:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP7:=((QDBTMPTMP8:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>=(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP9:=(OPEN>CLOSE);
前导选股:((TMP1)AND(TMP8)AND(TMP9))OR((TMP2)AND(TMP5)AND(TMP6)AND(TMP7)AND(TMP9));


{利多方舟B选股}
{VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));}
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
{DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),8);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),9);}
CROSS(VAR2,MA(VAR3,6)){,(LOW * 0.984),'B '),COLOR4440FF};
{DTLD顶天立地选股}
VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR21:=SMA(VAR1F,3,1);
趋势:=SMA(VAR21,3,1);
人气:=SMA(趋势,3,1);
出击:CROSS(趋势,人气) AND (趋势<30);
{短卖:IF(CROSS(人气,趋势) AND (人气>75),85,100),COLOR008000,LINETHICK2; };


{主力进出选股}
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSEM1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
主力进出:=MMS>REF(MMS,1) AND ZLGJ>REF(ZLGJ,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(ZLGJ,MAZL);
主力进出 OR 主进主轨;
{前导选股异动涨选股}
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
TMP1:=(LFMTMP>HIGH);
TMP2:=CLOSE>OPEN;
TMP3:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP4:=REF(CLOSE,1)前导选股:(TMP1)AND(TMP2)AND(TMP3)AND(TMP4);
{前导选股异动跌选股}
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
TMP1:=(LFMTMPTMP2:=CLOSETMP3:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP4:=REF(CLOSE,1)>REF(OPEN,1);
前导选股:(TMP1)AND(TMP2)AND(TMP3)AND(TMP4);

 

{黑马易找选股}
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VAR5:=EMA(COST(85),7);
VAR6:=EMA(COST(15),7);
VAR7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VAR8:=INTPART(VAR7*100)/100;
VAR9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VARA:=INTPART(VAR9*100)/100;
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
黑马易找选股: VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0;


{以逸待劳选股}
VAR1:=COST(10);
VAR2:=REF(CLOSE,7)/MA(REF(CLOSE,7),3)>=1.07 AND REF(CLOSE,7)=HHV(REF(CLOSE,7),3) AND MA(REF(VOL,7),2)/MA(REF(VOL,7),40)>=3 AND MA(REF(VOL,7),2)=HHV(MA(REF(VOL,7),2),3) AND REF(VOL,7)>REF(REF(VOL,7),1) AND REF(CLOSE,7)>REF(REF(CLOSE,7),1);
VAR3:=REF(REF(CLOSE,7),1);
VAR4:=SMA(MAX(REF(CLOSE,7)-VAR3,0),5,1)/SMA(ABS(REF(CLOSE,7)-VAR3),5,1)*100;
VAR5:=COUNT(VAR4<20,20)>=1;
VAR6:=(INDEXC-LLV(INDEXL,89))/(HHV(INDEXH,89)-LLV(INDEXL,89))*100;
VAR7:=SMA(VAR6,8,1);
VAR8:=SMA(VAR7,10,1);
VAR9:=REF(INDEXC,1);
VARA:=SMA(MAX(INDEXC-VAR9,0),6,1)/SMA(ABS(INDEXC-VAR9),6,1)*100;
VARB:=VARA>=75 AND VARA<90 AND VAR7>VAR8 AND BARSLAST(CROSS(VAR7,VAR8))<=21;
VAR2 AND VAR5 AND  VARB;


{抓住涨停 选股}

Var11:=WINNER(CLOSE)*90;
K:=SMA(Var11,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K>D AND J>K AND CLOSE>REF(CLOSE,1)*1.09 AND MA(VOL,10)>MA(VOL,45) AND VOL>MA(VOL,45);


{短线黑马选股}  密码:761207

{公式描述:K=1.4 90%成功率}

VAR1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR3:=(CLOSE-VAR1)/VAR1*100<-11/K*100;
VAR4:=(VAR1-VAR2)/VAR2*100<-22.3/K*100;
VAR5:=VAR3 AND VAR4 AND (OPEN>CLOSE OR OPEN(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)(REF(OPEN,2)>REF(CLOSE,2) OR REF
(OPEN,2)REF(CLOSE,3) OR REF(OPEN,3)(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)REF(CLOSE,5) OR REF(OPEN,5)
REF(CLOSE,6) OR REF(OPEN,6)REF
(CLOSE,7) OR REF(OPEN,7)VAR6:=DMA(CLOSE,VOL/MA(VOL,3)/3);
VAR7:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR8:=(CLOSE-VAR6)/VAR6*100<-5;
VAR9:=(VAR6-VAR7)/VAR7*100<-18;
VARA:=(INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100;
VARB:=SMA(VARA,30,1);
VARC:=SMA(VARB,50,1);
VARD:=VAR8 AND VAR9 AND (OPEN>CLOSE OR OPEN(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)VARE:=VARD AND COUNT(VARD,2)=1 ;
VAR5 OR VARE;


七剑选股公式    密码:jingweiniao


1.{白金星星点灯}

{公式描述:20T 10%  100%}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
E:=GJTJ1>60 AND GJTJ4>70;
ENTERLONG:A AND B  AND E;


2.{黄金星星点灯} 

{公式描述:20T 10% 94.05%}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
ENTERLONG:A AND B;


3.{天瀑}
{公式描述:启动金三角 (捉中线牛股起涨点)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5  AND GJTJ1>GJTJ4;
ENTERLONG:COUNT(XG,3)=1 AND XG;

4.{舍神}
{公式描述:阶段震仓启动点(黄金坑)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
B:=BARSLAST(CROSS(GJTJ4,GJTJ2));
D:=GJTJ3E:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
F:=GJTJ2B1:=A>0 AND REF(A,1)=0 AND REF(A,2)>0;
ENTERLONG:A AND B AND D AND E AND F;


5.{日月}
{公式描述:短线追涨 (高位横盘突破)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A1:=A AND B;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A2:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=AAA AND BAA ;
B1:=REF(A1,1);
B2:=REF(A2,1);
B3:=REF(A3,1);
D1:=GJTJ1=100 AND GJTJ2=100  AND A1 ;
D2:=GJTJ1=100 AND GJTJ2=100  AND A2 ;
D3:=GJTJ1=100 AND GJTJ2=100  AND A3 ;
ENTERLONG:D1 OR D2 OR D3;


6.{青干}
{公式描述:蓝三角启动 (精确定位起涨第一日)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(95,GJTJ1))<=2;
B:=BARSLAST(CROSS(95,GJTJ2))<=2;
E:= GJTJ4F:=GJTJ2>50 AND GJTJ3>50;
G:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G,2)=1;
ENTERLONG:A AND B AND E AND F AND TX;


7.{莫问}
{公式描述:银边启动 (波段启动前兆)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=GJTJ3=100;
B:=GJTJ4<90;
ENTERLONG:COUNT(A,2) = 2 AND B;


8.{竞星}
{公式描述:启动金三角 (捉中线牛股起涨点)}

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=GJTJ1=GJTJ2 AND GJTJ2=GJTJ3 AND GJTJ1=100 AND GJTJ4>96;
B:=COUNT(A,2)=1;
D:=GJTJ1YH:=INDEXC/REF(INDEXC,1)*REF(C,1);
YH1:=REF(C,1)+C-INDEXC/REF(INDEXC,1)*REF(C,1);
X1:=EMA(YH1,7);
X2:=EMA(YH1,14);
X3:=EMA(X1,14);
E:=X1>X2 AND X2>X3;
ENTERLONG:B AND D AND E;


套牢盘----真诚帮助大家
短线套牢盘:EMA(100*(1-WINNER(1.1*C)),1),COLORRED,LINETHICK2;
中线套牢盘:EMA(100*(1-WINNER(1.2*C)),1),COLORGREEN ,LINETHICK2;
长线套牢盘:EMA(100*(1-WINNER(1.5*C)),1),COLORYELLOW,LINETHICK2;   如果会用,就不用理回大盘,没周都会赚钱.大家自己酌磨吧.
{MACD美如画   通达信}
STICKLINE(C>0,0,60,6,0),COLORFFB0DC;
STICKLINE(C>0,0,-45,6,0)COLORFFB000;
DIFF1:= EMA(C,3) - EMA(C,13);
DEA1 := EMA(DIFF1,9);
MACD1:= 2*(DIFF1-DEA1)*10;
DIFF2:= EMA(C,5) - EMA(C,26);
DEA2 := EMA(DIFF2,9);
MACD2:= 2*(DIFF2-DEA2)*10;
DIFF3:= EMA(C,7) - EMA(C,89);
DEA3 := EMA(DIFF3,21);
MACD3:= 2*(DIFF3-DEA3)*10;
{DRAWGBK(C>0,COLORRGB(255,255,220),COLORRGB(5,100,255),1),COLORF80606;}
IF(MACD3>=0,MACD3,DRAWNULL)LINETHICK4,COLOR009E3A;
STICKLINE(MACD3>=0,0,MACD3,4,0),COLOR009E3A;
IF(MACD3<0,-MACD3,DRAWNULL)LINETHICK4,COLOR646464;
STICKLINE(MACD3<0,0,-MACD3,4,0),COLOR646464;
IF(MACD2>=0,MACD2,DRAWNULL)LINETHICK4,COLOR007D19;
STICKLINE(MACD2>=0,0,MACD2,4,0),COLOR007D19;
IF(MACD2<0,-MACD2,DRAWNULL)LINETHICK4,COLOR555555;
STICKLINE(MACD2<0,0,-MACD2,4,0),COLOR555555;
IF(MACD1<0,-MACD1,DRAWNULL)LINETHICK4,COLOR006400;
STICKLINE(MACD1<0,0,-MACD1,4,0),COLOR006400;
STICKLINE(MACD1<0,0,-MACD1,4,0),COLOR414141;
STICKLINE(MACD3,0,-ABS(MACD3)*0.6,4,0),COLOR232323;
STICKLINE(MACD1,0,-ABS(MACD1)*0.6,4,0),COLOR0F0F0F;
X1:=MA(LLV(C,8)*1.1,13);
X2:=MA(HHV(C,21)*0.9,13);
X3:=MA(LLV(INDEXC,8)*1.1,13);
X4:=MA(HHV(INDEXC,21)*0.9,13);
资金进出:=3*(MA(C,1)-(X1+X2)/2-(X1+X2)/2*((X3+X4)/2-EMA(INDEXC,3))/((X3+X4)/2));
(C>0,资金进出),COLORSTICK;

{桂林山水 副图}

空仓区:0,POINTDOT,COLORRED;
持股区:0,POINTDOT,COLORGREEN;
变盘点:0,POINTDOT,COLORYELLOW;
{DRAWGBK(C>0, COLORRGB(255,255,0), COLORRGB(0,0,255),1); }
A:=(3*C+L+O+H)/6;
DK:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
VA1:=EMA(DK,3);
VA2:=EMA(VA1,2);
LA:=VA1-VA2;
LB:=VA2-VA1;
桂林山水甲天下:-0.05,COLORGREEN,POINTDOT;
股市峰谷任逍遥:0.05,COLORFFFF00,POINTDOT;

{FILLRGN(LA>LB,LA,0),COLOR339900;
FILLRGN(LASTICKLINE(LA>LB,LA,0,6,0),COLOR339900;
STICKLINE(LASTICKLINE(LA>LB,LB,0,6,0),COLOR559933;
STICKLINE(LADRAWICON(LA>LB,0,11);
DRAWICON(LADRAWICON(CROSS(LA,LB) OR CROSS(LB,LA),0,12);


{《漓江渔歌》}

VARA:=MA(CLOSE,20);
RSV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27));
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
D2:=SMA(K,2,1);
T1:=(3*K-2*D)*100;
天空: STICKLINE(T1,0,120,6,0),LINETHICK7,COLORFF8000;
山:=(3*K-2*D)*100;
桂山: STICKLINE(山,0,山,5,0),COLOR00FFDD;
STICKLINE(山,0,山*0.95,5,0),COLOR00FFBB;
STICKLINE(山,0,山*0.88,5,0),COLOR00FF99;
STICKLINE(山,0,山*0.8,5,0),COLOR00DD99;
STICKLINE(山,0,山*0.71,5,0),COLOR00BB99;
STICKLINE(山,0,山*0.6,5,0),COLOR00AA99;
STICKLINE(山,0,山*0.5,5,0),COLOR009999;
STICKLINE(山,0,山*0.4,5,0),COLOR008899;
T2:=((100-山)-100)*2/3;
漓江水:STICKLINE(T2,T2,-72,6,0),LINETHICK7,COLORFFBB00;
倒影:T2,COLOR00FFCC,STICK;
STICKLINE(倒影,0,倒影*4/5,6,0),COLOR00CC99;
STICKLINE(倒影,0,倒影*3/5,6,0),COLOR009999;
STICKLINE(倒影,0,倒影*2/5,6,0),COLOR006699;
顶线:=100-((HIGH-VARA)/VARA);
RSV2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1:=SMA(RSV2,3,1);
VAR2:=SMA(VAR1,3,1);
买入:=VAR1<16 AND VAR2<21 ;
卖出预警:=T1>=88 OR 顶线>=88;
卖出:=CROSS(顶线,T1) OR CROSS(90,T1);
T3:=买入;
打渔船:DRAWTEXT(FILTER(T3,2),山-45,'︼'),COLOR0000FF;
T4:=卖出预警 OR 卖出;
南归雁:DRAWTEXT(FILTER(T4,2),山+20,'ω'),COLOR0000FF;
{DRAWTEXT(FILTER(INDEXC,90,0,'●'),COLORFFFFFF;};

{资金进场日选股}
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGHA3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A11:=IF(FILTER(A8,3),5,0);
资金进场日:A11>0,8;
{资金加仓日选股}
A:=WINNER(CLOSE+CLOSE*15/100)*100;
B:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=A-B;
D:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
E:=CC<3 AND D<0.5 AND OPEN!=LOW;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGHA3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR E,10,0);
资金加仓日:A12>0;

资金进场日  or  资金进场日选股的效果不好。我就不发了。
{股神选股}

AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:=DD;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
买入:CROSS(股海,90) AND (股神<40);

{股神抄底}

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
股神抄底:FILTER(VAR5,10)=1;

油门
VAR1:=DMA(EMA(CLOSE,5),SUM(AMOUNT,5)/3/CAPITAL);
VAR2:=DMA(EMA(CLOSE,10),SUM(VOL,10)/3/2/CAPITAL);
VAR3:=1-(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),3,1)/SMA(ABS(CLOSE-VAR4),3,1);
油料: VAR5*VAR3*IF(SUM(VAR1-REF(VAR1,1),3)>=0.5,0.5,SUM(VAR1-REF(VAR1,1),3)), COLORSTICK;

{黄金区选股1}

VAR13:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
黄金区: DRAWICON(IF(VAR13<15,15,0),13,12),COLORYELLOW;

{黄金区选股2}

VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
趋势:=CEILING(SMA(VAR5,13,8));
操盘线:=MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
黄金区选股2:FILTER(趋势>75 AND CROSS(操盘线,趋势),5);


{黄金区选股3}

VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
VAR8:=EMA(C,5);
VAR9:=MA((LLV(C,9))*1.1,14);
VAR10:=2*VAR9-VAR8-C*0.1;
VAR11:=IF(((VAR8-VAR10)*5>0),(POW((VAR8-VAR10)*5,2))/10,(-1*(POW((VAR8-VAR10)*(5),2)))/(10));
VAR12:=IF((VAR11>0),VAR11-0,12);
趋势:=CEILING(SMA(VAR5,13,8)),LINETHICK2,COLOR0000FF;
FILTER(CROSS(趋势,VAR12)AND 趋势>REF(C,1) OR 趋势>REF(趋势,1)AND 趋势<35 AND C>REF(C,1),5);


{主力进场选股}

VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1)*VAR1;
VAR4:=SMA(VAR3,3,1);
CROSS(VAR3,VAR4);

大智慧精品公式改

{20W 主图}

多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡,' →◆●¤主升行情'),COLORFF00FF;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH,' →◆●沽空↓'),COLORYELLOW;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSEMA(VOL,5)/240 AND CLOSE>=REF

(CLOSE,1)*1.08 AND CLOSEVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND

REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,'短空↓'),COLORYELLOW;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND

CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,' →◆●▲注意买入'),COLORRED;
S:=MA(VOL,5)/MA(VOL,60),COLORRED,,LINETHICK2;
A:=MA(S,5),COLORGREEN,,LINETHICK2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
F:=MA(S,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,' →◆●  逃顶!!◆●   '),COLORYELLOW ;
S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)>0.010),2,0),STICK,LINETHICK3,COLORGREEN;
DRAWTEXT(S1=2,LOW,' →◆● 关注!! ◆●  '), COLORGREEN;
中轨:HHV(MA(H,13),13),COLORRED,LINETHICK2;
趋势:LLV(MA(H,13),1),COLORGREEN,LINETHICK2;

{主力进场2  副图}

VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);
VARQ3:=EMA(VARQ2,10);
VARQ4:=LLV(LOW,33);
VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),3)*100;
主力进场:STICKLINE(VARQ5>REF(VARQ5,1),0,VARQ5,7,0 ),COLORFFFF00;
VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:SMA(VAR2,3,1)*VAR1,LINETHICK2,COLORRED;
VAR4:SMA(VAR3,3,1),LINETHICK2,COLOR0099FF;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(VAR9,VAR3-5,100,1,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(VAR9 AND COUNT(VAR9,10)=1,VAR3-15,'PL'),LINETHICK2,COLORYELLOW;
AA:=SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1);
TP:EMA(IF(L<=LLV(L,30),AA,0),3)*1000,COLORFF00FF,LINETHICK2;
HL99 := MA(COST(99 ),5);{获利99}
HL80:=MA(COST(80),5);{获利80}
HL20:=MA(COST(20),5);{获利20}
A5:=(HL99-HL80)/HL80*100;
A6:=(HL80-HL20)/HL20*100;
A8:=IF(A6<10 ,10000 ,0 );
A9:=IF(A6<15 ,5000 ,0 );
A10:=IF(A6<20 ,2500 ,0 );
高密集:A8,COLORBLUE,LINETHICK2;
中密集:A9,COLORWHITE,LINETHICK2;
低密集:A10,COLOR00FF00,LINETHICK2;

{猴王出世 副图}

VAR1:=MA(CLOSE,5);
VAR2:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR3:=SMA(VAR2,5,1);
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),8,1)/SMA(ABS(CLOSE-VAR4),8,1)*100;
VAR6:=SMA(MAX(CLOSE-VAR4,0),21,1)/SMA(ABS(CLOSE-VAR4),21,1)*100;
花果山: IF(100-VAR3<20 AND VAR6<25,VAR3+15,32.86),STICK,LINETHICK1,COLORF00FF0;32.86,STICK,LINETHICK1,COLOR000000;
山顶: IF(100-VAR3<30,VAR3+5,32.86),STICK ,LINETHICK1, COLORRED;32.86,STICK ,LINETHICK1, COLOR000000;
山腰: IF(100-VAR3<50,VAR3,32.86),STICK ,LINETHICK1, COLORGREEN;32.86,STICK ,LINETHICK1, COLOR000000;
山脚: IF(100-VAR3<50,VAR3-15,32.86),STICK ,LINETHICK1, COLORYELLOW;32.86,STICK ,LINETHICK1, COLOR000000;
水帘洞: IF(VAR5<40 AND VAR6<50 AND VAR3>70,30,100-VAR3),STICK,LINETHICK7,COLOR0FFF00;100-VAR3,STICK,LINETHICK7,COLOR000000;
猴王: 100-VAR3, , COLORRED;
猴王出世1: CROSS(VAR5,10) AND CROSS(VAR6,20)*125, , COLORRED;
猴王出世2: CROSS(猴王,10)*125, , COLORRED;
{DRAWICON(猴王出世1=125,130,1);};

{东方不败  副图}

VAR1:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR3:=SUM(VAR1,5);
VAR4:=SUM(VAR2,5);
VAR5:=IF(VAR3>VAR4,(VAR3-VAR4)/VAR3,IF(VAR3=VAR4,0,(VAR3-VAR4)/VAR4));
VAR6:=MA(VAR5,5);
VAR8:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR9:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VARA:=SUM(VAR8,3);
VARB:=SUM(VAR9,3);
VARC:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VARD:=MA(VARC,3);
火: BARSLAST(EMA(CLOSE,5)VARE:=HHV(CLOSE,2);
VARF:=BARSLAST(VAREVAR10:=IF(VARF>=1,LLV(VARE,VARF),LOW);
VAR11:=VAR10+VAR10*VARF*0.5/100;
VAR12:=IF(VAR11VAR13:=VAR10+VAR10*(VARF-1)*1.618/100;
山: COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5);
VAR14:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR15:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR16:=SUM(VAR8,3);
VAR17:=SUM(VAR9,3);
VAR18:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR19:=MA(VARC,3);
买入或持股: (山>0,火,0,2,0), COLORRED;
STICKLINE(山>0,火,0,2,0), COLORRED;
VAR1A:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR1B:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR1C:=SUM(VAR8,3);
VAR1D:=SUM(VAR9,3);
VAR1E:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR1F:=MA(VARC,3);
下跌→抛出: (山>0,火,山,2,1), COLORF0F000;
STICKLINE(山>0,火,山,2,1), COLORF0F000;
VAR20:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR21:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR22:=SUM(VAR8,3);
VAR23:=SUM(VAR9,3);
VAR24:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR25:=MA(VARC,3);
观望: STICKLINE(山=0 AND 火=0,0,1,4,1), COLORBLUE;
VAR26:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR27:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR28:=SUM(VAR8,3);
VAR29:=SUM(VAR9,3);
VAR2A:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR2B:=MA(VARC,3);
植被: (山<火,火,山,1,0), COLOR00FF00;
STICKLINE(山<火,火,山,1,0), COLOR00FF00;
VAR2C:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2D:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR2E:=SUM(VAR8,3);
VAR2F:=SUM(VAR9,3);
VAR30:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR31:=MA(VARC,3);
VAR32:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*10;
K: SMA(SMA(VAR32,2,1),2,1),COLOR00FF00 , ;
D: SMA(SMA(SMA(VAR32,2,1),2,1),3,1), COLORYELLOW;
J: (3*SMA(SMA(VAR32,2,1),2,1)-2*SMA(SMA(SMA(VAR32,2,1),2,1),3,1)), COLORF00FF0;
VAR33:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR34:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR35:=SUM(VAR8,3);
VAR36:=SUM(VAR9,3);
VAR37:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR38:=MA(VARC,3);
STICKLINE(REF(山,1)=0 AND 山>0,0,-1,2,0), COLORRED;
DRAWTEXT(REF(火,3)>0 AND REF(火,2)>0 AND REF(火,1)>0 AND 火=0 AND REF(火,1)>山,REF(火,1),'调整'),COLORYELLOW , ;

{逃顶100% 副图}

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((VOL > 0),VOL,0,4,1),COLORFFFFFF;
STICKLINE((买卖差 > 0),0,买卖差,4,0),COLOR0000FF;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,COLOR33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));


VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,4,1),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,4,1),COLOR00FF00;
STICKLINE((鬼力 > 0),鬼力,0,4,0),COLORFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),COLOR00FFFF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,4,0),COLORFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,4,0),COLORFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,4,0),COLORFF00FF;
相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);

{天狼50+操盘手  主图}

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
波动回调提示图:MA(CLOSE,10000);
买线:EMA(C,2),COLORRED;
卖线:EMA(SLOPE(C,21)*20+C,42),COLORGREEN; 
指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK1,COLORFFFFFF;
界: MA(CLOSE,27),LINETHICK1,COLOR00FFFF;STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLOR0000FF;
STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLORFF0000;
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'上拐点'),COLOR00FFFF;
DRAWTEXT(CROSS(MA15,FF),(HIGH * 1.02),'下拐点'),COLOR00FF00;
DRAWTEXT(CROSS(85,RSI),(HIGH * 1.02),'回调!'),COLORFFFFFF;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,CLOSE,OPEN,4.5,0),COLOR0000AA;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE(买线<卖线,CLOSE,OPEN,4.5,0),COLORAAAA00;
STICKLINE(买线<卖线,CLOSE,OPEN,4,0),COLORBBBB00;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,3,0),COLOR00FFFF;

{雪中莲 副图}

{N 5,50,27; S1 2,4,3; S 2,4,3}

种:=100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N));
芽:=SMA(种,S1,1);
土:=LLV(LOW,36);
肥:=EMA((CLOSE-土)/(HHV(HIGH,30)-土)*4,4)*25;
水:=(肥 -LLV(肥,21))/(HHV(肥,21)-LLV(肥,21))*100;
春 :=(HIGH+LOW+OPEN+3*CLOSE)/6;
夏 :=(春-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
秋 := SMA(夏,3,1);
冬 := SMA(秋,2,1);
季: SMA(芽,S2,1);
节: SMA(季,S2,1);
播种:=CROSS(季,15);
吐芽:=CROSS(季,节) AND 季<40;
拔节:=CROSS(水,90) &&肥<40;
孕蕾:IF(播种,10,IF(吐芽,20,IF(拔节,30,0)));
绽开:IF(CROSS(节,季) AND 节>75,90,100);
风 : 3*秋-2*冬;
向 : MA(风,3);

{水都观音  副图}

昨收:=REF(C,1);
最高价偏离:=ABS(H-昨收);
最低价偏离:=ABS(L-昨收);
高低偏离:=ABS(H-REF(L,1));
昨K线长:=ABS(昨收-REF(O,1));
稳定性测度:=IF(最低价偏离>高低偏离 AND 最低价偏离>最高价偏离,最低价偏离+最高价偏离/2+昨K线长/4,高低偏离+昨K线长/4);
强弱测度:=C+(C-O)/2-REF(C,1);
振动系数:=强弱测度/稳定性测度;
振动量:=振动系数*MAX(最高价偏离,最低价偏离);
振动线:=SUM(振动量,0);
均125:=EMA(振动线,125);
观音显圣:振动线>均125,COLORFF00FF, NODRAW;
均240:=EMA(振动线,240);
朝拜观音:FILTER(CROSS(振动线,均240),24),LINETHICK0,COLORYELLOW,NODRAW;
DRAWICON(朝拜观音,均125-0.10,9);
慈航普渡:均125>=REF(均125,1),COLORRED,NODRAW;
IF(慈航普渡,均125,DRAWNULL),COLORRED,LINETHICK2;
{IF(C,均125,DRAWNULL),COLOR004F00,LINETHICK1;}
STICKLINE(NOT(观音显圣),均125,振动线+(均125-振动线)*0.75,5,0),COLOR004F00;
STICKLINE(NOT(观音显圣),振动线+(均125-振动线)*0.75,振动线+(均125-振动线)*0.5,5,0),COLOR007600;
STICKLINE(NOT(观音显圣),振动线+(均125-振动线)*0.5,振动线+(均125-振动线)*0.25,5,0),COLOR00AD00;
STICKLINE(NOT(观音显圣),振动线,振动线+(均125-振动线)*0.25,5,0),COLOR00DE00;
STICKLINE(观音显圣,均125,均125+(振动线-均125)*0.25,5,0),COLORFA00FF;
STICKLINE(观音显圣,均125+(振动线-均125)*0.25,均125+(振动线-均125)*0.5,8,0),COLORFA50FF,LINETHICK3;
STICKLINE(观音显圣,均125+(振动线-均125)*0.5,均125+(振动线-均125)*0.75,8,0),COLORFA93FF,LINETHICK3;
STICKLINE(观音显圣,振动线,均125+(振动线-均125)*0.75,8,0),COLORFFCCFF;
均150:=EMA(振动线,150);
{IF(C,均150,DRAWNULL),COLOR88BBBB;}
均175:=EMA(振动线,175);
IF(C,均175,DRAWNULL),COLORFFCC00;
均200:=EMA(振动线,200);
IF(C,均200,DRAWNULL),COLOR777777;
均225:=EMA(振动线,225);
IF(C,均225,DRAWNULL),COLORBBBBBB;

{五星连珠  副图}

K2:=EMA(C,5);
K3:=EMA(C,10);
K5:=EMA(C,30);
K6:=2*(K2-K5);
K7:=2*(K2-K3);
K8:=2*(K7+K6);
中线指示:STICKLINE(CROSS(K8,0),0,40,8,0),COLORRED,LINETHICK2;
P1:= MA(CLOSE,2);
P2:= MA(CLOSE,5);
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
VMA1:=MA (VOL,2)/100000;
VMA2:=MA(VOL,5)/100000;
PPDAY:= BARSLAST(CROSS(P1,P2));
VVDAY:= BARSLAST(CROSS(VMA1,VMA2));
MACDDAY:= BARSLAST(CROSS(DIFF,DEA));
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
金叉:IF(REF(C,A1+1)>C AND REF(DIFF,A1+1)SJCJD:= IF((PPDAY<=3 AND VVDAY<=3 AND MACDDAY<=3)AND (DIFF<0),1,0);
STICKLINE(SJCJD,50,60,6,0),COLORWHITE,LINETHICK2;
短趋势:=((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50);
VAR2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR3:=LLV(LOW,34);
VAR4:=HHV(HIGH,34);
长趋势:=EMA((VAR2-VAR3)/(VAR4-VAR3)*100,13),COLOR00FF00;
判断底:SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*15;
VAR5:=CROSS(短趋势,长趋势)AND 长趋势<25;
STICKLINE(VAR5,60,70,8,0) ,COLORGREEN;
XX:=((((CLOSE-MA(CLOSE,34))/MA(CLOSE,34))*100)*5);
B001:=(((((CLOSE-MA(CLOSE,42))/MA(CLOSE,42)))*100)*5);
B002:=(((((CLOSE-MA(CLOSE,67))/MA(CLOSE,67)))*100)*5);
B003:=(((XX+B001)/2)-B002);
B004:=(((0-100)*(VAR4-CLOSE))/(VAR4- VAR3));
B005:=(((0-100)*(HHV(HIGH,42) - CLOSE))/(HHV(HIGH,42) - LLV(LOW,42)));
B006:=(((0-100)*(HHV(HIGH,72) - CLOSE))/(HHV(HIGH,72) - LLV(LOW,72)));
B007:=EMA((((B004+B005)/2)-B006),6);
B008:=REF(CLOSE,1);
B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);
B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);
B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);
多头:EMA(((((B009 + B010)/2) - B011) * 5),6),LINETHICK2;
空头:=(((-1*((B007 + B003) + 多头))/3) * 1.5);
多均:EMA(多头,4),LINETHICK2;
空均:=EMA(空头,4);
C026:=WINNER(CLOSE);
W:=(DMA(C026,(VOL/CAPITAL)) * 100);
XD1:=EMA(W,6);
庄家控盘:((W-XD1)*15),COLORSTICK,LINETHICK2;
STICKLINE(CROSS(多头,空均),80,70,8,0),COLORYELLOW;
VARB1:=(2*CLOSE+HIGH+LOW)/4;
VARB2:=LLV(LOW,34);
VARB3:=HHV(HIGH,34);
VARB4:=MA(HIGH,8);
XX1:=EMA((VARB1-VARB2)/(VARB3-VARB2)*100,13);
YY:=EMA(0.667*REF(XX1,1)+0.333*XX1,2) , ;
STICKLINE(CROSS(XX1,20) AND YYREF(VARB4,1),70,80,8,0),COLORFF0000;
逃顶:IF(FILTER(CROSS(YY,XX) AND XX>80 ,3),70,90),COLORFF0000,LINETHICK2;
DRAWTEXT(CROSS(多头,多均)AND 多均<-15,多均,'★'),COLORRED;
DRAWTEXT(CROSS(多均,多头)AND 多均>35,多均+7,'★'),COLOR00FF00;

{雨青升天  副图}

MA4:MA(CLOSE,4),COLORFFFFFF;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORFF00FF;
MA62:MA(CLOSE,62),COLORFFFF00;
SMA4:= REF(SLOPE(MA4,2),1)<0 AND SLOPE(MA4,2)<=0  AND REF(SLOPE(MA4,2),1)SMA10:= REF(SLOPE(MA10,2),1)<0 AND SLOPE(MA10,2)<=0  AND REF(SLOPE(MA10,2),1)SMA20:= REF(SLOPE(MA20,2),1)<0 AND SLOPE(MA20,2)<=0  AND REF(SLOPE(MA20,2),1)SMA62:=(SLOPE(MA62,3)>0) OR (REF(SLOPE(MA62,3),1)<0 AND SLOPE(MA62,3)<=0  AND REF(SLOPE(MA62,3),1)ANYUP:=(SLOPE(MA10,3)>0 OR SLOPE(MA20,3)>0 OR SLOPE(MA62,3)>0);
CONN:=ANYUP AND SMA62 AND (SMA10 OR SLOPE(MA10,2)>0)  AND (SMA20 OR SLOPE(MA20,2)>0) AND SMA4;
DRAWTEXT(NOT(REF(CONN,1)) AND NOT(REF(CONN,2)) AND CONN,LOW*0.99,'雨青升天');

控盘雷达
VAR1:=CLOSE-LOW;
VAR2:=HIGH-LOW;
VAR3:=CLOSE-HIGH;
VAR4:=IF(CLOSE>=0,(VAR1/VAR2+VAR3/VAR2)*VOL,(VAR3/VAR2+VAR1/VAR2)*VOL);
主力控盘雷达: SUM(VAR4,10)/10000, VOLSTICK;
天地人和
VAR1:=AMOUNT/VOL/100;
VAR2:=SUMBARS(VOL,CAPITAL*1.618);
VAR3:=IF(VAR2>100,1.033,IF(VAR2<=100 AND VAR2>33,1.039,1.05));
VAR4:=EMA(VAR1,34)*VAR3;
VAR5:=HHV(HIGH,150);
天: VAR5*0.95;
地: MA(CLOSE,125)-2*STD(CLOSE,145);
人: MA(CLOSE,10)-2*STD(CLOSE,30);
和: ZIG(3,10);


大明排序
VARA:=C;
VARB:=REF(VARA,1);
VARC:=INDEXC;
VARD:=REF(VARC,1);
VAR1:=(VARC-VARD)/VARD*100;
VAR2:=(VARA-VARB)/VARB*100;
VAR3:=IF(ABS(VAR1)<2,0.9,1);
VAR4:=VAR3*(VAR2-VAR1);
今日换手:V/CAPITAL*100;
今日涨幅:(C-REF(C,1))/REF(C,1)*100;
个股强度3:SUM(VAR4,3);
个股强度5:SUM(VAR4,5);
个股强度10:SUM(VAR4,10);
个股强度21:SUM(VAR4,21);


快乐家园
大马金刀
VAR1:=IF(LLV(LOW,5)<=CLOSE,LLV(LOW,5),CLOSE);
VAR2:=IF(LLV(LOW,10)<=VAR1,LLV(LOW,10),VAR1);
VAR3:=IF(LLV(LOW,20)<=VAR2,LLV(LOW,20),VAR2);
VAR4:=IF(LLV(LOW,30)<=VAR3,LLV(LOW,30),VAR3);
VAR5:=IF(LLV(LOW,40)<=VAR4,LLV(LOW,40),VAR4);
VAR6:=IF(LLV(LOW,50)<=VAR5,LLV(LOW,50),VAR5);
VAR7:=IF(LLV(LOW,60)<=VAR6,LLV(LOW,60),VAR6);
VAR8:=IF(LLV(LOW,100)<=VAR7,LLV(LOW,100),VAR7);
VAR9:=IF(LLV(LOW,150)<=VAR8,LLV(LOW,150),VAR8);
VARA:=SUM(MA(CLOSE/VAR9,1)-1.1,5);
大马: VARA, COLORSTICK;
金刀: CROSS(VARA,0);
{理财专家选股}
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,89))/(0.015*AVEDEV(VAR5,89));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
OX:=IF(VARB<90,VARB,100),COLORFFCC66;
预警:=IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60,COLOR00FF00;
VAR21:=IF(VAR1>0,VAR1,0);
VAR2A:=VAR21>48 AND 预警>60 AND OX<100;
拉升在即狂牛!:VAR2A AND COUNT(VAR2A,30)=1;

{MACD实战选股}

DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);
D1:=EMA(C,3)-EMA(C,8);
D2:=EMA(O,3)-EMA(O,8);
D3:=EMA(H,3)-EMA(H,8);
D4:=EMA(L,3)-EMA(L,8);
CROSS(D1,DIFF) AND DIFF<-0.05;

{波段鬼王1选股}

VAR26:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR28:=SMA(VAR26,3,1);
波段王:= SMA(VAR28,3,1);
波段鬼:= SMA(波段王,3,1);
低吸做波段:CROSS(波段王,波段鬼) AND 波段王<40;


{波段鬼王2选股}

VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR28:=SMA(VAR26,3,1);
波段王:=SMA(VAR28,3,1);
波段鬼:=SMA(波段王,3,1);
逢低吸呐:CROSS(波段王,波段鬼) AND 波段王<40;

{精品出山--绝对精品}
100,POINTDOT;
60,POINTDOT;
var1:=88;
var2:=68;
var3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
var4:=SMA(var3,3,1);
var5:=SMA(var4,3,1);
var6:=3*var4-2*var5;
var7:=SMA(CLOSE/HHV(HIGH,120),3,1)*100;
var8:=SMA(CLOSE/HHV(HIGH,120),3,1)*100;
var9:=var7>REF(var7,20) AND var7>75 AND FILTER(var7/REF(LLV(LOW,20),10)>1.18,20);
varA:=IF(var7>70 AND var7<75,1,0);
DRAWTEXT(COUNT(varA,20)>3 AND var7/HHV(HIGH,30)<1,var7,'调整到位');
varB:=REF(CLOSE,1);
varC:=SMA(MAX(CLOSE-varB,0),6,1)/SMA(ABS(CLOSE-varB),6,1)*100;
调整:var7,COLOR00ff00;
买进:STICKLINE(var7<68 AND BARSLAST(CROSS(var2,调整))>2 AND CROSS(var6,var5) AND var5<30,60,68,5,0),COLORf0f000;
顶区:IF(var7>var1,var7,var1),COLORRED;
底区:IF(var8DRAWTEXT(var9 AND var7<88,调整,'短期风险'),COLORf00ff0;
DRAWTEXT(var7<68 AND BARSLAST(CROSS(var2,var7))>2 AND var5<30 AND CROSS(var6,var5),63,'来抢钱吧'),color00ffe0;
DRAWTEXT(FILTER(调整<52,10),调整,'都疯我没疯');
DRAWTEXT(var7>88 AND CROSS(84,varC),调整,'高风险跑');

{高山瀑布  主图}
{N 1,100,2}

C1:=C;
D1:=LLV(LOW,15)*1;
D2:=LLV(LOW,10)*1;
D3:=LLV(LOW,5)*1;
XXX:=(D1=D2)=D3;
最值:=LLV(LOW,30);
X1:=HHV(CLOSE,35) ;
X2:=HHV(CLOSE,30);
X3:=HHV(CLOSE,25);
X4:=HHV(CLOSE,20);
X5:=HHV(CLOSE,15);
X6:=HHV(CLOSE,10);
X7:=HHV(CLOSE,5);
X8:=HHV(CLOSE,2);
STICKLINE(X2>X3,X2,X3,6,0),COLORFFA4A4,LINETHICK1;
STICKLINE(X3>X4,X3,X4,6,0),COLORFF7171,LINETHICK1;
STICKLINE(X4>X5,X4,X5,6,0),COLORFF3737,LINETHICK1;
STICKLINE(X5>X6,X5,X6,6,0),COLORF90000,LINETHICK1;
STICKLINE(X6>X7,X6,X7,6,0),COLOR990000,LINETHICK1;
STICKLINE(X8>D3,X8,D3,6,0),COLOR660000,LINETHICK1;
STICKLINE((最值)STICKLINE(D2>D1,D2,D1,6,0),COLOR005E00,LINETHICK1;
STICKLINE(D3>D2,D3,D2,6,0),COLOR22AA11,LINETHICK1;
STICKLINE(X7>D3,X7,D3,6,0),COLOR22AA55,LINETHICK1;
{X:=8;}
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND C>REF(C,1), HIGH, LOW, 0.1, 1), COLORRED;
STICKLINE(CLOSESTICKLINE(BARSCOUNT(C)=1 AND CLOSE=OPEN, HIGH, LOW, 0.1, 1), COLORRED;
STICKLINE(CLOSE>OPEN, CLOSE, OPEN, N, 1), COLORRED;
STICKLINE(CLOSE{STICKLINE(CLOSE=OPEN AND C>REF(C,1), CLOSE, OPEN, N, 1), COLORRED;
STICKLINE(CLOSE=OPEN AND C<=REF(C,1), CLOSE, OPEN, N, 0), COLORCYAN;}
STICKLINE(BARSCOUNT(C)=1 AND CLOSE=OPEN, CLOSE, OPEN, N, 1), COLORRED;

{黑马线1 选股}

LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑马线:IF(LS28>0.1,LS29,0)*5;

{黑马线2 选股}

LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑马线:LS28>0.1 AND CROSS(LS29,0);
黑马线(副)
LS3:=LLV(HIGH,240);
LS4:=100*(CLOSE-LS3)/LS3;
LS5:=REF(LLV(CLOSE,480),1);
LS6:=REF(HHV(CLOSE,480),1);
LS7:=100*(CLOSE-LS5)/(LS6-LS5);LS8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
LS9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
LSA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
LSB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
LSC1:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
LSC:=LSC1/4;
LSD:=IF(LSC>23.6,LSC,0);
LSE:=LSC<1;
LSF:=LSD;
LS10:=LS4;
LS11:=1;
LS12:=(HIGH+LOW+CLOSE*2)/4*LS11;
LS13:=EMA(LS12,21);
LS14:=STD(LS12,21);
LS15:=((LS12-LS13)/LS14*100+200)/4*LS11;
LS161:=EMA(LS15,89);
LS16:=(LS161-25)*1.56*LS11;
LS171:=EMA(LS16,5);
LS17:=LS171*1.22*LS11;
LS181:=EMA(LS17,3);
LS18:=LS181*LS11;
LS19:=3*LS17-2*LS18*LS11;
LS1A:=IF(CROSS(LS19,LS17)AND CROSS(LS19,LS18)AND CROSS(LS17,LS18),1,0);
LS1B:=IF(CROSS(LS17,LS19)AND CROSS(LS18,LS19)AND CROSS(LS18,LS17),1,0);
LS1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
LS1D1:=EMA(CLOSE,2);
LS1D2:=EMA(CLOSE,89);
LS1D:=LS1D1-LS1D2;
LS1E:=EMA(LS1D,30);
LS1F:=(LS1D-LS1E)*20;
LS20:=POW(LS1F,3)*0.1+POW(LS1F,2);
LS21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS22:=EMA(LS21*0.97,3);
LS23:=(HIGH+LOW+CLOSE)/3;
LS24:=(LS23-MA(LS23,14))/(0.015*AVEDEV(LS23,14));
LS25:=IF(LS1F>0.015,LS20,0)/45;
庄拉线:=LS25;
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
LS2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS2B:=EMA(LS2A*0.97,3);
LS2C:=(HIGH+LOW+CLOSE)/3;
LS2D:=(LS2C-MA(LS2C,14))/(0.015*AVEDEV(LS2C,14));
黑马线:IF(LS28>0.1,LS29,0)*5;
量价线:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
常数线:=0;
X1:LS3;

X2:LS5;
X3:LS6;
庄 股横盘启动 A1:=100*(WINNER(1.1*C)-WINNER(0.9*C));
A2:=((CLOSE-LOW)/(HIGH-LOW)+(CLOSE-HIGH)/(HIGH-LOW))*VOL;
A3:=SUM(A2,10)/10000;
Var1:=AMOUNT/VOL/100;
Var2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
Var3:=SUM(AMOUNT,5)/Var1/100;
Var4:=SUM(AMOUNT,13)/Var1/100;
Var5:=SUM(AMOUNT,34)/Var1/100;
CYC5:=DMA(Var2,VOL/Var3);
CYC13:=DMA(Var2,VOL/Var4);
CYC34:=DMA(Var2,VOL/Var5);
CYS13:=(CLOSE-CYC13)/CYC13*100;
CYR13:=CYC13/REF(CYC13,1)*120-120;
MA5:=MA(C,5);
B:=VOL*100/CAPITAL;
AA:=COUNT(A1>60,20)=20;
横盘启动:AA AND CYC5>CYC13 AND CYC13>CYC34
AND CYS13>0 AND CYR13>0.5 AND CYR13<2 AND C>MA5 AND A3>0 AND B<=4;


“风洞”核心公式破解+用法(转)
Var1:=FORCAST(CLOSE,30);
A:WINNER(Var1), LINETHICK1,COLORYELLOW;
A1:REVERSE(A),LINETHICK1 , COLORWHITE;
A2:(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)),COLOR00FF00;
A3:REVERSE(A2), COLORRED;
STICKLINE(C>0,1,{1}0.96,4,0),colorFF9999;
STICKLINE(C>0,-1,{-1}-0.95,4,0),colorFF9999;
-0.3,colorDDDDDD,POINTDOT,LINETHICK2;
0.3,colorDDDDDD,POINTDOT,LINETHICK2;

{用法:该指标引用了相反数、获利盘比例、线性回归预测值函数的原理表示股价
运行的趋势,四条线呈对称形,当四条线粘合运行在两条白色线区间时表示盘整,
不宜介入。当红绿两条线分离脱离白色线区间时表示开始涨升,分离的幅度越大,
涨升也就越大。当绿线临近顶线(蓝线)或触及顶线时,预示即将到顶,要择机卖出。}+


黑马强牛
Var3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4; Var4:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),44)/4; Var5:=EMA(CLOSE,1)-EMA(CLOSE,1297); Var6:=EMA(Var5,715); Var7:=2*(Var5-Var6); Var8:=POW(Var7,3)*0.1+POW(Var7,2); VarA:=EMA(CLOSE,2)-EMA(CLOSE,34); VarB:=EMA(VarA,33); VarC:=2*(VarA-VarB); VarD:=POW(VarC,3)*0.1+POW(VarC,3); VarF:=EMA(CLOSE,2)-EMA(CLOSE,89); Var10:=EMA(VarF,30); Var11:=2*(VarF-Var10)*10; Var12:=POW(Var11,3)*0.1+POW(Var11,2); Var13:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE)); Var14:=EMA(Var13*0.97,3); Var15:=(HIGH+LOW+CLOSE)/3; Var16:=(Var15-MA(Var15,14))/(0.015*AVEDEV(Var15,14)); Var17:=IF(Var11>0.015,Var12,0)*100; Var18:=(CLOSE-LLV(CLOSE,95))/(HHV(CLOSE,95)-LLV(CLOSE,95))*100; Var19:=VOL/240>MA(VOL,6)/240 AND CLOSE>OPEN*1.003; Var1A:=Var19 AND CLOSEREF(CLOSE,1),VOL,IF(CLOSE0 AND Var17>0 AND Var18<30 AND Var1F,90)=1,20,0),stick , COLORRED; 强牛: IF(FILTER(CROSS(EMA(CLOSE,3),EMA(CLOSE,13)) AND Var17>0 AND Var4<5 AND Var8>0 AND Var18<30 AND Var1A,5)=1,20,0),stick , COLOR6699cc; 强龙: IF(FILTER(强马 AND 强牛 AND Var1A,5)=1,20,0),stick , COLORYELLOW; 红马线: (CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100, , COLORstick; 见底: IF(HHV(CLOSE,20)/CLOSE>1.15 AND HIGH/LOW>1.05 AND CROSS(-28,红马线)*1/2,20,0),stick , COLORff0000; 强势必行: IF(FILTER(红马线>0 AND 强马 AND 红马线>0 AND 强牛 OR 红马线>0 AND 强龙,5)=1,30,0),linethick2 , COLORYELLOW; 当日强势预警: (强马 OR 强牛) AND DYNAINFO(14)>=0.02 AND DYNAINFO(17)>=0.5, , COLORff6600; DRAWTEXT(强马>0,5,'马'), , ; DRAWTEXT(强牛>0,13,'牛'), , COLOR6699cc; DRAWTEXT(强龙>0,18,'龙'), , COLORYELLOW; DRAWTEXT(见底>0,-7,'见底'), , COLORMAGENTA;


黑马VOL}

c0:((c+h+o+l+(c+o+l+h)/4+(o+C)/2+(l+h)/2+(o+l)/2+(c+l)/2+(c+h)/2+(o+h)/2+(c+h+o)/3+(h+o+l)/3+(c+h+l)/3+(o+l+c)/3)+(H+L+C*2)/4)/16;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(C0>ref(c0,1),AA*(HIGH-LOW),IF(C0主动卖盘:=IF(C0>ref(c0,1),0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(C0sh:=ema(主动买盘-主动卖盘,21)/1000;
买盘: IF(c0>0 ,sh,0),stick ,color777777;
黑马线:STICKLINE(c0>0,sh,ref(sh,1),6,1) ,coloraaaaaa;


上马骑牛
追涨:=EMA(C,3);
骑师:EMA(C,3),colorwhite;
压力:=MA(LLV(C,9)*1.1,14);
支撑:=MA(HHV(C,26)*0.9,14);
多空线:=(压力+支撑)/2;
上马: (压力+支撑)/2,coloryellow;
骑牛:MA(LLV(C,9)*1.1,14),color0099ff;
FD:=IF(CROSS(骑师,上马) AND EMA(C,60)

A:=MA(C,3)COLORGREEN,LINETHICK2;
B:=AVAR1:=IF(B-1,A,DRAWNULL)COLORRED,LINETHICK2;
REF(VAR1,1)=DRAWNULL AND VAR1=A;

这个公式昨天晚上选出的票,今天一开盘就翻红.

三浪启动选股
MA60:=MA(CLOSE,60),COLORGREEN;
MA250:=MA(CLOSE,250),COLORMAGENTA,LINETHICK3;
PL1:=(((CLOSE-MA60)/MA60)<0.1);
PL2:=(((CLOSE-MA250)/MA250) < 0.3);
偏离率:=(((PL1=1) AND (PL2=1)))*0.2;
突破:偏离率=0 AND REF(偏离率,1)=0.2 AND REF((COUNT((偏离率=0.2),10)=10),1) ;

大庆老杨的新变色KDJ选股

VAR1:=(H+L+O+C*2)/5;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,23);
VAR4:=EMA(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
K:=(EMA(VARA,23)+100)/2-3,COLOR00FFFF,LINETHICK2;
D:=SMA(K,5,1),COLORFFFF00,LINETHICK2;
J:=4*K-3*D,COLORFF00FF,LINETHICK2;
{IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
IF(JDRAWICON(FILTER(J>REF(J,1)AND JAND JREF(VAR4,1)
AND K>=REF(K,1)AND J<40
OR CROSS(J,K)AND CROSS(J,D)
AND J<40 OR J>REF(J,1)AND J<-20,7), J*0.8,1);

{庄影难逃底 选股}

趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,  COLORAABBDD;
BB:=((REF(趋势线,1)-25) AND  趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
底:BB;

庄影难逃机会选股

趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,  COLORAABBDD;
CC:=((REF(趋势线,1)-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-25,趋势线),1) AND CROSS(趋势线,-25));
机会:CC;

 

VAR1:=MA(CLOSE,5),COLOR00FFFF;
VAR6:=MA(CLOSE,54),COLORFF9900;
VAR8:= DMA(EMA(CLOSE,12),SUM(VOL/CAPITAL,5)/3),LINETHICK2;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(84,VARE),HIGH,'☆机构减仓'),COLORGREEN;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,23);
VAR11:=HHV(HIGH,23);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
DRAWTEXT(IF(COUNT(CLOSE0.3 AND COUNT(VAR12>VAR13,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,'★机构进场'),COLORYELLOW;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑价:LLV(LOW,34) ,COLOR7FFF00,LINETHICK2;
阻力价:HHV(HIGH,19),COLORFF9900, LINETHICK2;
十:MA(C,5),COLOR00FFFF,LINETHICK2;
涨:IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,5)=REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(CLOSE,5)

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)>C AND REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)>C AND REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D"),L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)>C AND REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1))+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离};
:《较大调整的预测方法》

当潮水退去的时候,才知道是谁在裸泳,这句话是华尔街的一位大师说的。意思是当牛市行情结束的时候,很多人都会损失很多的钱。特别是股市涨到这个地步,选好股票,保护好战斗成果,比任何时候都显得重要。

数据采集自大智慧证券软件。

2005年6月6日,大盘完成最后一跌,到达最低998.23,熊市结束;
2005年6月9日,大盘上涨到最高1146.42;
2005年7月12日,大盘下跌到最低1004.08;
2005年9月20日,大盘上涨到最高1223.56;
2005年10月28日,最低1067.41;
2006年3月1日,最高1308.20;
2006年3月8日,最低1238.16;
2006年6月2日,最高1695.58;
2006年6月14日,最低1512.52;
2006年7月5日,最高1757.47;
2006年8月7日,最低1541.41;
2007年1月24日,最高2994.28;
2007年2月6日,最低2541.52;
2007年2月27日,最高3049.77;
2007年3月5日,最低2723.06;
2007年5月29日,最高4335.96;
2007年6月5日,最低3404.15;
2007年6月20日,最高4312.00;
2007年7月6日,最低3563.54

再看一下2005年6月6日以来每次跌幅超过4.5%的日子,让我们记住这些日子。
2006年6月7日,跌5.33%,从1678.24到1589.55
2006年7月13日,跌4.84%,从1736.21到1655.77
2007年1月31日,跌4.92%,从2926.07到2786.33
2007年2月27日,跌8.84%,从3048.83到2771.79
2007年4月19日,跌4.52%,从3610.02到3449.02
2007年5月30日,跌6.50%,从4087.41到4053.09
2007年6月4日,跌8.26%,从3981.82到3670.40
2007年7月5日,跌5.25%,从3769.64到3615.87

对于大盘下个压力位的推算,以行情启动的最低点998.23最为基数,以1/4倍,2/4倍,3/4倍,2倍,2+1/4倍(以此类推)....为最有可能的阻力位。推算方法来自江恩理论。
998.23 的125%是1247.79,正好对应2005年9月20日大盘最高点1223.56
998.23的175%是1746.90,正好对应2006年7月5日大盘最高点1757.47
998.23的300%是2994.69,正好对应2007年1月24日的2994.28
998.23的425%是4242.47,正好对应2007年5月29日的4335.96,差93.49点
998.23的525%是5240.71,难道这是最有可能的下次大震荡发生的日期吗?

我不是很肯定,如果这天没有大震荡,则可以继续往下推算。我个人认为如果量放的很大的话,在这个点位可能会有股灾,如果大盘保持目前的量,则危险不大。

再补充一句,如果某天大盘跌幅超过4.5%,我们一定要警觉,这是每次股灾发生的前兆。

附:有意思的是,根据这篇文章的推测方法,在上星期五股指最高到5959.36。
        按上述方法计算:998.23*600%=5989.38 与实际相差30点。
        如果股指再涨的话,那么预计下一次的高点应为998.23*625%=6238.94。
       昨天浙江电视台有一股评家预测下次可能在6200点上调整。
N  1  20   20
N1 1  7    7
N2 1   79   79


{终结黄金主图}

Var1:=(CLOSE+HIGH+LOW)/3;
Var2:=EMA(Var1,10);
Var3:=REF(Var2,1);
终极黄金: if(Var2>Var3,Var2,0), pointdot,linethick5, COLORYELLOW;
一卸千里: if(Var2M1: EMA(CLOSE,3);
M2: EMA(CLOSE,8);
M3: EMA(M2,13);
M4: EMA(M2,55);
Var4:=EMA(M3,55);
M5: EMA(M4,81);
M6: EMA(Var4,144), , COLORRED;
Var5:=(REF(HIGH,1)+REF(LOW,1))/2;
Var6:=MA(CLOSE,N)+2*STD(CLOSE,N);
卖出1:if(CROSS(Var5,Var6),HIGH*1.035,0),color00ff00;
{DRAWTEXT(CROSS(Var5,Var6),HIGH*1.02,'卖出1'), , COLORGREEN;}
Var7:=REF(CLOSE,1);
Var8:=SMA(MAX(CLOSE-Var7,0),N1,1)/SMA(ABS(CLOSE-Var7),N1,1)*100;
Var9:=CROSS(N2,Var8);
VarA:=FILTER(Var9,4);
卖出2:if(VarA,HIGH*1.035,0),colorf0f000;
{DRAWTEXT(VarA,HIGH*1.02,'卖出2'), , COLORGREEN;}
VarB:=(2*CLOSE+HIGH+LOW)/4;
VarC:=LLV(LOW,34);
VarD:=HHV(HIGH,34);
VarE:=EMA((VarB-Var4)/(Var5-Var4)*100,7);
VarF:=EMA(0.667*REF(VarE,1)+0.333*VarE,5);
买进1:if(IF(COUNT(CLOSE0.6 AND VOL>=1.5*MA(VOL,5) AND COUNT(VarE>=VarF,3) AND REF(LOW,1)=LLV(LOW,120),1,0),HIGH*1.02,0), , COLORYELLOW;
买进2:if(IF(COUNT(CLOSE0.6 AND COUNT(VarE>VarF,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND OPEN>REF(CLOSE,1),1,0),HIGH*1.02,0), , COLORf00ff0;
Var10:=MA(CLOSE,80)-MA(CLOSE,10)/3;
抄底 :if(IF(CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE

{粘合出击----一品茶缘编写,通用副图指标}

{N1:1,100,5;N2:1,100,10;N3:1,100,20;}
{粘合出击指标使用说明:
均线粘合盘整期,放量上涨有好戏;
粘合之处放量涨,二次拉升快出击!}

MA1:=MA(C,N1);
MA2:=MA(C,N2);
MA3:=MA(C,N3);
MA30:=MA(C,30);
GX:=MAX(MA1,MAX(MA2,MA3));
DX:=MIN(MA1,MIN(MA2,MA3));
QSXS:=DX>MA30 AND MA30>REF(MA30,1);
均线粘合:IF(ABS(GX/DX-1)*100<=3,1,0),COLORFFFFFF,POINTDOT,LINETHICK0;
FL:=V>REF(V,1) OR V>MA(V,5);
SZ:=(CROSS(C,MA(C,3)) OR CROSS(C,MA(C,5))) AND C>=O;
放量上涨:IF(FL AND SZ,1,0),COLOR00FFFF,POINTDOT,LINETHICK0;
果断出击:FILTER(COUNT(均线粘合,2) AND COUNT(放量上涨,2) AND C>O AND QSXS,2)*100,COLOR00FF00;
{以下设置副图显示方式}
STICKLINE(均线粘合,0,10,4,0),COLOR00FF00;
STICKLINE(均线粘合,0,-10,4,0),COLORFF00FF;
STICKLINE(放量上涨,0,50,0.1,0),COLOR00FFFF;
{以下设置果断出击后的涨幅跟踪,不需要的可以删除}
MRSJ:=BARSLAST(果断出击);
涨:(C/REF(C,MRSJ)-1)*100*(MRSJ<=20),COLOR8800FF;
ZZ:=MRSJ<20 AND CROSS(H,REF(C,MRSJ)*1.09999);
知足:=ZZ AND COUNT(ZZ,MRSJ)=1;
DB:=MRSJ<20 AND CROSS(H,REF(C,MRSJ)*1.05);
达标:=DB AND COUNT(DB,MRSJ)=1;
STICKLINE(知足,0,50,4,0),COLOR0000FF;
DRAWTEXT(知足,80,'+10%'),COLORFFFFFF;
STICKLINE(达标,0,30,4,0),COLORFFFFFF;
DRAWTEXT(达标,50,'+5%'),COLOR00FFFF;
[量能饱和度]

 


SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);
饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;
STICKLINE(C>0 AND ISLASTBAR=1,5,100,10,1),COLORWHITE;
量能≤5:STICKLINE(饱和度<=5 AND ISLASTBAR=1,5,饱和度+20,6,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80) AND ISLASTBAR=1,5,饱和度+8,6,0),COLOR5290FF;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97) AND ISLASTBAR=1,5,饱和度,6,0),COLORFFCC00;
量能≥97:STICKLINE(饱和度>=97 AND ISLASTBAR=1,5,饱和度,8,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND 饱和度,0,'量能饱和度:'+饱和度),COLORFFCCFF;
5,POINTDOT,COLORFFEEBB;
97,POINTDOT,COLORGREEN;
天萝地网          副


VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3:=SMA(VAR2,2,1);
英雄:SMA(VAR3,2,1),COLORYELLOW,LINETHICK2;
天萝:100+(-ABS(VAR1)),COLORGREEN,LINETHICK2;
地网:ABS(VAR1),COLORMAGENTA,LINETHICK2;
牛熊分界:50,COLOR0BFFFF,POINTDOT;
弱:20,COLOR80FFFF,POINTDOT;
强:80,COLOR0BFFFF,POINTDOT;
DRAWTEXT(CROSS(英雄>=天萝,1),英雄,'◆'),LINETHICK4,COLORRED;


自用VOL          副

M1:2   500   5
M2:2   500   10
M3:2   500   20


正收益率:=IF(FINANCE(33)>0.01,FINANCE(33)*0.65,0);
市盈率:=IF(FINANCE(33)>0,DYNAINFO(39),0)*0.35;
蓝筹系数:(正收益率*市盈率)/2,LINETHICK0;
动态市盈:C/FINANCE(33),COLOR16CDEC,LINETHICK0 ;
量能饱和:(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100;
HAOCHEN:=(((HIGH + LOW) + CLOSE) / 3);
HC1:=IF((HIGH = LOW),1,(HIGH - MAX(OPEN,CLOSE)));
HC2:=IF((HIGH = LOW),1,(MAX(CLOSE,OPEN) - HAOCHEN));
HC3:=IF((HIGH = LOW),1,(MIN(OPEN,CLOSE) - LOW));
HC4:=IF((HIGH = LOW),1,(HAOCHEN - MIN(CLOSE,OPEN)));
HC5:=(VOL / IF((HIGH = LOW),4,(HIGH - LOW)));
HC6:=SUM((HC1 * HC5),1);
HC7:=SUM((HC2 * HC5),1);
HC8:=SUM((HC3 * HC5),1);
HC9:=SUM((HC4 * HC5),1);
买进量:=((HC9 + HC8)),COLOR0000FF,LINETHICK0,NODRAW;
卖出量:=(VOL - 买进量),COLORFF0000,LINETHICK0,NODRAW;
买卖量(差):=(买进量 - 卖出量),LINETHICK0,COLORFFFFFF,NODRAW;
日差占流通盘比:买卖量(差)/CAPITAL*100,COLOR0099FF,POINTDOT;
VOLUME:VOL,VOLSTICK;
MA5:MA(VOLUME,M1),COLORWHITE ;
MA10:MA(VOLUME,M2),COLORYELLOW ;
MA20:MA(VOLUME,M3),COLOR00FF00;


AHC2:=(HIGH - LOW);
AHC3:=ABS((OPEN - CLOSE));
AHC4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
AHC5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
AHC6:=((AHC3 / AHC2) * VOL);
AHC7:=((AHC4 / AHC2) * VOL);
AHC8:=((AHC5 / AHC2) * VOL);
AHC9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
AHCA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
AHCB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
AHCC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
相对地量:STICKLINE(((AHC9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,5,0),,COLOR00FFFF;
地量:DRAWTEXT(((AHC9 > 2) AND (VOL < (MA(VOL,5) / 2))),VOL,'地量'),COLOR00FFFF;
放量:STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0),,COLORFFFFFF;
高出:DRAWTEXT(((((((((AHC7 > AHC6) AND (AHCA > 2)) AND (AHC7 > AHC8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (AHC7 >= MA(VOL,5))),VOL,'高出'),COLOR00FF00;
低进:DRAWTEXT(((((((AHC8 > AHC6) AND (AHC8 > AHC7)) AND (AHCA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (AHC8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'低进'),COLORFF00FF;
强势参与:DRAWTEXT((((((AHC6 > (MA(VOL,5) * 2)) AND (AHC6 >= AHC7)) AND (AHC6 >= AHC8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND AHCB)),VOL,'参与'),,COLOR00FF00;
空头释放:DRAWTEXT(((((((AHC6 >= AHC7) AND (AHC6 >= AHC8)) AND (CLOSE < OPEN)) AND ((AHC6 / VOL) > 0.7)) AND AHCC) AND (AHC6 > MA(VOL,5))),(AHC6 * 1),'空头释放'),,COLOR00FF00;


筹码超跌    副      未来

VARAA:=AMOUNT/(100*VOL);
CYC13:=MA(VARAA,13);
CYC34:=MA(VARAA,34);
CYCMAX:=DMA(C,VOL/CAPITAL);
CYS13:=(C-CYC13)/CYC13*100;
CYS34:=(C-CYC34)/CYC34*100;
CYSMAX:=(C-CYCMAX)/CYCMAX*100;
亏损程度:
IF(CYS13<=-7,7,0),COLORWHITE,STICK,LINETHICK3;
IF(CYS13<=-10,10,0),COLORFFFF33,STICK,LINETHICK3;
IF(CYS13<=-16,16,0),COLORBLUE,STICK,LINETHICK3;
IF(CYS13<=-20,20,0),COLOR00FF77,STICK,LINETHICK3;
IF(CYS13<=-25,25,0),COLORYELLOW,STICK,LINETHICK3;
IF(CYS13<=-30,30,0),COLORFF00FF,STICK,LINETHICK3;
VAR1:=COST(10)*0;
VAR2:=REF(HIGH,1)*1.1;
VAR3:=HIGH*1.1;
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9;
VAR6:=LOW*0.9;
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);
VAR9:=EMA(VAR4,30);
VARA:=VAR9-2;
VARB:=IF(CLOSE<=VAR8,VARA,VAR9);
超跌: VARB*2.5,COLOR00FF00;
TAO:=100*(1-WINNER(C));
A:=1.1*C;
B:=0.9*C;
ASR:=100*(WINNER(A)-WINNER(B));
筹码超跌:IF((ASR<10) AND (TAO>90),30,0),COLOR0099FF;
短中长线超跌:IF((CYS13<(-16)) AND (CYS13>(-100)) AND (CYS34<(-20)) AND (CYS34>(-100)),40,0),COLOR00FF00;
IF((CYS34<(-20)) AND (CYS34>(-100)) AND (CYSMAX<(-30)) AND (CYSMAX>(-100)),50,0),COLORFFCC00;
反弹:VARA*2.5,COLORFF00FF;
风:IF(超跌=反弹 AND CYS13<=-10 AND 筹码超跌=30,-30,0),COLORYELLOW,STICK,LINETHICK3;
云:IF(超跌=反弹 AND CYS13<=-16 AND 筹码超跌=30 AND 短中长线超跌=40,-20,0),COLORRED,STICK,LINETHICK3;
庄筹线         副     未来


庄筹线:EMA(WINNER(C)*70,5), COLORRED ,LINETHICK2;
散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.91))*80,3), COLORGREEN ,LINETHICK2;
KS13:=(C-SMA(C,13,1))/SMA(C,13,1)*(-100);
AAA:=REF(KS13,1)>13 AND REF(KS13,1)/KS13>1.23 AND C/REF(C,1)>1.03;
海底活鱼:IF(AAA AND REF(C,1)STICKLINE(庄筹线>散筹线,庄筹线-1,散筹线+1,1,0), COLOR00FFFF;
海底捞活鱼:=CROSS(5,庄筹线) AND 散筹线< 20;
AA1:=REF(庄筹线,30)> 40 OR REF(庄筹线,20)> 40;
BB1:=CROSS(28,庄筹线) AND 散筹线> 40 AND AA1=1;
CC:=REF(散筹线,1)> 散筹线 AND REF(庄筹线,1)< 庄筹线 AND 庄筹线> 30 AND 散筹线> 30 AND REF(庄筹线,1)-REF(庄筹线,2)> 3.535;
DD:=COUNT(REF(散筹线,1)> REF(庄筹线,1),5);
鸡雀升天:=CROSS(庄筹线,散筹线) AND CC=1 AND DD>=5;


筹码突破     副      未来

 

主筹估算:EMA(WINNER(C)*70,3),LINETHICK2,COLORRED;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),COLOR009900;
筹码锁定:散筹估算-主筹估算,COLORFFBB00;
动态底部:EMA(IF(L<= LLV(L,99),SMA(ABS(L-REF(L,1)),99,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3),COLORYELLOW;
涨:CROSS(主筹估算,筹码锁定),COLORFFBB00;
强:CROSS(主筹估算,散筹估算),COLORFFBBCC;

IF(0,动态底部,动态底部>0),COLOR888888;
主筹估算,LINETHICK2,COLORRED;

STICKLINE(涨,0,筹码锁定,2,0),COLORWHITE;
STICKLINE(强,0,散筹估算,2,0),COLORYELLOW;
庄见哭优化       副     未来


庄筹估算:WINNER(C)*100,COLORMAGENTA,LINETHICK2;
散筹估算:(WINNER(C*1.1)-WINNER(C*0.9))*100,COLORGREEN,LINETHICK2;
CC:=FILTER( (CROSS(5,庄筹估算) AND 散筹估算<20 )*60,10 );
抄底:CC,COLORYELLOW;
DRAWTEXT(CC ,11 ,'抄底' ) ,COLORYELLOW;
AA:= REF(庄筹估算,30)>40 OR REF(庄筹估算,20)>40;
BB:=CROSS(28,庄筹估算) AND 散筹估算>40 AND AA=1};
洗盘:IF(BB ,30 ,60 ) ,COLORCYAN;
DRAWTEXT(FILTER(BB,4) ,66 ,'洗盘' ) ,COLORCYAN;
DRAWTEXT(庄筹估算>60,58,'★'),COLORRED;
STICKLINE(庄筹估算<散筹估算 AND 散筹估算<60,散筹估算,55,1,0),COLORGREEN;
STICKLINE(庄筹估算>散筹估算,散筹估算,50,1,0),COLORRED;
STICKLINE(庄筹估算<散筹估算,庄筹估算,0,0,0),COLORYELLOW;
筹码雷达     副     未来


获利筹码:EMA(WINNER(C)*70,5),ColorD98EF1;
亏损筹码:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5),ColorF3FF00;
stickline(获利筹码<亏损筹码 and 亏损筹码<60,亏损筹码,55,1,0),ColorF3FF00;
stickline(获利筹码>亏损筹码,亏损筹码,50,1,0),colorred;
主力控筹:If(获利筹码>亏损筹码,获利筹码, 0),POINTDOT,colorred;
stickline(获利筹码<亏损筹码,获利筹码,0,0,0),ColorD98EF1;
AI:=AMOUNT/VOL/100;
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
DSY:=100*vol/CApitAl;
抄底:If((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,10, 0),Color00FF00;
灾区:stickline(获利筹码<10,亏损筹码,亏损筹码+5,2,0),POINTDOT,ColorFF009D;
重灾区:stickline(获利筹码<5,亏损筹码,亏损筹码+8,2,0),POINTDOT,Color970000;
stickline(抄底,0,30,4,0),Color00FF00;
0,ColorFFFFFF;
超级资金流分析       副      未来
{N(21,0,100);}
散户套牢:(100 * (1 - WINNER(CLOSE))),COLOR00FFFF;
STICKLINE((CLOSE > 1),散户套牢,0,0,0),COLORFFFFFF;
KDCM:=(100 * WINNER(CLOSE));
主力控盘:KDCM,STICK,COLORFF0000;
STICKLINE((CLOSE > 1),KDCM,0,3,1),LINETHICK2,COLORAA0033;
STICKLINE((CLOSE > 1),KDCM,0,2,0),,COLOR330000;
STICKLINE((CLOSE > 1),KDCM,0,1,0),COLOR440011;
{STICKLINE((CLOSE > 1),KDCM,0,5,0),COLOR550022;
STICKLINE((CLOSE > 1),KDCM,0,4,0),COLOR660033;
STICKLINE((CLOSE > 1),KDCM,0,3,0),COLOR770044;
STICKLINE((CLOSE > 1),KDCM,0,2,0),COLOR880055;
STICKLINE((CLOSE > 1),KDCM,0,1,0),COLOR990066;}
DDCM:=EMA((100 * WINNER(CLOSE)),13);
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,3,1),LINETHICK2,COLORAA0033;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,2,0),COLOR0000FF;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,1,0),COLOR0011FF;
{STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,5,0),COLOR22FFFF;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,4,0),COLOR33FFFF;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,3,0),COLOR44FFFF;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,2,0),COLOR55FFFF;
STICKLINE(((CLOSE > 1) AND (DDCM < KDCM)),KDCM,DDCM,1,0),COLOR66FFFF;}
DRAWICON((KDCM < 2),0,10);
获利平均值:=MA(COST(99),5);
获利99:=MA(COST(80),5);
获利80:=MA(CLOSE,5);
均线5日:=MA(COST(20),5);
获利20:=MA(COST(1),5);
获利1:=(((获利平均值 - 获利99) / 获利99) * 100);
A1:=(((获利99 - 均线5日) / 均线5日) * 100);
A2:=(((均线5日 - 获利20) / 获利20) * 100);
AA3:=IF((A1 < 10),100,0);
A4:=IF((A1 < 15),50,0);
A5:=IF((A1 < 20),25,0);
密集度:A1,COLORAA00AA;
高密集:AA3,COLORFF9900;
中密集:A4,COLORFFCC00;
低密集:A5,COLORFFFF00;
A6:=HHV(KDCM,N);
乖离:EMA(((100 + KDCM) - A6),3),COLOR0000FF;
成本乖离:(((CLOSE / COST(50)) - 1) * 100);
全盘穿越     副     未来


套牢盘:100*(1-WINNER(C)),COLORGREEN;
VR1:=BARSLAST(CROSS(90,套牢盘));
穿越天数:VR1,,LINETHICK0;
DRAWICON(CROSS(10,套牢盘),6,12),;
A1:=SUM(VOL,13)/CAPITAL;
CYF:100-(100/(1+A1)),COLORRED,LINETHICK2;
A2:=AMOUNT/(100*VOL);
中线成本均线:=MA(A2,13);
CYS:100*(C-中线成本均线)/中线成本均线+50,COLORYELLOW,;
STICKLINE(CYS>50,50,CYS,4,0),COLORYELLOW,;
STICKLINE(CYS<50,50,CYS,4,0),COLORF0F000,;
10,COLORCCFF66;
20,COLORWHITE;
90,COLORCCFF66;
{旺狗出击 选股公式}

旺狗出击:cross(c,MA(CLOSE,55) + 2*STD(CLOSE,55)) and c>o 
and vol>1.6*ref(vol,1) and vol>=2*ma(vol,60) and
EMA(WINNER(C)*70,3)>EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3)
and vol>=1.6*ma(vol,5) ;
{陈元元(精品) TDX}

持仓线:MA(HIGH,21);
空仓线:MA(LOW,21);
操盘趋势:MA(CLOSE,3);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,60);
MACD:=2*(DIFF-DEA);
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
BBI: (MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

STICKLINE( C>=O,O ,O+(C-O)*1.0,4 ,0 ),COLOR0000ff;
STICKLINE( C>=O,O ,O+(C-O)*0.65,4 ,0 ),COLOR0099ff;
STICKLINE( C>=O,O ,O+(C-O)*0.25,4 ,0 ),COLOR00ccff;
STICKLINE( CSTICKLINE( CSTICKLINE( C

STICKLINE(MA(C,5)>=MA(C,60) AND MA(C,60)>=MA(C,10),MA(C,10),MA(C,60),4,0),colorblue;
STICKLINE(MA(C,5)>=MA(C,10) AND MA(C,5)<=MA(C,60),MA(C,10),MA(C,5),4,0),colorblue;
STICKLINE(MA(C,20)>=MA(C,60) AND MA(C,60)>=MA(C,40),MA(C,40),MA(C,60),4,0),colorff00ff;
STICKLINE(MA(C,20)>=MA(C,40) AND MA(C,20)STICKLINE(MA(C,5)>=MA(C,20) AND MA(C,20)>=MA(C,10),MA(C,10),MA(C,20),4,0),colorgreen;
STICKLINE(MA(C,5)>=MA(C,10) AND MA(C,5)


庄家操盘...常用的隐秘手法---《对敲》(识破庄家技俩)


庄家对敲主要是利用成交量制造有利于庄家的股票价位,吸引散户跟进或卖出.庄家经常在建仓、 震仓、拉高、出货,反弹行情中运用对敲,其实庄家对敲的方式主要有以下几种:
  
      第一      建仓,通过对敲的手法来打压股票价格,以便在低价位买到更多更便宜的筹码。
      在个股的K线图上表现为股票处于低位时,股价往往以小阴小阳沿10日线持续上扬,这说明有庄家在拉高建仓,然后出现成交量放大并且股价连续的阴线下跌,而股价下跌就是庄家利用大手笔对敲来打压股价。
      这期间K线图的主要特征是:股票价格基本是处于低位横盘(也有拉涨停的),但成交量却明显增加,从盘口看股票下跌时的每笔成交量明显大于上涨或者横盘时的每笔成交量, 这时的每笔成交会维持在相对较高的水平(因为在低位进行对敲散户尚未大举跟进),另外,在低位时庄家更多的运用夹板的手法,既上下都有大的买卖单,中间相差几分钱,同时不断有小买单吃货,其目的就是让股民觉得该股抛压沉重上涨乏力,而抛出手中股票, 把握升浪起点。

  第二      拉升,利用对敲的手法来大幅度拉抬股价。
      庄家利用较大的手笔大量对敲, 制造该股票被市场看好的假象,提升股民的期望值,减少日后该股票在高位盘整时的抛盘压力(散户跟他抢着出货)。
      这个时期散户投资者往往有买不到的感觉,需要高报许多价位才能成交,从盘口看小手笔的买单往往不容易成交,而每笔成交量明显有节奏放大,强势股的买卖盘均有3位数以上, 股价上涨很轻快,不会有向下掉的感觉,下边的买盘跟进很快, 这时的每笔成交会有所减少(因为对敲拉抬股价,不可能象吸筹时再投入更多资金, 加上散户跟风者众多,所以虽出现"价量齐升",但"每笔成交"会有所减少)。

  第三      震仓、洗盘,因为跟风盘获利比较丰厚,庄家一般会采用大幅度对敲震仓的手法使一些不够坚定的投资者出局。
     从盘口看在盘中震荡时,高点和低点的成交量明显放大,这是庄家为了控制股价涨跌幅度而用相当大的对敲手笔控制股票价格造成的。

  第四      对敲拉高,当经过高位的对敲震仓之后, 股评家也都长线看好,股价再次以巨量上攻,这时庄家开始出货。
      从盘口看往往是盘面上出现的卖二,卖三上成交的较大手笔,而我们并没有看到卖二,卖三上有非常大的卖单,而成交之后,原来买一或者是买二甚至是买三上的买单已经不见了,或者减小了,这往往是庄家运用比较微妙的时间差报单的方法对一些经验不足的投资者布下的陷阱, 散户吃进的往往是庄家事先挂好的卖单,而接庄家卖出的往往是跟风的散户。

  第五      反弹对敲,庄稼出货之后, 股票价格下跌,许多跟风买进的中小散户已经套牢, 成交量明显萎缩。
      庄家会找机会用较大的手笔连续对敲拉抬股价(这时庄家不会向以前那样卖力了), 较大的买卖盘总是突然出现又突然消失,因为庄家此时对敲拉抬的目的只是适当的拉高股价,以便能够把手中最后的筹码也卖个好价钱。

 

 

 

 

 

 

主力对敲手法大揭秘

  对敲主要是为了制造无中生有的成交量以及利用成交量制造有利于庄家的股票价位。庄家操盘常用对敲,过去一般是为了吸引散户跟进,而现在则变成了一种常用的操盘手法,建仓时对敲、震仓时对敲、拉高时对敲、出

货时对敲、做反弹行情仍然运用对敲。虽然对敲的方式有很多,但归结起来无外乎有以下几种:

  敲山震虎为建仓

  以压制股票价格为目的,在建仓时积极对敲,庄家是为了能够在低价位搜集到更多的筹码,往往通过对敲的手法来压制股票价格。在个股的?线图上表现为股票处于较低的价位时,股价往往以小阴小阳的形态持续上扬,这说明有较大的买家在积极吸纳。之后,出现成交量较大的并且较长的阴线回调,而阴线往往是由于庄家大手笔对敲打压股价形成的。从较长的时间上看,这期间股票价格基本是处于低位横向盘整,但是成交量却在悄悄地放大。这时候盘面表现的特点是股票下跌时,单笔成交量明显大于上涨或者横盘时的单笔成交量。如果能够在这个时候识别出庄家的对敲建仓,投资者就可以踏踏实实买一个地板价,比如近期的山东临工(600162),5月18日该股5852万职工股上市,而从5月10日以来该股成交量异常放大,很明显有主力运作迹象,5月17日主力利用大手笔冲高回落对敲,是一个典型的筹码收集手法。

  旱地拔葱拉股价

  以大幅度拉抬股价为目的对敲,一般是庄家在基本完成建仓过程之后的常用手法。在庄家基本完成建仓过程之后,股票价格往往会以很快的速度上扬,以巨量长阳甚至是以跳空缺口来突破层层阻力,往往以较大的手笔大量对敲,制造该股票被市场看好,大买家纷纷抢盘的假象,提升其他持股者的期望值,减少日后该股票在高位盘整时的抛盘压力,使筹码锁定更牢,股价能够比较轻松地拉抬起来。在这个时期,一般散户投资者往往有追不上股价的感觉,往往看准了价格,下了买单股价却飘起来了,似乎不高报许多价位就几乎不能成交。这时候盘面特点表现为小手笔的买单往往不易成交,而单笔成交量明显放大并且比较有节奏。其实如果您能够在这个时候果断一些,仍然会得到比较便宜的股票。

  雷鸣电闪为震仓

  当股票价格被拉抬到较高的位置之后,外围跟风盘的获利已经比较丰厚。庄家随时有可能在继续拉抬过程中兑现出局。为了减少进一步拉抬股价的压力,庄家采用大幅度对敲震仓的手法,使一些不够坚定的投资者出局。这期间的盘面特点是在盘中震荡时,高点和低点的成交量明显放大,这是庄家为了控制股价涨跌幅度而用相当大的对敲手笔控制股票价格造成的。如近期走势十分强劲的工益股份(600804)在今年5月28日的大幅下挫就是十分明显的对敲震仓行为。

  对倒拉高最疯狂

  当经过高位的对敲震仓之后,某只股票的利好消息会及时以多种多样的方式传播,股评分析也都长线看好。股价再次以巨量上攻,其实这已经是庄家开始出货的时候了,如果你能够看到盘面上显示的数据,您可能会发现这样一种现象——往往是盘面上出现的卖二甚至是卖三上成交的较大手笔,而您并没有看到卖二或者是卖三上有大的卖单,而成交之后,原来买一或者是买二甚至是买三上的买单已经不见了,或者减小了。这往往是庄家运用比较微妙的时间差报单的方法,对一些经验不足的投资者布下的陷阱,也就是我们常听说的所谓“吃上家喂下家”,吃的往往是庄家事先挂好的卖单,而喂的往往是跟风的买家。

  梅开二度再对敲

  经过一段时间的出货之后,股票的价格有了一定的下跌幅度,许多跟风买进的中小散户已经纷纷套牢,抛盘开始减轻,成交量明显萎缩。这时,庄家往往会不失时机的找机会,以较大的手笔连续对敲拉抬股价,但是这时的庄家已经不会再向以前那样卖力,较大的买卖盘总是突然出现又突然消失,因为庄家此时对敲拉抬的目的只是适当的拉高股价,以便能够把手中最后的筹码也卖个好价钱。

  对投资者而言,观察对敲盘需要耐心的长时间连续观察,结合大盘情况和个股的价位以及消息面等等情况综合分析,一旦会观察和把握对敲盘,就好像是掌握了庄家的脉搏。只要您有足够的耐心,就等着庄家给您送钱吧.


主力对敲行为分析


迅雷不及掩耳盗铃

我们在看盘的过程中,主力经常进行一些成交上的对敲行为。主力为什么要对敲?这其实是一个很有意思的问题。其实主力进行对敲行为就是让散户看的,他的目的性非常强。再说明白点就是,让散户习惯,搞不懂主力的方向,利于日后的出货。我们分股票的几个阶段来分析对敲的含义。
一、 盘底阶段
这时的对敲行为是突然性的比较多,而且时间间隔上稍长,对敲的次数较少。此时多为主力的试盘行为,而且对敲的价位往往成为全天的最高点或最低点。我们此时关注他们是没有意义的,从K线图上,基本上是长影线较多了起来。

二、 第一次收集拉升
此时的对敲慢慢多了起来,特点是早盘和中盘---买少,卖多,尾盘买多,卖少。主力采用基本是一种恐吓行为,欺诈散户,而且分时图中,高低错落,没有明确的方向感。但逐步盘上的的动力较足,即使主力经常出现大的抛单,实际是自己吃了,也没有阻碍上升的步伐。而且主力不愿在底部过多的停留,基本是快速突破,不给散户机会。

三、 欢迎散户参与阶段---调整的阶段
初次拉升收集以后,主力让散户参与了,实际也是即将面临调整洗盘的开始。这时的对敲尤为精彩,操盘手的对敲手段丰富多样。主要有一直往下做,这种居多。这是一种非常具有破坏性的对敲,主力实现埋单后,大单往下砸,散户没有反应过来是,参与的利润已经被吃掉,然后稍微放一放散户,利于主力吃单后,继续向下做,让坚定的持有者也产生了怀疑。一直到主力认可的点位以后才会停止,这时没有什么关键点,只要散户不出来,主力就会一直做下去。做低后,往往伴随的突然拉升,也是令人措手不及的。巨大的反差成了此时的主要行情。

四、 出货的拉升
这个阶段是,主力开盘就拉升,不给机会,对敲没有了,明睁眼露的告诉你,主力就是要拉升,不过拉升的出现多在开盘不久,然后慢慢跌,至尾盘又开始拉。或者经常尾盘拉,次日早盘跌。很少进行盘中拉升的。主力运用时间差多了起来,而主力对敲则成了卖多,买少,成交量一直放大。其实拉升已经成为骗局,出货成为主基调。

五、 盘头,下跌阶段
成交量已经不和升幅相匹配,对敲的手段基本是诱多行为,小单快拉,大单砸给跟风的。到主力利润完成后,对敲没了,只有赤裸裸的往下仍,更多是没人买时,主力撤单或小攻一下,跟风一足,出货为主。

巧识主力对敲


主力对敲的手法通常有两种,最常用的手法是使用两条交易跑道,同时对某一只股票发出买卖指令,价位与数量大致相同,这时庄家不预先挂单, 因此有时大家在盯盘中会发现委托盘中的买、卖单都很小,成交量中却突然冒出大笔成交。另一种手法就是主力事先在委托盘中挂出一笔大的买单或卖单,然后一路打下去或买上来,迅速吃掉预埋的委托单,从而造成虚假的成交量。
由于许多投资者经常是孤立的、静止的看待成交量,即只注重当日的成交量与价位,主力就投其所好,大量的利用对敲制造骗局和骗线。又由于对敲与普通的大手成交具有相同的形式,比较容易隐蔽,难以辨别,因此给投资者造成不少麻烦。我们认为,研判主力对敲主要应该从成交量的放大情况以及价量配合的情况入手,主力对敲最直接的表现就是成交量的增加,但是由于掺杂了人为操纵的因素在里面,这种放量会很不自然,前后缺乏连贯性;在价量配合上也容易脱节,具体实践中,我们可以留意从以下几个方面分析:
1.从每笔成交量上看,单笔成交数较大,经常为整数,例如100手、500手,买盘和卖盘的手数较接近,出现这样的情况,通常买卖方都是同一人,亦即是对敲行为。
2.在邻近的买卖价位上并没有大笔的挂单,但盘中突然出现大笔成交,此一般为主力的对敲盘。
3.股价无故大幅波动,但随即又恢复正常,如股价被一笔大买单推高几毛钱,但马上被打回原形,K线图上留下较长的长影线,这种情况多为主力对敲。
4.股价突破放量上攻,其间几乎没有回档,股价一路攀升,拉出一条斜线。这明显有人为控制的痕迹,往往为主力对敲推高股价,待机出货。
5.实时盘中成交量一直不活跃,突然出现大手笔成交,这种成交可能只有一笔或连续的几笔,但随后成交量又回到原先不活跃的状态,这种突破性的孤零零的大手成交量是主力的对敲行为。
6.当卖一、卖二、卖三挂单较小,随后有大笔的买单将它们全部扫清,但买单的量过大,有杀鸡用牛刀之感,且股价未出现较大的升幅。这种上涨状态的大手成交是主力的对敲。
7.当股价出现急跌,大笔成交连续出现有排山倒海之势,往往是主力为洗盘故意制造恐怖气氛。
8.股票刚启动上攻行情不久,涨幅不大,当天突破以大笔的成交量放量低开,且跌幅较大,此为主力对敲洗盘行为。
9.整日盘中呈弱势震荡走势,买卖盘各级挂单都较小,尾盘时突破连续大手成交拉升,这是主力在控制收市价格,为明天做盘的典型对敲行为。
10.上一交易日成交并不活跃的股票,当天突破以大笔的成交放量高开,此为主力为了控制开盘价格的对敲行为。


主力对敲诱多盘面特点(转)

首先,盘面显示主动抛单较多,空方力量明显强于多方;
   价量关系不理想,下跌放量,盘中反弹却缩量;
   股价下跌时抛盘如过江之鲫,要多少有多少。但每下跌一段之后,下面就会出现强大的承接盘,令人感觉主力在护盘,像盾牌一样让股价无法继续下穿,多头强大,诱使投资者去买委卖盘的货,使得股价在此位又横盘一段时间,等人心趋稳之后,又是一波下跌,然后再用强大的被动性买盘维持股价,以稳定投资者信心。
   盘中显示,一方面是买盘十分强大,另一方面却是股价在不断下跌,主力究竟是想护盘还是想掩护出货,这是研盘的疑难点。
   如果主力想要护盘,为什么要在股价急跌一段之后才挂出强大的接盘,如此强大的买盘为什么总是在下面被动地承接而不是主动出击甚至上攻。
   如果主力想要护盘,为什么一旦成交趋稳,接盘大单会立即撤得无影无踪,然后紧跟着又是一波下跌,大单接盘似乎只是稳定人心。
   股价在下跌的过程中,虽然下方有强大的接盘层层设防,但为什么股价重心仍在不断下移。实际上这是主力使用的对倒放量出货手法。
   表面上看,主力好象在护盘。实际是在出货。边打边撤,用强大的接盘暂时维持住股价,引诱投资者去买委买盘的货,先被动做多,然后撤掉下面的大笔接单,反手主动做空。
   从盘中当日K线图的技术指标中可清楚地看出股价需要调整,只是由于主力的诱多手法使得多数投资者忽视了盘面的假象,给主力造成了撤退的机会。

 

 

 

如何从盘口看懂主力的操盘手法
    对一个职业投资者而言,看盘水平的高低会直接影响其操作效果,即使是中线投资者也不能忽视其存在价值(如果中线投资者在较高位介入,却不懂利用高抛低吸降低成本,即使获利,也不能称其为合格的职业投资者。
    透过盘中的股指及个股走势,研判出多空双方力量的强弱,决定了其对股票的炒作节奏的把握,也是其是否盈利或盈利高低的关键。职业投资者区别于学院派的最大区别在于他们往往能从变化莫测的股市中的细微之处,见微知著,洞烛先机。而他们之所以能看出盘中诸多变化所传递的信息,主要是一种经验的积累,这种积累往往是通过多年对其自身操作失败经历的反复总结而得,但现在许多投资者入市多年也是散户(不论其资金量多大),即是其不善于总结之故。因此,看盘水平成功衡量一个职业投资者水平的重要依据。
    看盘主要应着眼于股指及个股的未来趋向的判断,大盘的研判一般从以下三方面来考量:
    一、股指与个股方面选择的研判(观察股指与大部分个股运行趋向是否一致)。
    二、盘面股指(走弱或走强)的背后隐性信息。
    三、掌握市场节奏,高抛低吸,降低持仓成本,(这一点尤为重要),本文主要对个股研判进行探讨。
    盘中个股走势是一天的交投产生的形态,能够清晰地反映当日投资者交易价格与数量,体现投资者买卖意愿,为了能更好的把握股价运行的方向,我们必须要看懂盘中走势,并结合其他因素做出综合判断,一般理解,看盘需要关注开盘,收盘,盘中走势,挂单价格,挂单数量,成交价格,成交数量与交投时间等,但这只是传统认知,其他因素在下文中详细探讨。
    挂单
    投资者进行短线交易时,常常进行盘口分析,而一般的交易系统软件可提供的及时图表是公布三档买卖盘的交易情况,即买一、买二、买三和卖一、卖二、卖三。这种买卖盘挂单交易往往是庄家的"表决心"的窗口,但由于目前数据传输质量和分析软件的缺陷,使投资者难以看到真实的交易情况,加之主力利用此种缺陷频频做出盘中骗线,使投资者产生错误交易行为。笔者将自己多年对盘口买卖单观察时的记录及理解写下,希望对投资者朋友有所帮助。
    总论:挂单真正的含义是---主流资金的当日运作布局:主流资金当日控制即时股价波动区域的窗口。波动区域注意理解其真正的含义,如:主流资金在什么价位挂出大单,上压下托的位置。关注焦点是:到达此价位,是否有主动性买卖盘的出现。一定要关注此时关键位置的即时买卖盘以及成交重心,它充分体现了主流资金的控制意图“放弃操作”与“坚决操作”。如大盘不好个股挂单被瞬间击破,要看是大额抛单还是散户的小额抛单以及股价下落的幅度、速度,其后能否瞬间收回,缩、放量能是否真实。分析即时当天主流资金的挂单布局意图--吸洗拉出:结合股价日K线图表的相对位置{高,低}来研判,细节下面将仔细展开。
    (一)单向整数抛单转买单的意义
    1、单向连续出现整数(多为100手,视流通盘大小而定)抛单,而挂单持续的较小(多为单手)且并不因此成交量出现大幅的改变,此种盘面一般多为主力在隐蔽式对敲所致,尤其在大盘成交稀少时极为明显,此时应是处于吸货末期,进行最后打压吸货之时(当然应结合股票的整体趋势来判断)。
    例如:2003年年初红河光明(600239),在低位(6.50元--6.85元左右)曾经持续突然出现100手连续抛单,且每隔几日便突然出现,而成交却并不活跃,换手率仍处在1.30%--0.3%之间,翻开该股的月线图表,可清楚地看到该股自2001年12月04日见到中期大顶之后,一路下行,连续阴跌13个月之久,与大盘的跌幅进行比较,该股跌幅超过43%以上,周线日线技术图表也表明该股处于历史低价区域,十大股东中广东证券持有1344857股而几名个人股东杜才信持有481286股、顾庆其持有360000股、尹秀芳持有316378股,其中广东证券有限公司是公司
    2001年配股的主承销商,通过"余额包销"的方式,成为了公司前十名股东之一,再加上日线图中经常出现上下影线,可初步判断有资金被套,在如此低的价位,此种表现,可判断为其主力正在小仓位吸货,后续在技术面配合下,出现短线拉升。
    2、单向连续出现整数(多为100手,视流通盘大小而定)买单,而挂盘并无明显变化,交易全为主力对倒所致,此时理解,一般多为主力拉升初期的试盘动作或派发初期激活追涨跟风盘的启动盘口。
    如近期鲁能泰山(000720)及2001年12月04日的中兴商业(000715)在短线躁动后持续杀跌跌幅超过50%,以中兴商业(000715)为例,该股运行较为典型,该股上市以来,一直在5.89元--14.23元的大型箱体中运行,究其原因,可能是基本面欠佳之故,但从2001年6月24日大盘见顶以来,该股出现强势横盘状态,盘中震荡幅度开始加大,但一到技术的关键位置,便有人为调控的痕迹,控盘庄股中经常出现的长上下影线的K线图形开始越来越多,在2001年09月21日该股突然出现大幅打压18天后该股震荡盘出上升通道,换手率也保持在3%以下,盘中筹码锁定较好,股价运行至2001年11月27日时,已经距历史高点14.23元只有一步之遥,盘中分时上窜下跳,在2001年12月04日09点52分,一笔416手的大单打开局面,其后在卖一上挂出500手左右的卖单,注意,此时的抛单并不一定是主力在抛空,应是庄家自己的筹码,庄家在制造成交量吸引散户注意,随着买单的汹涌而出,卖单也不断加大,在900多手卖单被吃掉后,盘中主力被激怒在此日竟在卖一上压出1600多手卖单,无论买盘多大,仍让其保持至收盘,笔者就是在盘中介入的,第三日,连续携量突破,第四日创出14.22元近五年的高点,但盘中抛盘如注,在下跌时成交持续放大,笔者在获利10%左右将股票抛出,但其后的走势也出乎笔者意料,该股从14.22元一口气跌至6.93元,笔者回想起来仍心有余悸。
    (二)无征兆的大单解读
    一般无征兆的大单多为主力对股价现有运行状态实施干预所致,如果是出现连续大单的个股,现行运作状态有可能被改变。如出现不连续的情况也不排除是资金量较大的个人大户或小机构所为,其研判实际意义不大。
    1、股价处于低位(复权后),买单盘口中出现层层较大买单(多为100手,视流通盘大小而定),而卖单盘口只有零星小单,但突然盘中不时出现大单炸掉下方买单,然后又快速扫光上方抛单,此时可理解为吸货震仓,例如2001年年末至2002年初ST厦新(600057)在6.50元--7.50元附近就出现此种情况。
    例如该股卖一在6.58元挂出200手卖单,买一6.60元挂100手买单,然后股价重心出现振荡上移,但始终是在卖一、买一中间相差一分钱,一旦出现6.59元单子便被资金迅速吃掉然后不再向上高挂,以此手法显示上档抛压较为沉重,诱使投资者抛出筹码,以达到迅速建仓的目的。
    2、股价处于高位(复权后),卖单盘口中出现层层较大卖单(多为100手,视流通盘大小而定),而买单盘口只有零星小单,但突然盘中不时出现小单持续吃掉上方大卖单,然后又快速炸掉下方出现较大买单,此时可理解为主力诱多减仓,例如2002年3月末4月初上实发展(600748)在11.60元--13.10元附近就出现此种情况。
    例如该股在卖一12.92元,只有17手小手挂单,买一12.91元有5手小手挂单。成交价为12.92元、成交为331手,而卖一处只减少了14手,显然此次成交是盘中资金对倒行为所致,配合该股出现在高位持续三日换手率达62%,可以判断主力开始大幅对倒减仓,其后该股跌至8.15元,跌幅惊人。
    (三)、买二、买三、卖二、卖三的解读。
    在盘面中不断有大挂单在卖三、卖二处挂出,并且股价价位不断上撤,最后突然出现一笔大买单(至少200手以上)一口吃掉所有挂单,然后股价立刻被打爆,出现短线大幅拉升,此时主力用意有二:一方面显示自己的资金实力,另一方面引诱跟风者持续跟入,减少自己实际资金过多介入控制持仓,利用同向合力形成技术共振,减少拉升压力。例如2003年3月07日的中信证券(600030),该股股价上市以来走出先抑后扬的走势。上市首日,收出中阴线,换手率不足50%,整体定位大大低于市场普遍预期的6元价位;上市次日,股价直接低开,收出小阴线,但换手率更小不足9%,市场惜售情况明显,但从该股60分钟图上看,有资金在当天接近5元价位处暗中吸纳,3月07日盘中走势极为稳健,全天大部分时间股价盘
    稳在均价上方,尾盘前1小时,突然放量连续拔高,在盘面中不断有大挂单在卖三、卖二处挂出,并且股价价位不断上撤,最后突然出现一笔大买单(10497手)一口吃掉所有挂单,然后股价立刻被打爆,短线跟风盘蜂拥而入,收盘前半小时,上封涨停。全日成交7200万股,涨停价位上成交1400万股,涨停封盘量3400万股,仔细观察,并无中线资金介入,此种盘口特征加之后续走势其实全为散户热钱打起的。
    (四)、买卖盘异常
    有时买盘较少,买一、买二、买三处只有10-30几手,在卖单处也只有几十手,却不时出现抛单,而买一却不是明显减少,有时买单反而悄然增加,且价位不断上移,可以肯定主力同时敲进买、卖单对敲。此类股票如蛰伏于低位,可作中线关注,在大盘弱市尤为明显,一般此类主力运作周期较长,且较为有耐心。如湖北车桥(000760)在2002年11月末-12月初时,该股仍处于历史低位区域,盘口观察,其交投不活跃,长时间出现不成交现象,基本是散户单成交,但在11月20日以后盘中开始振幅加大,在买一、买二、买三处只有10-30几手,在卖单处却也只有几十手,却不时出现抛单,而买一却不是明显减少,有时买单反而悄然增加,且价位不断上移,可以肯定该主力同时敲进买、卖单对敲,一方面活跃人气,另一方面清洗意志不坚的跟风者,其后该股走出震荡上扬走势。
    (五)、机会买单解读,
    如200手以上连续向上买单而卖单较少。卖一价格被吃掉后又出现抛单,而买一不见增加反而减少,价位甚至下降,很快出现小手买单将买一补上,但不见大单,反而在买三处有大单挂出,一旦买一被打掉,小单又迅速补上,买三处大单同时撤走,价位下移后,买二成为买一,而现在的买三处又出现大单(数量一般相同或相似)且委比是100%以上,如果此价位是高价位,则可以肯定主力正在出货。小单买进,大单卖出,同时对敲维持买气,如海虹控股(000503)在2003年1月14日--1月16日附近,该股盘中在17.40元--17.60元附近,近日就出现此种情况。买单虽较大,但仍被小单子持续不断的吃掉,如同蚂蚁吃大象一样,价位也在不知不觉中悄然下移,三天内在盘中几次冲高诱多后,股价跌至14元。
    (六)、交易单手数的解读
    通过长期盯盘,发现盘中主力市场通过买卖单的数量来传达信息,例如在2001年初,某生物制药股在22.80元处,股价震荡盘升,成交较为温和,主力初步完成控盘,在2000年11月29日9:51点盘中突然出现111手成交单,股价迅速上扬,股价持续强势,笔者在观察了一月之后,在12月29日10点发现,该股形成周线创新高后大型收敛形态之后,盘中突然出现111手单,便果断介入,短线获利不菲。一般主力常选择110、111,112、113、114、118、119等交易单进行操盘,原因是单子过大,容易引起市场注意,单子太小容易产生合并,百手单恰到好处。但由于证券市场的长庄模式开始没落,也许主力将改变手法,在使用时应谨慎分析,以免本末倒置。


有同学要求发骚牛公式,源码如下:
VAR1:=2*EMA(LLV(CLOSE,7),10)-CLOSE;
公牛: (-1)*SMA(3*VAR1-2*SMA(VAR1,10,1),3,1), , COLORBLUE;
母牛: (-1)*MA(3*CLOSE-2*SMA(CLOSE,2,1),12), , COLORRED;
VAR2:=(HIGH+LOW+OPEN+CLOSE)/4;
VAR3:=2*EMA(LLV(VAR2,7),10)-VAR2;
VAR4:=3*VAR3-2*SMA(VAR3,10,1);
VAR5:=MA(3*VAR2-2*SMA(VAR2,2,1),12);
VAR6:=IF(VAR4=0.8,1,0);
VAR7:=SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1);
VAR8:=3*VAR7-2*SMA(VAR7,3,1);
VAR9:=SMA(VAR8,3,1);
VARA:=EMA(VAR8,3);
VARB:=SMA(SMA(VARA,5,1),3,1);
VARC:=IF(VAR9>VARB AND VAR9<60,1,0);
骚牛: DRAWTEXT(FILTER(VAR6=1 AND VARC=1,25),公牛,'骚牛'), , COLORYELLOW;


是不是这个?专捉涨停板的.
Var2:IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND
CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
Var3:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
Var4:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
Var5:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
Var6:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
Var7:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
Var8:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
Var9:=(Var3+Var4+Var5+Var6+Var7+Var8)/6;
VarA:=EMA(Var9,3);
VarB:=ABS(Var6-Var8);
VarC:=(Var9+VarB)/2;
VarD:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VarE:=VarD+VarC;
VarF:IF(Var2>0 AND VarE<0,200,0);
Var10:IF(VarC<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
Var11:IF(VarE<0 AND Var10=-50,100,0);
Var12:=MA(CLOSE,3);
Var13:=REF(CLOSE,2)*0.865;
Var14:=REF(CLOSE,13)*0.772;
Var15:=MIN(Var13,Var14);
Var16:=100*VOL/CAPITAL;
Var17:=MA(CLOSE,13);
Var18:IF((CLOSE-Var15)/CLOSE<0.03 AND SUM(Var16,5)/5<1.8,1,0);
Var19:IF(Var18>0 AND (Var10<0 OR Var2>0),100,0);
Var1A:=Var19;
Var1B:=IF(VarF>0 AND Var11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VarF>0 AND Var11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var18>0) AND (Var10<0 OR Var2>0) AND Var19<10,50,0);
Var1C:=(VarF>0 AND Var11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var18>0) AND (Var10<0 OR Var2>0);
Var1D:=VarF>0 AND Var11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
Var1E:=Var1C OR Var1D;

{买牛  副图}
庄筹估算:EMA(WINNER(C)*70,3),COLOR0000FF;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),COLOR009900,LINETHICK2;
VA:=散筹估算-庄筹估算;
{动态底部:IF(庄筹估算+散筹估算<15,2*(15-庄筹估算-散筹估算),0),COLOR00FFFF;
筹码锁定:COLORRED,,LINETHICK4;}
筹码锁定:IF(VA>-50,VA,-49),COLORFFBB00,LINETHICK2;
动态底部:EMA(IF(L<= LLV(L,99),SMA(ABS(L-REF(L,1)),99,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3),COLORYELLOW,LINETHICK1;
STICKLINE(动态底部>0,-1.2,动态底部*0.94,8,0),COLORYELLOW;
庄筹估算,LINETHICK2,COLORRED;
A1:=SUM(AMOUNT,3)/SUM(VOL,3)/100;
A2:=SUM(AMOUNT,8)/SUM(VOL,8)/100;
A3:=SUM(AMOUNT,21)/SUM(VOL,21)/100;
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE;
DEA:=EMA(DIFF,9),COLORYELLOW;
白色: SMA(HIGH,21,2)*1.05,COLORWHITE;
黄色: SMA(LOW,21,2)*0.95,COLORYELLOW;
粉色: SMA(LOW,5,1),COLORRED;
绿色: SMA(CLOSE,2,1),COLORGREEN;
DRAWTEXT(CROSS(绿色,粉色),白色*1.0,'波段买牛'),COLORRED;
DRAWTEXT(CROSS(绿色,白色),白色*1.10,'卖头牛'),COLOR66AAFF;


{狂牛启动点}

VAR2:=1;
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(C<=VAR9,VARB,VARA);
VARD:=MA(C,80)-MA(C,10)/17;
准备: STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,MA((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,3)),50,0,5,0);
VORD: DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,MA((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,3)),4),55,'进!');
VARE:=(C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
SOLE: SMA(SMA(VARE,3,1),3,1);
BUY: 3*SMA(VARE,3,1)-2*SOLE;
DRAWICON(CROSS(90,BUY),90,2);
狂牛起点: STICKLINE(SMA(VARE,3,1)>SOLE,SMA(VARE,3,1),SOLE,4,0);

{实战精品:黑牛均线 主图}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42); 
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.2,1);
DRAWICON(SEL,H+0.2,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;

主力:EMA(CLOSE,10),COLORRED;
散户:EMA(CLOSE,5),COLORWHITE;
绿降:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;

LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLOR0000FF;
TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW - 0.6),'跟进'),COLORYELLOW;
DRAWTEXT((B2 = 1),(LOW - 0.6),'加码'),COLORFFAAFF;

{ 青松红牛   主图 含DynaInfo动态数据 }

A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
RCC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
STICKLINE(DK>0,RCC,RCC+DK,0,1),COLORRED;
STICKLINE(DK<0,RCC,RCC+DK,0,1),COLORCYAN;
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
IF(MA(C,3),MA(C,3),DRAWNULL),COLORYELLOW,LINETHICK2;
IF(MA(C,9),MA(C,9),DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MA(C,23.5),MA(C,23.5),DRAWNULL),COLORWHITE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30  AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,'★红牛'),COLORRED;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=LCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=LEE1:=V老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠仓,L*0.99,'老鼠仓'),COLOR0099FF;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'▼逃顶'),COLORYELLOW;

{犀牛  副图含未来WINNER}
VAR1:=MA(AMOUNT/(100*VOL),5);
VAR2:=MA(AMOUNT/(100*VOL),13);
VAR3:=MA(AMOUNT/(100*VOL),34);
VAR4:=DMA(CLOSE,VOL/CAPITAL);
VAR5:=WINNER(CLOSE)*100;
VAR6:=100*VOL/CAPITAL;
ABS(WINNER(CLOSE)-WINNER(OPEN))*70,VOLSTICK;

CYS13A:= (CLOSE-VAR2)/VAR2*100;{ POINTDOT;}
IF(CYS13A<=0,CYS13A,0),STICK,LINETHICK4,COLORGREEN;
IF(CYS13A>0,CYS13A,0),STICK,LINETHICK4,COLORBLUE;
IF(CROSS(CLOSE,VAR3),15.82,0),STICK,LINETHICK4,COLORRED;
IF(CROSS(CLOSE,VAR4),15.82,0),STICK,LINETHICK4,COLORRED;
IF(CROSS(VAR2,VAR4),15.82,0),STICK,LINETHICK4,COLORRED;
IF(VAR5>=90 AND VAR6<3,15.82,CYS13A),STICK,LINETHICK2,COLORWHITE;
CYS13:CYS13A,POINTDOT;

赢富伴侣

VarF:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
Var19:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
Var20:=VarFREF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(Var20 AND COUNT(Var20,30)=1,15,'有大资金进 关注!'),linethick1,COLORff00ff;aa:=WINNER(CLOSE+CLOSE*15/100)*100;
bb:=WINNER(CLOSE+CLOSE*0/100)*100;
cc:=aa-bb;
dd:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
ee:=cc<3 and dd<0.5 and OPEN<>LOW;
a1:=DYNAINFO(6);
a2:=IF(LOW>a1,0,IF(HIGHa3:=VOL/WINNER(LOW);
a4:=REF(HHV(CLOSE,120),1);
a5:=REF(LLV(CLOSE,120),1);
a6:=100*(CLOSE-a5)/(a4-a5);
a7:=a2>0 or a2=1;
a8:=a7 and a3/REF(a3,3)>=3 and a6<80;
a9:=REF(a8,1) or REF(a8,2) or REF(a8,3) or REF(a8,4);
a10:=a8 and a9;
a11:=IF(FILTER(a8,3),5,0);
a12:=IF(FILTER(a10,3) or ee,10,0);
资金进场日:IF(a11,8,0),LINETHICK0;
STICKLINE(a12,0,15,5,0),colorff00ff;
资金加仓日:IF(a12,88,0),LINETHICK0;
STICKLINE(a12,0,15,5,0),colorff00ff;
STICKLINE(a11,0,5,5,0),colorff7700;
STICKLINE(a11,0,5,4.5,0),colorff8800;
STICKLINE(a11,0,5,4,0),colorff9900;
STICKLINE(a11,0,5,3.5,0),colorffaa00;
STICKLINE(a11,0,5,3,0),colorffbb00;
STICKLINE(a11,0,5,2.5,0),colorffcc00;
STICKLINE(a11,0,5,2,0),colorffdd00;
STICKLINE(a11,0,5,1,0),colorffee00;
STICKLINE(a12,0,15,4.5,0),color102099;
STICKLINE(a12,0,15,4,0),color1020aa;
STICKLINE(a12,0,15,3.5,0),color1020bb;
STICKLINE(a12,0,15,3,0),color1020cc;
STICKLINE(a12,0,15,2.5,0),color1020dd;
STICKLINE(a12,0,15,2,0),color1020ee;
STICKLINE(a12,0,15,1,0),color1020ff;
DRAWTEXT(a11,8,'资金进场');
DRAWTEXT(a12,17,'资金加仓');Var1:=(CLOSE*2+HIGH+LOW)/4*10;
Var2:=EMA(Var1,13)-EMA(Var1,34);
Var3:=EMA(Var2,5);
Var4:=2*(Var2-Var3)*5.5;
主力: var4,COLORred,LINETHICK2 ;
0,colorwhite;
Var5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
Var6:=EMA(3*Var5-2*SMA(Var5,18,1),5);
Var7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
Var8:=(INDEXC*2+INDEXH+INDEXL)/4;
Var9:=EMA(Var8,13)-EMA(Var8,34);
VarA:=EMA(Var9,3);
VarB:=(Var9-VarA)/2;
大盘资金: VarB,colorgreen,linethick2;
VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
Var10:=(HIGH+LOW+CLOSE)/3;
Var11:=(Var10-MA(Var10,14))/(0.015*AVEDEV(Var10,14));
Var12:=(Var10-MA(Var10,70))/(0.015*AVEDEV(Var10,70));
Var13:=IF(Var11>=150 AND Var11<200 AND Var12>=150 AND Var12<200,10,0);
Var14:=IF(Var11<=-150 AND Var11>-200 AND Var12<=-150 AND Var12>-200,-10,Var13);
Var15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
Var16:=100-ABS(Var15);
Var17:=IF(Var16<90,Var16,100);
Var1A:=IF(VarE>0,VarE,0);
Var1B:=IF(Var12>=200 AND Var11>=150,15,IF(Var12<=-200 AND Var11<=-150,-15,Var14))+60;
Var1C:=Var1A>48 AND Var1B>60 AND Var17<100;
  DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,15,'大笔出货.缩量(低位)则洗.'),linethick1,COLORffcc66;
t1:= Var20 AND COUNT(Var20,30)=1;
t:=count(a8,30)>=3 and count(a10,30)>=3;
t1  ;

跟一起主力建仓
跟一起主力建仓
VAR2:=SMA(VAR1,4,1);
VAR3:=SMA(VAR2,2,1);
VAR4:=VOL/CAPITAL*34;
VAR5:=REF(VAR4,1);
主力建仓: IF(VAR3<8.5 AND VAR2<11,70,0),COLORYELLOW,LINETHICK2;
DRAWTEXT((CROSS(13,主力建仓)),70,'★< - - - - - - - →主力建仓'),COLORYELLOW;
VAR22:=MA(CLOSE,194.16);
VAR38:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
STICKLINE((CROSS(84,VAR38)),0,VAR22*60+3,5,1),COLOR3399CC;
DRAWTEXT((CROSS(84,VAR38)),60,'< - - - - - - →警'),COLORRED;
STICKLINE((CROSS(13,VAR38)),0,80,0.8,1);
DRAWTEXT((CROSS(13,VAR38)),80,'★< - - - - - - - →底'),COLORYELLOW;


趋势定输赢---未来
VARA1:=MA(CLOSE,27);
VARA2:=((CLOSE-VARA1)/(VARA1))*(100);
VARA3:=MA(VARA2,3);
VARA4:=BARSLAST((CROSS((-10),VARA3)=1));
趋势线:VARA3,COLORFF00FF;
观望区:IF((趋势线<(-0.15999999)),趋势线,0),COLORFFCF00,LINETHICK2;

操作区:IF((趋势线>0.15999999),趋势线,0),COLOR0000FF,LINETHICK2;
BB1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
CC1:=REF(CLOSE,1);
CC2:=SMA(MAX(CLOSE-CC1,0),6,1)/SMA(ABS(CLOSE-CC1),6,1)*100;
卖出:=CROSS(80,CC2);
STICKLINE(卖出,20,5,1,1),LINETHICK2,COLORBLUE;
DRAWTEXT(卖出 AND REF(卖出,1)=0,20,'天'),COLORWHITE;
STICKLINE(BB1,0,10,1,1),LINETHICK2,COLORRED;
DRAWTEXT(BB1 AND REF(BB1,1)=0,2,'地'),COLORYELLOW;
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
底部:IF(A2<19,5,0),COLOR00FF00;
买:IF( ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)卖:IF( ZIG(3,10)REF(ZIG(3,10),2),30,0),COLORF0F000;


znzgy破解
Var1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
Var2:=SMA(Var1,M1,1);
Var3:=SMA(Var2,M2,1);
Var4:=3*Var2-2*Var3;
Var5:=MA(Var2,2);
Var6:=MA(Var3,2);
Var7:=MA(Var4,2);
Var8:=(OPEN-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
Var9:=(HIGH-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VarA:=(LOW-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VarB:=MA(Var1,10);
VarC:=MA(Var8,10);
VarD:=MA(Var9,10);
VarE:=MA(VarA,10);
STICKLINE(Var1>Var8,Var1,Var8,6.8,1);
STICKLINE(Var9>VarA,Var9,VarA,0.8,1);
STICKLINE(VarA>Var9,VarA,Var9,0.8,1);
STICKLINE(Var8>Var1,Var8,Var1,6.8,1);
STICKLINE(Var1>Var8,Var1,Var8,6.8,1);


时空隧道
巫山群峰: SUM(SGN(CLOSE-REF(CLOSE,1)),0), , [00010001];
Var1:=MA(巫山群峰,7);
地线: Var1-3, , [00010001];
天线: Var1+3, , [00010001];
登峰: STICKLINE(巫山群峰>=Var1,Var1,Var1,3,1), , [00050001];
下山: STICKLINE(巫山群峰


[真实量比]源代码:

Var0:=100*(CLOSE-ma(AMOUNT/(100*vol),5))/ma(AMOUNT/(100*vol),5);
Var1:=(HIGH+LOW+CLOSE*2)/4;
Var2:=((Var1-EMA(Var1,21))/STD(Var1,21)*100+200)/4;
Var3:=(EMA(Var2,5)-25)*1.56;
Var4:=EMA(EMA(Var3,2)*1.22,2);
Var5:=3*EMA(Var3,2)*1.22-2*Var4;
Var6:=EMA((Var1-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,13);
Var7:=EMA(0.667*REF(Var6,1)+0.333*Var6,2);
Var8:=EMA(Var1,13)-EMA(Var1,21);
Var9:=2*(Var8-EMA(Var6,2))*3.8;
Var10:=Var9>REF(Var9,1) AND Var6 < 63 AND Var7 < 63 AND EMA(Var3,2)*1.22 < 63 AND Var4 < 63 AND Var5 < 63 AND CROSS(Var5,EMA(Var3,2)*1.22) AND FINANCE(33)> 0.01 AND FINANCE(34)> 1 AND REF(CLOSE,23)/CLOSE> 1.2 AND REF(CLOSE,10)/CLOSE < 1.5 ;
Var11:=MIN(ref(CLOSE,2)*0.865,ref(CLOSE,13)*0.772);
Var12:=if((CLOSE-Var11)/CLOSE < 4/100 and sum(100*vol/capital,5)/5 < 1.8 and WINNER(CLOSE)*100 < 0.1,1,0);
Var13:=CLOSE < (MA(CLOSE,80)-MA(CLOSE,10)/3) and VOL/240 > MA(VOL,5)/240 AND CLOSE > REF(CLOSE,1)*1.08 AND CLOSE < MA(CLOSE,13)*1.3;
Var14:=Var0<-10 and CLOSE < 10 AND CLOSE/REF(CLOSE,1) > 0.935;
Var15:=ma(CLOSE,3)-CLOSE-WINNER(OPEN)+(COST(55)-COST(45))/(COST(97)-COST(3))+(winner(c)-ref(winner(c),4))*0.05/ma(v/capital,5);
STICKLINE(Var15>=0,0,Var15,6,0),COLOR6600CC;
STICKLINE(Var15<=0,0,Var15,6,0),COLOR00FF99;
STICKLINE(Var15<=0,0,Var15*0.4,6,0),COLORCC0033;
STICKLINE(Var15>=0,0,Var15*0.4,6,0),COLORCC0033;
STICKLINE(Var12 > 0 OR Var10 > 0 OR Var13 > 0 OR Var14 > 0,0,0.6,6,0),linethick4,STICK,COLOR0000FF;


布林极限
Var1:=IF(YEAR>=2000 AND MONTH>2,0,1);
Var2:=MA(CLOSE,N)*Var1;
Var3:=Var2+P*STD(CLOSE,N);
Var4:=Var2-P*STD(CLOSE,N);
BB: (CLOSE-Var4)/(Var3-Var4)*Var1;
ML: EMA(BB,10)*Var1;
TX: 1, POINTDOT;
DX: 0, POINTDOT;
osc震荡量指标
osc CLOSE-REF(CLOSE,N))*100;
osc1 : MA(osc,m)


神光心电图
Var1:=CLOSE/"1A0001$CLOSE"*1000;
Var1;
Var2:=MA(Var1,5);
Var3:=MA(Var1,10);
M1: Var2;
M2: Var3;

sp*低点搜寻交易系统(特别版)
W:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45))-LLV(LOW,45)*100,N);
ENTERLONG:CROSS(-5,W);
EXITLONG:CLOSE<=0;


太阳风中线简易交易系统
Var1:=DMA(EMA(CLOSE,N1),SUM(VOL,N1)/N2/CAPITAL);
Var2:=DMA(EMA(CLOSE,2*N1),SUM(VOL,2*N1)/N2/2/CAPITAL);
Var3:=DMA(EMA(CLOSE,8*N1),SUM(VOL,8*N1)/N2/8/CAPITAL);
Var4:=1-(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
Var5:=REF(CLOSE,1);
Var6:=(SUM(Var1/Var2,5)-5)*100;
Var7:=SMA(MAX(CLOSE-Var5,0),N3,1)/SMA(ABS(CLOSE-Var5),N3,1);
Var8:=Var7*Var4*IF(SUM(Var1-REF(Var1,1),N3)>=0.5,0.5,SUM(Var1-REF(Var1,1),N3));
{多头买入} ENTERLONG: (CROSS(Var8,0) OR LLV(Var8,10)>=0 AND CROSS(Var8,0.008) AND Var8>REF(Var8,1) AND Var1>REF(Var1,1)) AND Var8>REF(Var8,2) AND Var1>Var3 AND Var6>REF(Var6,1) AND HHV(Var1,30)/Var1<1.1;

tdrh 天地人和
天时:cross((CLOSE-REF(CLOSE,12))/REF(CLOSE,12),0);
地利:cross((((HIGH + LOW + CLOSE)/3)-MA(((HIGH + LOW + CLOSE)/3),12))
/(0.015*AVEDEV(((HIGH + LOW + CLOSE)/3),12)),0)*-1;
人和:EMA(CLOSE,12) - EMA(CLOSE,26);

twr3 宝塔线三平

{多头买入} ENTERLONG:
Close > Ref(Close, 1) and Ref(Close, 1) > Ref(Close, 2) and Ref(Close, 1) < Ref(Close, 3) and
If(Ref(Close, 3) < Ref(Close, 4),
1,
If(Ref(Close, 4) < Ref(Close, 5),
Ref(Close, 1) < Ref(Close, 4) or( Ref(Close, 2) < Ref(Close, 4) and Ref(Close, 3) >= Ref(Close, 5) ),
If(Ref(Close, 5) < Ref(Close, 6),
1,
Ref(Close, 6) < Ref(Close, 7)
)
)
);
{多头卖出} EXITLONG:
Close < Ref(Close, 1) and Ref(Close, 1) < Ref(Close, 2) and Ref(Close, 1) > Ref(Close, 3) and
If(Ref(Close, 3) > Ref(Close, 4),
1,
If(Ref(Close, 4) > Ref(Close, 5),
Ref(Close, 1) > Ref(Close, 4) or( Ref(Close, 2) > Ref(Close, 4) and Ref(Close, 3) <= Ref(Close, 5) ),
If(Ref(Close, 5) > Ref(Close, 6),
1,
Ref(Close, 6) > Ref(Close, 7)
)
)
);
{空头买入} ENTERSHORT: ;
{空头卖出} EXITSHORT:

 

神雕猎狐(捕捉主力资金动向)
n=34
k=3
主流资金指数: EMA(100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),K),COLORMAGENTA;
非主流资金指数: EMA(100*(INDEXC-LLV(INDEXL,N))/(HHV(INDEXH,N)-LLV(INDEXL,N)),K), COLORBLUE;


鹰狐博弈(做庄意愿指数)
n=26
机构做庄意愿: SUM(HIGH-OPEN,N)/SUM(OPEN-LOW,N)*8,COLORCYAN;

豫狐狩猎(捕捉强庄股)
Var2:=VOL/SUM(VOL,13);
Var3:=DMA(CLOSE,Var2);
豫狐狩猎: (CLOSE-Var3)/Var3*100/2.5,COLORSTICK;
强势线: 2;


猎鹰渡关(监测大盘顶部)
n=34
k=3

大盘生命指数: EMA(100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),K)/4, STICK;
IF(大盘生命指数>23.16,大盘生命指数,0), COLORYELLOW;
DRAWICON(大盘生命指数<1,0,1), COLORRED;
强势: 21;
生命分水岭: 10;

 

机构做空能量线
Var2:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
机构做多能量: (SMA(Var3,5,1)-8),COLORRED;
机构做空能量: SMA(Var2,2,1),COLORGREEN;


命运之神
Var1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=3*Var2-2*Var3;
Var5:=LLV(LOW,5);
Var6:=HHV(HIGH,5);
Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);
Var9:=3*Var7-2*Var8;
VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VarB:=POW(MA(LOW,5),2)+MA(LOW,5);
VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;
VarE:=SMA(VarD,3,1)*1.5-100;
VarF:=SMA(VarE,3,1);
Var10:=3*VarE-2*VarF;
Var11:=(HIGH+LOW+CLOSE*2)/4;
Var12:=EMA(Var11,13);
Var13:=STD(Var11,13);
Var14:=(Var11-Var12)*100/Var13;
Var15:=EMA(Var14,5);
Var16:=EMA(Var15,13);
Var17:=EMA(Var15,13)+200-100;
Var18:=EMA(Var17,10);
Var19:=3*Var17-2*Var18;
Var1A:=Var2+Var7+VarE+Var17;
Var1B:=Var3+Var8+VarF+Var18;
Var1C:=Var4+Var9+Var10+Var19;
Var1D:=(HIGH+LOW+CLOSE)/3;
Var1E:=AMOUNT/VOL/100;
Var1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));
Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var22:=(HIGH+LOW+CLOSE+Var1D)/4;
Var23:=EMA(Var22,24);
Var24:=STD(Var22,24);
Var25:=(Var22-Var23)/Var24*100;
Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));
Var27:=EMA(Var25,5);
Var28:=(Var1E-MA(Var1E,21))/(0.015*AVEDEV(Var1E,21));
Var29:=(Var1F-MA(Var1F,90))/(0.015*AVEDEV(Var1F,90));
Var2A:=((Var29+Var28+Var27+Var26+Var20)/5+165)/4;
Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21;
Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15;
Var2D:=EMA(Var2C,13);
Var2E:=(Var2A+Var2C)/2/1.1;
0, POINTDOT;
50, POINTDOT;
105, POINTDOT;
短线: Var2E;
中线: (Var2B+Var2D)/2;
Var2F:=EMA(EMA(EMA(CLOSE,13),13),13);
Var30:=((Var2F-REF(Var2F,1))/REF(Var2F,1)*100+0.45)*50;
Var31:=MA(Var30,21);
Var32:=((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.96)*106;
Var33:=((HHV(HIGH,100)-CLOSE)/(HHV(HIGH,100)-LLV(LOW,100))*(-1)+0.96)*106;
Var34:=(HIGH+LOW+CLOSE)/3;
Var35:=((Var34-MA(Var34,14))/(0.015*AVEDEV(Var34,14))+200)/4;
Var36:=(HIGH+LOW+CLOSE*2)/4;
Var37:=EMA(Var36,13);
Var38:=STD(Var36,13);
Var39:=(Var36-Var37)*100/Var38;
Var3A:=EMA(Var39,5);
Var3B:=EMA(Var3A,13);
Var3C:=(EMA(Var3A,13)+100)/2-5;
Var3D:=EMA(Var3C,10);
Var3E:=EMA(VOL/CAPITAL,21)*13;
Var3F:=(92-100/(1+Var3E))*2.38;
Var40:=REF(CLOSE,1);
Var41:=WINNER(CLOSE)*100;
Var42:=WINNER(REF(CLOSE,1))*100;
Var43:=REF(INDEXC,1);
Var44:=(CLOSE-Var40)/Var40;
Var45:=(INDEXC-Var43)/Var43;
Var46:=Var44-Var45;
Var47:=SMA(MAX(CLOSE-Var40,0),4,1)/SMA(ABS(CLOSE-Var40),4,1)*100;
Var48:=SMA(MAX(CLOSE-Var40,0),8,1)/SMA(ABS(CLOSE-Var40),8,1)*100;
Var49:=SMA(MAX(CLOSE-Var40,0),12,1)/SMA(ABS(CLOSE-Var40),12,1)*100;
Var4A:=SMA(MAX(CLOSE-Var40,0)*(1+VOL/CAPITAL),12,1)/SMA(ABS(CLOSE-Var40)*(1+VOL/CAPITAL),12,1)*100;
Var4B:=SMA(MAX(Var41-Var42,0),12,1)/SMA(ABS(Var41-Var42),12,1)*100;
Var4C:=SMA(MAX(Var46,0),12,1)/SMA(ABS(Var46),12,1)*100;
Var4D:=(Var47+Var48+Var49)/3;
Var4E:=(Var4A+Var4B+Var4C+Var4D)/4;
Var4F:=(Var4E-31)*2.3;
Var50:=(EMA(EMA(EMA(EMA(Var4F,4),3),2),1)-10)*1.43;
Var51:=(HIGH+LOW+CLOSE*2)/4;
Var52:=EMA(Var51,13);
Var53:=STD(Var51,13);
Var54:=(Var51-Var52)*100/Var53;
Var55:=EMA(Var54,5);
Var56:=EMA(Var55,13);
Var57:=(EMA(Var56,13)+100)/2-5;
Var58:=EMA(Var57,10);
Var59:=3*Var57-2*Var58;
Var5A:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100;
Var5B:=SMA(Var5A,7,1);
Var5C:=SMA(Var5B,10,1);
Var5D:=3*Var5B-2*Var5C;
Var5E:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
Var5F:=POW(MA(LOW,5),2)+MA(LOW,5);
Var60:=POW(MA(HIGH,5),2)+MA(HIGH,5);
Var61:=(Var5E-LLV(Var5F,100))/(HHV(Var60,100)-LLV(Var5F,100))*100-15;
Var62:=SMA(Var61,21,1)*1.5;
Var63:=SMA(Var62,3,1);
Var64:=3*Var62-2*Var63;
Var65:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
Var66:=POW(MA(LOW,5),2)+MA(LOW,5);
Var67:=POW(MA(HIGH,5),2)+MA(HIGH,5);
Var68:=(Var65-LLV(Var66,64))/(HHV(Var67,64)-LLV(Var66,64))*100;
Var69:=SMA(Var68,2,1);
Var6A:=SMA(Var69,2,1);
Var6B:=3*Var69-2*Var6A;
Var6C:=EMA(VOL/CAPITAL,21)*100;
Var6D:=(100/(1+Var6C)*(-1)+92)*1.57;
Var6E:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var6F:=(HIGH+LOW+CLOSE)/3;
Var70:=((Var6F-MA(Var6F,5))/(0.015*AVEDEV(Var6F,5))+Var6E+140)/4;
Var71:=EMA(EMA(EMA(CLOSE,100),100),100);
Var72:=((Var71-REF(Var71,1))/REF(Var71,1)*100+0.28)*179;
Var73:=EMA(Var72,20);
Var74:=(Var5D+Var64)/2;
Var75:=(Var69+Var6A+Var6B+Var57+Var5B+Var62+Var6D+Var58+Var5C+Var63+Var59+Var5D+Var64+Var70+EMA(Var35,5)*5)/20;
Var76:=(Var57+Var5B+Var62+Var6D+Var74+Var72+Var73)/7;
Var77:=(Var58+Var5C+Var63+Var6D+Var74+Var72+Var73)/7;
Var78:=(Var76+Var77)/2*1.22;
Var79:=(EMA((Var74+Var78+EMA(Var75,5))/3,89)-12)*1.72;
长线: (Var78+Var79)/2;

lanmao 2004-4-13 14:38

技术指标公式:FXJ-10 (分析家十号(天地出击))  缺省周期:日线
=======================================================================================
参数描述: L01(1,300,12)L02(1,300,24)H0(1,300,48)
=======================================================================================
MA4: MA(CLOSE,4);
MA25: MA(CLOSE,25);
出击: LLV(LOW,L01), , [00070001];
地: LLV(LOW,L02), , [00010001];
天: HHV(HIGH,H0), , [00010001];
=======================================================================================


技术指标公式:FXJ-11 (分析家十一号(生死之图))  缺省周期:日线
=======================================================================================
参数描述: N1(1,300,5)N2(1,300,10)N3(1,300,30)N4(1,300,60)
=======================================================================================
Var1:=(MA(CLOSE,L01)+MA(CLOSE,L02)+MA(CLOSE,H0)+MA(CLOSE,))/4;
STICKLINE(CLOSE>Var1,CLOSE,Var1,9,0), , [00010001];
STICKLINE(CLOSEMA(CLOSE,68);

lanmao 2004-4-13 14:41

技术指标公式:FXJ-12 (分析家十二号(稳操胜劵))  缺省周期:日线
=======================================================================================
参数描述: N(1,100,34)K(1,50,3)
=======================================================================================
股MSD: EMA(100*(CLOSE-LLV(LOW,L01))/(HHV(HIGH,L01)-LLV(LOW,L01)),L02), , [00010001];
大盘MSD: EMA(100*(INDEXC-LLV(INDEXL,L01))/(HHV(INDEXH,L01)-LLV(INDEXL,L01)),L02), , [00010001];
100, POINTDOT;
0, POINTDOT;
差值: 股MSD-大盘MSD, , [00010008];
STICKLINE(差值>=0,0,差值*1,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.2,4,0), , [00010001];
STICKLINE(差值<0,0,差值*1,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.2,4,0), , [00010001];
20;
=======================================================================================
用法:
(1)指数与个股的MSD同时处于20以下的低位,表明个股与大盘同步下跌,通常这样一来的个股不值得关注。
(2)A:指数MSD处于低位,个股MSD脱离低位区并突破20,表明有庄先行介入,介入程度依赖个股MSD上升的位置。
     B:MSD上升到50附近即调头向下,重新回到低位区,是庄家试盘。
     C:如果MSD上升到80以上区域后调头向下,表明有庄逆势吸筹,大牛股踪迹已现,MSD重新回到20以下的低位是天赐的抄低机会。
     D:如果MSD上升到80以上区域拒绝回落,同时股价逆势走强,无论是老庄所为,还是新庄介入,都是大牛股主升浪的标志,应大胆追涨,不赚不休。
(3)指数MSD脱离低位向上是大盘反弹的信号,MSD进入50以上的强势区是大盘反转的信号。此前有逆势动作的股票都会成为大盘上涨的急先锋,通常都会成为大牛股。
(4)个股MSD大于指数MSD的个股属于大盘的领涨板块。追涨信号以个股MSD上穿指数MSD时确定。
(5)MSD处于50以上,无论是指数或个股,均属于强势着整理。从大盘角度看,可以维持足够的持
股信心。从个股角度看,是短线吸纳的良好机会。
(6)个股MSD先于大盘MSD调整到弱势区的股票是庄家已经出货,股价将进行中线调整的股票。
实战应用与评价:我在去年10月拿到程峰老师的《稳操胜劵》,反复读了不下10遍,字里行间,无不流露出这位伟大的农民的儿子的朴素情怀,在他指尖敲打键盘的心血真言,以及深奥证券经典技术的浅显表白。MSD揭示的(书上未明示)的K线形态,趋势线买卖点有更多的内涵值得我们去思想,单就指标的写法就是比较类指标的创新。应用上不单要看金叉,更重要的是金叉时的个股指标形态(望此说不会冒犯了程峰老师),提高金叉的成功率。笔者用其介入的股票是:0564(2001。01。15)600127(2001。01。16)0658(2001。02。06)0065(2001。03。01)600038(2001。02。23)。这些股票都是有与渔猎,CW盘中共议。至于介入点的确认不在此论。MSD指标给我们带来了创制指标的新思路,是这位期货,股票操盘手奉献给广大受伤累累的散户的一剂良药。

lanmao 2004-4-13 14:41

技术指标公式:FXJ-13 (分析家十三号(百万牛熊))  缺省周期:日线
=======================================================================================
80, , [00010001];
20;
Var1:=HHV(HIGH,9)-LLV(LOW,9);
Var2:=HHV(HIGH,9)-CLOSE;
Var3:=CLOSE-LLV(LOW,9);
Var4:=Var2/Var1*100-70;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(2*CLOSE+HIGH+LOW)/4;
Var7:=SMA(Var3/Var1*100,3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
VarA:=IF(Var9>100,Var9-100,0);
VarB:=HHV(HIGH,34);
VarC:=EMA((Var6-Var8)/(VarB-Var8)*100,13);
VarD:=EMA(0.667*REF(VarC,1)+0.333*VarC,2);
VarD, , [00010001];
STICKLINE(VarC-VarD>0,VarC,VarD,8,0), , [00010001];
STICKLINE(VarC-VarD<0,VarC,VarD,8,0), , [00010001];
差值: (VarC-VarD)*5, , [00010008];
STICKLINE(差值>=0,0,差值,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.2,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*1,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.2,4,0), , [00010001];

lanmao 2004-4-13 14:42

技术指标公式:FXJ-14 (分析家十四号(个股状态))  缺省周期:日线
=======================================================================================
安全线: 20;
平衡线: 50, , [00010001];
风险线: 80;
Var1:=LLV(LOW,18);
Var2:=HHV(HIGH,18);
Var3:=EMA((CLOSE-Var1)/(Var2-Var1)*100,13);
目前态势: EMA(0.618*REF(Var3,1)+0.382*Var3,3), , [00050001];

lanmao 2004-4-13 14:43

技术指标公式:FXJ-15 (分析家十五号(大风向标))  缺省周期:日线
=======================================================================================
Var1:=SMA("1A0001$AMOUNT",10,1)/10000000;
Var2:=EMA(Var1,13.5);
Var3:=(Var1-Var2)/Var2*100;
大盘风向标: Var3, POINTDOT;
STICKLINE(Var3>=0,0,Var3,8,0), , [00010001];
STICKLINE(Var3<0,0,Var3,8,0), , [00010001];

lanmao 2004-4-13 14:46

技术指标公式:FXJ-10 (分析家十号(天地出击))  缺省周期:日线
=======================================================================================
参数描述: L01(1,300,12)L02(1,300,24)H0(1,300,48)
=======================================================================================
MA4: MA(CLOSE,4);
MA25: MA(CLOSE,25);
出击: LLV(LOW,L01), , [00070001];
地: LLV(LOW,L02), , [00010001];
天: HHV(HIGH,H0), , [00010001];
=======================================================================================


技术指标公式:FXJ-11 (分析家十一号(生死之图))  缺省周期:日线
=======================================================================================
参数描述: N1(1,300,5)N2(1,300,10)N3(1,300,30)N4(1,300,60)
=======================================================================================
Var1:=(MA(CLOSE,L01)+MA(CLOSE,L02)+MA(CLOSE,H0)+MA(CLOSE,))/4;
STICKLINE(CLOSE>Var1,CLOSE,Var1,9,0), , [00010001];
STICKLINE(CLOSEMA(CLOSE,68);

 

技术指标公式:FXJ-12 (分析家十二号(稳操胜劵))  缺省周期:日线
=======================================================================================
参数描述: N(1,100,34)K(1,50,3)
=======================================================================================
股MSD: EMA(100*(CLOSE-LLV(LOW,L01))/(HHV(HIGH,L01)-LLV(LOW,L01)),L02), , [00010001];
大盘MSD: EMA(100*(INDEXC-LLV(INDEXL,L01))/(HHV(INDEXH,L01)-LLV(INDEXL,L01)),L02), , [00010001];
100, POINTDOT;
0, POINTDOT;
差值: 股MSD-大盘MSD, , [00010008];
STICKLINE(差值>=0,0,差值*1,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.2,4,0), , [00010001];
STICKLINE(差值<0,0,差值*1,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值<0,0,差值*0.2,4,0), , [00010001];
20;
=======================================================================================
用法:
(1)指数与个股的MSD同时处于20以下的低位,表明个股与大盘同步下跌,通常这样一来的个股不值得关注。
(2)A:指数MSD处于低位,个股MSD脱离低位区并突破20,表明有庄先行介入,介入程度依赖个股MSD上升的位置。
     B:MSD上升到50附近即调头向下,重新回到低位区,是庄家试盘。
     C:如果MSD上升到80以上区域后调头向下,表明有庄逆势吸筹,大牛股踪迹已现,MSD重新回到20以下的低位是天赐的抄低机会。
     D:如果MSD上升到80以上区域拒绝回落,同时股价逆势走强,无论是老庄所为,还是新庄介入,都是大牛股主升浪的标志,应大胆追涨,不赚不休。
(3)指数MSD脱离低位向上是大盘反弹的信号,MSD进入50以上的强势区是大盘反转的信号。此前有逆势动作的股票都会成为大盘上涨的急先锋,通常都会成为大牛股。
(4)个股MSD大于指数MSD的个股属于大盘的领涨板块。追涨信号以个股MSD上穿指数MSD时确定。
(5)MSD处于50以上,无论是指数或个股,均属于强势着整理。从大盘角度看,可以维持足够的持
股信心。从个股角度看,是短线吸纳的良好机会。
(6)个股MSD先于大盘MSD调整到弱势区的股票是庄家已经出货,股价将进行中线调整的股票。
实战应用与评价:我在去年10月拿到程峰老师的《稳操胜劵》,反复读了不下10遍,字里行间,无不流露出这位伟大的农民的儿子的朴素情怀,在他指尖敲打键盘的心血真言,以及深奥证券经典技术的浅显表白。MSD揭示的(书上未明示)的K线形态,趋势线买卖点有更多的内涵值得我们去思想,单就指标的写法就是比较类指标的创新。应用上不单要看金叉,更重要的是金叉时的个股指标形态(望此说不会冒犯了程峰老师),提高金叉的成功率。笔者用其介入的股票是:0564(2001。01。15)600127(2001。01。16)0658(2001。02。06)0065(2001。03。01)600038(2001。02。23)。这些股票都是有与渔猎,CW盘中共议。至于介入点的确认不在此论。MSD指标给我们带来了创制指标的新思路,是这位期货,股票操盘手奉献给广大受伤累累的散户的一剂良药。

 

技术指标公式:FXJ-13 (分析家十三号(百万牛熊))  缺省周期:日线
=======================================================================================
80, , [00010001];
20;
Var1:=HHV(HIGH,9)-LLV(LOW,9);
Var2:=HHV(HIGH,9)-CLOSE;
Var3:=CLOSE-LLV(LOW,9);
Var4:=Var2/Var1*100-70;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(2*CLOSE+HIGH+LOW)/4;
Var7:=SMA(Var3/Var1*100,3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
VarA:=IF(Var9>100,Var9-100,0);
VarB:=HHV(HIGH,34);
VarC:=EMA((Var6-Var8)/(VarB-Var8)*100,13);
VarD:=EMA(0.667*REF(VarC,1)+0.333*VarC,2);
VarD, , [00010001];
STICKLINE(VarC-VarD>0,VarC,VarD,8,0), , [00010001];
STICKLINE(VarC-VarD<0,VarC,VarD,8,0), , [00010001];
差值: (VarC-VarD)*5, , [00010008];
STICKLINE(差值>=0,0,差值,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值>=0,0,差值*0.2,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*1,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.8,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.6,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.4,4,0), , [00010001];
STICKLINE(差值<=0,0,差值*0.2,4,0), , [00010001];

 

 

技术指标公式:FXJ-14 (分析家十四号(个股状态))  缺省周期:日线
=======================================================================================
安全线: 20;
平衡线: 50, , [00010001];
风险线: 80;
Var1:=LLV(LOW,18);
Var2:=HHV(HIGH,18);
Var3:=EMA((CLOSE-Var1)/(Var2-Var1)*100,13);
目前态势: EMA(0.618*REF(Var3,1)+0.382*Var3,3), , [00050001];

 


技术指标公式:FXJ-15 (分析家十五号(大风向标))  缺省周期:日线
=======================================================================================
Var1:=SMA("1A0001$AMOUNT",10,1)/10000000;
Var2:=EMA(Var1,13.5);
Var3:=(Var1-Var2)/Var2*100;
大盘风向标: Var3, POINTDOT;
STICKLINE(Var3>=0,0,Var3,8,0), , [00010001];
STICKLINE(Var3<0,0,Var3,8,0), , [00010001];

  
                 
 
                                 
=======================================================================================


技术指标公式:FXJ-16 (分析家十六号(快速短线))  缺省周期:日线
=======================================================================================
参数描述: P1(2,20,5)P2(2,20,4)
=======================================================================================
80, POINTDOT;
20, POINTDOT;
Var1:=LLV(LOW,P1);
Var2:=HHV(HIGH,P1);
K: EMA((CLOSE-Var1)/(Var2-Var1)*100,P2), , [00010001];
D: EMA(0.667*REF(K,1)+0.333*K,2), , [00010001];

lanmao 2004-4-13 14:48

{!顶底背离}
0,COLORYELLOW;
A1:=BARSLAST(ref(cross("macd.diff","macd.dea"),1));
B1:=ref(c,A1+1)>c and ref("macd.diff",A1+1)<"macd.diff" and cross("macd.diff","macd.dea");
MACD底背离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGREEN;
DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLORGREEN;
A2:=BARSLAST(ref(cross("kdj.k","kdj.d"),1));
B2:=ref(c,A2+1)>c and ref("kdj.k",A2+1)<"kdj.k" and cross("kdj.k","kdj.d");
KDJ底背离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELLOW;
DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1","RSI.RSI2"),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1",A3+1)<"RSI.RSI1" and cross("RSI.RSI1","RSI.RSI2");
RSI底背离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORCYAN;
DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORCYAN;

2,COLORRED;
C1:=BARSLAST(ref(cross("macd.dea","macd.diff"),1));
D1:=ref(c,C1+1)"macd.diff" and cross("macd.dea","macd.diff");
MACD顶背离:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF;
DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(ref(cross("kdj.d","kdj.k"),1));
D2:=ref(c,C2+1)"kdj.k" and cross("kdj.d","kdj.k");
KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;
DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(ref(cross("RSI.RSI2","RSI.RSI1"),1));
D3:=ref(c,C3+1)"RSI.RSI1" and cross("RSI.RSI2","RSI.RSI1");
RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORMAGENTA;
DRAWTEXT(FILTER(D3>0,5),1.75,'RSI顶背离'),COLORMAGENTA;

lanmao 2004-4-13 14:49

配好色,全破解的[S散户主力]《散户经典系列2.0》
{S散户主力  《散户经典系列2.0》之一. n,1,30,11 m1,1,20,6 m,1,20,14}
Var5:=REF(LOW,1)*0.9;
Var6:=LOW*0.9;
Var7:=(Var6*VOL+Var5*(CAPITAL-VOL))/CAPITAL;
Var8:=EMA(Var7,30);
Var9:=CLOSE-REF(CLOSE,1);
VarA:=MAX(Var9,0);
VarB:=ABS(Var9);
VarC:=SMA(VarA,7,1)/SMA(VarB,7,1)*100;
VarD:=SMA(VarA,13,1)/SMA(VarB,13,1)*100;
VarE:=BARSCOUNT(CLOSE);
VarF:=SMA(MAX(Var9,0),6,1)/SMA(ABS(Var9),6,1)*100;
Var10:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var11:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var12:=SMA((SMA(Var11,4,1)-50)*2,3,1);
Var13:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var14:=SMA(Var13,4,1);
Var15:=SMA(Var14,3,1);
Var16:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var17:=VarF<=25 AND Var10<-95 AND Var16>20 AND Var12<-30 AND Var15<30 AND Var8-CLOSE>=-0.25 AND VarC<22 AND VarD<28 AND VarE>50;
Var18:=(HIGH+LOW+CLOSE)/3;
Var19:=(Var18-MA(Var18,14))/(0.015*AVEDEV(Var18,14));
Var1A:=(Var18-MA(Var18,70))/(0.015*AVEDEV(Var18,70));
Var1B:=IF(Var19>=150 AND Var19<200 AND Var1A>=150 AND Var1A<200,10,0);
Var1C:=IF(Var19<=-150 AND Var19>-200 AND Var1A<=-150 AND Var1A>-200,-10,Var1B);
Var1D:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Var1E:=REVERSE(Var1D);
Var1F:=SMA(Var1D,3,1);
Var20:=SMA(Var1F,3,1);
Var21:=SMA(Var20,3,1);
Var22:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
Var23:=SMA(Var22,M1,1);
散户: SMA(Var23,M1,1),colormagenta ,linethick2 ;
Var24:=(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M))*100;
Var25:=SMA(Var24,M1,1);
Var26:=SMA(Var25,M1,1);
主力: SMA(散户,M1,1),linethick2 ,;
Var27:=COST(10);
Var28:=(CLOSE-Var27)/Var27*100;
Var29:=COUNT(Var28<-2.05,3);
主力吸货: IF(Var29>=3,10,0),colorffff00 ,linethick2 ;
星星之火: IF(CROSS(5,主力吸货),20,0),colorred,colorstick ,linethick4;
大富翁: IF(CROSS(SMA(Var26,M1,1),85),75,0),colorwhite ,linethick3;
Var2A:IF(CROSS(Var17,0.1),60,0),colorgreen,stick,linethick3;
Var2B:=CROSS(SMA(MAX(CLOSE-(CLOSE+REF(CLOSE,1))/2,0),5,1)/SMA(ABS(CLOSE-(CLOSE+REF(CLOSE,1))/2),5,1)*100,(CLOSE+REF(CLOSE,1))/2) AND (CLOSE-REF(CLOSE,36))/REF(CLOSE,36)*100<-10 AND HHV(HIGH,40)*0.8>LLV(LOW,5) AND SMA((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)>80;
Var2C:=(CLOSE-OPEN)/OPEN*100;
Var2D:=REF(CLOSE,1);
Var2E:=SMA(MAX(CLOSE-Var2D,0),6,1)/SMA(ABS(CLOSE-Var2D),6,1)*100;
Var2F:=COUNT(Var2E<20,20)>=1;
Var30:IF(Var2C>6 and Var2F,60,0),colorgreen,stick,linethick3;
有钱人:Var2A or Var30 or Var2B*60,colorgreen,colorstick  ;
Var31:=IF("RSI.RSI1">78 AND "ROC.ROC"20,80,100);
Var32:=IF(CROSS(Var21,Var20) AND Var21>75,80,100);
DRAWTEXT(CROSS(Var17,0.5) AND COUNT(Var17=1,10)=1,35,'★'),colorred ,;
天: IF(Var31<100 OR Var32<100,80,100),colorred ,linethick2 ;
Var33:=(2*CLOSE+HIGH+LOW)/4;
Var34:=LLV(LOW,34);
Var35:=HHV(HIGH,34);
A: EMA((Var33-Var34)/(Var35-Var34)*100,30),color3399ff , ;
B: EMA(A,5),colorwhite , ;

lanmao 2004-4-13 14:50

分析家公式[筹码分析]

 


Var2:=(CLOSE-REF(OPEN, 19))/REF(OPEN, 19)*100;
Var3:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
筹码:MA((CLOSE-REF(OPEN, 29))/REF(OPEN, 29), 1)*100;
筹码差:MA(筹码, 10);
Var4:=VOL/MA(VOL, 5);
Var5:=VOL/CAPITAL*100;
上轨道:SUM(Var5, 30), COLOREE00FF;
下轨道:REVERSE(SUM(Var5, 30)), COLOREE00FF;
跌筹比:筹码/下轨道, COLORSTICK;
Var6:=LLVBARS(LOW, 50);
Var7:=SUM(VOL, Var6);
Var8:=HHVBARS(HIGH, 50);
Var9:=SUM(VOL, Var8);
Var10:=(CLOSE-REF(OPEN, Var8))/REF(OPEN, Var8)*100;
Var11:=Var9/CAPITAL*100;
Var12:=(CLOSE-REF(OPEN, Var6))/REF(OPEN, Var6)*100;
Var13:=Var7/CAPITAL*100;
STICKLINE(筹码>0, 筹码, 0, 1, 1), COLORRED;
STICKLINE(筹码>筹码差, 筹码, 筹码差, 1, 1), COLORYELLOW;
STICKLINE(筹码<筹码差, 筹码, 筹码差, 1, 1), COLORGREEN;
提示:STICKLINE(跌筹比>1 AND 筹码<5, 跌筹比*5, 0, 1, 1), COLORRED;
Var14:=IF(跌筹比>1, 10, 0);
Var15:=CLOSE<0.980*REF(CLOSE, 1);
Var16:=OPENVar17:=IF(DATE>=10341231 AND DATE<=10341231, 0, 1) AND IF(DATE>=10341231 AND DATE<=10341231, 0, 1) AND IF(DATE>=10341231 AND DATE<=10341231, 0, 1) AND IF(DATE>=10341230 AND DATE<=10341231, 0, 1);
Var18:=IF(CROSS(筹码, 筹码差) AND 筹码差<下轨道 AND 筹码<5 AND Var17 AND Var3>6, 下轨道*5, 0);
Var19:=(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17)*20;
Var20:=IF(Var19 OR COUNT(Var19, 5) AND Var15, 筹码*5, 0);
Var21:=STICKLINE(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17 OR COUNT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 5) AND Var15, 10, 0, 5, 0);
买入:STICKLINE(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17 OR COUNT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 5) AND Var15, 5, 0, 5, 0)*20, COLORYELLOW;
DRAWTEXT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 10, '买震打压'), COLORWHITE;
DRAWTEXT(COUNT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 5) AND CLOSE<0.950*REF(CLOSE, 1), 5, ''), COLORWHITE;
DRAWTEXT(COUNT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 5) AND CLOSE<0.980*REF(CLOSE, 1) AND CLOSE>0.960*REF(CLOSE, 1), 30, ''), COLORWHITE;
DRAWTEXT(COUNT(跌筹比>10/100 AND 筹码<5 AND Var3>6 AND Var17, 5) AND CLOSE<0.960*REF(CLOSE, 1) AND CLOSE>0.940*REF(CLOSE, 1), 30, ''), COLORWHITE;
STICKLINE(Var14>0 AND Var17 AND Var3>4.900 AND 跌筹比>1 AND 筹码<下轨道 AND 筹码<5, 0, 20, 5, 0), COLORRED;
(COUNT(Var14, 5) AND Var3>8 AND REF(Var14, 3)>=1 AND 筹码<5)*30, COLORYELLOW;
                                               说明:
指标线有上轨,下轨,正负零,筹码,筹码差 ,跌筹比。 筹码,筹码差平时在上轨,下轨围绕着正负零运行,一旦跌落到下轨,且在下方形成金叉,筹码换手(上轨,下轨)缩小,跌筹比>1,说明庄家刻意打压股价,庄家筹码还在其中,当日上涨Y3%,主力有意发力拉升,当日就发出买入信号,信号成立以后时间周期内如果庄家打压,洗盘,震仓,公式也发出追涨买入信号。当股价运行突破正负零或上轨,并在上方死叉,且5日均线掉头向下便是离场卖出信号。一般都有30%-50%以上的涨幅.(买入信号的前3-5天能发出提示信号让你有充分的考虑分析时间。)该指标属于高智能型软件,拒绝选出亏损绩差股(ST股)除权数据必需完整。如有意选入ST亏损股,则选股成功率降低一个百分点,选出信号增加586次即:信号增加23.21%,百分率降低一个百分点,合计失败信号增加 6次 ,
提示:
   大盘在加速下跌,近期下跌目标是1495,(小反弹可企),中期目标是1336.(大盘中期见底。注:'预测大盘'指标已升级)本周已有几只股票出现买入前的提示信号.成功率79%,静等'筹码分析'的正式买入信号出来

lanmao 2004-4-13 14:51

分析家公式:火眼地眼
参数描述:N, 5,300,26
             M1,1,100,5
             M2,1,100,10
             M3,1,100,20

ABC:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
X1:=SMA(ABC,3,1);
Y1:=SMA(X1,3,1);
HSL:=VOL/CAPITAL*100;
MID := (H+L+C)/3;
VAR1:=SUM(MAX(0,HIGH-REF(MID,1)),N)/SUM(MAX(0,REF(MID,1)-L),N)*100;
AA1:EMA(VAR1,3)-3;
VAR2:=REF(MA(VAR1,20),20/2.5+1);
G1:EMA(VAR2,10);
XX1:=CROSS(AA1,G1);
XX2:=(HSL>=1.8 AND HSL<=7.8) OR (REF(HSL,1)>=2.8);
XX3:=VOL/HHV(VOL,30)>=0.5 OR REF(VOL,1)/HHV(VOL,30)>=0.5;
XX:=XX1 AND XX2 AND XX3 AND G1<=140 AND CLOSE/MA(CLOSE,120)<=1.30;
VAR8:=LOW=LLV(LOW,60);
VAR9:=AA1> LLV(AA1,60);
WW:=VAR8 AND VAR9 AND G1>=REF(G1,1) AND Y1<=15 AND AA1/G1>=0.94 ;
JJ:=AA1<=46;
火眼: IF(XX, 300, 0), COLORSTICK;
底背: IF(WW, 120, 0), COLORSTICK;
地眼: IF(JJ,  80, 0), COLORSTICK;

 

分析家公式[背离指示]
指南针三十计Var1:=MA(CLOSE,50);
Var4:=EMA(CLOSE,21);
VarD:=Var4;
Var14:=1+MA(CLOSE,7);
Var15:=EMA(CLOSE,8);
Var16:=EMA(MA(CLOSE,5),8);
Var19:=MA(CLOSE,5)+1;
Var1B:=MA(OPEN+CLOSE,7);
Var1F:=IF(LOW>HIGH,Var4,1);
Var20:=(Var14+Var19)/(2*Var14);
Var21:=MA(OPEN+CLOSE,10)*0.125;
Var23:=Var1F;
Var24:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
Var25:=EMA(CLOSE,7);
Var26:=MA(EMA(CLOSE,5),9);
var35:=EMA(VarD-1,5)+EMA(CLOSE,8)-EMA(CLOSE,21)-EMA(CLOSE,9);
Var36:=IF(Var35>CLOSE,Var4,Var24);
Var37:=Var24*1.05;
Var38:=Var25*1.05;
Var39:=1*0.95;
Var3A:=EMA(CLOSE,25)*0.95;
Var3B:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
Var3C:=SMA(Var3B,7,1)*1;
Var3D:=SMA(Var3C,9,1);
Var3E:=3*Var3C-2*Var3D;
Var3F:=Var24*1.25*1;
Var40:=1*1.05*1;
Var41:=Var25*0.95*1;
Var42:=(CLOSE-LLV(LOW,9))*1/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var43:=SMA(Var42,2,1)*1;
Var44:=SMA(Var43,3,1)*1;
Var45:=3*Var43-2*Var44;
SEEK: CROSS(Var36,-87) AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58), VOLSTICK;
DRAWTEXT(CROSS(Var36,-87) AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58),0.3,'指示');
DRAWTEXT(CROSS(Var36,-87) AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58),0.7,'SEEK');
我用的投机指标:

投机1:100-100*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))COLORWHITE;
投机2:100-100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))COLORGREEN;
投机3:100-100*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))COLORMAGENTA;
投机4:100-100*(HHV(HIGH,30)-CLOSE)/(HHV(HIGH,30)-LLV(LOW,30))COLORRED,LINETHICK2;
A0:0,COLORWHITE,POINTDOT;
A1:20,COLORGREEN;
A2:50,COLORYELLOW;
A3:70,COLORBLUE;
A4:80,COLORRED;
A5:100,COLORWHITE,POINTDOT;


通达信的
{出入财神}--附图公式源码-----不函未来,放心使用

参数:n1 1 60 3
      n2 1 90 10
      m1 1 60  5
      m2 1 90  20

以下是源码:


lc:= ref(close,1);
rsi1:=sma(max(close-lc,0),n1,1)/sma(abs(close-lc),n1,1)*100;
rsi2:=sma(max(close-lc,0),n2,1)/sma(abs(close-lc),n2,1)*100;
买:ema(rsi1,m1),colorred,linethick2;
卖:ema(rsi2,m2),linethick2,colorffff00;
var1:=ref(close,1);
var2:=sma(max(close-var1,0),6,1)/sma(abs(close-var1),6,1)*100;
好财神:(cross(80,var2)),colorf00ff0,linethick2;
drawicon(好财神>0,买*1.15,2);
drawtext(好财神>0,买,'财神跑'),color00ff00;
var3:=(close-llv(low,20))/(hhv(high,20)-llv(low,20))*100;
var4:sma(sma(var3,3,1),3,1),color00ff00;
var5:=ema(var4,5);
var7:3*var4-2*var5,colorgreen;

恶财神:cross(var7,var4),coloryellow,stick;
drawtext(cross(var7,var4) and var7<21,var4,'财神到'),coloryellow;
drawicon(cross(var7,var4)>0 and var7<21,var4,1);
分界:45,colorff0000;
顶:90,coloryellow,linethick2;


{轻松寻牛记 主图} (飞狐改)

V1:EMA(CLOSE,5);
V2:EMA(EMA(CLOSE,90)*1.01,10),;
DRAWTEXT(CROSS(V1,V2),V1+0.05,'追牛'),COLOR00FF00,LINETHICK2;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWICON(CROSS(V1,V2),V2,1);
DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORYELLOW;
M5:MA(CLOSE,5),LINETHICK1,COLORYELLOW;
M13:MA(CLOSE,13),LINETHICK2,COLOR0099FF;

A:MA(CLOSE,3),COLORFF00FF,LINETHICK0;
A1:=(CLOSE+HIGH+LOW)/(3);
B:=EMA(A1,10);
B2:=REF(B,1);
MA20:=EMA(CLOSE,20);
DRAWTEXT((B>B2),MA20,'*'),COLORMAGENTA;
DRAWTEXT((B

{以下设置逃顶指标}
VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARC),HIGH,2);
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(84,VAR7),H*1.01,'▲逃顶'),COLORGREEN ;
{追涨}
VAR32:=CLOSE/REF(CLOSE, 1)>=1.062 AND HIGH/CLOSE<1.005 AND MA(CLOSE, 90)/CLOSE>=1.150;
VAR33:=VAR32 AND COUNT(VAR32, 20)=1 ;
VAR34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
VAR35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
VAR36:=IF(VAR34>0.010, 0.900, 1) AND IF(VAR34>(-0.025), 1, 1.200);
VAR37:=VAR36*(VAR35-VAR34)*100;
VAR38:=SUM(VAR37, 10);
VAR39:=SMA(VAR38, 40, 1);
VAR310:=VAR38>20;
VAR311:=CROSS(CLOSE, MA(CLOSE*1.055, 3)) AND CLOSE>OPEN*1.060 AND VOL>=REF(VOL, 1)*1.5 AND CLOSE>=MA(CLOSE, 10);
VAR312:=VAR310 AND VAR311 ;
VAR313:=(-100)*(HHV(HIGH, 3)-CLOSE)/(HHV(HIGH, 3)-LLV(LOW, 3));
VAR314:= CROSS(VAR313, (-87)) AND PEN=1.090*REF(CLOSE, 1) AND INDEXC>0.980*REF(INDEXC, 1) AND CLOSE<=1.470*LLV(CLOSE, 58);
VAR315:=EMA(CLOSE, 12)-EMA(CLOSE, 26);
VAR316:=EMA(VAR315, 9);
VAR317:=2*(VAR315-VAR316);
VAR318:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH, 9)-LLV(LOW, 9))*100;
VAR319:=SMA(VAR318, 3, 1);
VAR320:=SMA(VAR319, 3, 1);
VAR321:=EMA(IF(VAR316>REF(VAR316, 1), 1, (-1)), 14)*14;
VAR322:=EMA(IF(VAR320>REF(VAR320, 1), 1, (-1)), 14)*14*2;
VAR323:=(MA(CLOSE, 5)/MA(CLOSE, 70)-1)*100;
VAR324:=(VAR323+VAR322+VAR321)/3;
VAR325:=MA(CLOSE, 80)-MA(CLOSE, 10)/3;
VAR326:=IF(CLOSE AND MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);

{VAR38>VAR39;}
VAR327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
VAR328:=IF(VAR324>REF(VAR324, 1) AND REF(VAR324, 1)

VAR314) OR VAR326>0 OR VAR327>0, 85, 0);
VAR329:=IF(VAR327>0 ,95,0), STICK,LINETHICK2;
VAR330:=IF(VAR326>0 OR VAR327>0,91,0), STICK,LINETHICK2;
VAR331:=IF(VAR328>0 OR VAR327>0 OR VAR326>0,88,0), STICK,LINETHICK2;
VAR332:=100*(CLOSE-LLV(LOW,42))/(HHV(HIGH,42)-LLV(LOW,42)),LINETHICK1,COLORGREEN;
VAR333:=COUNT(MA(CLOSE,3)>REF(MA(CLOSE,3),1),1)=1;
VAR334:=(VAR332<93 AND VAR333 AND MAX(MAX(VAR329, VAR330), VAR331))*100; 
STICKLINE(VAR327>90,LOW*0.99,LOW*0.95,2,0),COLORYELLOW;
DRAWTEXT(VAR327>90,LOW*0.95,'追涨'),COLORYELLOW;
DRAWICON(VAR310>0 AND VAR327=0,HIGH*1.01,5);

{刻度线  副图}
RSV:=(HHV(HIGH,11)-CLOSE)/(HHV(HIGH,11)-LLV(LOW,11))*100;
QS1:SMA(RSV,3,1),COLORYELLOW,linethick2;
QS2:SMA(QS1,3,1),colorred,linethick2;
Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,10);
BB:EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*50,color00ff00,linethick2;


{买刻度线}
ccc:=bb-qs1;
dd2:=qs1-qs2;
dd:=slope(dd2,2);
MAI:if(ccc<-30 and bb<40,12,0),STICK,linethick3,COLOR0088ff;
MBI:if(ccc<-30 and bb<40 and dd<0,16,0),STICK,linethick3,COLOR0000ff;
{卖刻度线}
fff:=slope(bb,3);
MCI:if(ccc>110 and bb>130 and fff>5, -16,0),STICK,linethick3,COLORffff00;
0,linethick3,COLOR008800;

多空指标
多空力量
VAR2:=EMA(MA(IF(CLOSE>OPEN,(CLOSE-OPEN)*VOL,IF(CLOSEVAR3:=EMA(MA(IF(CLOSE>REF(CLOSE,1),(CLOSE-REF(CLOSE,1))*VOL,IF(CLOSE

(CLOSE-REF(CLOSE,1))*VOL,0)),5),1);
VAR4:=EMA(MA(IF(OPEN>REF(CLOSE,1),(OPEN-REF(CLOSE,1))*VOL,IF(OPEN

REF(CLOSE,1))*VOL,0)),5),1);
VAR5:=EMA(MA(IF(CLOSEOPEN,(OPEN-CLOSE)*VOL,0)),10),1);
VAR6:=EMA(MA(IF(CLOSEREF(CLOSE,1),(REF

(CLOSE,1)-CLOSE)*VOL,0)),10),1);
VAR7:=EMA(MA(IF(OPENREF(CLOSE,1),(REF

(CLOSE,1)-OPEN)*VOL,0)),10),1);
VAR8:=CLOSE>OPEN;
VAR9:=CLOSE>REF(CLOSE,1);
VARA:=OPEN>REF(CLOSE,1);
VARB:=VAR8 OR VAR9 OR VARA;
多头力量: (VAR2+VAR3+VAR4)/3/100,COLORWHITE;
空头力量: (VAR5+VAR6+VAR7)/3/100,COLORYELLOW;
STICKLINE(空头力量>0,空头力量,1,1,1),COLORYELLOW;
STICKLINE(空头力量<0,空头力量,1,1,1),COLOR6666FF;


筹码运动
筹码运动
VAR1:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,1);
主筹:EMA(WINNER(C)*70,1),COLORRED,LINETHICK1;
主筹月均:EMA(主筹,21),COLORWHITE;
主筹长期成本:EMA(EMA(主筹,5),89),COLOR009500;
筹差值:VAR1-主筹,COLORYELLOW;
VAR2:=IF(C>=O,H,0);
VAR3:=IF(C<=O,REF(H,1),VAR2);
VAR4:=IF(C>=O,V,0);
VAR5:=IF(C<=O,REF(V,1),VAR4);
VAR6:=COUNT(VAR3>REF(VAR3,1) AND VAR5=2 AND C>O;
量价背离:VAR6*30,STICK,COLORGRAY,LINETHICK2;
特色指标通达信全部源码
特色指标通达信全部源码


冰火两重天
按部就班
波段无敌
筹码分析
多空博弈
龙腾四海
买卖频谱
主力进出 B
喜欢盘线

{冰火两重天 P,1,100,16}
能量:=SQRT(VOL)*(((C-(H+L)/2))/((H+L)/2));
平滑能量:=EMA(能量,P);
能量惯性:EMA(平滑能量,P) ;
STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.05),(能量惯性-能量惯性*0.15),3,0), COLOR0000CC;
STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.2),(能量惯性-能量惯性*0.35),3,0), COLOR0066ff;
STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.4),(能量惯性-能量惯性*0.55),3,0),COLOR0099ff;
STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.6),(能量惯性-能量惯性*0.75),3,0), COLOR00CCff;
STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.8),(能量惯性-能量惯性*0.95),3,0), COLOR00ffff;
STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.05),(能量惯性-能量惯性*0.15),3,0), COLORff3300;
STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.2),(能量惯性-能量惯性*0.35),3,0), COLORFF6600;
STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.4),(能量惯性-能量惯性*0.55),3,0), COLORFF9900;
STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.6),(能量惯性-能量惯性*0.75),3,0), COLORffcc00;
STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.8),(能量惯性-能量惯性*0.95),3,0), COLORffff00;

{//按部就班 N,1,100,5 }
现价:C;
顶部: COST(19*n),colorffff33;
卖出: COST(15*n),colorgreen;
买入: COST(6*n),colorred;
底部: COST(1*n),coloryellow;

{ file://波段无敌   }
P1:=0;
P2:= IF (CLOSE>MA(CLOSE,5),P1+10,P1-10);
P3:= IF (CLOSE>MA(CLOSE,10),P2+10,P2-10);
P4:= IF (CLOSE>MA(CLOSE,10),P3+10,P3-10);
P5:= IF (MA(CLOSE,5)>MA(CLOSE,10),P4+10,P4-10);
P6:= IF (MA(CLOSE,10)>MA(CLOSE,20),P5+10,P5-10);
BD6;
STICKLINE(BD>=-50,-50,BD,3,0),COLORGREEN;
STICKLINE(BD>=-30,-30,BD,3,0),COLORFFFF00;
STICKLINE(BD>=0,0,BD,3,0),COLORYELLOW;
{STICKLINE(BD<=50 AND BD>=30,30,BD,3,0),COLORRED;}
STICKLINE(BD<=50 OR BD>=30,30,BD,3,0),COLORRED;

{ //筹码分析 }
HSL:=EMA(VOL/CAPITAL,3);
ZDL:=HHV(HSL,240);
ZXL:=LLV(HSL,240);
XS:=MA(C,33);
锁定筹码:EMA((HSL-ZXL)/ZXL*XS,13);
浮动筹码:EMA((ZDL-HSL)/HSL*XS,13);
力量对比:锁定筹码-浮动筹码 ,COLORSTICK

{//多空博弈}
Var1:=(HHV(HIGH,21)-C)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var2:=(C-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var3:=SMA(Var2,13,8);
高位:90;
低位:0;
多方: SMA(Var3,13,8),COLORRED;
空方: SMA(Var1,21,8),COLOR00FF00;
中轴:45

{ file://龙腾四海 N,1,100,8 }


龙腾四海:100-100*(HHV(HIGH,5*N)-CLOSE)/(HHV(HIGH,5*N)-LLV(LOW,5*N)),COLOR00FFFF;
海面:20,COLOR0000FF;
海天分界线:50,COLOR00FF00;
天际:80,COLORFF8800 ;
坐标线:0;20;50;80;100;

{ file://买卖频谱}
买线:EMA(C,3);
卖线:EMA(SLOPE(C,21)*20+C,55);
买卖差:=买线-卖线;
STICKLINE(买卖差>=0,(买线-买卖差*0.05),(买线-买卖差*0.15),3,0) ,COLOR00ffff;
STICKLINE(买卖差>=0,(买线-买卖差*0.2),(买线-买卖差*0.35),3,0) ,COLOR00ccff;
STICKLINE(买卖差>=0,(买线-买卖差*0.4),(买线-买卖差*0.55),3,0) ,COLOR0099ff;
STICKLINE(买卖差>=0,(买线-买卖差*0.6),(买线-买卖差*0.75),3,0) ,COLOR0066ff;
STICKLINE(买卖差>=0,(买线-买卖差*0.8),(买线-买卖差*0.95),3,0) ,COLOR0000cc;
STICKLINE(买卖差<0,(卖线+买卖差*0.05),(卖线+买卖差*0.15),3,0) ,COLOR006600;
STICKLINE(买卖差<0,(卖线+买卖差*0.2),(卖线+买卖差*0.35),3,0) ,COLOR009900;
STICKLINE(买卖差<0,(卖线+买卖差*0.4),(卖线+买卖差*0.55),3,0) ,COLOR00cc00;
STICKLINE(买卖差<0,(卖线+买卖差*0.6),(卖线+买卖差*0.75),3,0) ,COLOR00ff00;
STICKLINE(买卖差<0,(卖线+买卖差*0.8),(卖线+买卖差*0.95),3,0) ,COLOR66ff00;

{/主力进出 }
MAV:=(C*2+H+L)/4;
SK:=EMA(MAV,13) - EMA(MAV,34);
SD:=EMA(SK,5);
中轴:0;
空方主力 : (-2*(SK-SD))*3.8,COLOR00FF00;
多方主力 : (2*(SK-SD))*3.8,COLORRED;

{喜欢盘线}
MA5:MA(CLOSE,5),ColorFFFfff,linethick1;
MA10:MA(CLOSE,10),Color00Ffff,linethicK1;
MA21:MA(CLOSE,21),Color00ff00,linethick1;
MA30:MA(CLOSE,30),ColorFF00ff,linethick1;
MA60:MA(CLOSE,60),Color0000ff,linethick1;
MA120:MA(CLOSE,120),ColorFFff00,linethick1;
买线:EMA(C,2),color000000;
卖线:EMA(SLOPE(C,21)*20+C,42),pointdot,color000000;
BUY:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(buy,LOW*0.99,'Ψ'),colorf00ff0,linethick5;
drawtext(sel,HIGH*1.01,'◎'),colorwhite,linethick5;
stickline(买线>=卖线,low,high,0.1,0),colorred;
stickline(买线>=卖线,close,open,4.5,0),color0000AA;
stickline(买线>=卖线,close,open,3,0),color0000CC;
stickline(买线>=卖线,close,open,2,0),color0000DD;
stickline(买线>=卖线,close,open,1,0),color0000FF;
stickline(买线<卖线,close,open,1,0),colorEEEE00;
stickline(买线<卖线,close,open,2,0),colorDDDD00;
stickline(买线<卖线,close,open,3,0),colorCCCC00;
stickline(买线<卖线,close,open,4.5,0),colorAAAA00;
stickline(买线<卖线,low,high,0.1,0),colorFFff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,3.5,0),coloryellow;


{铁底成本  副图}(飞狐,大智慧L2改)
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
Y:EMA(X,13),COLORWHITE,LINETHICK2,POINTDOT;
DRAWTEXT(X>Y AND REF(X>Y,1)=0,X-0.5,'↑');
VAR4:=(2*CLOSE+HIGH+LOW)/4;
成本区:EMA(VAR4,90)*0.995,COLORFFCCCC,CIRCLEDOT;
操作区:EMA(VAR4,120)*0.998,COLORRED,LINETHICK2;
铁底区:EMA(VAR4,240)*0.885,COLORYELLOW,LINETHICK2;


{追牛至顶  主图)}

A:=(3*C+L+O+H)/6;
B:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF
(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF
(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
多:MA(B,2),COLORRED;
空:MA(B,3),COLORBLUE;
操作:MA(B,13),COLORYELLOW;
波段牛熊:MA(B,34),COLORGREEN;
长期牛熊:MA(B,233),COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(BU,LOW*0.999,'B'),COLORRED,LINETHICK3;
DRAWTEXT(SEL,HIGH*1.008,'S'),COLORFFFF00,LINETHICK3;
STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),COLOR0000EE;
STICKLINE(买线<卖线,CLOSE,OPEN,2,0),COLOREEEE00;
STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORFFFF00;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,2,0),COLOR00FFFF;
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK1,COLORFFFFFF;
界:=MA(CLOSE,27),LINETHICK1,COLOR00FFFF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
G:=95;
DRAWTEXT(CROSS(J,D),L*0.999,'P'),COLOR00FFFF,LINETHICK4;
DRAWTEXT(CROSS(J,G),H*1.005,'M'),COLORFFFF00,LINETHICK4;


{牛魔出山  副图  有未来ZIG}


V0:=ZIG(3,10);V1:=MA(V0,2);V3:=CONST(HHV(V1,200));V4:=CONST(0);
V6:=IF((V0>REF(V0,1)),0,C);V7:=IF(FILTER(V6,120),1,0);
V5:=REF(V6,1)=0 AND V6>0 AND V7=0;
V8:=NOT((H<=HHV(H,20) AND H>=HHV(H,20)*0.99) OR HV9:=IF(FILTER(IF((V0>REF(V0,1)),0,C),120),1,0);
DDD:=IF(V5,0,1);
FFF:=IF(V1>REF(V1,1) AND DDD AND V9=0 AND IF(DATE>1080630,0,V8),1,0);
{FFF:=1;}
H1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
H2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
H3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
H4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A1:=BARSLAST(CROSS(30,H1))<2 AND BARSLAST(CROSS(H1,50))<2;
B1:=BARSLAST(CROSS(H4,H1))<2 AND H1>H4;
E1:=H1>60 AND H4>70;
牛魔出山:IF(A1 AND B1 AND E1 AND FFF,10,0),COLORRED;
A2:=BARSLAST(CROSS(50,H1))<3 AND BARSLAST(CROSS(H1,50))<3;
B2:=BARSLAST(CROSS(H4,H1))<2 AND H1>H4;
疯牛越栏:IF(A2 AND B2 AND FFF,9,0),COLORLIRED;
A21:=BARSLAST(CROSS(H4,H1))<5 AND H1>H4;
牛心不改:IF(COUNT(A21,3)=1 AND A21 AND FFF,8,0),COLORYELLOW;
A3:=BARSLAST(CROSS(H4,H1))>3 AND BARSLAST(CROSS(H1,H4))<3;
B3:=BARSLAST(CROSS(H4,H2));
E3:=BARSLAST(CROSS(H4,H3))>3 AND BARSLAST(CROSS(H1,H4))<3;
{B31:=A>0 AND REF(A,1)=0 AND REF(A,2)>0; }
牛动震仓:IF(A3 AND B3 AND E3 AND H2 AND H3 AND FFF,7,0),COLOR0088CC;
{短线追涨 (高位横盘突破)}
H40:=BARSLAST(CROSS(97,H1))<=1 AND BARSLAST(CROSS(H1,85))<=1;
H41:=BARSLAST(CROSS(97,H2))<=1 AND BARSLAST(CROSS(H2,85))<=1;
H42:=BARSLAST(CROSS(97,H1))<=2 AND BARSLAST(CROSS(H1,85))<=1;
H43:=BARSLAST(CROSS(97,H2))<=2 AND BARSLAST(CROSS(H2,85))<=1;
H44:=H40 AND H41;
H45:=H42 AND H43 ;
H46:=BARSLAST(CROSS(97,H1))<=3 AND BARSLAST(CROSS(H1,85))<=1;
H47:=BARSLAST(CROSS(97,H2))<=3 AND BARSLAST(CROSS(H2,85))<=1;
H48:=H46 AND H47;
{H490:=REF(H44,1);H491:=REF(H45,1);H492:=REF(H48,1);}
Y41:=H1=100 AND H2=100  AND H44 ;
Y42:=H1=100 AND H2=100  AND H45 ;
Y43:=H1=100 AND H2=100  AND H48 ;
栏牛顶角:IF((Y41 OR Y42 OR Y43) AND FFF,6,0),COLORMAGENTA;
{波段启动前兆}
A6:=H3=100;
B6:=H4<90;
牛蹄初步:IF(COUNT(A6,2)=2 AND B6 AND FFF,5,0),COLORGREEN;
{捉中线牛股起涨点}
A7:=H1=H2 AND H2=H3 AND H1=100 AND H4>96;
B7:=COUNT(A7,2)=1;
D7:=H1;
YH:=INDEXC/REF(INDEXC,1)*REF(C,1);
YH1:=REF(C,1)+C-INDEXC/REF(INDEXC,1)*REF(C,1);
X71:=EMA(YH1,7);
X72:=EMA(YH1,14);
X73:=EMA(X71,14);
E7:=X71>X72 AND X72>X73;
T44:=IF(B7 AND D7 AND E7 AND FFF,4,0),COLOR6600FF;
{精确定位起涨第一日}
A5:=BARSLAST(CROSS(95,H1))<=2;

B5:=BARSLAST(CROSS(95,H2))<=2;
E5:=H4;
F5:=H2>50 AND H3>50;
G5:=H1=100 AND H2=100;
T5:=COUNT(G5,2)=1;
T55:=IF(A5 AND B5 AND E5 AND F5 AND T5 AND FFF,3,0),COLORFFAA55;
T66:=IF((H1=100 AND REF(H1,2)=100 AND REF(H1,1)=100 AND
    H2=100 AND H3=100 AND H4=100 AND REF(H2,2)<100 AND
    REF(H3,2)<100 AND REF(H4,2)<100) OR (H1=100 AND
    REF(H1,3)=100 AND REF(H1,2)=100 AND REF(H1,1)=100 AND
    H2=100 AND H3=100 AND H4=100 AND REF(H2,3)<100 AND
    REF(H3,3)<100 AND REF(H4,3)<100) AND FFF,2,0),COLOR448822;
牛性顿起:IF(T44 OR T66 AND FFF,4,0),COLORFFAA55;
牛气阵阵:IF(T55 AND FFF,2.5,0),COLORLIGRAY;
选牛:IF(牛魔出山 OR 疯牛越栏 OR 牛心不改 OR 牛动震仓 OR 栏牛顶角 OR 牛蹄初步 OR 牛性顿起
OR 牛气阵阵,1,0);

{抓牛线}

VAR1:=MA((HIGH+LOW+2*CLOSE)/4,5);
VAR2:=EMA(VAR1,10)-EMA(VAR1,30);
VAR3:=EMA(VAR2,5);
VAR4:=(VAR2-VAR3)*5;
VAR5:=IF(VAR4<=VAR1,VAR1,VAR4);
动向:= FORCAST(FORCAST(VAR5,10),10),LINETHICK1;
趋势: IF(VAR5>动向,VAR5,VAR1),COLORYELLOW;
强势: MA(VAR1,5),COLORRED;
弱势:= MA(HHV(VAR1,10),5),COLORWHITE;
主力: SMA(CLOSE,10,1),COLORFFFF00;
疯牛: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),LINETHICK2,COLORRED;
年线: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),LINETHICK2,POINTDOT,COLOR30CC00;
VAR6:=EMA(CLOSE,5);
VAR7:=EMA(CLOSE,10);
VAR8:=EMA(CLOSE,20);
VAR9:=EMA(CLOSE,30);
VARA:=EMA(CLOSE,60);
VARB:=EMA(CLOSE,90);
VARC:=EMA(CLOSE,125);
VARD:=EMA(CLOSE,250);
VAR10:=1.809*LLV(LOW,250);
VAR11:=MA(CLOSE,10)-EMA(CLOSE,10)*100;
VAR12:=MA(VAR11,5);
VAR13:=3*(VAR12-VAR11);
VAR14:=((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*200-100)/2-REF(CLOSE,5);
VAR15:=SMA(SMA(VAR14,5,1),5,1);
VAR16:=MA(MA(VAR15,5),5);
VAR17:=3*VAR16-5*VAR15;
VAR18:=EMA(VAR17,10);
VAR19:=MA(CLOSE,20)/MA(CLOSE,20)-REF(CLOSE,20)/CLOSE*100;
VAR1A:=DMA(SMA(EMA(VAR19,5),5,1),VOL/REF(VOL,5));
VAR1B:=SMA(EMA(VAR19,10),5,1);
VAR1C:=(-100)*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
VAR1D:=(-100)*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
VAR1E:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
VAR1F:=HIGH-REF(HIGH,1);
VAR20:=REF(LOW,1)-LOW;
VAR21:=SMA(IF(VAR1F>0 AND VAR1F>VAR20,VAR1F,0),14,1);
VAR22:=SMA(IF(VAR20>0 AND VAR20>VAR1F,VAR20,0),14,1);
VAR23:=VAR21*100/VAR1E;
VAR24:=VAR22*100/VAR1E;
VAR25:=SMA(ABS(VAR24-VAR23)/(VAR24+VAR23)*100,14,1);
VAR26:=(VAR25+REF(VAR25,6))/2;
DRAWTEXT(CROSS(VAR13,50) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND

VARA>VARB AND VARB>VARC AND VARC>VARD AND
疯牛>VARD AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND -

30>VAR18 AND VAR18>VAR17 AND
VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'宝典'),COLORYELLOW;
DRAWTEXT(CROSS(VAR13,200) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND

VARA>VARB AND VARB>VARC AND VARC>VARD AND
VARD>年线 AND 年线>VAR10 AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND

VAR1D>-20 AND VAR23>VAR25 AND
VAR25>VAR26 AND VAR26>VAR24,年线,'疯牛'),COLORYELLOW;

{宝典疯牛  主图}      
     
VAR1:=MA((HIGH+LOW+2*CLOSE)/4,5);     
VAR2:=EMA(VAR1,10)-EMA(VAR1,30);     
VAR3:=EMA(VAR2,5);     
VAR4:=(VAR2-VAR3)*5;     
VAR5:=IF(VAR4<=VAR1,VAR1,VAR4);     
动向:= FORCAST(FORCAST(VAR5,10),10),LINETHICK1;    
趋势: IF(VAR5>动向,VAR5,VAR1),COLORYELLOW;    
强势: MA(VAR1,5),COLORRED;     
弱势:= MA(HHV(VAR1,10),5),COLORWHITE;     
主力: SMA(CLOSE,10,1),COLORFFFF00;     
疯牛: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL/CAPITAL),LINETHICK2,COLORRED;     
年线: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL/CAPITAL),LINETHICK2,POINTDOT,COLOR30CC00;     
VAR6:=EMA(CLOSE,5);     
VAR7:=EMA(CLOSE,10);     
VAR8:=EMA(CLOSE,20);     
VAR9:=EMA(CLOSE,30);     
VARA:=EMA(CLOSE,60);     
VARB:=EMA(CLOSE,90);     
VARC:=EMA(CLOSE,125);     
VARD:=EMA(CLOSE,250);     
VAR10:=1.809*LLV(LOW,250);     
VAR11:=MA(CLOSE,10)-EMA(CLOSE,10)*100;     
VAR12:=MA(VAR11,5);     
VAR13:=3*(VAR12-VAR11);     
VAR14:=((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*200-100)/2-REF(CLOSE,5);     
VAR15:=SMA(SMA(VAR14,5,1),5,1);     
VAR16:=MA(MA(VAR15,5),5);     
VAR17:=3*VAR16-5*VAR15;     
VAR18:=EMA(VAR17,10);     
VAR19:=MA(CLOSE,20)/MA(CLOSE,20)-REF(CLOSE,20)/CLOSE*100;     
VAR1A:=DMA(SMA(EMA(VAR19,5),5,1),VOL/REF(VOL,5));     
VAR1B:=SMA(EMA(VAR19,10),5,1);     
VAR1C:=(-100)*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));     
VAR1D:=(-100)*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));     
VAR1E:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);     
VAR1F:=HIGH-REF(HIGH,1);     
VAR20:=REF(LOW,1)-LOW;     
VAR21:=SMA(IF(VAR1F>0 AND VAR1F>VAR20,VAR1F,0),14,1);     
VAR22:=SMA(IF(VAR20>0 AND VAR20>VAR1F,VAR20,0),14,1);     
VAR23:=VAR21*100/VAR1E;     
VAR24:=VAR22*100/VAR1E;     
VAR25:=SMA(ABS(VAR24-VAR23)/(VAR24+VAR23)*100,14,1);     
VAR26:=(VAR25+REF(VAR25,6))/2;     
DRAWTEXT(CROSS(VAR13,50) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND 疯牛>VARD AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND -30>VAR18 AND VAR18>VAR17 AND       VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'宝典'),COLORYELLOW;
DRAWTEXT(CROSS(VAR13,200) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND
VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND
VARD>年线 AND 年线>VAR10 AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND
VAR1C>-20 AND VAR1D>-20 AND VAR23>VAR25 AND
VAR25>VAR26 AND VAR26>VAR24,年线,'疯牛'),COLORYELLOW;


{牛熊骨头炖 副图}

{INPUT.:牛熊骨(18,0,888),心理线(15,0,888);}
RSV:=(((CLOSE - LLV(LOW,(牛熊骨 + 3))) / (HHV(HIGH,(牛熊骨 + 3)) - LLV(LOW,19))) * 100);
FASTK:=(((SMA(RSV,8,1) - 50) * 1.4) + 50);
D:=SMA(FASTK,8,1);
SSS:=SMA(D,8,1);
IF(D<=REF(D,1),D,DRAWNULL),COLOR005C00,LINETHICK8;
IF(D<=REF(D,1),D+1.5,DRAWNULL),COLOR007D00,LINETHICK8;
IF((D <= REF(D,1)),D+3,DRAWNULL)COLOR00B400,LINETHICK8;
IF((D <= REF(D,1)),D+4.5,DRAWNULL),COLOR00DE00,LINETHICK8;
IF((D <= REF(D,1)),D+6,DRAWNULL),COLOR00FF00,LINETHICK8;
IF(SSS>= REF(SSS,1),SSS,DRAWNULL),COLOR000082,LINETHICK8;
IF(SSS>= REF(SSS,1),SSS+1.5,DRAWNULL),COLOR00009D,LINETHICK8;
IF(SSS>= REF(SSS,1),SSS+3,DRAWNULL),COLOR0000B4,LINETHICK8;
IF(SSS>= REF(SSS,1),SSS+4.5,DRAWNULL),COLOR0000D6,LINETHICK8;
IF(SSS>= REF(SSS,1),SSS+6,DRAWNULL),COLOR0000FF,LINETHICK8;
B:=SSS;
W:=CROSS(BACKSET(ISLASTBAR,5),0.5);
VAR19:=BARSLAST(W);
DRAWLINE(W=1,B,ISLASTBAR AND B>REF(B,VAR19),B,1),COLOR0000FF,LINETHICK1;
DRAWLINE(W=1,B,ISLASTBAR AND B(COUNT(CLOSE>REF(CLOSE,1),心理线)/心理线)*100,COLORFF00FF,LINETHICK3;

{DRAWTEXT((SYSPARAM(1) = BARPOS),0,'☆'),ALIGN5,COLORFFFF;};


{【霸占大牛股】  副图}
M5:EMA(C,8),COLORFFAA66,LINETHICK2;
M6:EMA(C,13),COLORBLUE,LINETHICK3;
M7:MA(C,78),COLOR00FFFF,LINETHICK1;
M8:EMA(M7,3),COLOR00FFFF,LINETHICK1;
M9:EMA(M8,3),COLOR00FFFF,LINETHICK1;
M11:EMA(M9,3),COLOR00FFFF,LINETHICK1;
MA47:EMA(CLOSE,46),COLORFFAA66,LINETHICK2;
MA60:EMA(CLOSE,60),COLORBLUE,LINETHICK3;
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0JUD0:=REF(C,1)>=REF(UDGLINE,1) AND CJDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)DRAWTEXT(JDU2,M9*0.90,'锁定牛股'),COLORYELLOW;
DRAWTEXT(CROSS(M6,M9),M9*0.98,'霸占大牛股'),COLOR0000FF;


{搜牛 副图}

VAR1:=(HIGH+LOW+CLOSE)/3;
搜牛趋势: HHV(MA((LOW+HIGH+CLOSE)/3,5),1),COLORFF00FF;
搜牛轨道: LLV(MA((LOW+HIGH+CLOSE)/3,5),10),COLOR003300;
搜牛箱顶: HHV(MA((LOW+HIGH+CLOSE)/3,8),58),COLOR009900;
搜牛箱底: LLV(MA((LOW+HIGH+CLOSE)/3,8),58),COLOR006600;
VAR2:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+搜牛箱底,2);
VAR3:=(3*VAR2-2*SMA(VAR2,5,1))*0.6;
搜牛线: IF(VAR3>1.02*搜牛趋势,1.02*搜牛趋势,IF(VAR3<0.985*搜牛趋势,0.985*搜牛趋势,VAR3)),COLORBLUE;
STICKLINE(搜牛线>搜牛趋势,搜牛趋势,搜牛线,1,0),COLOR009900;
VAR4:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VAR5:=EMA(3*VAR4-2*SMA(VAR4,18,1),5);
VAR6:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VAR7:=3*SMA(VAR6,3,1)-2*SMA(SMA(VAR6,3,1),5,1);
主力控盘: STICKLINE(VAR7>VAR5,1*搜牛箱底,搜牛箱底,0,0),COLORFF00FF;
VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
VARA:=EMA(VAR9,5);
大盘资金: VAR9-VARA+搜牛箱底,COLORFF00FF;
STICKLINE(大盘资金>搜牛箱底,大盘资金,搜牛箱底,0,0),COLORFF00FF;
STICKLINE(大盘资金<搜牛箱底,大盘资金,搜牛箱底,0,0),COLORBLUE;

{牛熊买卖  副图 含WINNER}

{P1:3;P2:25;P3:55;P4:120}
MA1:MA(CLOSE,3);
MA2:MA(CLOSE,25);
MA3:MA(CLOSE,55);
MA4:MA(CLOSE,120);
牛熊:EMA(CLOSE,240);
底部:MA(CLOSE,125)-2*STD(CLOSE,165);
VAR1:=100*(WINNER(CLOSE)-WINNER(OPEN));
VAR2:=VAR1;


{大牛股  副图}

VAR1:=MA(VOL,5)=HHV(MA(VOL,5),10);
VAR2:=VOL>MA(VOL,5);
VAR3:=VAR1 AND VAR2;
VAR4:=REF(VAR3,1) OR REF(VAR3,2) OR REF(VAR3,3) OR REF(VAR3,4) OR REF(VAR3,5) OR REF(VAR3,6) OR REF(VAR3,7) OR REF(VAR3,8) OR REF(VAR3,9) OR REF(VAR3,10) OR REF(VAR3,11) OR REF(VAR3,12) OR REF(VAR3,13) OR REF(VAR3,14) OR REF(VAR3,15) OR REF(VAR3,16) OR REF(VAR3,17) OR REF(VAR3,18) OR REF(VAR3,19) OR REF(VAR3,20);
ENTERLONG: VAR1 AND VAR2 AND NOT(VAR4);

{牛市突破  主图}

A:EMA(CLOSE,13),COLORGREEN;
A1:EMA(CLOSE,55),COLORYELLOW;
A22:EMA(CLOSE,120),COLORMAGENTA;
AAAA:=FILTER(CLOSE>REF(HHV(HIGH,100),1)
AND REF(C,1)AND EXIST(EVERY(C>EMA(C,120),30),100)AND C/EMA(C,100)<1.5;
DRAWICON(AAAA,LOW,1);


{搜牛!(上涨能量、中短阻力一目了然)}

{N=100;M=1;P=20}
MAV:=(C*2+H+L)/4;
SK := EMA(MAV,1) - EMA(MAV,40);
SD := EMA(SK,5);
B:=(SK-SD)*N;
短线拉升:IF(B<-20,-20,IF(B>100,100,B)),COLORRED,LINETHICK2;
T:=(C-LLV(1.02*L,20))/(HHV(H,20)-LLV(L,20))*100;
上涨量能:IF(T>100,100,IF(T<0,0,T)),COLORFF00FF;
A:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20;
A1:=(3*A-2*SMA(A,3,1))*M;
短线阻力:IF(A1>100,100,IF(A1<-5,-5,A1)),COLORBLUE,LINETHICK2;
Q1:=(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*120,COLOR009900,LINETHICK2;
中线阻力:IF(Q1>100,100,Q1),COLOR009900;
STICKLINE(短线阻力>短线拉升 ,短线拉升,短线阻力,1,0),COLORBLUE;


主力筹码
庄筹估算:EMA(WINNER(C)*70,3)*C,COLORMAGENTA ;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5)*C, COLORGREEN;
成本压力:REF(MA(COST(95)*0.7,3),1)*100,COLORRED;
主升浪
VAR1:=WINNER(CLOSE*0.900)*100;
VAR2:=VOL/CAPITAL*100;
VAR3:=VAR1-VAR2;
VAR4:=VAR3<1;
VAR5:=VAR3>=1 AND VAR3<5;
VAR6:=VAR3>=5 AND VAR3<10;
VAR7:=VAR3>=10 AND VAR3<25;
VAR8:=VAR3>=25;
极弱股:IF(VAR4, (-10), 0),COLORWHITE, STICK;
弱势股:IF(VAR5, (-5), 0),COLORYELLOW, STICK;
转型股:IF(VAR6, 5, 0),COLORFF00FF, STICK;
强势股:IF(VAR7, 10, 0),COLORRED, STICK;
主升浪:IF(VAR8, 15, 0),COLORFFFF00, STICK;


主力进场
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,0 ),COLORRED;
洗盘:
STICKLINE(VAR5


{黑牛均线副图指标}

主力:EMA(CLOSE,10),COLORRED;
散户:EMA(CLOSE,5),COLORWHITE;
绿降:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
DRAWTEXT((CROSS(主力,操盘) AND 主力>REF(主力,1)) OR (CROSS(散户,绿降) AND CROSS(散户,主力)),操盘,'拉升'),COLORRED;
DRAWTEXT(CROSS(界点,操盘) AND REF(CROSS(界点,主力),2),操盘,'抢反弹'),COLORYELLOW;
DRAWTEXT((CROSS(操盘,绿降) AND REF(CROSS(散户,操盘),1)) OR (CROSS(散户,绿降) AND REF(CROSS(散户,操盘),1)),操盘,'要涨'),COLORFF77FF;
DRAWTEXT(CROSS(界点,绿降) AND 界点>REF(界点,1) AND 绿降>REF(绿降,2),操盘,'追涨'),COLORFFEEFF;
帮大家看青楚大盘的动向,回避风险
{鹰眼判断  主图}
A1:=C*2-REF(C,8.5/2);
A2:=REF(C,19/3)*2-C;
短期对称:=(A1+A2)/2;
关键点:=HHV(短期对称,27/2);
M1:=L*2-REF(H,27/2);
M2:=REF(H,27/2)*2-L;
M3:=(M1+M2)/2;
中期对称:=FORCAST(M3,21);
趋势判断:MA(M3,27*2),COLOR0000FF,NODRAW;
VAR5:=EMA((O+H+L+C)/4,233);
鹰派审美观:=VAR5+VAR5*6/100;
AMV0:=V*(O+C)/2;
朦胧才是美:=SUM(AMV0,45.5)/SUM(V,45.5);
CG:=MA(C,12.5);
FL:=HHV(CG,9);
FS:=CG-FL-CG;
ZA5:=趋势判断-REF(趋势判断,1);
IF(ZA5<0,趋势判断,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
IF(ZA5>0,趋势判断,DRAWNULL),COLOR0000FF,POINTDOT,LINETHICK4;
IF(ZA5=0,趋势判断,DRAWNULL),COLOR00FFFF,POINTDOT,LINETHICK4;
STICKLINE(C>=CG,O,C,2.5,0),COLOR0000FF;
STICKLINE(C>=CG,L,O,0,1),COLOR0000FF;
STICKLINE(C>=CG,C,H,0,1),COLOR0000FF;
STICKLINE(CSTICKLINE(CSTICKLINE(CH1:=HHVBARS(A1,13);
HB:=HHVBARS(A1,4.5);
短线判断:REF(短期对称,HB),COLORFFFF00;
中线判断:REF(M3,H1),COLOR00FFFF;


{大盘神针  副图}

VAR1:=INDEXA/100000000;
VAR2:=INDEXADV;
VAR3:=INDEXDEC;
VAR4:=VAR2/(VAR2+VAR3);
VAR5:=VAR3/(VAR2+VAR3);
VAR6:=EMA(VAR4,3);
VAR7:=EMA(VAR5,3);
VAR8:=EMA(VAR6,5);
VAR9:=EMA(VAR7,5);
进场资金: EMA(VAR8,10)/150 ,CIRCLEDOT,COLORRED;
资金: EMA(VAR9,10)/150, CIRCLEDOT,COLORGREEN;
大盘神针:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,3)),7,1)*100<20
AND SMA(MAX(CLOSE-REF(CLOSE,3),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,3)),13,1)*100<25
AND MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,5)>-19 
AND (LOW>LLV(LOW,5) AND (CLOSE-HHV(CLOSE,8))/HHV(CLOSE,8)<-0.05 AND
MA(AMOUNT,125)/MA(VOL,125)/(MA(AMOUNT,5)/MA(VOL,5))>1.12))*0.75;
买:=BARSLAST(大盘神针)<15 AND  CROSS(MACD.DIF,MACD.DEA);
底:=BARSLAST(LLV(L,4)=LLV(L,120))<5 ;
均线买:=CROSS(MA(C,5),MA(C,20));
介入:=(底 AND 均线买 AND (进场资金>资金) OR 买);
STICKLINE(介入,资金-0.5,资金+0.1,2,0),COLORRED;
DRAWTEXT(介入,资金-0.15,'介入'),COLORWHITE;
STICKLINE(大盘神针,资金-0.2,资金+0.6,2,0),COLORFFFF00;
DRAWTEXT(大盘神针,资金+0.5,'神针'),COLORFFFF00;
安全区:STICKLINE(底,资金-0.1,资金,3,0),COLORRED;


{做盘轨迹  副图}
STICKLINE(C>0,-20,100,100,0),COLOR334400;
主力做盘轨迹:(((CLOSE - MA(LLV(LOW,40),40)) / MA(LLV(LOW,40),40)) * 100),COLORF0F000;
BIAS1 : (CLOSE-MA(CLOSE,9))/MA(CLOSE,9)*100,COLORWHITE;
坚决买:=(主力做盘轨迹-BIAS1)<5.5;
DRAWTEXT(坚决买 ,38,'金子 '),COLORF0FF00;
STICKLINE (坚决买 ,0,30,5,0),COLORRED;
AA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*1000;
BB:=MA(AA,10);
趋势线:SMA(BB,3,1)/10,LINETHICK2,COLORRED;
JNYY2:=(((CLOSE - LLV(LOW,26)) / (HHV(HIGH,26) - LLV(LOW,26))) * 100);
判断:SMA(JNYY2,32,1)-20,COLOR00FF00,LINETHICK1;
买:DRAWTEXT(CROSS(趋势线,判断),趋势线+10,'买▲牛'),LINETHICK2,COLORWHITE;
建仓:DRAWTEXT(CROSS(判断,趋势线),判断,'建▲仓'),LINETHICK2,COLORYELLOW;
不怕死:DRAWTEXT(CROSS(主力做盘轨迹,判断),判断-10,'加▲码'),LINETHICK2,COLORRED;


秋风起蟹膏满+抄底不难,要等机会

 

{抄底不难,要等机会}
满仓:0.72*MA(FORCAST(CLOSE,2),40),COLOR0000FF;
DRAWTEXT(CROSS(满仓,L),L-0.7,'满仓');
DRAWICON(CROSS(满仓,L),L,1);
低吸:0.82*MA(FORCAST(CLOSE,2),40),COLORF7E300;
A:=DYNAINFO(3)>L AND 低吸>L;{DYNAINFO(3):昨日收盘价,不会导致信号漂移,以下类同}
DRAWTEXT(A,L,'低吸');
清仓:1.66*MA(FORCAST(CLOSE,2),40),LINETHICK2,COLORGREEN;
出货:1.36*MA(FORCAST(CLOSE,2),40),LINETHICK2,COLOR08FFFF;
高抛:1.16*MA(FORCAST(CLOSE,2),40),LINETHICK2,COLORFF82FF;
{秋风起蟹膏满}
VAR1A:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR2A:=REF(HIGH,10)/CLOSE>1.35;
VAR3A:=(COST(20)-CLOSE)/CLOSE>0.15;
VAR4A:=HIGH>LOW*1.051;
秋风起蟹膏满:=VAR4A AND COUNT(VAR4A,5)>1;
蟹膏满:=(((CLOSE-VAR1A)/VAR1A*100<-30) OR VAR2A) AND VAR3A AND 秋风起蟹膏满;
DRAWTEXT(蟹膏满,L-2,'秋风起蟹膏满');
DRAWICON(蟹膏满,L,1);
{输出满仓:0.72*收盘价的2日线性回归预测值的40日简单移动平均,COLOR0000FF
当满足条件满仓上穿最低价时,在最低价-0.7位置书写文字
当满足条件满仓上穿最低价时,在最低价位置画1号图标
输出低吸:0.82*收盘价的2日线性回归预测值的40日简单移动平均,COLORF7E300
A赋值:前收盘价>最低价 AND 低吸>最低价
当满足条件A时,在最低价位置书写文字
输出清仓:1.66*收盘价的2日线性回归预测值的40日简单移动平均,LINETHICK2,画绿色
输出出货:1.36*收盘价的2日线性回归预测值的40日简单移动平均,LINETHICK2,COLOR08FFFF
输出高抛:1.16*收盘价的2日线性回归预测值的40日简单移动平均,LINETHICK2,COLORFF82FF
VAR1A赋值:以成交量(手)的5日累和/3/当前流通股本(手)为权重收盘价的12日指数移动平均的动态移动平均
VAR2A赋值:10日前的最高价/收盘价>1.35
VAR3A赋值:(获利盘为20%的成本分布-收盘价)/收盘价>0.15
VAR4A赋值:最高价>最低价*1.051
秋风起蟹膏满赋值:VAR4A AND 统计5日中满足VAR4A的天数>1
蟹膏满赋值:(((收盘价-VAR1A)/VAR1A*100<-30) OR VAR2A) AND VAR3A AND 秋风起蟹膏满
当满足条件蟹膏满时,在最低价-2位置书写文字
当满足条件蟹膏满时,在最低价位置画1号图标}
==========================================
选股公式:
{抄底不难,要等机会}
满仓:=0.72*MA(FORCAST(CLOSE,2),40);
低吸:=0.82*MA(FORCAST(CLOSE,2),40);
A:=DYNAINFO(3)>L AND 低吸>L;
{秋风起蟹膏满}
VAR1A:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR2A:=REF(HIGH,10)/CLOSE>1.35;
VAR3A:=(COST(20)-CLOSE)/CLOSE>0.15;
VAR4A:=HIGH>LOW*1.051;
秋风起蟹膏满:=VAR4A AND COUNT(VAR4A,5)>1;
蟹膏满:=(((CLOSE-VAR1A)/VAR1A*100<-30) OR VAR2A) AND VAR3A AND 秋风起蟹膏满;
满仓 AND A AND 蟹膏满;
=======================================================================
满仓或低吸选股公式:
{抄底不难,要等机会}
满仓:=0.72*MA(FORCAST(CLOSE,2),40);
A:=CROSS(满仓,L);
低吸:=0.82*MA(FORCAST(CLOSE,2),40);
B:=DYNAINFO(3)>L AND 低吸>L;
A OR B;


{麒麟跟庄  主图}

{麒麟短线王}
AMV0:=VOL*(O+C)/2;
生命线:SUM(AMV0,88)/SUM(VOL,88),COLORFF00FF,LINETHICK2;
CG:MA(C,17),COLORFFCC66,LINETHICK2;
FL:=HHV(CG,2);
持股线:HHV(CG,2),COLOR00FF00;
FS:CG-(FL-CG),COLORYELLOW,LINETHICK2;

{跟庄到顶主图}
VAR4:=(LOW+HIGH+CLOSE)/3;
操作: MA(VAR4,5);
拉升: HHV(操作,13);
压力: HHV(操作,60);
买卖: LLV(操作,13);
底部支撑: LLV(LOW,60)*1.02;
顶部: HHV(HIGH,60)*0.98;


{极品公式七剑主图}
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=GJTJ1=GJTJ2 AND GJTJ2=GJTJ3 AND GJTJ1=100 AND GJTJ4>96;
B:=COUNT(A,2)=1;
D:=GJTJ1YH:=INDEXC/REF(INDEXC,1)*REF(C,1);
YH1:=REF(C,1)+C-INDEXC/REF(INDEXC,1)*REF(C,1);
X1:=EMA(YH1,7);
X2:=EMA(YH1,14);
X3:=EMA(X1,14);
E:=X1>X2 AND X2>X3;
竟星:=B AND D AND E;
DRAWTEXT(竟星,(L * 0.95),'竟星'),COLORWHITE;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5  AND GJTJ1>GJTJ4;
天瀑:=COUNT(XG,3)=1 AND XG;
DRAWTEXT(天瀑,(L * 0.95),'天瀑'),COLORYELLOW;
STICKLINE(天瀑,C,O,6,0),COLORYELLOW;
STICKLINE(天瀑,H,L,1,0),COLORYELLOW;
A1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B1:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
E1:=GJTJ1>60 AND GJTJ4>70;
白金:=A1 AND B1  AND E1;
DRAWTEXT(白金,(L * 0.95),'白金'),COLORGREEN;
STICKLINE(白金,C,O,6,0),COLORGREEN;
{日月}
A2:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B2:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=A2 AND B2;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A4:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A8:=AAA AND BAA ;
B21:=REF(A3,1);
B3:=REF(A4,1);
B4:=REF(A8,1);
D2:=GJTJ1=100 AND GJTJ2=100  AND A3 ;
D3:=GJTJ1=100 AND GJTJ2=100  AND A4 ;
D4:=GJTJ1=100 AND GJTJ2=100  AND A8 ;
日月:=D2 OR D3 OR D3;
DRAWTEXT(日月,(L * 0.95),'日月'),COLORF00FF0;
A5:=BARSLAST(CROSS(95,GJTJ1))<=2;
B5:=BARSLAST(CROSS(95,GJTJ2))<=2;
E5:= GJTJ4F1:=GJTJ2>50 AND GJTJ3>50;
G1:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G1,2)=1;
青干:=A5 AND B5 AND E5 AND F1 AND TX;
DRAWTEXT(青干,(L * 0.95),'青干'),COLORRED;
STICKLINE(青干,C,O,6,0),COLORRED;
STICKLINE(青干,H,L,1,0),COLORRED;
A6:=GJTJ3=100;
B6:=GJTJ4<90;
莫问:=COUNT(A6,2) = 2 AND B6;
DRAWTEXT(莫问,(L * 0.95),'莫问'),COLORBLUE;
A7:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
B7:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
黄金:=A7 AND B7;
DRAWTEXT(黄金,(L * 0.95),'黄金'),COLORFFBB00;
三十:MA(C,30),COLORRED,LINETHICK2;
跌:IF(MA(CLOSE,30)<=REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORGREEN,LINETHICK2;


{天堂地狱  主图}

VAR1:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100;
VAR2:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VAR3:=REF(VAR1,1)<-20 AND VAR2;
VAR4:=REF(VAR1,1)<-20 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VAR5:=FILTER(VAR3 OR VAR4,3);
VAR6:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPENVAR7:=REF(VAR1,1)>ABS(-20) AND VAR6;
VAR8:=REF(VAR1,1)>ABS(-20) AND CLOSE20;
VAR9:=FILTER(VAR7 OR VAR8,3);
VARA:=REF(VAR1,1)<-13 AND VAR2;
VARB:=REF(VAR1,1)<-13 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VARC:=FILTER(VARA OR VARB,3);
VARD:=REF(VAR1,1)>ABS(-13) AND VAR6;
VARE:=REF(VAR1,1)>ABS(-13) AND CLOSE20;
VARF:=FILTER(VARD OR VARE,3);
DRAWICON(VAR5*VAR1>0,LOW,1);
DRAWICON(VAR9*VAR1>0,HIGH,2);
DRAWTEXT(VARC*VAR1>0,1.02*REF(CLOSE,1),'关注');
DRAWTEXT(VARF*VAR1>0,0.99*REF(CLOSE,1),'风险');
VAR10:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(VAR10,3)+EMA(VAR10,6)+EMA(VAR10,12)+EMA(VAR10,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
生命线: EMA(CLOSE,55);
VAR11:=LLV(LOW,5);
VAR12:=HHV(HIGH,4);
VAR13:=EMA((VAR10-VAR11)/(VAR12-VAR11)*100,4);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,2);
DRAWTEXT(CROSS(VAR13,VAR14) AND VAR13<40,LOW,'买');
VAR15:=EMA(VAR10,13)-EMA(VAR10,34);
VAR16:=EMA(VAR15,5);
VAR17:=(-2)*(VAR15-VAR16)*3.8;
DRAWTEXT(CROSS(VAR17,MA(VAR17,3)) AND VAR16,HIGH,'卖');
VAR18:=(2*CLOSE+LOW+HIGH)/4;
天堂: EMA(VAR18,45)*1.15;
地狱: EMA(VAR18,40)*0.85;


{ 孟子强势  副图 }

强度:POW(MA(CLOSE/INDEXC,3)*10000,3);
形态:MA(MA(MA(MA(MA(强度,5),5),5),5),5);
强势:=BARSLASTCOUNT(形态/REF(形态,1)>1)>3;
MA5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA34:=MA(CLOSE,34);

AA10:=MA(C,10);
十日角度:ATAN((AA10-REF(AA10,1)))*180/3.1416,LINETHICK0;
AA20:=MA(C,20);
廿日角度:ATAN((AA20-REF(AA20,1)))*180/3.1416,LINETHICK0;

选股:强度*(CLOSE0 AND 

十日角度>0);

 

 

{趋势飘带}   主图

MA(EMA(CLOSE,12),1),COLORff00ff;
MA(EMA(CLOSE,12),3),COLORff00ff;
MA(EMA(CLOSE,12),5),COLORff00ff;
MA(EMA(CLOSE,12),7),COLORwhite;
MA(EMA(CLOSE,12),9),COLORff00ff;
MA(EMA(CLOSE,12),11),COLORff00ff;
MA(EMA(CLOSE,12),13),COLORff00ff;
MA(EMA(CLOSE,60),1),COLORGREEN;
MA(EMA(CLOSE,60),3),COLORGREEN;
MA(EMA(CLOSE,60),5),COLOR89BD00;
MA(EMA(CLOSE,60),7),COLORGREEN;
MA(EMA(CLOSE,60),9),COLORGREEN;
MA(EMA(CLOSE,60),11),COLORGREEN;
MA(EMA(CLOSE,60),13),COLORGREEN;
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),
LOW,'●'),COLORff00ff;
DRAWTEXT(FILTER(EMA(CLOSE,12)-EMA(CLOSE,60)>0 AND HIGH/EMA(CLOSE,12)>1.15,5),
HIGH,'●'),COLORYELLOW;
买卖力度     副


VAR1:=IF(YEAR>=2003 AND MONTH>=1,0,1);
VAR2:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10*VAR1;
买卖力度: SMA(VAR2,5,1)*VAR1;
卖出区: 1500*VAR1;
VAR3:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*VAR1;
VAR4:=(IF(CLOSE>OPEN,VAR3*(HIGH-LOW),IF(CLOSEOPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEOPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEOPEN,VAR3*(HIGH-LOW),IF(CLOSEVAR5:=AMOUNT/(100*VOL)*VAR1;
VAR6:=MA(VAR5,40)*VAR1;
VAR7:=100*(CLOSE-VAR6)/VAR6*VAR1;
底部追击: IF(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.08,300,200)*VAR1;
STICKLINE(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.08,1200,200,10,0)*VAR1;
买进: IF(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.05,300,200)*VAR1;
STICKLINE(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.05,800,200,6,1)*VAR1;
VAR8:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VAR9:=SMA(VAR8,3,1);
VARA:=SMA(VAR9,3,1);
D:SMA(VARA,5,1)*20;
短线泰斗   副


YS1:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
RK3:=EMA(YS1,10);
RK4:=STD(YS1,10);
RK5:=(((YS1 - RK3) * 100) / RK4);
RK6:=EMA(RK5,5);
RK7:=EMA(RK6,10);
涨:=(((EMA(RK6,10) + 100) / 2) - 5 );
跌:=EMA(涨,4);
回调可进:=IF((CROSS(涨,跌) AND (跌 < (0 - 10))),20,0);
风险:IF(CROSS(跌,80),80,100),LINETHICK1,COLOR99FF00;
量价线1:EMA(跌,4) ,COLORFFFF00;
量价线2:EMA(量价线1,4) ,COLOR00FF00;
量价线3:EMA(量价线2,4) ,COLORFFFF00;
量价线4:EMA(量价线3,4) ,COLORFF0000;
上升:IF((涨 > REF(涨,1)),涨,0),CIRCLEDOT,COLORFF0000;
下跌:IF((涨 < REF(涨,1)),涨,0),CIRCLEDOT,COLORF00F00;
转向:IF(CROSS(跌,80),涨,0),CIRCLEDOT,COLORF00FFF;
DRAWTEXT(回调可进,20,'回调可进'),COLORCCCCFF;
DRAWTEXT(((((涨 > REF(涨,1)) AND (跌 < 10)) AND (跌 > (0 - 10))) AND (REF(涨,1) < REF(涨,2))),10,'安全区'),COLORCCFF99;
VAR11:=SUMBARS(VOL,(FINANCE(7) * 100));
VAR22:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3) / CAPITAL));
VAR3:=(((CLOSE - VAR22) / VAR22) * 100);
VAR4:=HHV(VAR3,VAR11);
VAR5:=LLV(VAR3,VAR11);
VAR6:=(((VAR3 - VAR5) / (VAR4 - VAR5)) * 100);
K:=SMA(VAR6,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
MA1:=MA(J,3);
STICKLINE(((FILTER(((J > MA1) AND (J <= 3)),5) = 1) AND (跌 < 0)),涨,(涨 + 10),8,0),COLORFF00FF;
DRAWTEXT(((FILTER(((J > MA1) AND (J <= 3)),5) = 1) AND (跌 < 0)),(涨 + 13),'关注'),LINETHICK2,COLOR00FF00;
DRAWTEXT((((涨 < REF(涨,1)) AND (REF(涨,1) > REF(涨,2))) AND (涨 > 105)),(涨 - 3),'逃顶'),LINETHICK2,COLOR0000FF;


吉祥之烛    副


Var1:=REF(CLOSE,5);
Var2:=SMA(MAX(CLOSE-Var1,0),8,1)/SMA(ABS(CLOSE-Var1),8,1)*60;
火苗: MA(Var2,4), stick,color00ffff ,linethick3;
Var3:=MA(Var2,8);
Var4:=IF(Var2>Var3,火苗,0);
Var5:=IF(Var2DT:=Var4;
KT:=Var5;
RKP:IF(DT<=Var3,火苗,0),stick,linethick3,colorblue ;
QKP:IF(KT>=Var3,火苗,0),linethick2,colorwhite;
JKP:IF(DT>=Var3 ,火苗-8,0),stick,linethick4,color0033ff;
GP:=DRAWTEXT(QKP>0,40,'火灭了!'),colorwhite;


{超级排序盯庄 }   副

n:1 100 75

Var1:=3*SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,20,1)
-2*SMA(SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,20,1),15,1);
Var2:=3*SMA((OPEN-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,20,1)
-2*SMA(SMA((OPEN-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,20,1),15,1);
Var3:=100-Var2;
Var4:=100-Var1;
var6:=100*VOL/CAPITAL*10;
a:=IF(Var4总排序:IF(Var4进场资金:IF(Var4出场资金:IF(Var4>=REF(Var3,1),var6,0),COLORblue;
百日成交:ma(AMOUNT,100)*100/100000000;
百日换手:sum(v/capital*100,100);
STICKLINE(IF(进场资金>0,1,0),0,进场资金*10,4,0),COLORRED;
STICKLINE(IF(出场资金>0,1,0),0,出场资金*10,4,0),COLORblue;
选股:ref(总排序,1)=0 and 总排序>0,colorwhite;
{天堂星踏金浪}   副


Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=LLV(LOW,34);
Var3:=HHV(HIGH,34);
Var4:=LLV(LOW,13);
Var5:=HHV(HIGH,13);
Var6:=EMA((Var1-Var4)/(Var5-Var2)*100,5);
Var7:=EMA((Var1-Var2)/(Var3-Var2)*100,8);
金浪: Var6,coloryellow ,linethick2 ;
aa:ema(var6,7),colorf0f000;
海浪: Var7;
踏上金浪:if(cross(金浪,aa) and aa<=25 ,1,0),stick,colorred;
stickline(金浪stickline(海浪,0,海浪,10,0),color40cc00;
stickline(海浪,0,海浪*0.9,10,0),color40bc00;
stickline(海浪,0,海浪*0.8,10,0),color40ae00;
stickline(海浪,0,海浪*0.6,10,0),color409c00;
stickline(海浪,0,海浪*0.4,10,0),color409000;
stickline(金浪>=aa,金浪,aa,6,0),coloryellow;
stickline(aa>=海浪,aa,海浪,6,0),color40cc00;
drawicon(cross(金浪,aa) and aa<=25 ,金浪,1);
{战国箭雨}   副


Var1:=REF(CLOSE,2);
A2:SMA(MAX(CLOSE-Var1,0),7,1)/SMA(ABS(CLOSE-Var1),7,1)*100,COLOR00FF00;
车弩机: IF(A2<12,30,0);
Var2:=REF(CLOSE,1);
Var3:=SMA(MAX(CLOSE-Var2,0),7,1)/SMA(ABS(CLOSE-Var2),7,1)*100;
弯弓: IF(Var3<12,30,0);
STICKLINE(A2>80,A2+1,A2-1,4,0),COLORRED;
逢高派发区:0,COLORRED;
VAR1J:=close/(ema(ema((c+l+h)/3,3),26)*0.9)<0.95 ;
放箭:IF(VAR1J,15,0),STICK,linethick3,COLORRED;
DRAWTEXT(VAR1J ,8,'箭'),COLORF0F000;
Vare1:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
Vare2:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
Vare3:=IF(Vare1>0.010, 0.900, 1) AND IF(Vare1>(-0.025), 1, 1.200);
Vare4:=Vare3*(Vare2-Vare1)*100;
Vare5:=SUM(Vare4, 10);
Vare6:=SMA(Vare5, 40, 1);
Vare7:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);{Var38>Var39;}
Vare8:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND Vare7>0, 91, 0);
追击:IF(Vare8>90,30,0),STICK,linethick3,COLORBLUE;
DRAWTEXT(Vare8>90,30,'追击'),COLORYELLOW;
新改的三线开合 ,参数用原来的

C0:=(H+L+C+O)/4;
A1:=HHV(C0,N);A2:=LLV(C0,N);A3:=A1-A2;
A4:=SMA((C0-A2)/A3,3,1)*100;
B1:=HHV(C0,4*N);B2:=LLV(C0,4*N);B3:=B1-B2;
B4:=SMA((C0-B2)/B3,3,1)*100;
C1:=HHV(C0,11*N);C2:=LLV(C0,11*N);C3:=C1-C2;
C4:=SMA((C0-C2)/C3,3,1)*100;
短期相对价位:A4,COLOR66FFFF,LINETHICK2;
中期相对价位:B4,COLOR6688FF,LINETHICK2;
长期相对价位:C4,COLOR6600FF,LINETHICK2;
{天线:90,LINETHICK1,COLOREEEE33,POINTDOT;
地线:10,LINETHICK1,COLOR33EE33,POINTDOT;
中线:50,LINETHICK1,COLOREEEEEE,POINTDOT;}
短抛:IF(短期相对价位>99,55,0),LINETHICK0,COLORWHITE;
中抛:IF(中期相对价位>99,55,0),LINETHICK0,COLORYELLOW;
长抛:IF(长期相对价位>99,55,0),LINETHICK0,COLORMAGENTA;
STICKLINE(短期相对价位<4.10 ,25,0,3,0),COLORYELLOW;
STICKLINE(短期相对价位>99 ,95,100,4,0),COLORWHITE;
STICKLINE(中期相对价位>99 ,95,100,4,0),COLORYELLOW;
STICKLINE(长期相对价位>99 ,95,100,4,0),COLORMAGENTA;
STICKLINE(长期相对价位>=99 AND 中期相对价位>=99 AND 短期相对价位>=99,长期相对价位,50,1,0), COLORYELLOW;
STICKLINE(长期相对价位>=99 AND 中期相对价位>=99 AND 短期相对价位>=99,60,50,1,0),COLORRED;
STICKLINE(长期相对价位<=2 AND 中期相对价位<=2 AND 短期相对价位<=5 , 长期相对价位,50,1,0), COLORRED;
STICKLINE(长期相对价位<=2 AND 中期相对价位<=2 AND 短期相对价位<=5 , 35,50,1,0),COLORYELLOW;


{看趋势}   副


DBIAS:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13)*100;
大盘底:IF(REF(DBIAS,1)<-5 AND DBIAS>-5,100,0),STICK,LINETHICK3,COLORYELLOW;
STICKLINE(DBIAS<-5,50,0,4,0),COLOR0099CC;
GBIAS:=(C-MA(C,13))/MA(C,13)*100;
个股底:IF(REF(GBIAS,1)<-8 AND GBIAS>-8,80,0),STICK,LINETHICK2,COLORFFFF11;
STICKLINE(GBIAS<-8,30,0,3,0),COLORFF9900;
VARA:=IF(REF(L,1)<=LLV(L,120) AND HHV(C,120)/LLV(C,120)>1.25 AND C>O AND HIGH>LOW+0.04,4,0);
探底:IF(VARA>0,-40,0),COLOR00FF00,STICK,LINETHICK3;

A3:=REF(HHV(INDEXC,30),1);
B3:=REF(LLV(INDEXC,30),1);
大盘趋势:100*(INDEXC-B3)/(A3-B3),COLORRED;
A4:=REF(HHV(C,30),1);
B4:=REF(LLV(C,30),1);
个股趋势:100*(C-B4)/(A4-B4),COLORWHITE;
底线:0,COLORGREEN;
顶线:100,COLORGREEN;
A1:=LLV(H,250);
MYP:100*(C-A1)/A1,COLORFF00FF;
A2:=HHV(H,250);
MYL:100*(A2-C)/C,COLOR66FF33;
VARB:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
VARC:=EMA(IF(C< EMA(C,250),VARB*1000,VARB*10),3);
VARD:=EMA(IF(L<=LLV(L,30),VARC/2+HHV(VARC,30),0),3)/618;
IF(VARD>100,-25,0),STICK,COLOR99FFCC,LINETHICK3;
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,7)/VAR1/100;
VAR4:=DMA(VAR2,VOL/VAR3);
VAR5:=(CLOSE-VAR4)/VAR4*100;
VAR6:=MA(VAR5,20)+STD(VAR5,20);
VAR7:=MA(VAR5,20)+1.732*STD(VAR5,20);
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR8:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K1:=SMA(VAR8,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
VAR9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(VAR9,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR6,VAR5) AND REF(J1,1)>80 AND REF(J2,1)>80,100,0,4,0),COLORBLUE;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(VAR7,VAR5) AND REF(J1,1)>80 AND REF(J2,1)>80 ,100,0,4,0),COLORBLUE;
VAR10:=REF(CLOSE,1.5);
VAR11:=SMA(MAX(CLOSE-VAR10,0),6,1)/SMA(ABS(CLOSE-VAR10),6,1)*100;
STICKLINE((REF(VAR11,1)>80) AND (VAR11<79),70,0,4,0),COLORDDDDFF;
VAR12:=REF(CLOSE,1);
VAR13:=SMA(MAX(CLOSE-VAR12,0),6,1)/SMA(ABS(CLOSE-VAR12),6,1)*100;
STICKLINE(CROSS(84,VAR13),50,0,4,0),COLORFFCC00;
海洋大底   副


CYS:=(C-CYC(13))/CYC(13)*100;
绝对底:IF(CYS<=-27,90,0),COLORWHITE,LINETHICK2;
大底:IF(CYS<=-20,60,0),COLORBLUE,LINETHICK2;
中底:IF(CYS<=-17,35,0),COLORYELLOW,LINETHICK2;
小底:IF(CYS<=-9,20,0),COLORGRAY,LINETHICK2;
快线:SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,COLORRED;
慢线:SMA(MAX(CLOSE-REF(CLOSE,1),0),12,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),12,1)*100,COLORFFCCCC;
{波滔浪涌}  副

 

短线WR:MA((CLOSE-LLV(LOW,98))/(HHV(HIGH,98)-LLV(LOW,98))*120,8),colorFF0033,LINETHICK2;
中线WR:MA((CLOSE-LLV(LOW,88))/(HHV(HIGH,88)-LLV(LOW,88))*120,8),colorYELLOW,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25));
DY1:=(O+CLOSE+HIGH+LOW)/4;
DY2:=LLV(L,20);
DY3:=HHV(H,99);
DYA:=MA((DY1-DY2)/(DY3-DY2)*100,1);
DYB:=MA(DYA,5);
A1:=EMA((DY1-DY2)/(DY3-DY2)*180,20{88});
B1:=EMA(REF(A1,1),1);
B2:=MA((0.667*REF(RSV,1)+0.333*RSV),1);
弱波:=IF(A1>=B2,A1,B2),colorGREEN,pointdot,LINETHICK2;
强浪:=IF(B1-A1,B1,A1),coloryellow,pointdot,LINETHICK2;
STICKLINE(弱波>强浪,强浪,弱波+0.03,6,0),colorff22ff;
STICKLINE(弱波>强浪,强浪,弱波+0.03,6,0),colorff66ff;
STICKLINE(弱波>强浪,强浪,弱波+0.03,1,0),colorff88ff;
STICKLINE(弱波<强浪,强浪,弱波,6,0),COLOR00aa00;
STICKLINE(弱波<强浪,强浪,弱波,6,0),COLOR00cc00;
STICKLINE(弱波<强浪,强浪,弱波,1,0),COLOR00ee00;
{中线看盘}    副


v1:=hhv(high,30)=high;
创三十日新高:if(v1,1,0),colorred,stick,linethick4;
v2:=LLV(LOW,30)=LOW;
创三十日新低:if(v2,0.55,0),color00ff00,stick,linethick4;
a1:=LLV(LOW,30)=LOW;
a2:=CLOSE>=(HIGH-LOW)*2/3+LOW;
a3:=a1 AND a2 AND CLOSE>OPEN;
有反弹愿望:if(a3,0.4,0),colorblue,stick,linethick4;
a4:=CLOSE>=MA(CLOSE,60);
中线状态:if(a4,0.15,0),colorffcc66,stick,linethick4;
var1:=MA(CLOSE,10);
var2:=MA(CLOSE,60);
var3:=CLOSE>=var1 AND var1>var2;
中线强势:if(var3,0.35,0),colorff00ff,stick,linethick4;
y1:=MA(CLOSE,3);
y2:=MA(CLOSE,10);
y3:=MA(CLOSE,60);
y4:=y1>y2;
y5:=y2>y3;
y6:=CLOSE>=y1 AND y4 AND y5;
中线超强势:if(y6,0.20,0),colorwhite,stick,linethick4;
{上下通道}    副


Var2:=MA(HIGH-LOW,21);
Var3:=VOL;
Var4:=Var2>REF(Var2,1) AND Var3>REF(Var3,1);
Var5:=Var2>REF(Var2,1) AND Var3Var6:=Var2REF(Var3,1);
Var7:=Var2趋势延续: STICKLINE(Var4>0,LOW,HIGH,5.5,1),COLORRED;
可能变盘: STICKLINE(Var5>0,LOW,HIGH,5.5,0),COLORBLUE;
多空平衡: STICKLINE(Var6>0,LOW,HIGH,5.5,1),COLORYELLOW;
趋势预测: STICKLINE(Var7>0,LOW,HIGH,5.5,0), COLORFF00FF;
ma10:ma(c,10),colorwhite;
v1:=ma(HIGH,30)*1.15 ;
v2:=ma(HIGH,3)*1.03;
v3:=ma(LOW,3)*0.97;
v4:=ma(LOW,30)*0.85;
小通道上:ma(v2,30),colorred,linethick2;
小通道下:ma(v3,30),color00ff00,linethick2;
{三丰铁手}  副


AS:=EMA((C/MA(C,20)-1)*666,3);
正镜:AS,LINETHICK2,colorred;
反镜:AS*(-1),color00ff00,LINETHICK2;
STICKLINE(正镜>0,0,正镜,6,0),colorred;
STICKLINE(正镜>0,0,反镜,6,0),color888888;
100,colorwhite,pointdot;
-100,colorwhite,pointdot;
50,colorffcc66,pointdot;
-50,colorffcc66,pointdot;
初升介入     副

V1:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
V2:=SMA(V1,20,1);
V3:=SMA(V2,15,1);
V4:=(3*V2+2*V3)/4;
V5:= REF(V4,1);
RSA:SMA(MAX(V4-V5,0),2,1)/SMA(ABS(V4-V5),2,1)*100;
RSB:MA(RSA,10);
初升介入:IF(CROSS(RSA,RSB),50,0),STICK,LINETHICK2;
洗盘加仓:IF(CROSS(RSB,90),50,0),STICK,LINETHICK2;
DRAWTEXT(CROSS(RSA,RSB),-15,'初升介入'),COLOR00FF00;
DRAWTEXT(CROSS(RSB,90),-15,'洗盘加仓'),COLORWHITE;
-30;
㊣利多㊣抛吸        副

 

AAA:=100-100*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
BBB:=100-100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42));
DDD:=100-100*(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89));
短:EMA(AAA,4),COLOR66DDDD;
中:EMA(BBB,4),COLOR00FF00;
长:EMA(DDD,4),COLOR6600FF;
短抛:IF(短>88,55,0),COLORWHITE,LINETHICK0;
中抛:IF(中>94,55,0),COLORYELLOW,LINETHICK0;
长抛:IF(长>98,55,0),COLORMAGENTA,LINETHICK0;
STICKLINE(短<4.10 ,25,0,3,0),COLORYELLOW;
STICKLINE(短>88 ,95,100,4,0),COLORWHITE;
STICKLINE(中>94 ,95,100,4,0),COLORYELLOW;
STICKLINE(长>98 ,95,100,4,0),COLORMAGENTA;
STICKLINE(长>=98 AND 中>=93 ,长,50,1,0), COLORYELLOW;
STICKLINE(长>=98 AND 中>=93,60,50,1,0),COLORRED;
STICKLINE(长<=2 AND 中<=2 AND 短<=5 , 长,50,1,0), COLORRED;
STICKLINE(长<=2 AND 中<=2 AND 短<=5 , 35,50,1,0),COLORYELLOW;
股价:=(CLOSE-LLV(LOW,360))/(HHV(HIGH,360)-LLV(LOW,360))*80;
AA:=EMA(股价,3); CC:=REF(EMA(股价,10),1);
STICKLINE(AA>=CC ,0,4,2,0),COLORYELLOW;
STICKLINE(AA<=CC ,0,4,2,0),COLORGRAY;
判顶
通达信.大智慧可用


VAR1:4*SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,5,1),3.2,1),
COLORYELLOW,LINETHICK1;
VAR2:8,COLORBLUE;
上升在即: IF(CROSS(VAR1,VAR2),50,0),STICK,COLOR0000CC,LINETHICK2;
专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWICON(CROSS(VAR1,VAR2),8,1);
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLORBLUE;
0,LINETHICK2 ,COLORFFCC00;
DRAWICON(CROSS(100,VAR1),100,2);
DRAWICON((100-VAR1<3 AND 100-VAR1>0),100,2);
强弱分界线:55,LINESTICK,COLORBLUE;
DRAWTEXT(CROSS(VAR1,104),104,'◆'),COLORWHITE;
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
B7:IF(B6>60,B6-60,0);
持有:STICKLINE(REF(B7,1)A:0,POINTDOT,COLORRED,LINETHICK3;


(昊晨鬼变脸)
主图

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,0),COLORRED;
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORYELLOW;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑价:LLV(LOW,23) ,COLOR7FFF00,LINETHICK2;
阻力价:HHV(HIGH,23),COLORFF9900, LINETHICK2;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
DRAWTEXT(REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
DRAWTEXT(REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D"),L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
DRAWTEXT(REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离};
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
DRAWTEXT(REF(C,C1+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离};
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
DRAWTEXT(REF(C,C2+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
DRAWTEXT(REF(C,C3+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离};


佚名     ( 主 )

VAR2:=(H+L+O+2*C)/5;
CHH低吸线:EMA(SLOPE(VAR2,21)*20+VAR2,55),CIRCLEDOT;
DRAWICON(REF(C,1)CHH低吸线,0.98*L,1);
DRAWICON(REF(C,1)>CHH低吸线 AND CBB:=LLV(H,1);
神顶抄底逃顶线:FORCAST(FORCAST(BB,15),15), COLORYELLOW,LINETHICK2;
神顶逃顶抄底线:FORCAST(FORCAST(BB,25),25), COLORRED,LINETHICK2;
IF(SLOPE(神顶抄底逃顶线,2)>0,CHH低吸线,C),CIRCLEDOT,COLORFF00FF;
C,CIRCLEDOT,COLORBLUE;
{K线}
V2:=(C*2+H+L)/4;
VAR3:=EMA(V2,3);
VAR4:=EMA(VAR3,6);
L1:=EMA(V2,3);
L2:=EMA(VAR3,4);
L3:=EMA(VAR4,5);
VAR5:=REF(L1,1)>L1 AND L1>L2;
STICKLINE(L1>=L2,H,L,1,0),COLORRED;
STICKLINE(L1STICKLINE(L1>=L2,C,O,4,0),COLORRED;
STICKLINE(L1STICKLINE(VAR5,H,L,1,0),COLORYELLOW;
STICKLINE(VAR5,C,O,4,0),COLORYELLOW;
{冰枫看盘}   主


MA13: MA(CLOSE,13);
MA21: MA(CLOSE,21);
年线: MA(CLOSE,250);
底部线: EMA(COST(3.5),10);
s:=MA(VOL,5)/MA(VOL,60),colorred,,linethick2;
a:=ma(s,5),colorgreen,,linethick2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
f:=ma(s,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,'→ 逃顶 '),COLORYELLOW ;
DRAWTEXT(CROSS(RSI,11) , LOW,'→ 低吸 '),COLORRED ;
MID := MA(CLOSE,26);
UPPER:= MID + 2*STD(CLOSE,26);
LOWER:= MID - 2*STD(CLOSE,26);
s1:=IF((j<11 and BIAS>-11 and cross( s,f) and (s-f)>0.010),2,0),stick,linethick3,colorgreen;
DRAWTEXT(s1=2,LOW,'→关注 '), colorgreen;
DRAWICON( FILTER(cross(s,a) and a<0.5 and j<20,13),LOW,1 );
{白金趋势}   主


Var1:=(CLOSE*2+HIGH+LOW)/4;
Var2:=EMA(Var1,3);
Var3:=EMA(Var2,6);
L1: EMA(Var1,3);
L2: EMA(Var2,4);
L3: EMA(Var3,5);
Var4:=REF(L1,1)>L1 AND L1>L2;
Var5:=L1>L2 AND CLOSEVar6:=AMOUNT/10000;
Var7:=Var6/MA(Var6,5);
Var8:=VOL/FINANCE(7);
Var9:=Var7>2 AND REF(Var7>1,1) AND REF(Var7>1,2);
VarA:=Var8>5 AND REF(Var7>1,1) OR Var8>5 AND Var7>1 OR Var8>4 AND Var7>2;
VarB:=CLOSE-REF(MA(CLOSE,21),1);
VarC:=EMA(VarB-MA(VarB,21),5);
VarD:=SMA(VarB,7,1);
VarE:=CROSS(VarB,VarD) AND VarD<-1;
drawicon(count(ema(ema(l1,5),3)>ref(ema(ema(l1,5),3),1),1)=1 and  ref(ema(ema(l1,5),3),1){搜牛}   主图

 

var1:=(high+low+open+close)/4;
分水岭:ma(3*var1-2*sma(var1,2,1),12),colorwhite;
上涨:if(var1>分水岭,var1,分水岭),colorred;
支撑:reverse(上涨)+2*分水岭,colorred;
var2:=if(var1<分水岭,var1,分水岭);
var3:=2*ema(llv(var1,7),10)-var1;
ma5:ma(close,5);
ma10:ma(close,10);
ma20:ma(close,20);
ma30:ma(close,30);
阻力极限:3*var3-2*sma(var3,10,1),colorgreen;
阻力:reverse(var2)+2*分水岭,colorBLUE;
drawtext(filter(cross(75,sma(max(close-ref(close,1),0),8,1)/sma(abs(close-ref(close,1)),8,1)*100),10),high,'卖'),coloryellow;
drawtext(filter(cross(-5,ma((llv(low,45)-close)/(hhv(high,45)-llv(low,45))*100,5)),5),low,'买'),colorred;
{蛟龙}       主图

 

MA5: MA(CLOSE,5),COLORRED , ;
MA10: MA(CLOSE,10),COLOR00FF00;
Var1:=MA(CLOSE,21);
MA20: MA(CLOSE,20),COLORYELLOW , ;
MA30: MA(CLOSE,30),COLORF00FF0 , ;
Var2:=MA(CLOSE,124);
Var3:=MA(CLOSE,240);
Var4:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var5:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var6:=SMA(Var5,13,8);
Var7:=85;
Var8:=20;
Var9:=SMA(Var6,13,8);
VarA:=SMA(Var4,21,8);
VarB:=45;
VarC:=DRAWICON(CROSS((CLOSE+OPEN+LOW+HIGH)/4,MA20) AND (CLOSE+OPEN+LOW+HIGH)/4>MA20,(CLOSE+OPEN+LOW+HIGH)/4,1);
VarD:=REF(CLOSE,1);
VarE:=SMA(MAX(CLOSE-VarD,0),12,1)/SMA(ABS(CLOSE-VarD),12,1)*100;
VarF:=MA(VarE,4);
Var10:=IF(CROSS(VarF,REF(VarF,2)) AND VarF<32,80,IF(CROSS(REF(VarF,2),VarF) AND VarF>62,20,50));
M: DRAWTEXT(Var10>52,LOW,'买'),COLORwhite ;
Z: DRAWTEXT(Var10<50,HIGH*1.008,'赚'),COLORF00FF0 , ;
DRAWTEXT(LONGCROSS(MA(CLOSE,10),MA(CLOSE,124),3),MA(CLOSE,124),'强'),COLORRED , ;
Var11:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
蛟龙出水: DRAWTEXT(CROSS(Var11,66),OPEN,'蛟龙'),COLOR00FF00 , ;
蛟龙沉渊: DRAWTEXT(CROSS(84,Var11),HIGH,'沉渊'),COLORyellow ,;
A1:=((CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200)-105;
A2:=SMA(A1,5,1);
A3:=65;
DRAWTEXT(CROSS(A2,A3),LOW,'=卖'),COLORRED;
{天罗地网}          主

 

SUM( MA(CLOSE,10),9)/10.110,colorwhite,circledot;
SUM( MA(CLOSE,10),9)/11.114,color0099ff,circledot;
SUM( MA(CLOSE,10),9)/7.883,colorwhite,circledot;
SUM( MA(CLOSE,10),9)/7.007,color0099ff,circledot;
Var1:=LLV(LOW,144);
1*Var1,colorred;
1.191*Var1,POINTDOT,linethick2,coloryellow;
1.382*Var1,POINTDOT,linethick2;
1.618*Var1,POINTDOT,linethick2,colorred;
1.809*Var1,colorred;
e1:DRAWLINE(c=LLV(c,60),LOW,c=LLV(c,30) and c>llv(c,45),LLV(LOW,3),1),linethick2,color0099ff;
va11:=HIGH>=HHV(HIGH,60);
v1:=(ref(va11,1)>0 and va11<1);
va12:=LOW<=LLV(LOW,60);
v2:=ref(va12,1)>0 and va12<1;
e2:DRAWLINE(v2,LOW,v1,LLV(LOW,6),1),colorred,linethick2;
{小天RSI }     主

nn:1 111 20 n:1 111 6

STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),COLORF0F000;
STICKLINE(C<=O,H,L,0,0),COLORF0F000;
Var1:=REF(CLOSE,1);
MA5:MA(CLOSE,5);
MA20: MA(CLOSE,NN),COLORWHITE;
Var3:=SMA(MAX(CLOSE-Var1,0),N,1)/SMA(ABS(CLOSE-Var1),N,1)*100;
Var4:=SMA(MAX(CLOSE-Var1,0),12,1)/SMA(ABS(CLOSE-Var1),12,1)*100;
Var5:=SMA(MAX(CLOSE-Var1,0),24,1)/SMA(ABS(CLOSE-Var1),24,1)*100;
Var6:=IF(CROSS(Var3,Var5),LOW,REF(LOW,BARSLAST(CROSS(Var3,Var5))));
Var7:=IF(CROSS(Var5,Var3),HIGH,REF(HIGH,BARSLAST(CROSS(Var5,Var3))));
Var8:=IF(CLOSE>=MA(CLOSE,NN),80,50);
Var9:=IF(CLOSE>=MA(CLOSE,NN),50,20);
VarA:=IF(Var3=Var8,HHV(REF(HIGH,1),BARSLAST(Var3>=Var8 AND REF(Var3,1)=Var8 AND REF(Var3,1)VarB:=IF(HIGH>VarA,LOW,REF(LOW,BARSLAST(HIGH>VarA)));
VarC:=IF(HIGH>VarA,Var3,REF(Var3,BARSLAST(HIGH>VarA)));
VarD:=IF(HIGH>VarB AND Var3VarB AND Var3VarE:=IF(Var3>Var9 AND REF(Var3,1)<=Var9,LLV(REF(LOW,1),BARSLAST(Var3<=Var9 AND REF(Var3,1)>Var9)-1),REF(LLV(REF(LOW,1),BARSLAST(Var3<=Var9 AND REF(Var3,1)>Var9)-1),BARSLAST(Var3>Var9 AND REF(Var3,1))));
VarF:=IF(LOWVar10:=IF(LOWVar11:=IF(LOWVar10 AND Var3>Var5,LOW,REF(LOW,BARSLAST(LOWVar10 AND Var3>Var5)));
cb:=amount/v/100;
cd:=cb>h or cb{STICKLINE(cd<1,cb-0.002,cb+0.002,8,1),COLORYELLOW;}
多防线: Var11,COLORFF00FF,pointdot, LINETHICK2;
空防线: VarD,COLORBLUE,pointdot, LINETHICK2;
{八阵图 }          主


var11:=(2*c+o+h+l)/5;
var12:=vol;
m1:=sum(var11*var12,1)/sum(var12,1);
m5:=sum(var11*var12,5)/sum(var12,5);
m13:=sum(var11*var12,13)/sum(var12,13);
m8:=sum(var11*var12,8)/sum(var12,8);
m21:=sum(var11*var12,21)/sum(var12,21);
Y:=m1;
u1:=m5,colorred;
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff{B0B0FF};
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),{COLORCYAN;}colorffcc66;
STICKLINE(C<=O,H,L,0,0),{COLORCYAN}colorffcc66;
主力:m8,COLORYELLOW,linethick1;
u3:=m13,colorEE33CC;
XX1:=u1>主力 AND 主力>u3;
c5:=IF(XX1>0,llv(u1, 5),hhv(主力,5)),linethick2,COLOR00ff00;
c8:=IF(XX1>0,llv(主力, 8),hhv(主力,5)),linethick2,coloryellow;
c13:=IF(XX1>0,llv(u3, 13),hhv(主力,5)),colorff00ff,linethick2;
散户:llv(主力, 8),color00ff00,linethick1;
雷达:DYNAINFO(7),colorffcc66,POINTDOT;
风向标:ma(close,30),colorwhite,linethick2;
DRAWTEXT(散户=ref(散户,1),散户,' ┬ '),colorwhite;
DRAWTEXT(ref(散户,1)Var326:=IF(CLOSE>REF(CLOSE, 1),88,0);
Var327:=IF(CLOSE/REF(CLOSE, 1)>1.050  AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
STICKLINE(Var327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(Var327>90,LOW*0.95,'追涨'),COLORYELLOW;
{不亏均线-急进型}        主


m9:ma(c,9);
m6:Ema(c,60),COLORRED,LINETHICK0;
ma23:ema(c,23),COLORyellow;
m43:=Ema(c,43),COLORRED;
m47:ma(c,47),colorgreen;
m48:Ema(m47,3),colorgreen;
m49:ema(m48,3),COLORff00ff;
m50:Ema(m49,3),COLORff00ff;
MA60:eMA(CLOSE,60),COLORred,LINETHICK2;
{stickline(c<=o,C,o,8,0),COLORffcc66;
stickline(c<=o,H,L,0.1,0),COLORffcc66;
stickline(c>=o,C,o,8,1),COLORRED;
stickline(c>=o,H,c,0.1,0),COLORRED;
stickline(c>=o,L,o,0.1,0),COLORRED;}
HZ1:=EMA(CLOSE,13);
HZ2:=MA(C,21);
stickline(c>o AND HZ1>HZ2,C,o,3,0),COLORYELLOW;
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0JUD0:=REF(C,1)>=REF(UDGLINE,1) AND CJDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)DRAWTEXT(JDU2,m9*0.978,'空转多'),COLORyellow;
DRAWTEXT(cross(m6,m9),m9*0.98,'空转多'),COLORwhite;
市场潜能


MID:=(HIGH+LOW+CLOSE)/3;
市场潜能:(SUM(MAX(0,HIGH-REF(MID,1)),26)/SUM(MAX(0,REF(MID,1)-L),26)*100),COLORRED;
MA1:EMA(市场潜能,8),COLOR00FF00,POINTDOT;
MA2:EMA(市场潜能,13),COLORWHITE;
MA3:EMA(市场潜能,55),COLORFF00FF,LINETHICK2;
STICKLINE(市场潜能>=MA2,市场潜能,MA2,2,0),COLORWHITE;
STICKLINE(市场潜能STICKLINE(市场潜能>=MA1,市场潜能,MA1,2,0),COLORRED;
STICKLINE(市场潜能40,COLORYELLOW;
资金监控

 

VAR1:=SMA(AMOUNT,10,1)/1000000;
VAR2:=REF(VAR1,1);
VAR3:=MA(REF(CLOSE,1),5);
最高:VAR1*HIGH/VAR3*1/10,POINTDOT,COLOR009900,COLORGRAY;
最低:VAR1*LOW/VAR3*1/10,POINTDOT,COLOR009900,COLORYELLOW;
开盘:VAR1*OPEN/VAR3*1/10,POINTDOT,COLOR009900,COLORMAGENTA;
收盘:VAR1*CLOSE/VAR3*1/10,COLOR009900,COLORGREEN,POINTDOT;
生命线:EMA(收盘,13),COLORWHITE;             
昨收盘:=REF(收盘,1),POINTDOT,COLOR009900,LINETHICK0;
涨跌:=(收盘-REF(收盘,1))/REF(收盘,1)*100,POINTDOT,COLOR009900,LINETHICK0;
STICKLINE(收盘>开盘,收盘,开盘,3,0),COLORRED;
STICKLINE(收盘>开盘,最高,MAX(收盘,开盘),0,1),COLORRED;
STICKLINE(收盘>开盘,MIN(收盘,开盘),最低,0,1),COLORRED;
STICKLINE(收盘<开盘,收盘,开盘,2,0),COLORGREEN;
STICKLINE(收盘<开盘,最高,MAX(收盘,开盘),0,1),COLORGREEN;
STICKLINE(收盘<开盘,MIN(收盘,开盘),最低,0,1),COLORGREEN;
神龙飞天


VAR1:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4;
VAR2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52));
VAR6:=COUNT(VAR1,5)>=1 AND (VAR5<-99.9 OR VAR4<15 AND VAR3<12);
VAR7:=VOL/FINANCE(7);
VAR8:=100*WINNER(CLOSE);
VAR9:=MA(VAR8,3);
VARA:=MA(VAR7,34);
VARB:=VAR9VARC:=SUM(IF(CLOSE>REF(CLOSE,1),1,0),0);
VARD:=SUMBARS(VOL,CAPITAL);
VARE:=IF(CLOSE>LLV(CLOSE,VARD),1,-1)*IF(VARC>LLV(VARC,VARD),1,-1);
VARF:=COUNT(IF(VARE=-1,1,0)=1,8)>2;
VAR10:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;
VAR11:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01;
VAR12:=VARF AND VAR10 AND VAR11;
VAR13:=VOL/CAPITAL>=0.02 AND VOL/CAPITAL<=0.2 AND PEN=1.105;
VAR14:=VAR13 AND COUNT(VAR13,5)=1;
VAR15:=VAR12 OR VAR13;
VAR16:=REF(CLOSE,1);
VAR17:=SMA(MAX(CLOSE-VAR16,0),7,1)/SMA(ABS(CLOSE-VAR16),7,1)*100;
VAR18:=SMA(MAX(CLOSE-VAR16,0),13,1)/SMA(ABS(CLOSE-VAR16),13,1)*100;
VAR19:=VAR17<20 AND VAR18<25;
VAR1A:=VAR19;
VAR1B:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSEVAR1C:=IF(CLOSE>LLV(CLOSE,VARD),1,-1);
VAR1D:=IF(VAR1B>LLV(VAR1B,VARD),1,-1);
VAR1E:=VAR1C*VAR1D;
VAR1F:=IF(VAR1E=-1,1,0);
VAR20:=VAR1F AND CLOSE=LLV(CLOSE,120) AND VAR8VAR21:=IF(FILTER(VAR6 AND VARB AND VAR15 AND VAR1A AND VAR20>0,4),70,0);
VAR22:=IF(VARB AND VAR1A AND VAR20>0,50,0);
持仓区: STICKLINE(CLOSE>EMA(CLOSE,20),80,85,8,1),COLORRED;
空仓区: STICKLINE(CLOSEVAR23:=HHV(HIGH,9)-LLV(LOW,9);
VAR24:=HHV(HIGH,9)-CLOSE;
VAR25:=CLOSE-LLV(LOW,9);
VAR26:=VAR24/VAR23*100-70;
VAR27:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR28:=(2*CLOSE+HIGH+LOW)/4;
VAR29:=SMA(VAR25/VAR23*100,3,1);
VAR2A:=LLV(LOW,34);
VAR2B:=SMA(VAR29,3,1)-SMA(VAR26,9,1);
VAR2C:=IF(VAR2B>100,VAR2B-100,0);
VAR2D:=HHV(HIGH,34);
VAR2E:=EMA((VAR28-VAR2A)/(VAR2D-VAR2A)*100,13);
VAR2F:=EMA(0.667*REF(VAR2E,1)+0.333*VAR2E,2);
神龙飞天: VAR2F;
STICKLINE(VAR2E-VAR2F>0,VAR2E,VAR2F,8,0),COLORRED;
STICKLINE(VAR2E-VAR2F<0,VAR2E,VAR2F,8,0),COLORGREEN;
潜龙能量: (VAR2E-VAR2F)*5;
STICKLINE(潜龙能量>=0,0,潜龙能量*1,2,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.8,2,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.6,2,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.4,2,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.2,2,0);
STICKLINE(潜龙能量<0,0,潜龙能量*1,2,0),COLORFFFF00;
STICKLINE(潜龙能量<0,0,潜龙能量*0.8,2,0),COLORFFFF00;
STICKLINE(潜龙能量<0,0,潜龙能量*0.6,2,0),COLORFFFF00;
STICKLINE(潜龙能量<0,0,潜龙能量*0.4,2,0),COLORFFFF00;
STICKLINE(潜龙能量<0,0,潜龙能量*0.2,2,0),COLORFFFF00;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
STICKLINE(VAR9>-150,0,VAR9,3,0), , COLORFF00FF;
底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00;
STICKLINE(CROSS(底部吸筹指标,-24),100,0,6,0), , COLORFFFFFF;
先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , COLORFF00FF;
可能放量拉升: IF(CROSS(底部吸筹指标,-24),1,0), , COLORFFFFFF;
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
短线获利:STICKLINE(REF(J1,1)<0 AND J1>0,60,0,2,0),COLOR0000FF;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);波段王:=SMA(VARK3,3,1), , COLORRED,LINETHICK2;
波段鬼:=SMA(波段王,2.5,1),COLORYELLOW,LINETHICK2;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV
(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), ,COLORFF6666,LINETHICK2;
DK1:=K1-REF(K1,1),COLORSTICK;
出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0), STICK,COLORYELLOW;
DRAWICON(出手就赢>0,50 ,1);
买点准备:IF(趋势线<=10,0,10), COLORFF9933,LINETHICK3;
STICKLINE( CROSS(趋势线,10),0,73,6,0), COLOR3366FF,;
DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'抄底'),COLORWHITE ;
DRAWTEXT(IF(CROSS(10,趋势线),1,0), 10,'$备钱'),COLOR33FFCC,;
DRAWTEXT(REF(J1,1)<0 AND J1>0,50,'短买'),,,,COLORRED ,;
DRAWTEXT(CROSS(底部吸筹指标,-24),80,'抄底'),COLORWHITE ,;

自用主图

VAR1:=(LOW+HIGH+CLOSE+O)/4;
操作:MA(VAR1,5),COLOR00FFFF,LINETHICK2;
拉升:HHV(操作,13),COLORFF00FF;
买卖:LLV(操作,13),COLOR00FFFF;
压力:HHV(操作,60),COLORFF6600;
支撑:LLV(LOW,60)*1.02,COLOR00FF00,LINETHICK2;
顶部:HHV(HIGH,60)*0.98,COLORFFFF00,LINETHICK2;
涨:IF(MA(VAR1,5)>REF(MA(VAR1,5),1),MA(VAR1,5),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(VAR1,5)=REF(MA(VAR1,5),1),MA(VAR1,5),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(VAR1,5)DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,30),L,'★<--极品绝底'), LINETHICK1;
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)>C AND REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)>C AND REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D"),L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)>C AND REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1))+1)"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离};
昊晨出击

 

SHORT:1   500  12
LONG: 1   500  26
M:    1   500   9

 

DIF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),COLORRED;
DEA  : EMA(DIF,M),COLORYELLOW;
MACD : 2*(DIF-DEA),LINETHICK0;
{STICKLINE(MACD0,0,MACD,4,0 ),COLOR00AAFF;}
STICKLINE(MACD0,0,MACD,3,0 ),COLOR00CCFF;
{STICKLINE(MACD0,0,MACD,2.2,0 ),COLOR00EEFF; }
STICKLINE(MACD0,0,MACD,1.1,0 ),COLOR00FFFF;
{STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000AA;}
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1 ,0 ),COLOR0055FF;
{STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORAA00BB; }
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.3,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFF55BB;
{STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFFAA00;}
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.3,0 ),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFFFF55;
昊晨出击:MACD<0 AND REF(MACD,2)>REF(MACD,1) AND REF(MACD,1)

前导公式

 


1:QDB
前导乖离
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
TMP1:=(2*SUM(CLOSE,M1)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,M2))/M1;
TMP2:=(2*SUM(CLOSE,M2)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,(2*M2-M1)))/M2;
TMP3:=TMP1-TMP2;
QDB:0;
STICKLINE(0,0,0,0.5,0);
STICKLINE((REF(TMP3,1)STICKLINE((REF(TMP3,1)>=TMP3),0,(TMP3),0.5,0);
M3:LFM.N,POINTDOT,COLORWHITE;
M4:LFM.M,POINTDOT,COLORWHITE;

2:LFM
前导线
M1:=6;
N1:=3;
LFM:CLOSE;
ADVLFM:LFM;
M:M1;
N:N1;

3:LCD
前导选股跌
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
QDBTMP1:=(2*SUM(CLOSE,M1)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,M2))/M1;
QDBTMP2:=(2*SUM(CLOSE,M2)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,(2*M2-M1)))/M2;
QDBTMP:=QDBTMP1-QDBTMP2;
TMP1:=(LFMTMP>HIGH);
TMP2:=((LFMTMP>=LOW)AND(LFMTMP<=HIGH));
TMP3:=BARSLAST(TMP2);
TMP4:=REF(TMP3,1);
TMP5:=(LFMTMP>REF(LFMTMP,(TMP4+1)));
TMP6:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP7:=((QDBTMPTMP8:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>=(2*CLOSE-REF(CLOSE,(M2-M1))));
前导选股:((TMP1)AND(TMP8))OR((TMP2)AND(TMP5)AND(TMP6)AND(TMP7));

4:LYD
前导选股异动跌
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
TMP1:=(LFMTMPTMP2:=CLOSETMP3:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))>(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP4:=REF(CLOSE,1)>REF(OPEN,1);
前导选股:(TMP1)AND(TMP2)AND(TMP3)AND(TMP4);

5:LYZ
前导选股异动涨
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
TMP1:=(LFMTMP>HIGH);
TMP2:=CLOSE>OPEN;
TMP3:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP4:=REF(CLOSE,1)前导选股:(TMP1)AND(TMP2)AND(TMP3)AND(TMP4);

6:LCZ
前导选股涨
NN1:=IF(LFM.N<1,1,LFM.N);
M1:=IF(NN1>30,30,NN1);
MM1:=IF(LFM.M>60,60,LFM.M);
M2:=IF(MM1>M1,MM1,(M1+1));
LFMTMP:=2*REF(CLOSE,M1)-REF(CLOSE,M2);
QDBTMP1:=(2*SUM(CLOSE,M1)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,M2))/M1;
QDBTMP2:=(2*SUM(CLOSE,M2)+SUM(CLOSE,(M2-M1))-SUM(CLOSE,(2*M2-M1)))/M2;
QDBTMP:=QDBTMP1-QDBTMP2;
TMP1:=(LFMTMPTMP2:=((LFMTMP>=LOW)AND(LFMTMP<=HIGH));
TMP3:=BARSLAST(TMP2);
TMP4:=REF(TMP3,1);
TMP5:=(LFMTMPTMP6:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<(2*CLOSE-REF(CLOSE,(M2-M1))));
TMP7:=((QDBTMP>REF(QDBTMP,1))AND(REF(QDBTMP,1)TMP8:=((2*REF(CLOSE,1)-REF(CLOSE,(M2-M1+1)))<=(2*CLOSE-REF(CLOSE,(M2-M1))));
前导选股:((TMP1)AND(TMP8))OR((TMP2)AND(TMP5)AND(TMP6)AND(TMP7));

 

{35秘密Z一品茶缘编写主图}
MA3:MA(C,3),COLOR00FF00;
MA5:MA(C,5),COLORFFFFFF;
ZX:=(MA3+MA5)/2;
MA20:MA(C,20),COLORFF00FF;
MA30:MA(C,30),COLORYELLOW;
QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)YB:=C>REF((O-C)/2+C,2);
买:CROSS(C,ZX) AND (GD OR YB) AND QSXS,COLOR00FF00,POINTDOT,LINETHICK0,NODRAW;
优:买 AND MA5>REF(MA5,1),COLORYELLOW,POINTDOT,linethick0,NODRAW;
{以下设置主图显示方式}
STICKLINE(买,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(买,o,c,4,1),COLOR00FF00,linethick2;
STICKLINE(优,h,l,0,1),COLORYELLOW,linethick2;
STICKLINE(优,o,c,4,1),COLORYELLOW,linethick2;
DRAWTEXT(买,L*0.99, '买'),COLOR00FF00;
DRAWICON(优,L,1);
{经典震仓----白马饮水,一品茶缘副图指标}
{DDF:10,30,10;----参数选择18以上最安全,一般股票只需要设置10。}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
DTPL:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
DTSJ:=BARSLAST(DTPL AND NOT(REF(DTPL,1)));
ZXDT:=MA10>MA20 AND MA20>MA30 AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
BMBD:=DTSJ<20 AND ZXDT AND COUNT(ZXDT,5)>=3;
TDDF:=(L/REF(C,1)-1)*100<=-5 AND (REF(HHV(H,5),1)/L-1)*100>=DDF;
跳水:TDDF*1,COLOR00FF00,LINETHICK2;
DRZC:=COUNT(H/REF(C,1)>=1.08,7) AND L/REF(C,1)<=0.93 AND BMBD;
运动:IF(DRZC>0,1,0),COLORFF00FF,LINETHICK2;
经典:((DRZC OR TDDF) AND BMBD AND L=LLV(L,5))*1,COLORYELLOW,LINETHICK2;
STICKLINE(DRZC,0,0.5,4,0),COLORYELLOW;
DRAWTEXT(DRZC OR 经典=1,1,'经◆典'),COLORFF00FF;
优选:DRZC AND TDDF AND BMBD AND L=LLV(L,5),COLORYELLOW,POINTDOT,LINETHICK0;
DRAWICON(优选,1,20);

 

 

{一品爱家}指标信号与使用说明:
1、生命=筹码;
2、孕育=短线超跌;
3、健康=筹码脱离低位区;
4、成长=筹码进入集中区;
5、快乐=筹码进入控盘区;
6、步步高=筹码集中后拐点;
7、退、休=高位回调信号;
8、经典震仓:
绿色跳水=短线超跌;
紫色运动=单日急跌;
黄色经典=安全低吸。
{特快列车Z----一品茶缘编写精品指标,主图}
{特快列车指标使用说明:
均线角度巧安排,要乘特快看站台;
买票上车是提示,启动加速列车开!}
A5:MA(C,5),COLOR00FFFF;
A20:MA(C,20),COLORFF00FF;
A30:MA(C,30),COLOR00FF00;
M5:=ATAN((A5/REF(A5,1)-1)*100)*180/3.14159;
M20:=ATAN((A20/REF(A20,1)-1)*100)*180/3.14159;
M30:=ATAN((A30/REF(A30,1)-1)*100)*180/3.14159;
QSXS:=M30>0;
A50:=IF(M5<0,-25,0);
A51:=IF(BETWEEN(M5,0,45),25,A50);
A52:=IF(BETWEEN(M5,45,75),50,A51);
MA5:=IF(M5>75,75,A52)*QSXS;
A200:=IF(M20<0,-25,0);
A201:=IF(BETWEEN(M20,0,45),25,A200);
A202:=IF(BETWEEN(M20,45,75),50,A201);
MA20:=IF(M20>75,75,A202)*QSXS;
A300:=IF(M30<0,-25,0);
A301:=IF(BETWEEN(M30,0,45),25,A300);
A302:=IF(BETWEEN(M30,45,75),50,A301);
MA30:=IF(M30>75,75,A302)*QSXS;
SGSJ:=BARSLAST(CROSS(MA5,REF(MA5+1,1)));
XGSJ:=BARSLAST(CROSS(REF(MA5-1,1),MA5));
列车:=IF(MA5>=50 AND MA20>=25 AND MA30>=25 AND SGSJ启动:=IF(CROSS(列车,45),50,25);
站台:=IF(MA5<=0 AND COUNT(MA20>=25,10)>=9 AND MA30>=25,-25,25);
买票:=IF(站台=-25 AND COUNT(站台=-25,3)>=2 AND C>=REF(C,4),25,-10);
上车:=IF(CROSS(MA5,0) AND COUNT(MA20>=25,10)>=9 AND MA30>=25,50,25);
DRAWTEXT(列车=50,A30, '○'),COLOR88FFFF;
DRAWTEXT(启动=50,A30, '●'),COLORFF00FF;
STICKLINE(站台=-25,A30,A30*0.98,4,0),COLORFFFF00;
STICKLINE(买票=25,A30,A30*0.98,2,0),COLORFFFFFF;
DRAWTEXT(买票=25,A30*0.97, '票'),COLORFF8800;
DRAWTEXT(上车=50,A30, '△'),COLORFFFFFF;

 

 

{一品【特快列车】----副图}
{特快列车指标使用说明:
均线角度巧安排,要乘特快看站台;
买票上车是提示,启动加速列车开!}
A5:=MA(C,5);
A20:=MA(C,20);
A30:=MA(C,30);
M5:=ATAN((A5/REF(A5,1)-1)*100)*180/3.14159;
M20:=ATAN((A20/REF(A20,1)-1)*100)*180/3.14159;
M30:=ATAN((A30/REF(A30,1)-1)*100)*180/3.14159;
QSXS:=M30>0;
A50:=IF(M5<0,-25,0);
A51:=IF(BETWEEN(M5,0,45),25,A50);
A52:=IF(BETWEEN(M5,45,75),50,A51);
MA5:IF(M5>75,75,A52)*QSXS,COLOR00FFFF;
A200:=IF(M20<0,-25,0);
A201:=IF(BETWEEN(M20,0,45),25,A200);
A202:=IF(BETWEEN(M20,45,75),50,A201);
MA20:IF(M20>75,75,A202)*QSXS,COLORFF00FF;
A300:=IF(M30<0,-25,0);
A301:=IF(BETWEEN(M30,0,45),25,A300);
A302:=IF(BETWEEN(M30,45,75),50,A301);
MA30:IF(M30>75,75,A302)*QSXS,COLOR00FF00;
SGSJ:=BARSLAST(CROSS(MA5,REF(MA5+1,1)));
XGSJ:=BARSLAST(CROSS(REF(MA5-1,1),MA5));
列车:IF(MA5>=50 AND MA20>=25 AND MA30>=25 AND SGSJ启动:IF(CROSS(列车,45),50,25),COLORFF00FF;
站台:IF(MA5<=0 AND COUNT(MA20>=25,10)>=9 AND MA30>=25,-25,25),COLORFFFF00;
买票:IF(站台=-25 AND COUNT(站台=-25,3)>=2 AND C>=REF(C,4),25,-10),COLORFF8800;
上车:IF(CROSS(MA5,0) AND COUNT(MA20>=25,10)>=9 AND MA30>=25,50,25),COLORFFFFFF;
{以下设置副图显示方式}
DRAWTEXT(列车=50,25, '○'),COLOR88FFFF;
DRAWTEXT(启动=50,25, '●'),COLORFF00FF;
DRAWTEXT(上车=50,25, '△'),COLORFFFFFF;
STICKLINE(站台=-25,-10,-25,4,0),COLORFFFF00;
{低位反转}副 (一品)

MA30:=MA(C,30);
QSXS:=MA30>=REF(MA30,1);
ZF:=(C/REF(C,1)-1)*100;
波段低点:=LLV(C,3)=LLV(C,10) OR LLV(L,3)=LLV(L,10);
STICKLINE(波段低点,0 ,0.2 ,5 ,1 ),COLORFF6600;
放量上涨:V/REF(V,1)>=1.5 AND ZF>=2 AND C>O,COLORYELLOW,STICK;
低位反转1:放量上涨 AND 波段低点,COLOR00FF00,linethick2;
低位反转2:(COUNT(ZF>0,2)=2 AND 波段低点)*2,COLORWHITE,linethick2;
优选:(低位反转1 OR 低位反转2) AND QSXS,COLORFF00FF,POINTDOT,linethick4;
DRAWICON(优选,0.3,1);
一品秘密 (副)


{指标信号说明:白银=低吸;黄金=启动;金包银=回调后重新启动;}
{N:2,5,3;,N10:5,250,14;}

MA20:=MA(C,20);
MA30:=MA(C,30);
QSXS:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
ZF:=(C/REF(C,1)-1)*100;
TDDF:=(L/REF(C,1)-1)*100<=-5 AND (REF(HHV(H,5),1)/L-1)*100>=10;
N1:=BARSLAST(CROSS(C,MA(C,5)));
N2:=BARSLAST(CROSS(MA(C,5),C));
HM:IF(N1黄金:HM=1 AND ZF>=0 AND C>O AND QSXS,COLOR00FFFF,POINTDOT,LINETHICK2;
KX1:=ZF<=-N AND CXDSJ:=BARSLAST(KX1);
KX2:=ZF>=N AND C>O;
JBY:=KX2 AND XDSJ<=2 AND C>=REF(O*0.99,XDSJ) AND ZF>ABS(REF(ZF,XDSJ)*0.99);
金包银:IF(FILTER(JBY,1) AND QSXS,5,0),COLORFF00FF,LINETHICK2;
{以下设置副图显示方式}
STICKLINE(黄金,0,2,4,0),COLOR00FFFF;
K:=N10/2;
DTPL:=MA(C,N10)>MA(C,N10*1.5) AND MA(C,N10*1.5)>MA(C,N10*3) AND MA(C,3)>MA(C,N10*6);
连续走强:=COUNT(C>MA(C,N10),K)=K;
ZQSJ:=BARSLAST(连续走强);
下穿:=CROSS(MA(C,N10),C);
GL:=MA(C,N10/2)/MA(C,N10*2)>=1.05;
买跌:(下穿 AND ZQSJ<=3 AND DTPL AND GL)*N10,COLOR00FF00,LINETHICK2;
连续走弱:=COUNT(CZRSJ:=BARSLAST(连续走弱);
上穿:=CROSS(C,MA(C,N10));
买涨:(上穿 AND ZRSJ<=3)*K,COLORFF00FF,LINETHICK2;
DRAWTEXT( 买涨,5,'买涨'),COLORred;
DRAWTEXT( 买跌,5,'买跌'),COLORyellow;
WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
涨:WR2<10,POINTDOT,COLORRED;
跌:=WR2>80,POINTDOT,COLORWHITE;
DRAWTEXT(跌>0 ,1 , '#'),COLORWHITE;
P1:=5;P2:=10;P3:=20;P4:=30;P5:=60;P6:=120;
MA1:=MA(C,P1),COLORYELLOW;
MA2:=MA(C,P2),COLORFF00FF;
MA3:=MA(C,P3),COLOR00FF00;
MA4:=MA(C,P4),COLORWHITE;
MA5:=MA(C,P5),COLORFF9900;
MA6:=MA(C,P6),COLOR0000FF;
{ENV轨道线支撑}
UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
MID:=(UPPER+LOWER)/2,COLORYELLOW,LINETHICK2;
生命线:=MID,COLORYELLOW,POINTDOT,LINETHICK2;
DTPLENV:=COUNT(MID>REF(MID,1),5)=5;
回:=((CROSS(MID,L) OR CROSS(MID,C)) AND DTPLENV)*1,COLORYELLOW,POINTDOT;
{MA2支撑}
QSXS2:=MA2>=REF(MA2,1);
DTPL2:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP2:=COUNT(C>MA2,P1)=P1 AND DTPL2;
HCP2A:=CROSS(MA2*1.02,L) AND REF(ZWP2,1);
HCP2B:=CROSS(MA2,C) AND REF(ZWP2,1);
回2:=((HCP2A OR HCP2B) AND QSXS2 AND DTPL2)*3,COLOR00FF00,POINTDOT;
{MA3支撑}
QSXS3:=MA3>=REF(MA3,1);
DTPL3:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP3:=COUNT(C>MA3,P1)=P1 AND DTPL3;
HCP3A:=CROSS(MA3*1.03,L) AND REF(ZWP3,1);
HCP3B:=CROSS(MA3,C) AND REF(ZWP3,1);
回3:=((HCP3A OR HCP3B) AND QSXS3)*3,COLOR00FF00,POINTDOT;
{MA4支撑}
QSXS4:=MA4>=REF(MA4,1);
DTPL4:=MA2>MA3 AND MA3>MA4 AND MA4>MA5;
ZWP4:=COUNT(C>MA4,P2)=P2 AND DTPL4;
HCP4A:=CROSS(MA4*1.04,L) AND REF(ZWP4,1);
HCP4B:=CROSS(MA4*1.02,C) AND REF(ZWP4,1);
回4:=((HCP4A OR HCP4B) AND QSXS4)*4,COLORWHITE,POINTDOT;
{MA5支撑}
QSXS5:=MA5>=REF(MA5,1);
DTPL5:=MA3>MA4 AND MA4>MA5 AND MA5>MA6;
ZWP5:=COUNT(C>MA5,P3)=P3 AND DTPL5;
HCP5A:=CROSS(MA5*1.05,L) AND REF(ZWP5,1);
HCP5B:=CROSS(MA5*1.02,C) AND REF(ZWP5,1);
回5:=((HCP5A OR HCP5B) AND QSXS5)*5,COLORFF9900,POINTDOT;
{MA6支撑}
QSXS6:=MA6>=REF(MA6,1);
DTPL6:=MA5>MA6;
ZWP6:=COUNT(C>MA6,P3)=P3 AND DTPL6;
HCP6A:=CROSS(MA6*1.05,L) AND REF(ZWP6,1);
HCP6B:=CROSS(MA6*1.02,C) AND REF(ZWP6,1);
回6:=((HCP6A OR HCP6B) AND QSXS6)*6,COLORRED,POINTDOT;
买:=COUNT(回>0,2)>=1 AND ABS(L/MID-1)*100<=2,COLORYELLOW,POINTDOT;
买2:=COUNT(回2>0,2)>=1 AND ABS(L/MA2-1)*100<=2,COLORFF00FF,POINTDOT;
买3:=COUNT(回3>0,2)>=1 AND ABS(L/MA3-1)*100<=2,COLOR00FF00,POINTDOT;
买4:=COUNT(回4>0,2)>=1 AND ABS(L/MA4-1)*100<=2,COLORWHITE,POINTDOT;
买5:=COUNT(回5>0,2)>=1 AND ABS(L/MA5-1)*100<=2,COLORFF9900,POINTDOT;
买6:=COUNT(回6>0,2)>=1 AND ABS(L/MA6-1)*100<=2,COLORRED,POINTDOT;
MBZ:=买 OR 买2 OR 买3 OR 买4 OR 买5 OR 买6;
QSXS10:=DTPL4 AND MA3>REF(MA3,1) AND MA4>REF(MA4,1);
YX:=跌 AND MBZ AND QSXS10 AND COUNT(V=2 AND COUNT(C>=2;
支撑优选:(YX OR (REF(YX,1) AND CDRAWTEXT( 支撑优选,10,'支撑'),COLORblue;
{一品波段Z----一品茶缘编写}

MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA30:MA(C,30);
VAR1:=(CLOSE*2+HIGH+LOW)/4;{当日股价中线}
SK:=EMA(VAR1,13)-EMA(VAR1,73);{13日均线-73日均线,求差}
SD:=EMA(SK,2);{SK的2日均线}
DX1:=CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)*100>=3;
{SK与SD低位金叉,当日涨幅大于+3%}
DX2:=CROSS(SK,SD) AND SK<=-0.14;{SK与SD超跌低位金叉}
DX3:=CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR (C-REF(C,1))/REF(C,1)*100>=3.5);
{SK与SD中位金叉,并且放量上涨。(当日量大于5日均量2倍,或者涨幅大于+3.5%)}
短线:=(DX1 OR DX2 OR DX3)*0.5,POINTDOT,COLOR00FF00;{满足条件DX1DX2DX3之一,设定为短线买入条件。}
买入:=(CROSS(SK,SD) AND BARSLAST(CROSS(SD,SK))>=8)*0.2,POINTDOT,COLORWHITE,LINETHICK0;
加码:=(CROSS(SK,SD) AND BARSLAST(CROSS(SD,SK))<8)*0.3,POINTDOT,COLORYELLOW,LINETHICK0;
{以下设置主图显示方式}
DRAWTEXT(短线>0 ,L*0.99,'短线'),COLOR00FF00;
STICKLINE(短线>0,H,L,1,0),LINETHICK2,COLORRED;
{STICKLINE(短线>0,O,C,4,1),LINETHICK2,COLORRED;}
DRAWTEXT(买入>0 ,L*0.99,'买入'),COLORWHITE;
STICKLINE(买入>0,H,L,1,0),LINETHICK2,COLORWHITE;
{STICKLINE(买入>0,O,C,4,1),LINETHICK2,COLORWHITE;}
DRAWTEXT(加码>0 ,L*0.99,'加码'),COLORYELLOW;
STICKLINE(加码>0,H,L,1,0),LINETHICK2,COLORYELLOW;
{STICKLINE(加码>0,O,C,4,1),LINETHICK2,COLORYELLOW;};


{一品波段----一品茶缘编写}  副

VAR1:=(CLOSE*2+HIGH+LOW)/4;{当日股价中线}
SK:=EMA(VAR1,13)-EMA(VAR1,73);{13日均线-73日均线,求差}
SD:=EMA(SK,2);{SK的2日均线}
DX1:=CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)*100>=3;
{SK与SD低位金叉,当日涨幅大于+3%}
DX2:=CROSS(SK,SD) AND SK<=-0.14;{SK与SD超跌低位金叉}
DX3:=CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR (C-REF(C,1))/REF(C,1)*100>=3.5);
{SK与SD中位金叉,并且放量上涨。(当日量大于5日均量2倍,或者涨幅大于+3.5%)}
短线:(DX1 OR DX2 OR DX3)*0.5,COLOR00FF00;{满足条件DX1DX2DX3之一,设定为短线买入条件。}
买入:(CROSS(SK,SD) AND BARSLAST(CROSS(SD,SK))>=8)*0.2,COLORWHITE;
加码:(CROSS(SK,SD) AND BARSLAST(CROSS(SD,SK))<8)*0.3,COLORYELLOW;
{以下设置副图显示方式}
DRAWTEXT(短线>0 ,0.8,'短线'),COLOR00FF00;
DRAWTEXT(买入>0 ,0.5,'买入'),COLORWHITE;
DRAWTEXT(加码>0 ,0.5,'加码'),COLORYELLOW;
一品买点


副图:未来
{N;1,30,10,}
{N2:5,15,10}
{P10:1,30,3}
{N10:1,30,10}


QW:1.1,POINTDOT,COLORWHITE;
UP:=( C > O OR C > REF(C,1)) AND V > REF(V,1);
AA:=COUNT(UP,3)=3;
BB:=LLV(L,5)=LLV(L,120);
CC:=C > MA(C,3);
LLT:=AA AND BB AND CC;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
SQ:3.5,COLORFF937F;
ZQ:EMA((C-V1)/(V2-V1)*4,4),LINESTICK,COLOR808000;
M5:=MA(ZQ,5);
DRAWTEXT(CROSS(ZQ,QW),QW,'买'),COLORYELLOW; VAR2:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
VAR3:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR4:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR5:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR6:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
VAR7:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
VAR8:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6;
VARA:=EMA(VAR9,3);
VARB:=ABS(VAR6-VAR8);
VARC:=(VAR9+VARB)/2;
VARD:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VARE:=VARD+VARC;
VARF:=IF(VAR2>0 AND VARE<0,200,0);
VAR10:=IF(VARC<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
VAR11:=IF(VARE<0 AND VAR10=-50,100,0);
VAR12:=MA(CLOSE,3);
VAR13:=REF(CLOSE,2)*0.865;
VAR14:=REF(CLOSE,13)*0.772;
VAR15:=MIN(VAR13,VAR14);
VAR16:=100*VOL/CAPITAL;
VAR17:=MA(CLOSE,13);
VAR18:=IF((CLOSE-VAR15)/CLOSE<0.03 AND SUM(VAR16,5)/5<1.8,1,0);
VAR19:=IF(VAR18>0 AND (VAR10<0 OR VAR2>0),100,0);
VAR1A:=VAR19;
VAR1B:=IF(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0) AND VAR19<10,50,0);
VAR1C:=(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0);
VAR1D:=VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
抄底:IF(乖离<-12 AND 乖离>=-18,-4,0), COLORBLUE,LINETHICK1;
STICKLINE(乖离<-12 AND 乖离>=-18,2,0,6,0) , COLORBLUE;
抄底二:IF(乖离<-18,3,0),COLORFF35FF,LINETHICK1;
STICKLINE(乖离<-18,3,0,6,0),COLORFF35FF;
抄底三:IF(乖离<-6,5,0),COLORRED,LINETHICK1;
STICKLINE(乖离<-6,5,3,2,1),COLORRED;
抄底四:IF(乖离<-4.5,0,0),COLOR00FFFF,LINETHICK1;
STICKLINE(乖离<-4.5,0,1,3,1),COLOR00FFFF;

VAR21:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR22:=DMA(CLOSE,VOL/MA(VOL,31)/31);
VAR23:=(CLOSE-VAR21)/VAR21*100<-10;
VAR24:=(VAR21-VAR22)/VAR22*100<-16;
VAR25:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
VAR26:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
VAR27:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
VAR28:=INDEXC;
VAR29:=MA(VAR28,6);
VARA1:=MA(VAR28,24);
VARB1:=MA(VAR28,32);
VARC1:=VARB1>VAR29*1.11 AND VARA1>VAR29*1.095;
SSS:=(VAR23 AND VAR24 AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 OR VAR25 AND VAR26 AND CROSS(VAR27,79) OR VARC1 AND CLOSE/COST(8)<=0.8)*100;
抄底王:SSS>0,COLORWHITE,LINETHICK1;
STICKLINE(SSS>0,0,6,6,0),COLORWHITE;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
短线多头:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
中线多头:=MA30>MA120 AND MA60>MA120;
均线粘合:=(HHV(MA5,HHV(MA10,MA20))/LLV(MA5,LLV(MA10,MA20))-1)*5<=N;
均线拐点:=COUNT(短线多头,10) AND COUNT(MA5REF(MA5,1);
XG:=中线多头 AND 均线粘合 AND 均线拐点 AND C>REF(C,1);
拐点选股:XG AND NOT(REF(XG,1)),COLORYELLOW,LINETHICK2;
均线粘合2:=(MAX(MA5,MAX(MA10,MA20))/MIN(MA5,MIN(MA10,MA20))-1)*100<=N;
XG2:=中线多头 AND 均线粘合2 AND 均线拐点 AND C>REF(C,1);
选股2:=(XG2 AND NOT(REF(XG2,1)))*0.5,COLORWHITE,LINETHICK2;
MA90:=MA(CLOSE,90);
MA250:=MA(CLOSE,250);
DTPL:=MA10>MA30 AND MA30>REF(MA30,1);
DG:=MAX(MAX(MA5,MA10),MAX(MA20,MA30));
ZG:=MAX(MAX(DG,MA60),MAX(MA90,MA120));
DD:=MIN(MIN(MA5,MA10),MIN(MA20,MA30));
ZD:=MIN(MIN(DD,MA60),MIN(MA90,MA120));
粘合:=(ZG/ZD-1)*100高粘:=(ZG/ZD-1)*100MA250,POINTDOT,LINETHICK0;
穿5:=(粘合 AND CROSS(C,MA5))*0.5,COLOR000000;
穿10:=(粘合 AND CROSS(C,MA10))*1,COLOR000000;
穿20:=(粘合 AND CROSS(C,MA20))*2,COLOR000000;
穿30:=(粘合 AND CROSS(C,MA30))*3,COLOR000000;
FLSZ:=(C/REF(C,1)-1)*100>=2 AND V>REF(V,1);
DXTP:=((穿5/0.5)+穿10+(穿20/2)+(穿30/3))>=2;
优飞:=(FLSZ AND DXTP AND MA30>REF(MA30,1))*3,COLOR00FFFF,LINETHICK2;
选优:=(FLSZ AND DXTP AND MA30>REF(MA30,1) AND COUNT(高粘,20)>=15)*3,COLOR0000FF,LINETHICK2;
JXDT:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
起飞:(NOT(粘合) AND REF(粘合,1) AND COUNT(粘合,20)>=15 AND DTPL)*3,COLORFF00FF,LINETHICK2;


{放量攻击----一品茶缘编写副图指标}
{N:5,60,34;}
{放量攻击指标使用说明:
量能饱和看股市,放量上涨要升值;
攻击凶猛防登顶,缩量小坑幸福池。}
A:=EMA(AMOUNT/C/1000000,7);
MID :=EMA(A,N);
UPPER:=MID + 2*STD(A,N);
LOWER:=MID - 2*STD(A,N);
量能:(A-LOWER)/(UPPER-LOWER)*100,COLORFFFFFF;
放量:IF(CROSS(量能,70),70,50),COLOR00FF00;
↑:IF(CROSS(量能,50),1,0),COLORFF00FF;
攻击:IF(CROSS(量能,100),1,0),COLOR0000FF,POINTDOT,LINETHICK0;
缩量:IF(CROSS(30,量能),1,0),COLORFFFF00,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
100,POINTDOT,COLORFF00FF;
70,COLORFFFFFF;
30,POINTDOT,COLORFFFFFF;
0,POINTDOT,COLORFF6600;
STICKLINE(量能>70,70,量能,4,0),COLOR00FFFF;
STICKLINE(量能>100,100,量能,4,0),COLOR0000FF;
STICKLINE(量能<30,30,量能,4,0),COLORFFFF00;
STICKLINE(量能<0,0,量能,4,0),COLOR00FF00;
DRAWTEXT(↑,50,'↑'),COLORFF00FF;
DRAWTEXT(攻击,70, '↑'),COLOR0000FF;
DRAWTEXT(缩量,30, '↓'),COLORFFFF00;
{一品【空中加油Z】----一品茶缘编写主图指标}
{指标使用方法:
1、启动跑道可关注,航空飞机安全行;空中加油等买票,加速远航好收益!
2、启动时间长又长,航天飞机要远航!
3、启动时间长,均线越顺畅;航天飞机快,登上要坐好!}

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA250:MA(CLOSE,250),COLORRED;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1空:=IF(N2QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
启动:=多*QSXS,COLORRED,LINETHICK0;
跑道:=空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
航空飞机:=HKFJ*多,COLORFF00FF,LINETHICK2;
HKSJ:=BARSLAST(航空飞机>0 AND NOT(REF(航空飞机,1)))+1;
高度:=(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
空中加油:=启动>0 AND 航空飞机=0,COLOR00FF00,POINTDOT,LINETHICK0;
N3:=BARSLAST(空中加油)+1;
K5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159;
JXGD1:=K5>REF(K5,1) AND REF(K5,1)JXGD2:=MA5>REF(MA5,1) AND REF(MA5,1)加速远航:=FILTER((JXGD1 OR JXGD2) AND C>MA5 AND HKFJ,3),COLOR00FFFF,POINTDOT,LINETHICK0;
N4:=BARSLAST(加速远航);

{以下设置主图显示方式}
STICKLINE(空中加油,(O+C)/2-0.01,(O+C)/2+0.01,4,0),COLOR00FF00;
STICKLINE(空中加油,L,H,1,1),COLOR00FF00;
STICKLINE(加速远航,(O+C)/2-0.01,(O+C)/2+0.01,4,0),COLOR00FFFF;
STICKLINE(加速远航,L,H,1,1),COLOR00FFFF;
STICKLINE(N4>0 AND N4<=5,REF(O,N4+1),REF(O,N4+1),4,1),COLORFFFFFF;
DRAWTEXT(加速远航,L,'加▲速'),COLOR00FFFF;
DRAWTEXT(航空飞机,MA30,'○'),COLORFFFFFF;
DRAWTEXT(空中加油,MA30,'□'),COLOR00FF00;

 

 

 

{一品【空中加油】----一品茶缘编写副图指标}
{指标使用方法:
1、启动跑道可关注,航空飞机安全行;空中加油等买票,加速远航好收益!
2、启动时间长又长,航天飞机要远航!
3、启动时间长,均线越顺畅;航天飞机快,登上要坐好!}

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA250:=MA(CLOSE,250),COLORRED;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1空:=IF(N2QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
启动:多*QSXS,COLORRED,LINETHICK0;
跑道:空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
航空飞机:HKFJ*多,COLORFF00FF,LINETHICK2;
HKSJ:=BARSLAST(航空飞机>0 AND NOT(REF(航空飞机,1)))+1;
高度:(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
空中加油:启动>0 AND 航空飞机=0,COLOR00FF00,POINTDOT,LINETHICK0;
N3:=BARSLAST(空中加油)+1;
K5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159;
JXGD1:=K5>REF(K5,1) AND REF(K5,1)JXGD2:=MA5>REF(MA5,1) AND REF(MA5,1)加速远航:FILTER((JXGD1 OR JXGD2) AND C>MA5 AND HKFJ,3),COLOR00FFFF,POINTDOT,LINETHICK0;
N4:=BARSLAST(加速远航);

{以下设置副图显示方式}
STICKLINE(空中加油,0,启动/10+1,4,1),COLOR00FF00;
STICKLINE(N4>0 AND N4<=5,REF(启动,N4+1),REF(启动,N4+1),4,0),COLORFFFFFF;
DRAWTEXT(加速远航,启动,'▲'),COLOR00FFFF;
{五线布林Z----一品茶缘编写精品指标主图}
{N:1,10,5;参数N表示步林口上下轨之间的最小差距;}
{五线布林Z指标使用方法:
一品五线变布林,开合趋势真分明;
突破上轨拉升快,回归中轨反弹轻。}
N1:=10;P1:=3;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上:BBI+P1*STD(BBI,N1),COLORYELLOW;
IF(BBI*1.15>上*1.03,上*1.06,上*1.03),COLOR0000FF,POINTDOT,LINETHICK0;
下:BBI-P1*STD(BBI,N1),COLORFF00FF;
中:BBI,COLORWHITE;
AA:BBI+P1*STD(BBI,N1)/2,COLOR88FF88;
BB:BBI-P1*STD(BBI,N1)/2,COLOR88FF88;
MA30:MA(C,30),POINTDOT,COLOR00FF00;
QSXS1:=AA>REF(AA,1) AND BBI>REF(BBI,1);
QSXS2:=COUNT(MA30>REF(MA30,1),5)=5;
FLSZ:=C>O AND V>REF(V,1);
RMG:=FLSZ AND (C/REF(C,1)-1)*100>=2;
SCAA:=CROSS(C,AA) OR (OAA);
BLK:=LLV((上-下),2)=LLV((上-下),10);
XBLK:=(上/下-1)*100<=N;
BLKSJ:=BARSLAST(BLK)+1;
拉升:FILTER(SCAA AND FLSZ AND (QSXS1 OR (QSXS2 AND BLKSJ<5)),3),COLORFF00FF,POINTDOT,LINETHICK0;
优选:拉升 AND COUNT(XBLK,4)>=1 AND RMG,COLOR00FF00,POINTDOT,LINETHICK0;
XZF:=(C/REF(C,1)-1)*100<=1;
XPL:=ABS(C-BBI)/BBI*100<=2 OR ABS(l-BBI)/BBI*100<=2;
回:COUNT(QSXS1,8)>=6 AND XZF AND XPL,COLORFFFFFF,POINTDOT,LINETHICK0;
{以下设置主图显示方式}
STICKLINE(拉升,(O+C)/2,(O+C)/2,4,0),COLORFF00FF;
STICKLINE(拉升,H,L,0,1),COLORFF00FF;
DRAWTEXT(拉升,L*0.99,'◆'),COLORFF00FF;
DRAWTEXT(回,L*0.99,'回'),COLORFFFFFF;
DRAWTEXT(XBLK,BBI*1.01,'口'),COLOR00FF00;
STICKLINE(优选,H,L,1,0),COLORFF00FF;
DRAWICON(优选,L*0.99,1);
高:=((H/BBI-1)*100>=15 AND (H/上-1)*100>=3) OR (H/上-1)*100>=6;
STICKLINE(高,H*1.01,H*1.02,4,0),COLOR00FFFF;
{五线布林Z----一品茶缘编写精品指标主图}
{N:1,10,5;参数N表示步林口上下轨之间的最小差距;}
{五线布林Z指标使用方法:
一品五线变布林,开合趋势真分明;
突破上轨拉升快,回归中轨反弹轻。}
N1:=10;P1:=3;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上:BBI+P1*STD(BBI,N1),COLORYELLOW;
IF(BBI*1.15>上*1.03,上*1.06,上*1.03),COLOR0000FF,POINTDOT,LINETHICK0;
下:BBI-P1*STD(BBI,N1),COLORFF00FF;
中:BBI,COLORWHITE;
AA:BBI+P1*STD(BBI,N1)/2,COLOR88FF88;
BB:BBI-P1*STD(BBI,N1)/2,COLOR88FF88;
MA30:MA(C,30),POINTDOT,COLOR00FF00;
QSXS1:=AA>REF(AA,1) AND BBI>REF(BBI,1);
QSXS2:=COUNT(MA30>REF(MA30,1),5)=5;
FLSZ:=C>O AND V>REF(V,1);
RMG:=FLSZ AND (C/REF(C,1)-1)*100>=2;
SCAA:=CROSS(C,AA) OR (OAA);
BLK:=LLV((上-下),2)=LLV((上-下),10);
XBLK:=(上/下-1)*100<=N;
BLKSJ:=BARSLAST(BLK)+1;
拉升:FILTER(SCAA AND FLSZ AND (QSXS1 OR (QSXS2 AND BLKSJ<5)),3),COLORFF00FF,POINTDOT,LINETHICK0;
优选:拉升 AND COUNT(XBLK,4)>=1 AND RMG,COLOR00FF00,POINTDOT,LINETHICK0;
XZF:=(C/REF(C,1)-1)*100<=1;
XPL:=ABS(C-BBI)/BBI*100<=2 OR ABS(l-BBI)/BBI*100<=2;
回:COUNT(QSXS1,8)>=6 AND XZF AND XPL,COLORFFFFFF,POINTDOT,LINETHICK0;
{以下设置主图显示方式}
STICKLINE(拉升,(O+C)/2,(O+C)/2,4,0),COLORFF00FF;
STICKLINE(拉升,H,L,0,1),COLORFF00FF;
DRAWTEXT(拉升,L*0.99,'◆'),COLORFF00FF;
DRAWTEXT(回,L*0.99,'回'),COLORFFFFFF;
DRAWTEXT(XBLK,BBI*1.01,'口'),COLOR00FF00;
STICKLINE(优选,H,L,1,0),COLORFF00FF;
DRAWICON(优选,L*0.99,1);
高:=((H/BBI-1)*100>=15 AND (H/上-1)*100>=3) OR (H/上-1)*100>=6;
STICKLINE(高,H*1.01,H*1.02,4,0),COLOR00FFFF;
{RSV共振----一品茶缘副图}
{P1:5,250,8;P2:5,250,13;P3:5,250,21;P4:5,250,34;----短线参数组合:8132134;中线参数组合6090120250。}
{指标使用方法:重点关注长期横盘后出现的三强+优选信号,同时出现三合更佳。}

RSV:(CLOSE-LLV(LOW,P1))/(HHV(HIGH,P1)-LLV(LOW,P1))*100;
RSV1:(CLOSE-LLV(LOW,P2))/(HHV(HIGH,P2)-LLV(LOW,P2))*100;
RSV2:(CLOSE-LLV(LOW,P3))/(HHV(HIGH,P3)-LLV(LOW,P3))*100;
RSV3:(CLOSE-LLV(LOW,P4))/(HHV(HIGH,P4)-LLV(LOW,P4))*100;
ZH01:=ABS(RSV-RSV1)/RSV1<0.03;
ZH02:=ABS(RSV-RSV2)/RSV2<0.03;
ZH03:=ABS(RSV-RSV3)/RSV3<0.03;
ZH12:=ABS(RSV1-RSV2)/RSV2<0.03;
ZH13:=ABS(RSV1-RSV3)/RSV3<0.03;
ZH23:=ABS(RSV2-RSV3)/RSV3<0.03;
SXHY:=(ZH01+ZH02+ZH03+ZH12+ZH13+ZH23)>=3;
三合:IF(SXHY,55,50),COLORFFFFFF;
GX:=MAX(MAX(RSV,RSV1),MAX(RSV,RSV1));
BDGD:=GX=HHV(GX,60);
GDSJ:=BARSLAST(BDGD);
QD0:=CROSS(RSV,50);
QD1:=CROSS(RSV1,50);
QD2:=CROSS(RSV2,50);
QD3:=CROSS(RSV3,50);
SXQD:=(QD0+QD1+QD2+QD3)>=3;
三启:IF(SXQD AND GDSJ>=5,70,50),COLOR00FF00;
TP0:=CROSS(RSV,80);
TP1:=CROSS(RSV1,80);
TP2:=CROSS(RSV2,80);
TP3:=CROSS(RSV3,80);
SXTP:=(TP0+TP1+TP2+TP3)>=3;
三强:IF(SXTP AND (GDSJ>=5 OR COUNT(GX<80,30)>=20),80,100),COLOR00FFFF;
优选:IF(三强=80 AND COUNT(GX<80,30)>=20,80,50),COLORFF00FF;
{以下设置副图显示方式}
stickline(三合=55,50,55,4,1),COLORFFFFFF;
stickline(三合=55,50,45,4,1),COLOR00FF00;
stickline(三启=70,50,70,4,0),COLOR00FF00;
stickline(三强=80,50,80,4,0),COLOR00FFFF;
50,COLOR0000FF;
80,COLORFF00FF,POINTDOT;
DRAWICON(优选=80,55,1);
黑马回头----{颠倒黑白}主副图指标原码
{颠倒黑白----一品茶缘主图、副图指标}
指标编写思路:
1、趋势向上:30日均线保持向上,安全操作;
2、黑马界定:连续三天大幅拉升,阶段涨幅较大(参数ZF1);
3、白马界定:四天内至少有三天拉升,阶段涨幅较大(参数ZF1);
4、黑白买点:以黑马、白马起涨的第一天收盘价为支撑点,设为黑、白买点;
5、买点1、2:当股价在10天内重新回落到黑白买点时,分别设定为买点1、买点2。
6、信号过滤:当买点信号第一次出现后,并有反弹超过黑白买点后,此后买点过滤。
7、奔马界定:5日均线连续5天(参数N)以上向上运行,且短期均线多头排列,确定为奔马;
8、奔马饮水:奔马最后确认的5日内,5日均线回头,且日线收盘位于10日均线与30日均线之间,短线趋势向上不变,设定为奔马饮水;此时股价一般是第一波拉升建仓后的洗盘买点。

指标使用技巧:
1、清楚反弹:该指标为寻找大幅拉升龙头的回调买点,一般只是反弹行情,期望值不可过高;
2、短期优选:买点信号离黑马、白马信号时间越短越好;
3、趋势优选:买点股价依然保持在30日均线支撑附近,优选。
4、盘中把握:买点设定为黑白买点,盘中股价打到黑白买点位置即会出现低买信号,---注意尽量买在黑白买点附近,盘中切记不可追涨!
5、饮水判断:如前期已经有饮水信号出现,说明短期内股价已经明显出现多个拉升波段,此时的回调也许会变成破位走弱,应该适当回避。

名称来源:一品认为,做股票重在顺势而为,即买在股票波段的起涨点,只做拉升段最好。但是许多朋友对拉升段的判断又难以把握,因此,拉升后的回调、反弹行情,也许可以成为我们的一点补充----当然,这已经与顺势而为的思路相背离了。因此本该是黑马回头的指标,一品命名为:{颠倒黑白}!呵呵^-^

 

 

 


{颠倒黑白Z----一品茶缘主图指标}
{ZF1:5,30,15;ZF2:1,10,3;N:1,10,1;}
MA5:MA(C,5),COLORWHITE,LINETHICK2;
MA10:MA(C,10),COLORYELLOW,LINETHICK1;
MA20:MA(C,20),COLORFF00FF,LINETHICK1;
MA30:MA(C,30),COLORRED,LINETHICK2;
QSXS:=MA(C,30)>=REF(MA(C,30),1);
ZF:=(C/REF(C,1)-1)*100;
黑马:=((c/ref(c,3)-1)*100>=ZF1 and count(ZF>=ZF2,3)=3 AND QSXS)*15,COLORFF00FF,LINETHICK2;
HMSJ:=BARSLAST(黑马);
黑:IF(HMSJ<=10 AND QSXS,REF(C,HMSJ+2),0),COLORFF6600,POINTDOT,LINETHICK2;
DM1:=LOW<=REF(C,HMSJ+2) AND HMSJ<=10 AND 黑马=0;
GL1:=黑>0 AND CROSS(C,黑);
低买1:=(DM1>0 AND COUNT(GL1,HMSJ)=0)*黑,COLOR00FF00,LINETHICK2;
白马:=((H/ref(l,4)-1)*100>=ZF1 and count(ZF>=ZF2,4)>=3 AND H=HHV(H,3) AND QSXS)*10,COLORYELLOW,STICK,LINETHICK5;
BMSJ:=BARSLAST(白马);
白:IF(BMSJ<=10 AND QSXS,REF(C,BMSJ+3),0),COLORWHITE,POINTDOT,LINETHICK2;
DM2:=LOWGL2:=白>0 AND CROSS(C,白);
低买2:=(DM2>0 AND COUNT(GL2,BMSJ)=0)*白,COLORWHITE,LINETHICK2;
BM:=COUNT(MA5>REF(MA5,1),N)=N AND MA5>MA10 AND MA10>MA20 AND MA20>MA30;
奔马:=BM*5,COLOR0000FF,POINTDOT,LINETHICK2;
{STICKLINE(奔马>0,0 ,5 ,5 ,1 ),color0000FF;}
BMSJ2:=BARSLAST(奔马);
BMHT:=MA5MA30;
饮水:=(BMSJ2<=5 AND BMHT AND QSXS)*3,COLORFF6600,LINETHICK2;
{以下设置主图显示方式}
STICKLINE(白马,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(白马,o,c,4,1),colorYELLOW,linethick2;
STICKLINE(黑马,h,l,0,1),colorFF00FF,linethick2;
STICKLINE(黑马,o,c,4,1),colorFF00FF,linethick2;
DRAWTEXT(奔马>0 ,MA30-0.02 , '○'),coloryellow;
STICKLINE(饮水,h,l,0,1),color00FF00,linethick2;
STICKLINE(饮水,o,c,4,1),color00FF00,linethick2;
DRAWTEXT(低买1>0 ,L*0.99 , '◆'),COLOR00FF00,LINETHICK1;
DRAWTEXT(低买2>0 ,L*0.99 , '□'),COLORWHITE,LINETHICK1;

 

 

 

{颠倒黑白----一品茶缘副图指标}
{ZF1:5,30,15;ZF2:1,10,3;N:1,10,1;}
QSXS:=MA(C,30)>=REF(MA(C,30),1);
ZF:=(C/REF(C,1)-1)*100;
黑马:((C/ref(C,3)-1)*100>=ZF1 and count(ZF>=ZF2,3)=3 AND QSXS)*15,COLORFF00FF,LINETHICK2;
HMSJ:=BARSLAST(黑马);
黑:IF(HMSJ<=10 AND QSXS,REF(C,HMSJ+2),0),COLORFF6600,POINTDOT,LINETHICK2;
DM1:=LOW<=REF(C,HMSJ+2) AND HMSJ<=10 AND 黑马=0;
GL1:=黑>0 AND CROSS(C,黑);
低买1:(DM1>0 AND COUNT(GL1,HMSJ)=0)*黑,COLOR00FF00,LINETHICK2;
白马:((H/ref(L,4)-1)*100>=ZF1 and count(ZF>=ZF2,4)>=3 AND H=HHV(H,3) AND QSXS)*10,COLORYELLOW,STICK,LINETHICK5;
BMSJ:=BARSLAST(白马);
白:IF(BMSJ<=10 AND QSXS,REF(C,BMSJ+3),0),COLORWHITE,POINTDOT,LINETHICK2;
DM2:=LOWGL2:=白>0 AND CROSS(C,白);
低买2:(DM2>0 AND COUNT(GL2,BMSJ)=0)*白,COLORWHITE,LINETHICK2;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
BM:=COUNT(MA5>REF(MA5,1),N)=N AND MA5>MA10 AND MA10>MA20 AND MA20>MA30;
奔马:BM*5,COLOR0000FF,POINTDOT,LINETHICK2;
STICKLINE(奔马>0,0 ,5 ,5 ,1 ),color0000FF;
BMSJ2:=BARSLAST(奔马);
BMHT:=MA5MA30;
饮水:(BMSJ2<=5 AND BMHT AND QSXS)*3,COLORFF6600,LINETHICK2;
{清凉西瓜(200万一品茶缘优化版主图指标}
Var1:=(LOW+HIGH+CLOSE)/3;
操作:MA(Var1,5),color00FF00,linethick2;
拉升:HHV(操作,13),colorFF00FF;
买卖: LLV(操作,13),colorwhite;
压力: HHV(操作,60),colorFF6600;
中线:HHV(MA(H,13),13),coloryellow;
支撑: LLV(LOW,60)*1.02,color00FF00;
顶部: HHV(HIGH,60)*0.98,colorred;
STICKLINE(操作<拉升,中线,拉升,1,0),colorgreen;
QSXS:=操作>REF(操作,1) AND REF(操作,1)GJSC:=L<拉升 AND H>拉升 AND C>REF(C,1) AND C>O;
LSMR:=GJSC AND COUNT(QSXS,2);
买1:LSMR AND NOT(REF(LSMR,1)),coloryellow,POINTDOT,LINETHICK0;
DRAWTEXT(买1,L*0.99, '◆'),COLOR00FF00;
DRAWTEXT(买1,L*0.95, '买'),coloryellow;

{清凉西瓜(200万)----一品茶缘优化版买选股信号}
Var1:=(LOW+HIGH+CLOSE)/3;
操作:=MA(Var1,5);
拉升:=HHV(操作,13);
QSXS:=操作>REF(操作,1) AND REF(操作,1)GJSC:=L<拉升 AND H>拉升 AND C>REF(C,1) AND C>O;
LSMR:=GJSC AND COUNT(QSXS,2);
买1:LSMR AND NOT(REF(LSMR,1));
{个股强弱----一品茶缘优化版,副图指标}

{个股强弱指标使用说明:
个股走势比大盘,阶段强弱易分辨;
转强关注好操作,强于50龙在天!}
C1:=(((10000 * CLOSE) / INDEXC));
Var1:=REF(c1,1);
A1:=SMA(MAX(c1-Var1,0),7,1)/SMA(ABS(c1-Var1),7,1)*100;
Var2:=REF(c1,2);
A2:=SMA(MAX(c1-Var2,0),7,1)/SMA(ABS(c1-Var2),7,1)*100;
Var3:=REF(c1,3);
A3:=SMA(MAX(c1-Var3,0),7,1)/SMA(ABS(c1-Var3),7,1)*100;
Var4:=REF(c1,4);
A4:=SMA(MAX(c1-Var4,0),7,1)/SMA(ABS(c1-Var4),7,1)*100;
XRSI1:=(A1+A2+A3+A4)/4;
XRSI:(A1+A2+A3+A4)/4,COLORYELLOW,LINETHICK1;
MX13:MA(XRSI,13),COLORRED;
关注:CROSS(XRSI,MA(XRSI,2)) AND BETWEEN(XRSI,20,60),COLORFFFFFF,POINTDOT;
QSXS:=XRSI>REF(XRSI,1) OR MX13>REF(MX13,1);
操作区:XRSI>MX13 AND QSXS,COLOR00FFFF,POINTDOT;
STICKLINE(XRSI1>=30,30,XRSI1,4,0),COLOR00FF00;
STICKLINE(XRSI1>=50,50,XRSI1,4,0),COLORFF00FF;
STICKLINE(XRSI1>=70,70,XRSI1,4,0),COLOR0000FF;
STICKLINE(操作区,XRSI,MX13,4,1),COLOR00FFFF;
DRAWTEXT(CROSS(关注,0.8),XRSI,'↑'),COLORFFFFFF;
DRAWTEXT(CROSS(操作区,0.8),MX13,'◆'),COLOR0000FF;
弱:30,COLORFFFFFF;
强:50,COLOR00FFFF,POINTDOT;
龙:70,COLORFF00FF,POINTDOT;
险:IF(XRSI1>90,75,90),COLOR0000FF;
{鸳鸯对----一品茶缘编写,副图指标}
{鸳鸯对指标使用说明:
长阴与长阳,分别是鸳鸯;
鸳鸯来配对,好事要成双!}

ZF:=(C/REF(C,1)-1)*100;
DRDD:=ZF<=-5 AND (O/C-1)*100>=4;
DRDZ:=ZF>=5 AND (C/O-1)*100>=4;
鸳:DRDD*-1,COLOR00FF00,POINTDOT,LINETHICK0;
鸯:DRDZ,COLORFF00FF,POINTDOT,LINETHICK0;
鸳鸯对:(DRDZ AND REF(DRDD,1) AND C>REF(O,1)*0.995)*8,COLOR00FFFF;
YX:=V>REF(V,1) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
优选:鸳鸯对 AND YX,COLOR0000FF,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
STICKLINE(DRDD,0,-1,4,0),COLOR00FF00;
STICKLINE(DRDZ,0,1,4,0),COLORFF00FF;
DRAWICON(优选,1,1);


{清澈见底----一品茶缘副图指标}
{清澈见底指标使用说明:
连续跳空四连阴,股价超跌寒人心;
清澈好水先关注,见底出现抢黄金!}
TKQK:=ODFXD:=(C/REF(C,1)-1)*100<=-4;
DRDD:=(C/REF(C,1)-1)*100<=-6;
清澈:COUNT(TKQK OR DFXD,4)=4 AND COUNT(DRDD,4),COLORFFFFFF;
JD1:=C>O AND C>REF(C,1);
JD2:=(MIN(C,O)-L)/ABS(C-O)>=1.5;
见底:(JD1 OR JD2) AND REF(清澈,1),COLOR00FFFF;
MA60:=MA(C,60);
QSXS:=C>=MA60 AND MA60>REF(MA60,1);
优选:见底 AND QSXS,COLORFF00FF,POINTDOT,LINETHICK0;
DRAWICON(优选,0.1,1);
{一品抄底----一品茶缘编写副图指标}
{一品抄底使用说明:
1、一品抄底=CCI+RSI+股价与均线大幅乖离三重超跌组合;
2、买点把握:一品抄底,尽量低吸,买在抄底信号当日最低价附近或者短期的更低价最佳;
3、利润把握:一品抄底,短线机遇;低买高卖,不贪不惧;把握节奏,快进快出!}
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=(C/MA(C,5)-1)*100<-10;
A2:=(C/MA(C,13)-1)*100<-10;
A3:=(C/MA(C,34)-1)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
底部:A1 AND A2 AND A3 AND A4 AND A5 AND A6,COLOR00FFFF,LINETHICK2;
一品

{简单KDJ指标使用方法:
重读经典KDJ,J值转向定策略;
超跌关注重启买,加码小心更明确!}
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1),COLORFFFFFF;
D:SMA(K,3,1),COLOR00FFFF;
J:3*K-2*D,COLORFF00FF;
超跌:IF(J<0,10,0),COLORFFFF00;
BDDD:=LLV(J,2)=LLV(J,8);
重启:IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0),COLOR00FF00;
加码:IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND BETWEEN(J,20,60),1,0),COLOR00FFFF,POINTDOT,LINETHICK0;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
小心:IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),70,100),COLOR0000FF;
DRAWTEXT(加码,J,'△'),COLOR00FFFF;


选股:
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDDD:=LLV(J,2)=LLV(J,8);
重启:=CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20;
加码:=CROSS(J,REF(J+0.01,1)) AND BDDD AND BETWEEN(J,20,60);
选股:重启 or 加码;
阴阳交欢  副

{n,1,1000,107}
var1:= REF(CLOSE,1);
var2:=SMA(MAX(CLOSE-var1,0),14,1);
var3:=SMA(ABS(CLOSE-var1),14,1);
阳:ma(var2/var3*100,5)coloryellow, linethick2;
阴:ma(var3/var2*5,5)colorgreen ,linethick2;
交欢:if(阳-阴STICKLINE(阳-阴


新思维-BB     主
Var2:=MA(LOW,3)*0.99;
Var3:=MA(LOW,30)*0.753;
Var4:=FORCAST(Var2,10);
DRAWICON(COUNT(CROSS(Var2,Var4),1)>=1 AND Var4Var5:=IF(DATE<1081201,1,0);
Var6:=IF(DATE<1081201,1,0);
Var7:=EMA(CLOSE*Var6,8);
Var8:=EMA(CLOSE*Var5,34)-0.1;
★: EMA(Var5*CLOSE,5),colorred , ;
乱: EMA(Var6*CLOSE,13)-0.15,colorff6633 , ;
云: MA(CLOSE,60)*0.98, , ;
飞: FORCAST(★,8),colorffff00 , ;
STICKLINE(飞>=乱,飞,乱,1,0), , ;
DRAWTEXT(COUNT(CROSS(★,乱),1)>=1 AND 乱>REF(乱,1),LOW,'★'),colorred , ;
Var9:=SLOPE(EMA(CLOSE,2),10)*15+CLOSE;
VarA:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);
仍: EMA(VarA,3);
从: EMA(仍,3), ,;
VarB:=EMA(从,3);
VarC:=EMA(VarB,3);
VarD:=EMA(VarC,3);
VarE:=EMA(VarD,3);
VarF:=EMA(VarE,3);
Var10:=EMA(VarF,3);
Var11:=EMA(Var10,3);
容: EMA(SLOPE(EMA(CLOSE,15),10)*15+CLOSE,5), , ;
『安全度』副

Var2:=LLV(LOW,33);
Var3:=HHV(HIGH,21);
Var4:=EMA((CLOSE-Var2)/(Var3-Var2)*100,20)*0.998;
100,stick,LINETHICK7, COLORffcc33;
80, stick,LINETHICK7, COLORFF9933;
50,stick,LINETHICK7, colorblue;
20,stick,LINETHICK7,colorcc0033;
20,,  COLORWHITE;
50,,  COLORYELLOW;
80,,  COLORCYAN;
DRAWTEXT(FILTER(CLOSE>0,25),10,'极度危险区'),, COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),30,'危险区'), ,  COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),65,'安全区'), ,  COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),88,'高安全区'), ,  COLORWHITE;
当前安全度: 100-EMA(0.667*REF(Var4,1)+0.333*Var4,1),circledot,linethick2 ,COLORRED;
[超级牛魔]
Var3:=1;
Var4:=MA(CLOSE,5);
Var5:=MA(CLOSE,10);
Var6:=MA(CLOSE,30);
Var7:=MA(CLOSE,60);
Var8:=EMA(COST(85),7);
Var9:=EMA(COST(15),7);
VarA:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VarB:=Intpart(VarA*100)/100;
VarC:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VarD:=Intpart(VarC*100)/100;
VarE:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarF:=Intpart(VarE*100)/100;
短线趋势:EMA(CLOSE,5)-EMA(CLOSE,10);
中线趋势:EMA(短线趋势,30);
Var10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Var11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Var12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Var13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Var14:=REF(中线趋势,1);
Var15:=中线趋势;
Var16:=Var15-Var14;
Var17:=REF(短线趋势,1);
Var18:=短线趋势;
Var19:=Var18-Var17;
Var1A:=OPEN;
Var1B:=CLOSE;
超级牛魔王:If(Var1A<=Var4 AND Var1A<=Var5 AND Var1A<=Var6 AND Var1B>=Var4 AND Var1B>=VarF AND Var16>0 AND Var19>0 AND Var3=1,0.5,0);
短线指标:IF(CROSS(短线趋势,中线趋势) AND 短线趋势<0 AND 中线趋势<-0.2 AND Var11>45 AND Var16>0 AND Var3=1,1,0);
{短线强弱副}
{N:(1,10,3);N1:(1,10,3);M1:(1,10,3);M2:(1,10,2)}
UP:=SMA(IF(CLOSE>REF(CLOSE,1), CLOSE-REF(CLOSE,1),0),N,1);
DN:=SMA(IF (CLOSE<=REF(CLOSE,1),ABS(CLOSE-REF(CLOSE,1)),0),N,1);
指标:=100*UP/(UP+DN);
强弱:EMA(指标,3),COLORRED;
平均:EMA(强弱,3),COLORGREEN;
风险:80,COLOR8887EA;
安全:20,COLOR8887EA;
分界:50,CIRCLEDOT,LINETHICK2,COLORGREEN;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,M1,1);
D:=EMA(K,M2);
PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSEOPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEHSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击流量,2);
资金流:=LLJX/1000;
卖出:IF(强弱<平均 AND D观望:IF((强弱>=平均 AND D>=REF(D,1) AND MA(C,3)>=REF(MA(C,3),1)) OR (D>=REF(D,1) AND 资金流>0 AND MA(C,3)>=REF(MA(C,3),1)) OR(强弱>=平均 AND 资金流>0 AND MA(C,3)>=REF(MA(C,3),1)) OR (强弱>=平均 AND 资金流>0 AND D>=REF(D,1)),50,DRAWNULL),CIRCLEDOT,LINETHICK2,COLORLIMAGENTA;
买进:IF(强弱>=平均 AND D>=REF(D,1) AND 资金流>0 AND MA(C,3)>=REF(MA(C,3),1),50,DRAWNULL),CIRCLEDOT,LINETHICK2,COLORRED;

VAR1:=1/WINNER(CLOSE);
VAR2:=MA(CLOSE,13);
VAR3:=100-ABS((CLOSE-VAR2)/VAR2*100);
VAR4:=LLV(LOW,75);
VAR5:=HHV(HIGH,75);
VAR6:=(VAR5-VAR4)/100;
VAR7:=SMA((CLOSE-VAR4)/VAR6,20,1);
VAR8:=SMA((OPEN-VAR4)/VAR6,20,1);
VAR9:=3*VAR7-2*SMA(VAR7,15,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=100-VARA;
VARC:=IF(900101VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
散户: SMA(VAR28,3,1)*VARC, ,COLORLIBLUE ;
主力: SMA(散户,3,1)*VARC, , COLORYELLOW;
{说明:强弱上传平均时为关注点,当散户上传主力时可快速介入,反之亦然!
若强弱线,平均线和散户线同时上传主力时,那么你发财了!
强弱红色、平均是绿色、散户兰色、主力黄色};

{短线强弱副}

买进选股
{N:(1,10,3)}
UP:=SMA(IF(CLOSE>REF(CLOSE,1), CLOSE-REF(CLOSE,1),0),N,1);
DN:=SMA(IF (CLOSE<=REF(CLOSE,1),ABS(CLOSE-REF(CLOSE,1)),0),N,1);
指标:=100*UP/(UP+DN);
强弱:=EMA(指标,3),COLORRED;
平均:=EMA(强弱,3),COLORGREEN;
买进:CROSS(强弱,平均);

{渔家公式一:渔家乐}    副

用法:此公式用于横盘股的中长线,短线不适用。

公式原码:

渔家:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2 , COLORYELLOW;
渔家乐: IF(CROSS(渔家,MA(渔家,10)) AND 渔家<=10,35,0),LINETHICK3 , COLORMAGENTA;
渔家出海: IF(CROSS(渔家,MA(渔家,10)) AND 渔家<35,70,0),LINETHICK3 ,  COLORRED;
渔家网: IF(CROSS(MA(渔家,9),渔家) AND 渔家>70,110,72),LINESTICK ,  COLORCYAN;
VAR1:=DRAWICON(CROSS(渔家,62),68,1);
VAR2:=DRAWICON(CROSS(渔家,72),70,1);
VAR3:=DRAWICON(CROSS(渔家,66),72,1);
VAR4:=DRAWICON(CROSS(渔家,68),66,1);
VAR5:=DRAWICON(CROSS(76,渔家),70,2);
VAR6:=DRAWICON(CROSS(68,渔家),84,2);
VAR7:=DRAWICON(CROSS(66,渔家),80,2);
VAR8:=DRAWICON(CROSS(64,渔家),70,2);
准备下网: IF(渔家<=10,30,0),STICK ,COLORF2A2BE,LINETHICK4;
此处下网: IF(CROSS(渔家,10),45,0),STICK ,COLORRED LINETHICK4;
DRAWTEXT(此处下网,40,'关注!!!'), , COLORYELLOW;
准备休渔吧: STICKLINE(渔家>=90,70,40,4,0), , COLORGREEN;
休渔吧: IF(CROSS(84,渔家),100,0),STICK ,COLOR77AAFF,LINETHICK5;
DRAWTEXT(休渔吧,98,'回家!'), ,COLOR77AAFF ;
水面: 72, ,COLORCYAN ;
网架: 105;
水底: 10;
渔家2: MA(渔家,9),LINETHICK2 ,COLORFF0000;
IF(CROSS(渔家,MA(渔家,6)) AND 渔家2<45,渔家2,0),COLORCCB3E2 ,LINETHICK3 ;
{渔家公式二:市场脉搏}  副

用法:此公式用于看趋势。对于周K线,脉搏线两次进入静脉实体是底。

公式原码:

心脏:=MA(CLOSE,5);
血液:=MA(MA(CLOSE,13),5);
脉搏:(心脏-REF(心脏,1))/REF(心脏,1)*100, COLORYELLOW LINETHICK1;
动静脉:(血液-REF(血液,1))/REF(血液,1)*100,COLORMAGENTA LINETHICK1;
STICKLINE(动静脉>0,动静脉,0,0.00000001,0),COLORRED;
STICKLINE(动静脉<0,动静脉,0,0.00000001,0),COLORGREEN;
生命线:0,COLORRED LINETHICK1;

上瓣膜:2,LINETHICK2 COLORGREEN;
下瓣膜:-2,LINETHICK2 COLORGREEN;
动脉界:1,LINETHICK1 COLORRED;
静脉界:-1,LINETHICK1 COLORRED;
{渔家公式三:牛熊先知}  副

用法:此公式用于短线和长线,要慢慢体会,此公式暗含信号。

公式原码:


VAR1:=EMA(EMA(EMA(CLOSE,5),2),1);
牛熊先知: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1,COLORRED COLORSTICK;
牛熊神经: EXPMA(牛熊先知,13),COLORYELLOW;
牛熊界线: 0, COLORMAGENTA;
VAR2:=AMOUNT/VOL/100;
VAR3:=MAX(ABS(HIGH-VAR2),ABS(VAR2-LOW));
VAR4:=ABS((OPEN+CLOSE)/2-VAR2);
VAR5:=5;
VAR6:=(VAR3+VAR4)/VAR2*50;
牛熊变换: IF(CROSS(VAR6,VAR5),0.008,0),COLORCYAN;
{渔家公式四——牛踪熊影}   副

用法:此公式主要用于大盘的长期趋势的判断,不适用于短线。

公式原码:

VAR1:=1;
VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,55)/SUM(VAR5,55);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,55);
VAR9:=EMA(VAR8,5);
VARA:=EMA(VAR8,3);
牛熊边界: (VAR8-VARA)*VAR1;
牛踪熊影: (VAR9-VARA)*VAR1;
枫林草地: 牛熊边界*VAR1, COLORSTICK;
牛熊界:0,COLORRED LINETHICK1;
{渔家公式五——万丈霞光}   副

用法:此公式用于判断大盘的底和顶。

公式原码:

蔽日乌云:0.00001*EXPMEMA(AMO/100000,99),COLORWHITE STICK LINETHICK2;
万丈霞光:0.00001*EXPMEMA(AMO/100000,27),COLORRED STICK LINETHICK2;
漫山翠绿:0.00001*EXPMEMA(AMO/100000,47),COLORGREEN STICK LINETHICK2;
{渔家公式六——汗血黑马}   副

用法:此公式用于量能判断,主要用于大盘股的分析,要结合价格公式使用,公式并不精确,仅是一个参考。

公式原码:

血:0.01*EXPMA(AMOUNT,5)/EXPMA(VOL,5),COLORRED LINETHICK1;
汗:0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13),COLORWHITE LINETHICK1;
劲:0.01*EXPMA(AMOUNT,21)/EXPMA(VOL,21);
途:DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE(7)));
STICKLINE(劲>途,劲,途,1,0),COLORRED;
STICKLINE(劲<途,劲,途,1,0),COLORGREEN;
STICKLINE(血>汗,血,汗,1,0),COLORMAGENTA;
STICKLINE(血<汗,血,汗,1,0),COLORCYAN;
{渔家公式七——量能图谱}  副

用法:此公式主要用于大盘分析,对于大盘股,也可用于参考。

公式原码:

量能:=AMOUNT,COLORWHITE STICK;
量能1:MA(量能,34),COLORWHITE LINETHICK1;
量能2:MA(量能,55),COLORWHITE LINETHICK1;
量能3:MA(量能,89),COLORGREEN LINETHICK1;
量能4:MA(量能,21),COLORMAGENTA LINETHICK1;


STICKLINE(量能1>量能2,量能2,量能1,0.001,0),COLORRED;
STICKLINE(量能1<量能2,量能2,量能1,0.001,0),COLORGREEN;
{渔家公式八——渔家指数}    副

用法:此公式用于大盘的分析,与《万丈霞光》相同,只是直观一些。

公式原码:

渔家指数:AMOUNT/100000000000, COLORYELLOW LINESTICK;
渔家指数1:MA(渔家指数,27),COLORMAGENTA LINETHICK2;
渔家指数2:MA(渔家指数,49),COLORRED LINETHICK2;
渔家指数3:MA(渔家指数,99),COLORGREEN  LINETHICK2;
{渔家公式九——行情山谷}    副

用法:此公式主要用于行情的定性,行情上涨时,显示不同的颜色,代表不同的行情,主要用于大盘,也可用于个股。

公式原码:

反弹行情:COUNT(CLOSE>REF(CLOSE,3),5)/5*100,STICK LINETHICK3,COLORRED;
荒漠行情:COUNT(LOW>REF(LOW,3),5)/5*100,STICK LINETHICK3;
鸡肋行情:COUNT(OPEN>REF(OPEN,3),5)/5*100,STICK LINETHICK3;
绿色行情:COUNT(HIGH>REF(HIGH,3),5)/5*100,STICK LINETHICK3;
{渔家公式十——睡醒就买}  副


用法:均线型公式,信号滞后,牛市时用可以,熊市时买点用60分钟分时线,卖点用15分钟分时线。

公式原码:

梦乡:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
初醒:SMA(梦乡,8,1);
清醒:SMA(初醒,5,1);
挣开眼就买吧:IF(CROSS(初醒,清醒) AND 清醒<12,50,10);
睡醒了就卖吧:IF(CROSS(清醒,初醒) AND 清醒>40,50,10);

地板:5,COLORRED,LINETHICK2;
房顶:75,COLORGREEN,LINETHICK2;
{渔家公式十——雾里看花}   副

仅用于大盘。

公式原码:

花茎:=REF(HIGH+LOW,1)/2;
花蕊:=SUM(MAX(0,HIGH-花茎),21)/SUM(MAX(0,花茎-LOW),21)*100;
花香:REF(EXPMA(花蕊,21),1+13/3),COLORMAGENTA STICK LINETHICK2;
鲜花:REF(EXPMA(花蕊,34),1+21/3),COLORRED STICK LINETHICK2;
绿叶:REF(EXPMA(花蕊,55),1+34/3),COLORGREEN STICK LINETHICK1;
薄雾:REF(EXPMA(花蕊,89),1+55/3),COLORWHITE STICK LINETHICK1;
{渔家变盘布林线}   主

公式用法:基本同布林线,中间的线可做趋势线用。

公式原码:

V1:=1;
V2:=CLOSE*VOL;
趋势线: EMA((EMA(V2,3)/EMA(VOL,3)+EMA(V2,5)/EMA(VOL,5)+EMA(V2,13)/EMA(VOL,13)+EMA(V2,21)/EMA(VOL,21))/4,1)*V1, COLORGREEN LINETHICK2;
上轨: EMA(趋势线+5*STD(趋势线,8),1)*V1,COLORRED LINETHICK2;
下轨: EMA(趋势线-5*STD(趋势线,8),1)*V1, COLORMAGENTA,LINETHICK2;
《渔家通道》原码    主

{VAR2:=MA(ADVANCE-DECLINE,3)/100;}
VAR3:=MA(CLOSE,5)*1.01;
VAR4:=MA(OPEN,13)*1.01;
VAR5:=(MA(HIGH,3)+MA(LOW,5)+MA(CLOSE,3)+MA(OPEN,3)+CLOSE+OPEN)/6{+VAR2};
VAR6:=IF(VAR4>VAR5,VAR4,VAR5);
VAR7:=IF(VAR4VAR8:=3/100;
下轨:MA(VAR7,5)*(1-VAR8),LINETHICK1,COLORRED;
上轨:MA(VAR6,5)*(1+VAR8),LINETHICK1,COLOR00FF11;
STICKLINE(VAR3>VAR4,VAR4,VAR3,0.01,0),LINETHICK4,COLORYELLOW;
STICKLINE(VAR5>VAR4,VAR5,VAR4,0.01,0),LINETHICK4,COLORred;
STICKLINE(VAR3STICKLINE(VAR50轴以下MACD两次金叉的选股公式
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
W:=BARSLAST(CROSS(DIF,DEA) AND DIF<0 AND DEA<0) ;
零以下:FILTER(COUNT(W,30)=2 AND REF(CROSS(DEA,DIF),1),30) ;

红牛白马

 

{n:2、20、9}
{n1:1、1000、26}
{z:1、20、5}

 

VAR3a:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
VAR4a:=(CLOSE-LLV(CLOSE,N1))/(HHV(CLOSE,N1)-LLV(CLOSE,N1))*100;
VAR5a:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR6a:=EMA(VAR5a,100);
VAR7a:=2*(VAR5a-VAR6a);
VAR8a:=POW(VAR7a,3)*0.1+POW(VAR7a,1);
VAR9a:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VARAa:=EMA(VAR9a*0.97,3);
VARBa:=(HIGH+LOW+CLOSE)/3;
VARCa:=(VARBa-MA(VARBa,14))/(0.015*AVEDEV(VARBa,14));
白马: IF(YEAR<2008 AND VAR7a>0.1,VAR8a,0)*5,COLORFFFFFF;
VARDa:=LLV(HIGH,240);
VAREa:=100*(CLOSE-VARDa)/VARDa;
VARFa:=AMOUNT/VOL;
VAR10:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
VAR11:=INDEXC;
VAR12:=MA(VAR11,5);
VAR13:=MA(VAR11,20);
VAR14:=MA(VAR11,30);
VAR15:=VAR14>VAR12*1.08 AND VAR13>VAR12*1.055;
VAR16:=VAR12>VAR11*1.03 AND VAR13>VAR11*1.13;
VAR17:=VAR16;
VAR18:=IF(FILTER(VAR10<6,5)=1,1,0);
VAR19:=VAR10<6 AND VAR17;
{黑马: IF(FILTER(VAR19,1)=1,1,0)*20, , ;}
{大黑马: VAR19 AND VAR18*80, , ;}
VAR1A:=CROSS(白马,2);
VAR1B:=CROSS(白马,4);
{庄拉: IF(FILTER((VAR1A OR VAR1B) AND VAR4a<40 AND VAR3a<40,5)=1,35,0), , ;}

var2:=REF(LOW,1);
var3:=SMA(ABS(LOW-var2),3,1)/SMA(MAX(LOW-var2,0),3,1)*20;
var4:=EMA(IF(CLOSE*1.2,var3*10,var3/10),3);
var5:=LLV(LOW,30);
var6:=HHV(var4,30);
var7:=IF(LLV(LOW,58),1,0);
var8:=EMA(IF(LOW<=var5,(var4+var6*2)/2,0),3)/618*var7;
var9:=IF(var8>100,100,var8);
var5x:=llv(low,75);
var6x:=hhv(high,75);
var7x:=(var6x-var5x)/100;
var8x:=sma((close-var5x)/var7x,20,1);
vara:=3*var8x-2*sma(var8x,15,1);
var26:=(close-llv(low,27))/(hhv(high,27)-llv(low,27))*20;
var28:=sma(var26,3,1);
STICKLINE(var9>-150,0,var9,3,0),colorff00ff;
{底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,color00ff00;}
STICKLINE(var8,0,var8,6,1),colorred;
红牛:if(var8,var8,1),colorred;

 

 
通达信主副图指标----------股票实战技术指标公式研究本博500人腾讯群81329... 通达信主副图指标集锦一起贡献给大家——股票实战技术指标公式研究本博500人腾讯群81329... “家九公式”通达信发个黑马翻番预警——股票实战技术指标公式研究本博500人腾讯群8132... 专家九公式”通达信发个黑马翻番预警——股票实战技术指标公式研究本博500人腾讯群8132... “家九公式”通达信发个黑马翻番预警——股票实战技术指标公式研究本博500人腾讯群8132... “专家九公式”通达信发个黑马翻番预警——股票实战技术指标公式研究本博500人腾讯群8132... 非常棒的一个通达信主图源码——股票实战技术指标公式研究本博500人腾讯群48493698—... 神奇柱量【通达信】1——股票实战技术指标公式研究本博500人腾讯群81329885——东方财... 神奇柱量【通达信】2——股票实战技术指标公式研究本博500人腾讯群81329885——东方财... 通达信软件操作说明2——股票实战技术指标公式研究本博500人腾讯群81329885——东方财... 神奇柱量【通达信】——股票实战技术指标公式研究本博500人腾讯群81329885——东方财... “器官果蔬”吃啥补啥不看后悔——股票实战技术指标公式研究本博500人腾讯群81329885... 姜汤-----神奇妙药——股票实战技术指标公式研究本博500人腾讯群81329885——东... 永远离开癌症(再忙也要看)——股票实战技术指标公式研究本博500人腾讯群48493... 15种能力:决定了你的未来能走多远——股票实战技术指标公式研究本博500人腾讯群81329... 炒股就那么几招 技术指标——股票实战技术指标公式研究本博500人腾讯群81329885——... 计算时间窗口的公式——股票实战技术指标公式研究本博500人腾讯群48493698——东方财! 黑洞公式1——股票实战技术指标公式研究本博500人腾讯群41559361——东方财富网博客 激活先天之本,何惧疾病衰老——股票实战技术指标公式研究本博500人腾讯群48493698—... 儿童止咳妙方——股票实战技术指标公式研究本博500人腾讯群81329885——东方财富网博... 吃出乌黑靓发——股票实战技术指标公式研究本博500人腾讯群48493698——东方财富网博... 清晨9个动作——股票实战技术指标公式研究本博500人腾讯群48493698——东方财富网博... 22条方法优化大脑——股票实战技术指标公式研究本博500人腾讯群81329885——东方财... 每天睡前6分钟,2个月后再看你的身材和容颜——股票实战技术指标公式研究本博500人腾讯群8...